SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Evangelist mumford1's Avatar
    Join Date
    Sep 2002
    Location
    UK
    Posts
    571
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry Leftcontent shifting way left..help!!

    Hi

    Could someone take a look at this please http://www.jjwhite.co.uk/new/test.htm

    I have put a red border around the leftside content to illustrate, you will see in netscape that it shifts way to the left and does not sit under the text "dsdsd"

    Also if you look at the site in IE there is a grey box that sits under the green strip, this is meant to be the same size as the green strip, but I think the leftcontent is shifting it a few pixels to the right!!

    Your help is much appreciated

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,287
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Also if you look at the site in IE there is a grey box that sits under the green strip, this is meant to be the same size as the green strip, but I think the leftcontent is shifting it a few pixels to the right!!
    Although you have knocked 3 pixels of the right margin of the float yo alos need to knock 3 pixels off the margin f the content alongside because ie will still add it back on.

    Code:
    #content {
     margin-left:198px;/*this is the space for the left column */
    }
    * html #content {
     height:1%;
     margin-left:195px;/* 3 pixel jog*/
    }
    The Netscape problem I assume is an older browser version because it looks ok in moz/firefox.

    NN6 does have some issues with positioning and floats etc but I haven't had time to check yet.

    Paul

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,287
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    The problem with netscape is because of the erroneous backslash that crept into the code when no-one was looking
    Code:
    <div class="clr" /></div>
    It should of course be:
    Code:
    <div class="clr"></div>
    Thats all it was

    paul

  4. #4
    SitePoint Evangelist mumford1's Avatar
    Join Date
    Sep 2002
    Location
    UK
    Posts
    571
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I am using Netscape 6 to view it, and it does shift to the left, that 3 pixel jog worked thanks, I hope you can guide me with NN issue

    Dave

  5. #5
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,287
    Mentioned
    179 Post(s)
    Tagged
    6 Thread(s)
    Look up

  6. #6
    SitePoint Evangelist mumford1's Avatar
    Join Date
    Sep 2002
    Location
    UK
    Posts
    571
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Damn that was simple, it has taken me all day looking at the code and I did not spot it ................ thanks!!!!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •