<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.blogs.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.2.0/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    <meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KL8PMMW');</script>

    <script class="SP_stripMobile" type="text/javascript">
      var propertag = propertag || {};
      propertag.cmd = propertag.cmd || [];
      (function() {
      var pm = document.createElement('script');
      pm.async = true; pm.type = 'text/javascript';
      var is_ssl = 'https:' == document.location.protocol;
      pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/sitepoint.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(pm, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();

      var oSpP;
    </script>
    <script charset="UTF-8" src="//cdn.sendpulse.com/js/push/ee9a890c7a9d2a9236648c25e40bd03e_1.js" async></script>

    
    
<!-- This site is optimized with the Yoast SEO plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>SitePoint Premium New Releases: DevOps Security, jQuery &amp; Vue Projects &mdash; SitePoint</title>
<meta name="description" content="Check out our new books on DevOps security, jQuery, and building Vue projects, as well as our new Premium library interface."/>
<link rel="canonical" href="https://www.sitepoint.com/sitepoint-premium-new-releases-devops-security-jquery-vue-projects/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SitePoint Premium New Releases: DevOps Security, jQuery &amp; Vue Projects &mdash; SitePoint" />
<meta property="og:description" content="Check out our new books on DevOps security, jQuery, and building Vue projects, as well as our new Premium library interface." />
<meta property="og:url" content="https://www.sitepoint.com/sitepoint-premium-new-releases-devops-security-jquery-vue-projects/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:section" content="Blogs" />
<meta property="article:published_time" content="2019-03-22T16:00:31+00:00" />
<meta property="article:modified_time" content="2019-03-22T03:56:42+00:00" />
<meta property="og:updated_time" content="2019-03-22T03:56:42+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Check out our new books on DevOps security, jQuery, and building Vue projects, as well as our new Premium library interface." />
<meta name="twitter:title" content="SitePoint Premium New Releases: DevOps Security, jQuery &amp; Vue Projects &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://www.sitepoint.com/wp-content/uploads/2019/03/1553225769learning-jquery.jpg" />
<meta name="twitter:creator" content="@joelfalconer" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; SitePoint Premium New Releases: DevOps Security, jQuery &#038; Vue Projects Comments Feed" href="https://www.sitepoint.com/sitepoint-premium-new-releases-devops-security-jquery-vue-projects/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1553143621' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.9.8' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.722e2b01a90e7cb60e0b.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.722e2b01a90e7cb60e0b.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-302ae967a92241deb24be6e2a54eeefd.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=171469' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fsitepoint-premium-new-releases-devops-security-jquery-vue-projects%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fsitepoint-premium-new-releases-devops-security-jquery-vue-projects%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/sitepoint-premium-new-releases-devops-security-jquery-vue-projects\/"},"headline":"SitePoint Premium New Releases: DevOps Security, jQuery &#038; Vue Projects","url":"http:\/\/www.sitepoint.com\/sitepoint-premium-new-releases-devops-security-jquery-vue-projects\/","dateCreated":"2019-03-22T16:00:31Z","datePublished":"2019-03-22T16:00:31Z","dateModified":"2019-03-22T16:00:31Z","articleSection":"Blogs","author":[{"@type":"Person","name":"Joel Falconer"}],"creator":["Joel Falconer"],"keywords":[],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "blogs");
		googletag.pubads().setTargeting("post_id", "171469");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #075858 }
  a.t-color:hover,
  button.t-color:hover { color: #108787 }

  .t-bg { background-color: #075858 }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #108787}

  .t-border { border-color: #075858 }
  a.t-border:hover,
  button.t-border:hover { border-color: #108787 }

  .t-bg-dark { background-color: #108787 }

  .t-list li:before { background-color: #075858; }

</style>
  </head>
  <body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
        <header class="main-header u-isSingle" role="banner">
      <nav id="navigation-bar" class="l-d-f l-p-fix l-w-100">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto">
          <section class="l-d-f l-ai-str l-jc-sta l-gs-ph2 l-gs-ph1--2col">
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-f l-as-cen l-b-n">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
            </a>
          </section>
          <section id="hamburger-container" class="l-ai-cen l-d-f l-gs-ph1">
            <div class="hamburger">
              <div class="hamburger-box">
                <div class="hamburger-inner"></div>
              </div>
            </div>
          </section>

          <section id="nav-container" class="l-ai-cen">
            <ul id="nav" class="l-d-f l-w-100 l-ma0 l-fd-col">
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a id="nav-blog" href="/blog" data-text="Blog">Blog</a>
              </li>
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a href="/community" data-text="Community">Community</a>
              </li>
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a href="/premium/topics/all" data-text="Library">Library</a>
              </li>
                              <div class="l-d-f--2col"><li class="l-gs-ph2 l-gs-ph1--2col t-ls-n invert"><a href="/premium/sign-in" data-text="Login">Login</a></li><a href="/premium/sign-up?ref_source=sitepoint&amp;ref_medium=topnav&amp;ref_campaign=sitepoint-premium-new-releases-devops-security-jquery-vue-projects&amp;ref_content=blogs" class="Button u-small u-pink l-as-cen l-d-n l-gs-ph1 l-gs-mh1 f-smaller f-small--3col">Free 7-Day Trial</a></div>
                          </ul>
          </section>
        </div>
      </nav>

      <div class="NavBar_offsetSpacer"></div>
      <script>
                var current_category = ['blogs'];
          if (localStorage.getItem('SP_categories') !== null) {
            if (localStorage.getItem('SP_categories').includes(current_category) === false ) {
              var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
              var temp = current_category.concat(sp_categories);
              var filtered_categories = Array.from(new Set(temp));
              localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
            }
          }else {
            localStorage.setItem('SP_categories', JSON.stringify('blogs'));
          }
            // campaign
            localStorage.setItem('SP_slug', 'sitepoint-premium-new-releases-devops-security-jquery-vue-projects');

        
        /* Toggle mobile navigation */
        var toggleMobileNav = function(event) {
          var target = event.target;
          if(target.className.includes("hamburger")) {
            document.getElementById("hamburger-container").classList.toggle("open");
          }
        }
        var isTouchSupported = 'ontouchstart' in window;
        var startEvent = isTouchSupported ? 'touchstart' : 'click';
        document.addEventListener(startEvent, toggleMobileNav);

        /* Set active navigation item  */
        var current_url = window.location.href;
        if (current_url.indexOf("/blog") > -1) {
          document.getElementById("nav-blog").classList.add("youarehere");
        }  
      </script>
          </header>
<div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol itemscope itemtype='https://schema.org/BreadcrumbList' class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'>
              <a
                itemprop='item'
                itemscope
                itemtype='https://schema.org/Thing'
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/blogs/">
                <span itemprop='name'>
                  blogs                </span>
              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
            >
                              <span itemprop='name'>
                  March 22, 2019                </span>
                          </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    itemprop='item'
                    itemscope
                    itemtype='https://schema.org/Thing'
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/jfalconer/">
                    <span itemprop='name'>
                      Joel Falconer                    </span>
                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">SitePoint Premium New Releases: DevOps Security, jQuery &#038; Vue Projects</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
                <div class="l-d-f l-jc-sb l-mt3 l-w-4col--4col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-">
      <div class='l-mt3 l-mh5--2col'>
      <p>We&#8217;re working hard to keep you on the cutting edge of your field with SitePoint Premium. We&#8217;ve got plenty of new books and mini-books to <a href="https://www.sitepoint.com/premium/">check out in the library</a> — let us introduce you to them.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225769learning-jquery.jpg" alt="" width="150" height="185" class="alignleft size-full wp-image-171471" /></p>
<h2 id="learningjquery3fifthedition">Learning jQuery 3 Fifth Edition</h2>
<p>A step-by-step, practical tutorial on creating efficient and smart web apps and high-performance interactive pages with jQuery 3.0. Create a fully featured and responsive client-side app using jQuery. Explore jQuery 3.0 features and code examples updated to reflect modern JS environments.</p>
<p>Read <a href="https://www.sitepoint.com/premium/books/learning-jquery-3-fifth-edition/">Learning jQuery 3 Fifth Edition</a>.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225779vue-storybook.jpg" alt="" width="150" height="188" class="alignleft size-full wp-image-171472" /></p>
<h2 id="howtodevelopandtestvuecomponentswithstorybook">How to Develop and Test Vue Components with Storybook</h2>
<p>Learn Storybook, an interactive environment for developing and testing UI components. It allows you to build components and play with them in isolation from the app that you&#8217;re building.</p>
<p>Read <a href="https://www.sitepoint.com/premium/books/how-to-develop-and-test-vue-components-with-storybook/">How to Develop and Test Vue Components with Storybook</a>.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225791vue-shopping.jpg" alt="" width="150" height="188" class="alignleft size-full wp-image-171473" /></p>
<h2 id="buildashoppinglistappwithvuevuexandbootstrapvue">Build a Shopping List App with Vue, Vuex and Bootstrap Vue</h2>
<p>Build a simple shopping list app using Vue, Vuex and Bootstrap. Along the way, you&#8217;ll discover how Vue&#8217;s official state management solution can help you manage state throughout your app as it grows.</p>
<p>Read <a href="https://www.sitepoint.com/premium/books/build-a-shopping-list-app-with-vue-vuex-and-bootstrap-vue/">Build a Shopping List App with Vue, Vuex and Bootstrap Vue</a>.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225801devops-security.jpg" alt="" width="150" height="185" class="alignleft size-full wp-image-171474" /></p>
<h2 id="handsonsecurityindevops">Hands-On Security in DevOps</h2>
<p>Protect your organization&#8217;s security at all levels with the latest strategies for securing DevOps at each layer of the pipeline. Discover security practices to protect your cloud services by detecting fraud and intrusion. Explore solutions to infrastructure security using DevOps principles.</p>
<p>Read <a href="https://www.sitepoint.com/premium/books/hands-on-security-in-devops/">Hands-On Security in DevOps</a>.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225811vue-headless.jpg" alt="" width="150" height="188" class="alignleft size-full wp-image-171475" /></p>
<h2 id="buildingavuefrontendforaheadlesscms">Building a Vue Front End for a Headless CMS</h2>
<p>Learn how to build a modern blog site using Vue.js and GraphCMS, a headless CMS platform that delivers content via GraphQL, for a faster and more customizable website than using WordPress.</p>
<p>Read <a href="https://www.sitepoint.com/premium/books/building-a-vue-front-end-for-a-headless-cms/">Building a Vue Front End for a Headless CMS</a>.</p>
<h2>A New Library Interface</h2>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2019/03/1553225956library.jpg" alt="" width="1200" height="960" class="aligncenter size-full wp-image-171476" /></p>
<p>If you&#8217;re a Premium member, check out our new library. We&#8217;ve launched a cleaner, faster library interface that makes tracking and resuming your current books much quicker.</p>
<h2 id="andmoretocome">And More to Come…</h2>
<p>We&#8217;re releasing new content on SitePoint Premium almost every day, so we&#8217;ll be back next week with the latest updates. And don&#8217;t forget: if you haven&#8217;t checked out our offering yet, take our <a href="https://www.sitepoint.com/premium/sign-up?step=0">7 day free trial for a spin</a>.</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/jfalconer/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2016/02/1456206971img-96x96.jpg" width="96" height="96" alt="Joel Falconer" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/jfalconer/">
                Joel Falconer              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/joelfalconer"><i class="fab fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/joelfalconer/"><i class="fab fa-linkedin-in"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3"><a href="http://www.joelfalconer.com/">Joel Falconer</a> is the managing editor of SitePoint. In the past he's worked at Envato, DesignCrowd, The Next Web and AppStorm.</div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
            <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <div>Sponsors</div>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-765"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_sponsor_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_sponsor_1'); }); </script> </div>

</div></div></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-763"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_side_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_1'); }); </script> </div>

</div></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html " id="maestro-728"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_side_2"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_2'); }); </script> </div>
</div></div><div class="widget maestro maestro-content-type-html " id="maestro-730"><div class="proper-ad-unit Sticky">

    <div id="proper-ad-sitepoint_side_3"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_3'); }); </script> </div>

</div></div>        <ads-weighted widget='21' data='{"NL":[{"id":"584","weight":"50","randMax":50},{"id":"585","weight":"50","randMax":100}]}' fallback='' url='sitepoint-premium-new-releases-devops-security-jquery-vue-projects' channelSlug='blogs'></ads-weighted></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
          </div>

      <div class="u-accordion-end"></div>
          <div class="l-pa3 l-mt4">
      <div class="t-t t-o-100"><div class="l-w-100 l-w-4col--4col l-mh-auto  l-d-f l-jc-sb l-fw-w l-ai-cen"><a href="/premium?q=&amp;limit=24&amp;offset=0&amp;page=1&amp;content_types[]=All&amp;slugs[]=blogs&amp;states[]=available&amp;order="><h4>Latest Blogs Books <i class="fa fa-angle-right"></i></h4></a></div><div class="l-d-n l-d-f--4col l-fw-w l-jc-sa l-pv4 l-w-4col l-mh-auto"><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/how-to-develop-and-test-vue-components-with-storybook"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/76c39f57-061f-44fb-9677-80730c36340a_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="f-mini f-light l-mb0">Ivaylo Gerchev</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">How to Develop and Test Vue Components with Storybook</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/learning-jquery-3-fifth-edition"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/570d5d36-907b-4588-a580-0be42d0a5198_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Learning jQuery 3 Fifth Edition</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/build-a-shopping-list-app-with-vue-vuex-and-bootstrap-vue"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/e97fe8e9-296c-425d-8436-f5c6aeb273e9_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="f-mini f-light l-mb0">Michael Wanyoike</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Build a Shopping List App with Vue, Vuex and Bootstrap Vue</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/hands-on-security-in-devops"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-workflow" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/97caeadb-fd1f-497e-a144-ddde69cc4c6e_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Hands-On Security in DevOps</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a></div><div class="l-d-n--4col l-d-f l-fw-w l-jc-sb l-pv4"><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/how-to-develop-and-test-vue-components-with-storybook"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/76c39f57-061f-44fb-9677-80730c36340a_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="l-d-n l-d-b--4col f-mini f-light">Ivaylo Gerchev<span>, 17 hours ago</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">How to Develop and Test Vue Components with Storybook</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/learning-jquery-3-fifth-edition"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/570d5d36-907b-4588-a580-0be42d0a5198_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Learning jQuery 3 Fifth Edition</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/build-a-shopping-list-app-with-vue-vuex-and-bootstrap-vue"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/e97fe8e9-296c-425d-8436-f5c6aeb273e9_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="l-d-n l-d-b--4col f-mini f-light">Michael Wanyoike<span>, 3 days ago</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Build a Shopping List App with Vue, Vuex and Bootstrap Vue</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/hands-on-security-in-devops"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-workflow" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/97caeadb-fd1f-497e-a144-ddde69cc4c6e_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Hands-On Security in DevOps</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div></div></div>
    </div>
    <div class="l-d-f l-jc-cen l-w-100 l-mb4">
      <a href="/premium?q=&limit=24&offset=0&page=1&content_types[]=All&slugs[]=blogs&states[]=available&order=" class="Button u-large">All Blogs Books</a>
    </div>
          <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                      </div>
        </div>
      </div>

    
    <script>
      let data = 'blogs';
      if (localStorage && localStorage.SP_categories) {
        data = JSON.parse(localStorage.SP_categories).toString();
        data = data ? data.replace('-', '') : 'blogs'
      }

      oSpP && oSpP.push('channel', data);
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fas fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2019 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <sp-cookie-warning></sp-cookie-warning>
    

<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<div class="widget maestro maestro-content-type-html " id="maestro-758"><script id="spout-tag-7c887d1e-c4ea-4682-bad8-216a89ce74e5">
  (function() {
    var r = encodeURIComponent(top.document.referrer.substring(0,250)),
        p = encodeURIComponent(top.document.location.href.substring(0,250)),
        t = Date.now(),
        u = '7c887d1e-c4ea-4682-bad8-216a89ce74e5',
        e = document.createElement('script'),
        s = sessionStorage.getItem('spoutable-' + u);
    if (!s) {
      var m = Math.random.bind(Math);
      s = JSON.stringify({ sessionId: [ t, m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m() ]});
      sessionStorage.setItem('spoutable-' + u, s);
    }
    e.async = true;
    e.src='//s.spoutable.com/s?u='+u+'&s='+encodeURIComponent(s)+'&t='+t+'&r='+r+'&p='+p;
    document.head.appendChild(e);
  })();
</script></div><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-746"><div id="Sticky--bottom" class="l-d-f l-p-fix l-jc-cen u-fixed l-pt3 l-w-100 l-pt3">
<div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_main_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_main_1'); }); </script> </div>
</div>
<i class="fas fa-times bottom-ad-close-button l-p-a"></i>
</div></div><script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-77d7df963c349e8aaeb6f2c765ce9a6e.js?ver=4.9.8'></script>
<script type="text/javascript" src="/dist/js/compiled.722e2b01a90e7cb60e0b.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 35/64 objects using memcached
Page Caching using memcached 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2019-03-22 10:16:08 by W3 Total Cache
-->