<!DOCTYPE html><html lang="en"><head><meta charSet="utf-8"/><meta http-equiv="x-ua-compatible" content="ie=edge"/><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"/><style data-href="/styles.fd20db7a16e3f9d08ca4.css" id="gatsby-global-css">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</style><meta name="generator" content="Gatsby 3.5.0"/><title data-react-helmet="true">Craig Buckler, Author at SitePoint - Page 4</title><link data-react-helmet="true" rel="canonical" href="https://www.sitepoint.com/author/craig-buckler/page/4/"/><link data-react-helmet="true" href="/favicons/32x32.png" rel="icon" type="image/png"/><link data-react-helmet="true" href="//dab1nmslvvntp.cloudfront.net"/><link data-react-helmet="true" href="//d2sis3lil8ndrq.cloudfront.net"/><link data-react-helmet="true" href="https://bid.g.doubleclick.net"/><meta data-react-helmet="true" name="description" content="Craig is a freelance UK web consultant who built his first page for IE2.0 in 1995. Since that time he&#x27;s been advocating standards, accessibility, and best-practice HTML5 techniques. He&#x27;s created enterprise specifications, websites and online applications for companies and organisations including the UK Parliament, the European Parliament, the Department of Energy &amp;amp; Climate Change, Microsoft, and more. He&#x27;s written more than 1,000 articles for SitePoint and you can find him &lt;a href=&quot;http://twitter.com/craigbuckler&quot;&gt;@craigbuckler&lt;/a&gt;. - Page 4"/><meta data-react-helmet="true" property="og:title" content="Craig Buckler, Author at SitePoint - Page 4"/><meta data-react-helmet="true" property="og:description" content="Craig is a freelance UK web consultant who built his first page for IE2.0 in 1995. Since that time he&#x27;s been advocating standards, accessibility, and best-practice HTML5 techniques. He&#x27;s created enterprise specifications, websites and online applications for companies and organisations including the UK Parliament, the European Parliament, the Department of Energy &amp;amp; Climate Change, Microsoft, and more. He&#x27;s written more than 1,000 articles for SitePoint and you can find him &lt;a href=&quot;http://twitter.com/craigbuckler&quot;&gt;@craigbuckler&lt;/a&gt;. - Page 4"/><meta data-react-helmet="true" property="og:type" content="website"/><meta data-react-helmet="true" property="og:image"/><meta data-react-helmet="true" property="twitter:account_id" content="15743570"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:image"/><meta data-react-helmet="true" name="twitter:title" content="Craig Buckler, Author at SitePoint - Page 4"/><meta data-react-helmet="true" name="twitter:description" content="Craig is a freelance UK web consultant who built his first page for IE2.0 in 1995. Since that time he&#x27;s been advocating standards, accessibility, and best-practice HTML5 techniques. He&#x27;s created enterprise specifications, websites and online applications for companies and organisations including the UK Parliament, the European Parliament, the Department of Energy &amp;amp; Climate Change, Microsoft, and more. He&#x27;s written more than 1,000 articles for SitePoint and you can find him &lt;a href=&quot;http://twitter.com/craigbuckler&quot;&gt;@craigbuckler&lt;/a&gt;. - Page 4"/><script data-react-helmet="true" type="text/javascript" async="">(function() {
  var host = 'www.sitepoint.com';
  var element = document.createElement('script');
  var firstScript = document.getElementsByTagName('script')[0];
  var url = 'https://quantcast.mgr.consensu.org'
    .concat('/choice/', 'DsckBJsAJpkVK', '/', host, '/choice.js')
  var uspTries = 0;
  var uspTriesLimit = 3;
  element.async = true;
  element.type = 'text/javascript';
  element.src = url;

  firstScript.parentNode.insertBefore(element, firstScript);

  function makeStub() {
    var TCF_LOCATOR_NAME = '__tcfapiLocator';
    var queue = [];
    var win = window;
    var cmpFrame;

    function addFrame() {
      var doc = win.document;
      var otherCMP = !!(win.frames[TCF_LOCATOR_NAME]);

      if (!otherCMP) {
        if (doc.body) {
          var iframe = doc.createElement('iframe');

          iframe.style.cssText = 'display:none';
          iframe.name = TCF_LOCATOR_NAME;
          doc.body.appendChild(iframe);
        } else {
          setTimeout(addFrame, 5);
        }
      }
      return !otherCMP;
    }

    function tcfAPIHandler() {
      var gdprApplies;
      var args = arguments;

      if (!args.length) {
        return queue;
      } else if (args[0] === 'setGdprApplies') {
        if (
          args.length > 3 &&
          args[2] === 2 &&
          typeof args[3] === 'boolean'
        ) {
          gdprApplies = args[3];
          if (typeof args[2] === 'function') {
            args[2]('set', true);
          }
        }
      } else if (args[0] === 'ping') {
        var retr = {
          gdprApplies: gdprApplies,
          cmpLoaded: false,
          cmpStatus: 'stub'
        };

        if (typeof args[2] === 'function') {
          args[2](retr);
        }
      } else {
        queue.push(args);
      }
    }

    function postMessageEventHandler(event) {
      var msgIsString = typeof event.data === 'string';
      var json = {};

      try {
        if (msgIsString) {
          json = JSON.parse(event.data);
        } else {
          json = event.data;
        }
      } catch (ignore) {}

      var payload = json.__tcfapiCall;

      if (payload) {
        window.__tcfapi(
          payload.command,
          payload.version,
          function(retValue, success) {
            var returnMsg = {
              __tcfapiReturn: {
                returnValue: retValue,
                success: success,
                callId: payload.callId
              }
            };
            if (msgIsString) {
              returnMsg = JSON.stringify(returnMsg);
            }
            event.source.postMessage(returnMsg, '*');
          },
          payload.parameter
        );
      }
    }

    while (win) {
      try {
        if (win.frames[TCF_LOCATOR_NAME]) {
          cmpFrame = win;
          break;
        }
      } catch (ignore) {}

      if (win === window.top) {
        break;
      }
      win = win.parent;
    }
    if (!cmpFrame) {
      addFrame();
      win.__tcfapi = tcfAPIHandler;
      win.addEventListener('message', postMessageEventHandler, false);
    }
  };

  makeStub();

  var uspStubFunction = function() {
    var arg = arguments;
    if (typeof window.__uspapi !== uspStubFunction) {
      setTimeout(function() {
        if (typeof window.__uspapi !== 'undefined') {
          window.__uspapi.apply(window.__uspapi, arg);
        }
      }, 500);
    }
  };

  var checkIfUspIsReady = function() {
    uspTries++;
    if (window.__uspapi === uspStubFunction && uspTries < uspTriesLimit) {
      console.warn('USP is not accessible');
    } else {
      clearInterval(uspInterval);
    }
  };

  if (typeof window.__uspapi === 'undefined') {
    window.__uspapi = uspStubFunction;
    var uspInterval = setInterval(checkIfUspIsReady, 6000);
  }
})();</script><style>.gatsby-image-wrapper{position:relative;overflow:hidden}.gatsby-image-wrapper img{all:inherit;bottom:0;height:100%;left:0;margin:0;max-width:none;padding:0;position:absolute;right:0;top:0;width:100%;object-fit:cover}.gatsby-image-wrapper [data-main-image]{opacity:0;transform:translateZ(0);transition:opacity .25s linear;will-change:opacity}.gatsby-image-wrapper-constrained{display:inline-block}</style><noscript><style>.gatsby-image-wrapper noscript [data-main-image]{opacity:1!important}.gatsby-image-wrapper [data-placeholder-image]{opacity:0!important}</style></noscript><script type="module">const e="undefined"!=typeof HTMLImageElement&&"loading"in HTMLImageElement.prototype;e&&document.body.addEventListener("load",(function(e){if(void 0===e.target.dataset.mainImage)return;if(void 0===e.target.dataset.gatsbyImageSsr)return;const t=e.target;let a=null,n=t;for(;null===a&&n;)void 0!==n.parentNode.dataset.gatsbyImageWrapper&&(a=n.parentNode),n=n.parentNode;const o=a.querySelector("[data-placeholder-image]"),r=new Image;r.src=t.currentSrc,r.decode().catch((()=>{})).then((()=>{t.style.opacity=1,o&&(o.style.opacity=0,o.style.transition="opacity 500ms linear")}))}),!0);</script><script>window.dataLayer = window.dataLayer || [];window.dataLayer.push({"platform":"gatsby"}); (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src= 'https://www.googletagmanager.com/gtm.js?id='+i+dl+'';f.parentNode.insertBefore(j,f); })(window,document,'script','dataLayer', 'GTM-KL8PMMW');</script><link rel="manifest" href="/manifest.webmanifest" crossorigin="anonymous"/><meta name="theme-color" content="#3a3a3a"/><link rel="apple-touch-icon" sizes="48x48" href="/favicons/48x48.png"/><link rel="apple-touch-icon" sizes="72x72" href="/favicons/72x72.png"/><link rel="apple-touch-icon" sizes="96x96" href="/favicons/96x96.png"/><link rel="apple-touch-icon" sizes="144x144" href="/favicons/144x144.png"/><link rel="apple-touch-icon" sizes="192x192" href="/favicons/192x192.png"/><link rel="apple-touch-icon" sizes="256x256" href="/favicons/256x256.png"/><link rel="apple-touch-icon" sizes="384x384" href="/favicons/384x384.png"/><link rel="apple-touch-icon" sizes="512x512" href="/favicons/512x512.png"/><style>@font-face{font-family:Roboto;font-style:italic;font-weight:300;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TjASc6CsI.woff) format("woff")}@font-face{font-family:Roboto;font-style:italic;font-weight:400;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOkCnqEu92Fr1Mu51xIIzQ.woff) format("woff")}@font-face{font-family:Roboto;font-style:italic;font-weight:500;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51S7ACc6CsI.woff) format("woff")}@font-face{font-family:Roboto;font-style:italic;font-weight:700;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TzBic6CsI.woff) format("woff")}@font-face{font-family:Roboto;font-style:italic;font-weight:900;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TLBCc6CsI.woff) format("woff")}@font-face{font-family:Roboto;font-style:normal;font-weight:300;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmSU5fBBc-.woff) format("woff")}@font-face{font-family:Roboto;font-style:normal;font-weight:400;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOmCnqEu92Fr1Mu4mxM.woff) format("woff")}@font-face{font-family:Roboto;font-style:normal;font-weight:500;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmEU9fBBc-.woff) format("woff")}@font-face{font-family:Roboto;font-style:normal;font-weight:700;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmWUlfBBc-.woff) format("woff")}@font-face{font-family:Roboto;font-style:normal;font-weight:900;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmYUtfBBc-.woff) format("woff")}@font-face{font-family:Roboto;font-style:italic;font-weight:300;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TjASc6CsQ.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:italic;font-weight:400;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOkCnqEu92Fr1Mu51xIIzI.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:italic;font-weight:500;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51S7ACc6CsQ.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:italic;font-weight:700;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TzBic6CsQ.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:italic;font-weight:900;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOjCnqEu92Fr1Mu51TLBCc6CsQ.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:normal;font-weight:300;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmSU5fBBc4.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:normal;font-weight:400;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOmCnqEu92Fr1Mu4mxK.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:normal;font-weight:500;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmEU9fBBc4.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:normal;font-weight:700;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmWUlfBBc4.woff2) format("woff2")}@font-face{font-family:Roboto;font-style:normal;font-weight:900;font-display:swap;src:url(/static/webfonts/s/roboto/v27/KFOlCnqEu92Fr1MmYUtfBBc4.woff2) format("woff2")}</style><link rel="preconnect" href="https://cdn.sanity.io"/><link rel="sitemap" type="application/xml" href="/sitemap.xml"/><link rel="alternate" type="application/rss+xml" title="SitePoint" href="/sitepoint.rss"/><link as="script" rel="preload" href="/webpack-runtime-e447793b1f68dfc83ae3.js"/><link as="script" rel="preload" href="/framework-9e1d3bc9c6d0e2137f08.js"/><link as="script" rel="preload" href="/ec1189df-1d42d02c0d3b321dd3c9.js"/><link as="script" rel="preload" href="/af13d906-1932a438ec612a66348c.js"/><link as="script" rel="preload" href="/a9a7754c-ed6fc4875d4344a7c426.js"/><link as="script" rel="preload" href="/app-cd68b425007a5cc70b08.js"/><link as="fetch" rel="preload" href="/page-data/author/craig-buckler/page/4/page-data.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/1047298929.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/1108168975.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/1408741470.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/3000541721.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/3448431816.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/sq/d/803733183.json" crossorigin="anonymous"/><link as="fetch" rel="preload" href="/page-data/app-data.json" crossorigin="anonymous"/></head><body><noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW" height="0" width="0" style="display: none; visibility: hidden" aria-hidden="true"></iframe></noscript><div id="___gatsby"><div style="outline:none" tabindex="-1" id="gatsby-focus-wrapper"><div data-display="true" class="s13se1v"></div><header class="szqta7"><a id="skip-navigation" href="#main-content" class="s40erwn">Skip to main content</a><nav aria-label="Menu bar" class="nj1r5zu"><div class="c19tig4s"><a aria-label="SitePoint" class="lwzbxzs" href="/"><svg viewBox="0 0 123 27" role="img" focusable="false"><title>SitePoint</title><g fill-rule="evenodd"><path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path><path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path><path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path><path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path><path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path><path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path><path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path><path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path><path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path><path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path><path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path><path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path><path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path></g></svg></a><button type="button" data-toggle="main-nav" aria-label="Toggle navigation" aria-controls="main-nav" class="h1sloftb"><span></span></button><ul id="main-nav" class="napbdwr"><li class="ns13f0v"><a data-text="Blog" class="ny3bhvl" href="/blog/">Blog</a></li><li class="ns13f0v"><a data-text="Community" href="/community/" class="ny3bhvl">Community</a></li><li class="ns13f0v"><a data-text="Jobs" href="/jobs/" class="ny3bhvl">Jobs</a></li><li class="ns13f0v"><a data-text="Library" href="/premium/library/" class="ny3bhvl">Library</a></li><li class="ns13f0v"><a data-text="Login" href="/premium/sign-in/" class="ny3bhvl">Login</a></li></ul><a data-color="pink" data-type="default" data-size="default" id="join-premium" href="/premium/products/Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvMzA3" target="_blank" class="jglk3p4 s65o7al">Join Premium</a></div></nav></header><main id="main-content" class="wj3nsdq" style="--wj3nsdq-0:0 auto;--wj3nsdq-1:none;--wj3nsdq-2:none"><article aria-label="Article title: Craig Buckler"><section class="suhqeno" style="--suhqeno-0:url(https://uploads.sitepoint.com/wp-content/uploads/2020/04/1586298076bg_header.svg#authors)"><div class="wcqh0z5"><header class="im6tdkb"><div class="m6bjvs0"><div><h1 class="td3jbbo">Craig Buckler</h1><div class="cxli7a9"><a href="http://www.facebook.com/craigbuckler" rel="noreferrer noopener" target="_blank" aria-label="Craig Buckler&#x27;s facebook account" class="c14zotb4"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="facebook-square" class="svg-inline--fa fa-facebook-square fa-w-14 fa-lg share-icon" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48A48 48 0 0 0 0 80v352a48 48 0 0 0 48 48h137.25V327.69h-63V256h63v-54.64c0-62.15 37-96.48 93.67-96.48 27.14 0 55.52 4.84 55.52 4.84v61h-31.27c-30.81 0-40.42 19.12-40.42 38.73V256h68.78l-11 71.69h-57.78V480H400a48 48 0 0 0 48-48V80a48 48 0 0 0-48-48z"></path></svg></a><a href="https://github.com/craigbuckler" rel="noreferrer noopener" target="_blank" aria-label="Craig Buckler&#x27;s github account" class="c14zotb4"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="github-square" class="svg-inline--fa fa-github-square fa-w-14 fa-lg share-icon" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.5 32 0 53.5 0 80v352c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48V80c0-26.5-21.5-48-48-48zM277.3 415.7c-8.4 1.5-11.5-3.7-11.5-8 0-5.4.2-33 .2-55.3 0-15.6-5.2-25.5-11.3-30.7 37-4.1 76-9.2 76-73.1 0-18.2-6.5-27.3-17.1-39 1.7-4.3 7.4-22-1.7-45-13.9-4.3-45.7 17.9-45.7 17.9-13.2-3.7-27.5-5.6-41.6-5.6-14.1 0-28.4 1.9-41.6 5.6 0 0-31.8-22.2-45.7-17.9-9.1 22.9-3.5 40.6-1.7 45-10.6 11.7-15.6 20.8-15.6 39 0 63.6 37.3 69 74.3 73.1-4.8 4.3-9.1 11.7-10.6 22.3-9.5 4.3-33.8 11.7-48.3-13.9-9.1-15.8-25.5-17.1-25.5-17.1-16.2-.2-1.1 10.2-1.1 10.2 10.8 5 18.4 24.2 18.4 24.2 9.7 29.7 56.1 19.7 56.1 19.7 0 13.9.2 36.5.2 40.6 0 4.3-3 9.5-11.5 8-66-22.1-112.2-84.9-112.2-158.3 0-91.8 70.2-161.5 162-161.5S388 165.6 388 257.4c.1 73.4-44.7 136.3-110.7 158.3zm-98.1-61.1c-1.9.4-3.7-.4-3.9-1.7-.2-1.5 1.1-2.8 3-3.2 1.9-.2 3.7.6 3.9 1.9.3 1.3-1 2.6-3 3zm-9.5-.9c0 1.3-1.5 2.4-3.5 2.4-2.2.2-3.7-.9-3.7-2.4 0-1.3 1.5-2.4 3.5-2.4 1.9-.2 3.7.9 3.7 2.4zm-13.7-1.1c-.4 1.3-2.4 1.9-4.1 1.3-1.9-.4-3.2-1.9-2.8-3.2.4-1.3 2.4-1.9 4.1-1.5 2 .6 3.3 2.1 2.8 3.4zm-12.3-5.4c-.9 1.1-2.8.9-4.3-.6-1.5-1.3-1.9-3.2-.9-4.1.9-1.1 2.8-.9 4.3.6 1.3 1.3 1.8 3.3.9 4.1zm-9.1-9.1c-.9.6-2.6 0-3.7-1.5s-1.1-3.2 0-3.9c1.1-.9 2.8-.2 3.7 1.3 1.1 1.5 1.1 3.3 0 4.1zm-6.5-9.7c-.9.9-2.4.4-3.5-.6-1.1-1.3-1.3-2.8-.4-3.5.9-.9 2.4-.4 3.5.6 1.1 1.3 1.3 2.8.4 3.5zm-6.7-7.4c-.4.9-1.7 1.1-2.8.4-1.3-.6-1.9-1.7-1.5-2.6.4-.6 1.5-.9 2.8-.4 1.3.7 1.9 1.8 1.5 2.6z"></path></svg></a><a href="http://www.linkedin.com/in/craigbuckler" rel="noreferrer noopener" target="_blank" aria-label="Craig Buckler&#x27;s linkedin account" class="c14zotb4"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="linkedin" class="svg-inline--fa fa-linkedin fa-w-14 fa-lg share-icon" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M416 32H31.9C14.3 32 0 46.5 0 64.3v383.4C0 465.5 14.3 480 31.9 480H416c17.6 0 32-14.5 32-32.3V64.3c0-17.8-14.4-32.3-32-32.3zM135.4 416H69V202.2h66.5V416zm-33.2-243c-21.3 0-38.5-17.3-38.5-38.5S80.9 96 102.2 96c21.2 0 38.5 17.3 38.5 38.5 0 21.3-17.2 38.5-38.5 38.5zm282.1 243h-66.4V312c0-24.8-.5-56.7-34.5-56.7-34.6 0-39.9 27-39.9 54.9V416h-66.4V202.2h63.7v29.2h.9c8.9-16.8 30.6-34.5 62.9-34.5 67.2 0 79.7 44.3 79.7 101.9V416z"></path></svg></a><a href="https://twitter.com/craigbuckler" rel="noreferrer noopener" target="_blank" aria-label="Craig Buckler&#x27;s twitter account" class="c14zotb4"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter-square" class="svg-inline--fa fa-twitter-square fa-w-14 fa-lg share-icon" role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.5 32 0 53.5 0 80v352c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48V80c0-26.5-21.5-48-48-48zm-48.9 158.8c.2 2.8.2 5.7.2 8.5 0 86.7-66 186.6-186.6 186.6-37.2 0-71.7-10.8-100.7-29.4 5.3.6 10.4.8 15.8.8 30.7 0 58.9-10.4 81.4-28-28.8-.6-53-19.5-61.3-45.5 10.1 1.5 19.2 1.5 29.6-1.2-30-6.1-52.5-32.5-52.5-64.4v-.8c8.7 4.9 18.9 7.9 29.6 8.3a65.447 65.447 0 0 1-29.2-54.6c0-12.2 3.2-23.4 8.9-33.1 32.3 39.8 80.8 65.8 135.2 68.6-9.3-44.5 24-80.6 64-80.6 18.9 0 35.9 7.9 47.9 20.7 14.8-2.8 29-8.3 41.6-15.8-4.9 15.2-15.2 28-28.8 36.1 13.2-1.4 26-5.1 37.8-10.2-8.9 13.1-20.1 24.7-32.9 34z"></path></svg></a></div></div></div><div class="m1odfayv"><div><img src="https://secure.gravatar.com/avatar/439aeaff7de2bae365adc3eb4947b44d?s=96&amp;#038;d=mm&amp;#038;r=g" alt="Craig Buckler" loading="lazy" class="ajqjnq"/><p class="d17w3rty">Craig is a freelance UK web consultant who built his first page for IE2.0 in 1995. Since that time he's been advocating standards, accessibility, and best-practice HTML5 techniques. He's created enterprise specifications, websites and online applications for companies and organisations including the UK Parliament, the European Parliament, the Department of Energy &amp; Climate Change, Microsoft, and more. He's written more than 1,000 articles for SitePoint and you can find him <a href="http://twitter.com/craigbuckler">@craigbuckler</a>.</p></div></div></header></div></section><section class="sprezz4"><h2 class="s7dxtzg">Craig&#x27;s articles</h2><article class="s1ym2p63"><a href="/shared-server-hosting/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2016/10/1475909933server-cogwheel.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">Shared Server Hosting: the Pros and Cons</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#1c94c6">Web</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-04-21T09:30:16">April 21, 2017</time></p></div><p class="ejt0qrr">The range of hosting options has become bewilderingly complex. Craig discusses the advantages and disadvantages of choosing a shared server option.</p></div></a></article><article class="s1ym2p63"><a href="/dedicated-server-hosting/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2016/10/1475909933server-cogwheel.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">Dedicated Server Hosting: the Pros and Cons</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#1c94c6">Web</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-04-20T09:30:56">April 20, 2017</time></p></div><p class="ejt0qrr">When you're new to the world of internet hosting, figuring out all options can be tough. In this article, Craig Buckler explains the dedicated server.</p></div></a></article><article class="s1ym2p63"><a href="/key-takeaways-stack-overflow-2017-developer-survey/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/04/1492530590survey_feature.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">Web Industry Insights 2017</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#1c94c6">Web</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-04-18T15:00:13">April 18, 2017</time></p></div><p class="ejt0qrr">Craig discusses the tools, languages and career satisfaction levels of 64,000 developers who completed the 2017 Stack Overflow survey.</p></div></a></article><article class="s1ym2p63"><a href="/social-media-2-augmented-reality/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/03/1489144905077-social-media-phone.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">Social Media 2.0: Real Life Augmentation</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#1c94c6">Web</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-04-01T00:01:27">April 01, 2017</time></p></div><p class="ejt0qrr">The next generation of social media is here. Your devices will integrate augmented reality to end the distinction between your real and online lives.</p></div></a></article><article class="s1ym2p63"><a href="/synchronize-wordpress-live-development-databases/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2014/11/1415473542Fotolia_42677898_Subscription_Monthly_M-Small.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">How to Synchronize WordPress Live and Development Databases</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#666699">PHP</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-31T12:30:36">March 31, 2017</time></p></div><p class="ejt0qrr">Developing WordPress themes and plugins on a local server can be problematic if it doesn't match your live system. Craig discusses synchronization options.</p></div></a></article><article class="s1ym2p63"><a href="/make-wordpress-simpler-users/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2016/07/1469244667cms.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">7 Ways to Make WordPress Simpler for Users</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#248aaf">WordPress</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-29T15:30:56">March 29, 2017</time></p></div><p class="ejt0qrr">Despite being one of the easier Content Management Systems, WordPress can be bewildering for some users. Fortunately, the experience can be simplified.</p></div></a></article><article class="s1ym2p63"><a href="/how-to-create-wordpress-mysql-databases-on-cpanel/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/03/1489989703filing.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">How to Create WordPress MySQL Databases on cPanel</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#248aaf">WordPress</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-22T10:30:26">March 22, 2017</time></p></div><p class="ejt0qrr">Craig's simple tutorial is for anyone who's ever struggled to install a WordPress MySQL database using cPanel. That's everyone, right?!</p></div></a></article><article class="s1ym2p63"><a href="/what-is-http2/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/02/1487712032if-junction.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">What is HTTP/2?</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#1c94c6">Web</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-17T16:00:48">March 17, 2017</time></p></div><p class="ejt0qrr">HTTP/2 will eventually supersede HTTP/1.1. What is it? Can you use it today? Do you need to update your website? Craig Buckler provides the answers.</p></div></a></article><article class="s1ym2p63"><a href="/10-features-to-look-for-in-a-premium-wordpress-theme/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/03/1488953756frontline-creative-178990.jpg" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">10 Features to Look for in a Premium WordPress Theme</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#248aaf">WordPress</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-15T09:00:20">March 15, 2017</time></p></div><p class="ejt0qrr">Craig Buckler looks at ten considerations to help you make the best choice when purchasing a premium WordPress theme.</p></div></a></article><article class="s1ym2p63"><a href="/pass-parameters-gulp-tasks/"><div data-bg="https://uploads.sitepoint.com/wp-content/uploads/2017/03/1489445315js15-01.png" class="lazyload f13hvvvv"></div><div class="c16injma"><h3 class="t12xxw3g">How to Pass Command Line Parameters to Gulp Tasks</h3><div class="ms9srjd"><span class="ctub9nm" style="--ctub9nm-4:#f6b33c">JavaScript</span><p class="m11jemzk"><span>By <!-- -->Craig Buckler</span>, <time dateTime="2017-03-13T15:00:26">March 13, 2017</time></p></div><p class="ejt0qrr">Have you ever wanted to write Gulp Tasks that accept command line arguments? Craig Buckler shows you how and covers some potential use cases.</p></div></a></article><nav aria-label="Page Navigation"><ul class="pg2pojl"><li type="prev" class="p1q14x1v" style="--p1q14x1v-0:0"><a rel="prev" class="psmqk2r" href="/author/craig-buckler/page/3/">← Previous</a></li></ul></nav></section></article></main><footer class="syzew71"><nav aria-label="Footer navigation"><div class="crfuex9"><div class="footer-links"><ul><li><h2>Stuff we do</h2></li><li><a href="/premium">Premium</a></li><li><a href="/newsletters">Newsletters</a></li><li><a href="/community">Forums</a></li><li><a href="/premium/deals">Deals</a></li><li><a href="/jobs">Remote Jobs</a></li></ul><ul><li><h2>About</h2></li><li><a href="/about-us">Our story</a></li><li><a href="/legals">Terms of use</a></li><li><a href="/privacy-policy">Privacy policy</a></li><li><a href="https://sitepoint.typeform.com/to/fNY7XG">Corporate memberships</a></li></ul><ul><li><h2>Contact</h2></li><li><a href="/contact-us">Contact us</a></li><li><a href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a></li><li><a href="https://sitepoint.typeform.com/to/HtAXVN">Publish your book with us</a></li><li><a href="/write-for-us">Write an article for us</a></li><li><a href="/advertise">Advertise</a></li></ul></div><div class="s1no14m2"></div><div class="footer-extra"><ul><li><h2>Connect</h2></li><li><a href="https://www.facebook.com/sitepoint" rel="noopener noreferrer" target="_blank" aria-label="See sitepoint facebook account"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="facebook-square" class="svg-inline--fa fa-facebook-square fa-w-14 fa-lg " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48A48 48 0 0 0 0 80v352a48 48 0 0 0 48 48h137.25V327.69h-63V256h63v-54.64c0-62.15 37-96.48 93.67-96.48 27.14 0 55.52 4.84 55.52 4.84v61h-31.27c-30.81 0-40.42 19.12-40.42 38.73V256h68.78l-11 71.69h-57.78V480H400a48 48 0 0 0 48-48V80a48 48 0 0 0-48-48z"></path></svg></a><a href="http://twitter.com/sitepointdotcom" rel="noopener noreferrer" target="_blank" aria-label="See sitepoint twitter account"><svg aria-hidden="true" focusable="false" data-prefix="fab" data-icon="twitter-square" class="svg-inline--fa fa-twitter-square fa-w-14 fa-lg " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.5 32 0 53.5 0 80v352c0 26.5 21.5 48 48 48h352c26.5 0 48-21.5 48-48V80c0-26.5-21.5-48-48-48zm-48.9 158.8c.2 2.8.2 5.7.2 8.5 0 86.7-66 186.6-186.6 186.6-37.2 0-71.7-10.8-100.7-29.4 5.3.6 10.4.8 15.8.8 30.7 0 58.9-10.4 81.4-28-28.8-.6-53-19.5-61.3-45.5 10.1 1.5 19.2 1.5 29.6-1.2-30-6.1-52.5-32.5-52.5-64.4v-.8c8.7 4.9 18.9 7.9 29.6 8.3a65.447 65.447 0 0 1-29.2-54.6c0-12.2 3.2-23.4 8.9-33.1 32.3 39.8 80.8 65.8 135.2 68.6-9.3-44.5 24-80.6 64-80.6 18.9 0 35.9 7.9 47.9 20.7 14.8-2.8 29-8.3 41.6-15.8-4.9 15.2-15.2 28-28.8 36.1 13.2-1.4 26-5.1 37.8-10.2-8.9 13.1-20.1 24.7-32.9 34z"></path></svg></a><a href="/feed" rel="noopener noreferrer" target="_blank" aria-label="See sitepoint RSS feed"><svg aria-hidden="true" focusable="false" data-prefix="fas" data-icon="rss-square" class="svg-inline--fa fa-rss-square fa-w-14 fa-lg " role="img" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 448 512"><path fill="currentColor" d="M400 32H48C21.49 32 0 53.49 0 80v352c0 26.51 21.49 48 48 48h352c26.51 0 48-21.49 48-48V80c0-26.51-21.49-48-48-48zM112 416c-26.51 0-48-21.49-48-48s21.49-48 48-48 48 21.49 48 48-21.49 48-48 48zm157.533 0h-34.335c-6.011 0-11.051-4.636-11.442-10.634-5.214-80.05-69.243-143.92-149.123-149.123-5.997-.39-10.633-5.431-10.633-11.441v-34.335c0-6.535 5.468-11.777 11.994-11.425 110.546 5.974 198.997 94.536 204.964 204.964.352 6.526-4.89 11.994-11.425 11.994zm103.027 0h-34.334c-6.161 0-11.175-4.882-11.427-11.038-5.598-136.535-115.204-246.161-251.76-251.76C68.882 152.949 64 147.935 64 141.774V107.44c0-6.454 5.338-11.664 11.787-11.432 167.83 6.025 302.21 141.191 308.205 308.205.232 6.449-4.978 11.787-11.432 11.787z"></path></svg></a></li></ul><div><p>© 2000 – <!-- -->2021<!-- --> SitePoint Pty. Ltd.</p><p class="recaptcha-branding">This site is protected by reCAPTCHA and the Google<a href="https://policies.google.com/privacy"> Privacy Policy </a>and<a href="https://policies.google.com/terms"> Terms of Service </a>apply.</p></div></div></div></nav></footer></div><div id="gatsby-announcer" style="position:absolute;top:0;width:1px;height:1px;padding:0;overflow:hidden;clip:rect(0, 0, 0, 0);white-space:nowrap;border:0" aria-live="assertive" aria-atomic="true"></div></div><script id="gatsby-script-loader">/*<![CDATA[*/window.pagePath="/author/craig-buckler/page/4/";/*]]>*/</script><script id="gatsby-chunk-mapping">/*<![CDATA[*/window.___chunkMapping={"polyfill":["/polyfill-7b73c51c960df52c0af1.js"],"app":["/app-cd68b425007a5cc70b08.js"]};/*]]>*/</script><script src="/polyfill-7b73c51c960df52c0af1.js" nomodule=""></script><script src="/app-cd68b425007a5cc70b08.js" async=""></script><script src="/a9a7754c-ed6fc4875d4344a7c426.js" async=""></script><script src="/af13d906-1932a438ec612a66348c.js" async=""></script><script src="/ec1189df-1d42d02c0d3b321dd3c9.js" async=""></script><script src="/framework-9e1d3bc9c6d0e2137f08.js" async=""></script><script src="/webpack-runtime-e447793b1f68dfc83ae3.js" async=""></script></body></html>