Im using win2k with iis5 running php 4.3. I took out the ; in front of the php_domxml.dll entry in the php.ini file and when i run phpinfo it shows it running. So I tried a tutorial from devarticles and am having problems. Below is the script I am running:

<?php
$xmlDoc = xmldocfile("test.xml");
$root = $xmlDoc->root();
$node = array_shift($root->children());
echo
$node->content;
?>

The test.xml file is:

<?xml version="1.0" encoding="ISO-8859-1"?>
<website>
<url>http://www.devarticles.com</url>
</website>

Now when the script runs it gives me this error if I dont use the full http path to the xml file:

Warning: xmldocfile() [function.xmldocfile]: warning: in c:\inetpub\wwwroot\survey\test.php on line 3

Warning: xmldocfile() [
function.xmldocfile]: failed to load external entity "test.xml" in c:\inetpub\wwwroot\survey\test.php on line 3

Fatal error: Call to a member function on a non-object in c:\inetpub\wwwroot\survey\test.php on line 5


But when I do put the full path in I get a blank page. I tried to echo out the world hi and it worked. So I believe that means the script worked. Just nothing is coming out. Any ideas? Hope this isnt to vague.

Silly