<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.php.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/113214561650167033983" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'php');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var purchs2s = purchs2s||{};
      purchs2s.cmd = purchs2s.cmd || [];
      purchs2s.timeout=500;
      (function() {
        var ps2s = document.createElement('script');
        ps2s.async = true;
        ps2s.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        ps2s.src = (useSSL ? 'https:' : 'http:') + '//ads.servebom.com/purchs2s.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(ps2s, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
    }]);
  </script>
        
<!-- This site is optimized with the Yoast SEO plugin v5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Git and Wordpress: How to Auto-Update Posts with Pull Requests &mdash; SitePoint</title>
<meta name="description" content="How compatible are git and wordpress? Let&#039;s see how easy it is to make WordPress posts auto-update based on PR submissions on the Github repository!"/>
<link rel="canonical" href="https://www.sitepoint.com/git-and-wordpress-how-to-auto-update-posts-with-pull-requests/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Git and Wordpress: How to Auto-Update Posts with Pull Requests &mdash; SitePoint" />
<meta property="og:description" content="How compatible are git and wordpress? Let&#039;s see how easy it is to make WordPress posts auto-update based on PR submissions on the Github repository!" />
<meta property="og:url" content="https://www.sitepoint.com/git-and-wordpress-how-to-auto-update-posts-with-pull-requests/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="auto deployment" />
<meta property="article:tag" content="automation" />
<meta property="article:tag" content="BrunoS" />
<meta property="article:tag" content="git" />
<meta property="article:tag" content="OOPHP" />
<meta property="article:tag" content="PHP" />
<meta property="article:tag" content="WordPress" />
<meta property="article:tag" content="workflow automation" />
<meta property="article:section" content="automation" />
<meta property="article:published_time" content="2017-10-18T14:54:17-07:00" />
<meta property="fb:admins" content="121300382" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/05/1495148199wordpress-mod.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/05/1495148199wordpress-mod.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="1269" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="How compatible are git and wordpress? Let&#039;s see how easy it is to make WordPress posts auto-update based on PR submissions on the Github repository!" />
<meta name="twitter:title" content="Git and Wordpress: How to Auto-Update Posts with Pull Requests &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/05/1495148199wordpress-mod.jpg" />
<meta name="twitter:creator" content="@bitfalls" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Git and WordPress: How to Auto-Update Posts with Pull Requests Comments Feed" href="https://www.sitepoint.com/git-and-wordpress-how-to-auto-update-posts-with-pull-requests/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.8.1' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.5a25ace8636ab92d3ffd.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.198612b145321809d889.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=160833' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fgit-and-wordpress-how-to-auto-update-posts-with-pull-requests%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fgit-and-wordpress-how-to-auto-update-posts-with-pull-requests%2F&#038;format=xml" />
<script data-cfasync="false" src="//load.sumome.com/" data-sumo-platform="wordpress" data-sumo-site-id="64b8e500e3524000ecfa2000d01e2100033e83009398f000ab804c005e0e4300" async></script><!-- BEGIN wp-parsely Plugin Version 1.10.2 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.10.2' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/git-and-wordpress-how-to-auto-update-posts-with-pull-requests\/"},"headline":"Git and WordPress: How to Auto-Update Posts with Pull Requests","url":"http:\/\/www.sitepoint.com\/git-and-wordpress-how-to-auto-update-posts-with-pull-requests\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/05\/1495148199wordpress-mod-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/05\/1495148199wordpress-mod-150x150.jpg"},"dateCreated":"2017-10-18T21:54:17Z","datePublished":"2017-10-18T21:54:17Z","dateModified":"2004-02-02T01:34:47Z","articleSection":"PHP","author":[{"@type":"Person","name":"Bruno Skvorc"}],"creator":["Bruno Skvorc"],"publisher":{"@type":"Organization","name":"SitePoint"},"keywords":["auto deployment","automation","brunos","git","oophp","php","wordpress","workflow automation"]}   </script>
    <!-- END wp-parsely Plugin Version 1.10.2 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.defineSlot("/7448792/SP2013_Articles_300x250_1", [300,250], "div-gpt-ad-1392428092543-0").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1392428092543-0").addSize([0, 0], []).addSize([768, 0], [300,250]).addSize([1024, 0], [300,250]).build()).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP2013_Articles_300x600_1", [[300, 600], [300, 250], [160, 600]], "div-gpt-ad-1392428092543-4").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1392428092543-4").addSize([0, 0], []).addSize([768, 0], [[300, 600], [300, 250], [160, 600]]).addSize([1024, 0], [[300, 600], [300, 250], [160, 600]]).build()).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_1", [200,125], "div-gpt-ad-1436815711585-0").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1436815711585-0").addSize([0, 0], []).addSize([768, 0], [200,125]).addSize([1024, 0], [200,125]).build()).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_2", [200,125], "div-gpt-ad-1436815711585-1").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1436815711585-1").addSize([0, 0], []).addSize([768, 0], [200,125]).addSize([1024, 0], [200,125]).build()).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_3", [200,125], "div-gpt-ad-1436815711585-2").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1436815711585-2").addSize([0, 0], []).addSize([768, 0], [200,125]).addSize([1024, 0], [200,125]).build()).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_4", [200,125], "div-gpt-ad-1436815711585-3").defineSizeMapping(purchs2s.sizeMapping("div-gpt-ad-1436815711585-3").addSize([0, 0], []).addSize([768, 0], [200,125]).addSize([1024, 0], [200,125]).build()).addService(googletag.pubads());
		googletag.pubads().setTargeting("channel", "php");
		googletag.pubads().setTargeting("post_id", "160833");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
          googletag.pubads().setTargeting("tags", ["auto deployment","automation","BrunoS","git","OOPHP","PHP","WordPress","workflow automation"]);
          googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #666699 }
  a.t-color:hover,
  button.t-color:hover { color: #565681 }

  .t-bg { background-color: #666699 }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #565681}

  .t-border { border-color: #666699 }
  a.t-border:hover,
  button.t-border:hover { border-color: #565681 }

  .t-bg-dark { background-color: #565681 }

  .t-list li:before { background-color: #666699; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
    <header class="main-header u-isSingle" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-premium/l/monthly-membership/?ref_source=sitepoint&ref_medium=drawer">
            <i class="SidebarNav_icon fa fa-user u-premium/l/monthly-membership/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/l/monthly-membership/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer">Sign Up</a>
          </li>      <li class="SidebarNav_link u-premium/sign-in">
            <i class="SidebarNav_icon fa fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
              <li class="SidebarNav_link u-premium/deals/?ref_source=sitepoint&ref_medium=drawer">
            <i class="SidebarNav_icon fa fa-diamond u-premium/deals/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/deals/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer">Deals</a>
          </li>            <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer">Courses</a>
          </li>      <li class="SidebarNav_link u-premium/paths">
            <i class="SidebarNav_icon fa fa-map-marker u-premium/paths"></i>
            
            <a class="f-light" href="/premium/paths/?ref_source=sitepoint&ref_medium=drawer">Paths</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php u-active">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/?ref_source=sitepoint&ref_medium=drawer" data-channel="woorank">SEO By WooRank</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-developer-center">
            <i class="SidebarNav_icon fa fa-circle u-developer-center"></i>
            <a class="f-light" href="https://www.sitepoint.com/developer-center/?ref_source=sitepoint&ref_medium=drawer" data-channel="developer-center">Microsoft Tech</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer">Community</a>
          </li>      <li class="SidebarNav_link u-versioning">
            <i class="SidebarNav_icon fa fa-envelope u-versioning"></i>
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/?ref_source=sitepoint&ref_medium=drawer">Versioning</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer">Advertise</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
                                      <a class="l-d-n l-d-f--3col l-ai-cen f-small f-light f-c-white NavBar_item" href="/premium/deals/?ref_source=sitepoint&ref_medium=topnav"><i class="l-mr2 f-medium fa fa-diamond"></i>Deals</a>
                        <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium"><i class="l-mr2 f-medium fa fa-book"></i>Books & Courses</a>
            <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/l/monthly-membership?ref_source=sitepoint&amp;ref_medium=topnav" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Sign Up</a></div>
          </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>

      <div class="widget maestro maestro-content-type-html " id="maestro-646"><sp-fixed-countdown-bar button_text="Get All Our Books and Courses For $9" button_url="/premium/l/monthly-membership?ref_source=sitepoint&amp;ref_medium=noticebar" buttonclass="u-red u-white" end="2017-10-20 14:54:00 +1000" end_message="Get in quick, we can't let this offer run forever!" landingpageclass="v3 l-ph3"
ga_event_label="646"
></sp-fixed-countdown-bar><script>ga('SitePointPlugin:observeImpressions', 'maestro-646')</script></div>    </header>
<div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                <a href="https://www.sitepoint.com/php/" class="f-c-grey-200 f-bold l-pa2 l-d-if l-ai-cen">PHP</a>
              <span>-</span> 
                <time class="l-d-ib l-pa2" datetime="2017-10-18" pubdate>October 18, 2017</time>
                        <span>-</span> 
              <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/bskvorc/" class="f-c-grey-200">
            Bruno Skvorc        </a>
          </span>
            </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <h1 class="f-lh-title f-larger l-mb4 f-c-white f-xxlarge--2col">
            <span class="f-c-white l-mr3">Git and WordPress: How to Auto-Update Posts with Pull Requests</span>
          </h1>
                <div class="l-w-1col--3col l-as-cen l-fs0 l-d-n l-d-b--2col l-ml3">
        <div class="f-c-white f-small f-bold l-w-100 l-mb3">Related Topics:</div>
        <div class="l-d-f l-fw-w">
        <a class="f-c-white" href="https://www.sitepoint.com/php/database/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Database</div></a><a class="f-c-white" href="https://www.sitepoint.com/php/debugging-and-deployment/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Debugging &amp; Deployment</div></a><a class="f-c-white" href="https://www.sitepoint.com/php/frameworks-php/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Frameworks</div></a><a class="f-c-white" href="https://www.sitepoint.com/php/laravel-php/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Laravel</div></a><a class="f-c-white" href="https://www.sitepoint.com/php/security/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Security</div></a><a class="f-c-white" href="https://www.sitepoint.com/php/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">More...</div></a>        </div>
      </div>
              </div>
      </div>
    </div>
    
      <div class="l-d-f l-jc-sb l-w-4col--4col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-php">
      <div class='l-mt3 l-mh5--2col'>
      <p>At <a href="https://bitfalls.com">Bitfalls.com</a>, we also use WordPress for now, and use the same peer review approach for content as we do <a href="https://www.sitepoint.com/write-for-us/">at SitePoint</a>. </p>
<p>We decided to build a tool which automatically pulls content from merged pull requests into articles, giving us the ability to fix typos and update posts from Github, and see the changes reflected on the live site. This tutorial will walk you through the creation of this tool, so you can start using it for your own WordPress site, or build your own version.</p>

<h2 id="theplan">The Plan</h2>
<p>The first part is identifying the problem and the situation surrounding it.</p>
<ul><li>we use WPGlobus for multi-language support, which means content gets saved like this: <code>{:en}English content{:}{:hr}Croatian content{:}</code>.</li>
<li>authors submit PRs via Github, the PRs are peer reviewed and merged, and then (currently) manually imported into WP&rsquo;s Posts UI through the browser.</li>
<li>every post has the same folder layout: <code>author_folder/post_folder/language/final.md</code></li>
<li>this is slow and error prone, and sometimes mistakes slip by. It also makes updating posts tedious.</li>
</ul><p>The solution is the following:</p>
<ul><li>add a hook processor which will detect pushes to the master branch (i.e. merges from PRs)</li>
<li>the processor should look for a meta file in the commit which would contain information on where to save the updated content</li>
<li>the processor automatically converts the MD content to HTML, merges the languages in the WPGlobus format, and saves them into the database</li>
</ul><h2 id="bootstrapping">Bootstrapping</h2>
<p>If you&rsquo;d like to follow along (highly recommended), please boot up a <a href="http://www.sitepoint.com/quick-tip-get-homestead-vagrant-vm-running/">good virtual machine environment</a>, install the newest version of WordPress on it, and add the WPGlobus plugin. Alternatively, you can use a prepared WordPress box like <a href="https://www.sitepoint.com/wordpress-meets-vagrant-vvv/">VVV</a>. Additionally, make sure your environment has <a href="https://www.sitepoint.com/use-ngrok-test-local-site/">ngrok</a> installed &ndash; we&rsquo;ll use that to pipe Github hook triggers to our local machine, so we can test locally instead of having to deploy.</p>
<h2 id="hooks">Hooks</h2>
<p>For this experiment, let&rsquo;s create a new repository. I&rsquo;ll call mine <a href="https://github.com/Swader/autopush">autopush</a>.</p>
<p>In the settings of this repository, we need to add a <a href="https://github.com/Swader/autopush/settings/hooks/new">new hook</a>. Since we&rsquo;re talking about a temporary Ngrok URL, let&rsquo;s first spin that up. In my case, entering the following on the host machine does the trick:</p>
<pre><code class="bash language-bash">ngrok http homestead.app:80
</code></pre>
<p>I was given the link <code>http://03672a64.ngrok.io</code>, so that&rsquo;s what goes into the webhook, with an arbitrary suffix like <code>githook</code>. We only need push events. The <code>json</code> data type is cleaner, so that&rsquo;s selected as a preference, and the final webhook setup looks something like this:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508224690Screenshot-2017-10-17-09.17.48.png" alt="Webhook setup"></p>
<p>Let&rsquo;s test this now.</p>
<pre><code class="bash language-bash">git clone https://github.com/swader/autopush
cd autopush
touch README.md
echo "This is a README file" &gt;&gt; README.md
git add -A
git commit -am "We're pushing for the first time"
git push origin master
</code></pre>
<p>The ngrok log screen should display something like this:</p>
<pre><code class="bash language-bash">POST /githook/                  404 Not Found
</code></pre>
<p>This is fine. We haven&rsquo;t made the <code>/githook</code> endpoint yet.</p>
<div class="widget maestro maestro-content-type-html " id="maestro-652"><span data-sumome-listbuilder-embed-id="a5047315669ea28f9652485dfd816e21a7b7d3873736b516d897111b300bf50b"></span><script>ga('SitePointPlugin:observeImpressions', 'maestro-652')</script></div><h2 id="processingwebhooks">Processing Webhooks</h2>
<p>We&rsquo;ll read this new data into WordPress with custom logic. Due to the spaghetti-code nature of WP itself, it&rsquo;s easier to circumvent it entirely with a small custom application. First, we&rsquo;ll create the <code>githook</code> folder in the WordPress project&rsquo;s root, and an <code>index.php</code> file inside it. This makes the <code>/githook/</code> path accessible, and the hook will no longer return 404, but 200 OK.</p>
<p>According to the <a href="https://developer.github.com/v3/activity/events/types/#pushevent">docs</a>, the payload will have a <code>commits</code> field with a <code>modified</code> field in each commit. Since we&rsquo;re only looking to update posts, not schedule them or delete them &ndash; those steps are still manual, for safety &ndash; we&rsquo;ll only be paying attention to that one. Let&rsquo;s see if we can catch it on a test push.</p>
<p>First, we&rsquo;ll save our request data to a text file, for debugging purposes. We can do this by modifying our <code>githook/index.php</code> file:</p>
<pre><code class="php language-php">&lt;?php
file_put_contents('test.txt', file_get_contents('php://input'));
</code></pre>
<p>Then we&rsquo;ll create a new branch, add a file, and push it online.</p>
<pre><code class="bash language-bash">git checkout -b test-branch
touch testfile.md
git add testfile.md
git commit -am "Added test file"
git push origin test-branch
</code></pre>
<p>Sure enough, our <code>test.json</code> file is filled with the payload now. <a href="http://jsoneditoronline.org/?id=3d65c7107d3233d8660ebb7419bf3104">This</a> is the payload I got. You can see that we have only one commit, and that commit&rsquo;s <code>modified</code> field is empty, while the <code>added</code> field has <code>testfile.md</code>. We can also see this happened on <code>refs/heads/test-branch</code>, ergo, we&rsquo;re not interested in it. But what happens if we make a PR out of this branch and merge it?</p>
<p>Our payload looks <a href="http://jsoneditoronline.org/?id=78d6d3e59f0b6944cde0c8ae3ff5b023">different</a>. Most notably, we now have <code>refs/heads/master</code> as the <code>ref</code> field, meaning it happened on the <code>master</code> branch and we <em>must</em> pay attention to it. We also have 2 commits instead of just one: the first one is the same as in the original PR, the adding of the file. The second one corresponds to the change on the master branch: the merging itself. Both reference the same <code>added</code> file.</p>
<p>Let&rsquo;s do one final test. Let&rsquo;s edit <code>testfile.md</code>, push that, and do a PR and merge.</p>
<pre><code class="bash language-bash">echo "Hello" &gt;&gt; testfile.md
git add testfile.md
git commit -am "Added test file"
git push origin test-branch
</code></pre>
<p>Ahh, <a href="http://jsoneditoronline.org/?id=78d6d3e59f0b6944cde0c8ae3ff95d1e">there we go</a>. We now have a modified file in the payload.</p>
<p>Now let&rsquo;s do a &ldquo;real&rdquo; scenario and simulate an update submission. First we&rsquo;ll create a post&rsquo;s default folder, and then we&rsquo;ll PR an update into it.</p>
<pre><code class="bash language-bash">git checkout master
git pull
mkdir -p authors/some-author/some-post/{en_EN,hr_HR,images}
echo "English content" &gt;&gt; authors/some-author/some-post/en_EN/final.md
echo "Croatian content" &gt;&gt; authors/some-author/some-post/hr_HR/final.md
touch authors/some-author/some-post/images/.gitkeep
git add -A
git commit -am "Added some author"
git push origin master
</code></pre>
<p>Then we do the edit.</p>
<pre><code class="bash language-bash">git checkout -b edit-for-some-post
echo "This is a new line" &gt;&gt; authors/some-author/some-post/en_EN/final.md
git add -A
git commit -am "Added an update on the English version of the post"
git push origin edit-for-some-post
</code></pre>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508229112Screenshot-2017-10-17-10.31.01.png" alt="New post edit PR suggested"></p>
<p>If we turn this into a pull request in the Github web UI and merge the PR, we&rsquo;ll get <a href="http://jsoneditoronline.org/?id=34653146cd548c1d9d164ad64e727fb4">this payload</a>.</p>
<p>If we follow the path from the modified files in the payload, we can easily discern the folder we&rsquo;re talking about. Let&rsquo;s modify the <code>index.php</code> file from before.</p>
<pre><code class="php language-php">$payload = json_decode($json, true);
$last_commit = array_pop($payload['commits']);

$modified = $last_commit['modified'];

$prefix = 'https://raw.githubusercontent.com/';
$repo = 'swader/autopush/master/';
$lvl = 2;

$folders = [];
foreach ($modified as $file) {
    $folder = explode('/', $file);
    $folder = implode('/', array_slice($folder, 0, -$lvl));
    $folders[] = $folder;
}
$folders = array_unique($folders);
var_dump($folders);
</code></pre>
<p>We fetch the last commit in the payload, extract its modified files list, and find the parent folder of each modified file. The parent is dictated by the <code>$lvl</code> variable &ndash; in our case it&rsquo;s 2 because the folder is 2 levels up: one extra for language (<code>en_EN</code>).</p>
<p>And there we have it &ndash; the path of the folder that holds the files that need to be updated. Now all we have to do is fetch the contents, turn the Markdown of those files into HTML, and save it into the database.</p>
<h2 id="processingmarkdown">Processing Markdown</h2>
<p>To process MarkDown, we can use the <a href="https://github.com/erusev/parsedown">Parsedown</a> package. We&rsquo;ll install these dependencies in the <code>githooks</code> folder itself, to make the app as standalone as possible.</p>
<pre><code class="bash language-bash">composer require erusev/parsedown
</code></pre>
<p>Parsedown is the same flavor of Markdown we use at Bitfalls while writing with the <a href="http://caret.io">Caret</a> editor, so it&rsquo;s a perfect match.</p>
<p>Now we can modify <code>index.php</code> again.</p>
<pre><code class="php language-php">$payload = json_decode($json, true);
$last_commit = array_pop($payload['commits']);

$modified = $last_commit['modified'];

$prefix = 'https://raw.githubusercontent.com/';
$repo = 'swader/autopush/';
$branch = 'master/';

$languages = [
    'en_EN' =&gt; 'en',
    'hr_HR' =&gt; 'hr'
];
$lvl = 2;

$folders = [];
foreach ($modified as $file) {
    $folder = explode('/', $file);
    $folder = implode('/', array_slice($folder, 0, -$lvl));
    $folders[] = $folder;
}
$folders = array_unique($folders);

foreach ($folders as $folder) {
    $fullFolderPath = $prefix.$repo.$branch.$folder.'/';
    $content = '';
    foreach ($languages as $langpath =&gt; $key) {
        $url = $fullFolderPath.$langpath.'/final.md';
        $content .= "{:$key}".mdToHtml(getContent($url))."{:}";
    }
    if (!empty($content)) {
        // Save to database
    }
}

function getContent(string $url): string {
    $ch = curl_init();
    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($ch, CURLOPT_URL, $url.'?nonce='.md5(microtime()));
    curl_setopt($ch, CURLOPT_FRESH_CONNECT, TRUE);
    $data = curl_exec($ch);
    $code = curl_getinfo($ch, CURLINFO_HTTP_CODE);
    if ($code != 200) {
        return '';
    }
    curl_close($ch);
    return $data;
}

function mdToHtml(string $text): string {
    $p = new Parsedown();
    $p-&gt;setUrlsLinked(true);
    return $p-&gt;parse($text);
}
</code></pre>
<p>We made some really simple functions to avoid repetition. We also added a mapping of language folders (locales) to their WPGlobus keys, so that when iterating through all the files in a folder, we know how to delimit them in the post&rsquo;s body. </p>
<p><em>Note: we have to update all language versions of a post when doing an update to just one, because WPGlobus doesn&rsquo;t use an extra field or a different database row to save another language of a post &ndash; it saves them all in one field, so the whole value of that field needs to be updated.</em></p>
<p>We iterate through the folders that got updates (there might be more than one in a single PR), grab the contents of the file and convert it to HTML, then store all this into a WPGlobus-friendly string. Now it&rsquo;s time to save this into the database.</p>
<p><em>Note: we used a nonce at the end of the URL to invalidate a possible cache issue with raw github content.</em></p>
<h2 id="savingeditedcontent">Saving Edited Content</h2>
<p>We have no idea where to save the new content. We need to add support for meta files.</p>
<p>First, we&rsquo;ll add a new function which gets this meta file:</p>
<pre><code class="php language-php">function getMeta(string $folder): ?array {
    $data = getContent(trim($folder, '/').'/meta.json');
    if (!empty($data)) {
        return json_decode($data, true);
    }
    return null;
}
</code></pre>
<p>Simple, if it exists, it&rsquo;ll return its contents. The meta files will be JSON, so all the parsing we&rsquo;ll ever need is already built into PHP.</p>
<p>Then, we&rsquo;ll add a check to our main loop so that the process skips any folder without a meta file.</p>
<pre><code class="php language-php">foreach ($folders as $folder) {
    $fullFolderPath = $prefix.$repo.$branch.$folder.'/';

    $meta = getMeta($fullFolderPath);
    if (!$meta) {
        continue;
    }

    // ...
</code></pre>
<p>We&rsquo;ll use the <a href="https://developer.wordpress.org/cli/commands/post/update/">WP CLI</a> to make updates. The CLI can be installed with the following commands:</p>
<pre><code class="bash language-bash">curl -O https://raw.githubusercontent.com/wp-cli/builds/gh-pages/phar/wp-cli.phar
sudo mv wp-cli.phar /usr/local/bin/wp
sudo chmod +x /usr/local/bin/wp
</code></pre>
<p>This downloads the WP-CLI tool, puts it into the server&rsquo;s path (so it can be executed from anywhere), and adds &ldquo;executable&rdquo; permission to it.</p>
<p>The <code>post update</code> command needs a post ID, and the field to update. WordPress posts are saved into the <code>wp_posts</code> database table, and the field we&rsquo;re looking to update is the <code>post_content</code> field.</p>
<p>Let&rsquo;s try this out in the command line to make sure it works as intended. First we&rsquo;ll add an example post. I gave it an example title of &ldquo;Example post&rdquo; in English and &ldquo;Primjer&rdquo; in Croatian, with the body <code>This is some English content for a post!</code> for the English content, and <code>Ovo je primjer!</code> for the Croatian content. When saved, this is what it looks like in the database:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508250773Screenshot-2017-10-17-16.31.16.png" alt="Example post in the database"></p>
<p>In my case, the ID of the post is 428. If your WP installation is fresh, yours will probably be closer to 1.</p>
<p>Now let&rsquo;s see what happens if we execute the following on the command line:</p>
<pre><code class="bash language-bash">wp post update 428 --post_content='{:en}This is some English content for a post - edited!{:}{:hr}Ovo je primjer - editiran!{:}'
</code></pre>
<p>Sure enough, our post was updated.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508251400Screenshot-2017-10-17-16.43.09.png" alt="Updated post"></p>
<p>This looks like it might become problematic when dealing with quotes which would need to be escaped. It&rsquo;s better if we update from file, and let this tool handle the quotes and such. Let&rsquo;s give it a try.</p>
<p>Let&rsquo;s put the content <code>:en}This is some English 'content' for a post - edited "again"!{:}{:hr}Ovo je 'primjer' - editiran "opet"!{:}</code> into a file called <code>updateme.txt</code>. Then&hellip;</p>
<pre><code class="bash language-bash">wp post update 428 updateme.txt
</code></pre>
<p>Yup, all good.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508329677Screenshot-2017-10-18-14.27.25.png" alt="Screenshot of update from file"></p>
<p>Okay, now let&rsquo;s add this into our tool.</p>
<p>For now, our meta file will only have the ID of the post, so let&rsquo;s add one such file to the content repo.:</p>
<pre><code class="bash language-bash">git checkout master
git pull
echo '{"id": 428}' &gt;&gt; authors/some-author/some-post/meta.json
git add -A
git commit -am "Added meta file for post 428"
git push origin master
</code></pre>
<p><em>Note: update the ID to match yours.</em></p>
<p>At this point, our content repo should look like <a href="https://github.com/Swader/autopush/releases/tag/1">this</a> (version saved as release, feel free to clone).</p>
<p>Replace the <code>// Save to database</code> line in the code from before and its surrounding lines with:</p>
<pre><code class="php language-php">    if (!empty($content) &amp;&amp; is_numeric($meta['id'])) {
        file_put_contents('/tmp/wpupdate', $content);
        exec('wp post update '.$meta['id'].' /tmp/wpupdate', $output);
        var_dump($output);
    }
</code></pre>
<p>We make sure that both content and the ID of the post to be updated are somewhat valid, and then we write the contents into a temporary file, from which we then feed it to the <code>wp cli</code> tool.</p>
<p>We should also add some more checks to the beginning of the script to make sure we only execute the updates we want to execute:</p>
<pre><code class="php language-php">// ...

$payload = json_decode($json, true);

if (empty($json)) {
    header("HTTP/1.1 500 Internal Server Error");
    die('No data provided for parsing, payload invalid.');
}

if ($payload['ref'] !== 'refs/heads/master') {
    die('Ignored. Not master.');
}

$last_commit = array_pop($payload['commits']);

// ...
</code></pre>
<p>The full <code>index.php</code> file looks like this now:</p>
<pre><code class="php language-php">&lt;?php

require_once 'vendor/autoload.php';

$json = file_get_contents('php://input');
file_put_contents('test.json', $json);
$payload = json_decode($json, true);

if (empty($json)) {
    header("HTTP/1.1 500 Internal Server Error");
    die('No data provided for parsing, payload invalid.');
}

if ($payload['ref'] !== 'refs/heads/master') {
    die('Ignored. Not master.');
}

$last_commit = array_pop($payload['commits']);

$modified = $last_commit['modified'];

$prefix = 'https://raw.githubusercontent.com/';
$repo = 'swader/autopush/';
$branch = 'master/';

$languages = [
    'en_EN' =&gt; 'en',
    'hr_HR' =&gt; 'hr'
];
$lvl = 2;

$folders = [];
foreach ($modified as $file) {
    $folder = explode('/', $file);
    $folder = implode('/', array_slice($folder, 0, -$lvl));
    $folders[] = $folder;
}
$folders = array_unique($folders);

foreach ($folders as $folder) {
    $fullFolderPath = $prefix.$repo.$branch.$folder.'/';

    $meta = getMeta($fullFolderPath);
    if (!$meta) {
        continue;
    }

    $content = '';
    foreach ($languages as $langpath =&gt; $key) {
        $url = $fullFolderPath.$langpath.'/final.md';
        $content .= "{:$key}".mdToHtml(getContent($url))."{:}";
    }
    if (!empty($content) &amp;&amp; is_numeric($meta['id'])) {
        file_put_contents('/tmp/wpupdate', $content);
        exec('wp post update '.$meta['id'].' /tmp/wpupdate', $output);
        var_dump($output);
    }
}

function getContent(string $url): ?string {
    $ch = curl_init();
    curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($ch, CURLOPT_URL, $url.'?nonce='.md5(microtime()));
    curl_setopt($ch, CURLOPT_FRESH_CONNECT, TRUE);

    $data = curl_exec($ch);
    $code = curl_getinfo($ch, CURLINFO_HTTP_CODE);
    if ($code != 200) {
        return null;
    }
    curl_close($ch);
    return $data;
}

function mdToHtml(string $text): string {
    $p = new Parsedown();
    $p-&gt;setUrlsLinked(true);
    return $p-&gt;parse($text);
}

function getMeta(string $folder): ?array {
    $data = getContent(trim($folder, '/').'/meta.json');
    if (!empty($data)) {
        return json_decode($data, true);
    }
    return null;
}
</code></pre>
<p>At this point, we can test things. Perfect chance for a brand new branch, too.</p>
<pre><code class="bash language-bash">git checkout -b post-update
echo 'Adding a new line yay!' &gt;&gt; authors/some-author/some-post/en_EN/final.md
git add -A; git commit -am "Edit"; git push origin post-update
</code></pre>
<p>Let&rsquo;s check our post out.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/10/1508360135Screenshot-2017-10-18-22.54.23.png" alt="Final updated post"></p>
<p>It works &ndash; deploying this script now is as simple as deploying the WP code of your app itself, and updating the webhook&rsquo;s URL for the repo in question.</p>
<h2 id="conclusion">Conclusion</h2>
<p>In true WordPress fashion, we hacked together a tool that took us less than an afternoon, but saved us days or weeks in the long run. The tool is now deployed and functioning adequately. There is, of course, room for updates. If you&rsquo;re feeling inspired, try adding the following:</p>
<ul><li>modify the post updating procedure so that it uses <code>stdin</code> instead of a file, making it compatible with no-writable-filesystem hosts like AWS, Heroku, or Google Cloud.</li>
<li>custom output types: instead of fixed <code>{:en}{:}{:hr}{:}</code>, maybe someone else is using a different multi-language plugin, or doesn&rsquo;t use one at all. This should be customizable somehow.</li>
<li>auto-insertion of images. Right now it&rsquo;s manual, but the images are saved in the repo alongside the language versions and could probably be easily imported, auto-optimized, and added into the posts as well.</li>
<li>staging mode &ndash; make sure the merged update first goes through to a staging version of the site before going to the main one, so the changes can be verified before being sent to master. Rather than having to activate and deactivate webhooks, why not make this programmable?</li>
<li>a plugin interface: it would be handy to be able to define all this in the WP UI rather than in the code. A WP plugin abstraction around the functionality would, thus, be useful.</li>
</ul><p>With this tutorial, our intention was to show you that optimizing workflow isn&rsquo;t such a big deal when you take the time to do it, and the return on investment for sacrificing some time on getting automation up and running can be immense when thinking long term.</p>
<p>Any other ideas or tips on how to optimize this? Let us know!</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/bskvorc/">
            <img src="https://secure.gravatar.com/avatar/a461aa958fa45b31936af6a1ca8f9106?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/bskvorc/">
                Bruno Skvorc              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/bitfalls"><i class="fa fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://plus.google.com/+BrunoSkvorc?rel=author"><i class="fa fa-google-plus"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="http://linkedin.bitfalls.com"><i class="fa fa-linkedin"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="http://www.github.com/swader"><i class="fa fa-github"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://medium.com/@bitfalls"><i class="fa fa-medium"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3"><a href="https://twitter.com/bitfalls">Bruno</a> is a coder from Croatia with Master’s Degrees in Computer Science and English Language and Literature. He runs a cryptocurrency business at <a href="http://bitfalls.com">Bitfalls.com</a> via which he trades crypto and makes blockchain tech approachable to the masses. He’s also an editor for SitePoint, and a developer evangelist for <a href="http://diffbot.com">Diffbot.com</a>.</div>
      </div>
            
      </div>
    </div>
        </div>
            </div>
            <div class="l-w-aside-i l-mt6 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
        <div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-1"><!-- SP2013_Articles_300x250_1 -->
<div id="div-gpt-ad-1392428092543-0" style="" class="adspot ">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1392428092543-0"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1392428092543-0",
        name    : "SP2013_Articles_300x250_1",
        sizes   : [300,250],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div>      </div>
          <div class="l-as-fs l-mv0 l-pv1 l-ph3 f-light f-larger f-uppercase f-c-white t-bg-grey-500">Sponsors</div>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-bsa hide-for-mobile-SP" id="maestro-448"><div class="l-pa3" style="border-bottom: 1px solid #e5e5e5" id="maestro-448-bsa-155663">
<a href="//srv.buysellads.com/ads/click/x/GTND42QEFT7IE2JYFTBLYKQMCTADV27ICASILZ3JCWYDE2QLCVADL2QKC6BIT53WCTYDTK3EHJNCLSIZ" class="l-d-f l-ai-sta" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-448-bsa-155663" data-ga-event-action="click"
>
<img class="l-s5" src="https://cdn4.buysellads.net/uu/1/72/1506466136-57260.png">
<div class="f-small l-d-f l-fd-col l-ml3 f-lh-title f-c-grey-700">
<span class="f-bold">Slack</span>
<span>It&#039;s teamwork, but simpler, more pleasant and more productive.</span>
</div>
</a>
</div><img src="https://slack.sp1.convertro.com/view/vt/v1/slack/0/cvo.gif?cvosrc=display.carbon.two%20cpc&utm_source=carbon&utm_medium=display&utm_campaign=two%20cpc" height="1" width="1" border="0" style="display: none;" /><img src="https://569-img.c3tag.com/v.gif?cid=569&c3ch=Carbon%20Networks&c3nid=Two%20CPC" height="1" width="1" border="0" style="display: none;" /><div class="l-pa3" style="border-bottom: 1px solid #e5e5e5" id="maestro-448-bsa-155743">
<a href="//srv.buysellads.com/ads/click/x/GTND42QEFT7IE2JYFTBLYKQMCTADV27IFT7D4Z3JCWYDE2QLCVAI52QKC6BIT53WCTYDTK3EHJNCLSIZ" class="l-d-f l-ai-sta" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-448-bsa-155743" data-ga-event-action="click"
>
<img class="l-s5" src="https://cdn4.buysellads.net/uu/1/72/1506550242-52292 (1).png">
<div class="f-small l-d-f l-fd-col l-ml3 f-lh-title f-c-grey-700">
<span class="f-bold">HelloSign</span>
<span>Embed docs directly on your website with a few lines of code.</span>
</div>
</a>
</div><script>ga('SitePointPlugin:observeImpressions', ['maestro-448-bsa-155663','maestro-448-bsa-155743'])</script></div></div>
          <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row ArticleAside_newboxads"><div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-251"><!-- SP_Articles_200x125_1 -->
<div id="div-gpt-ad-1436815711585-0" style="" class="adspot ">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1436815711585-0"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1436815711585-0",
        name    : "SP_Articles_200x125_1",
        sizes   : [200,125],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div><div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-252"><!-- SP_Articles_200x125_2 -->
<div id="div-gpt-ad-1436815711585-1" style="" class="adspot ">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1436815711585-1"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1436815711585-1",
        name    : "SP_Articles_200x125_2",
        sizes   : [200,125],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div><div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-253"><!-- SP_Articles_200x125_3 -->
<div id="div-gpt-ad-1436815711585-2" style="" class="adspot ">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1436815711585-2"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1436815711585-2",
        name    : "SP_Articles_200x125_3",
        sizes   : [200,125],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div><div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-254"><!-- SP_Articles_200x125_4 -->
<div id="div-gpt-ad-1436815711585-3" style="" class="adspot ">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1436815711585-3"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1436815711585-3",
        name    : "SP_Articles_200x125_4",
        sizes   : [200,125],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-56"><!-- SP2013_Articles_300x600_1 -->
<div id="div-gpt-ad-1392428092543-4" style="" class="adspot na">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-1392428092543-4"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "1392428092543-4",
        name    : "SP2013_Articles_300x600_1",
        sizes   : [[300, 600], [300, 250], [160, 600]],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div>        <ads-weighted widget='21' data='{"NL":[{"id":"585","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":50},{"id":"584","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":100}]}' fallback='' url='git-and-wordpress-how-to-auto-update-posts-with-pull-requests' channelSlug='php'></ads-weighted></div>
    </div>
          </div>
      
      <div class="u-accordion-end"></div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
          
          
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                        <a id="comments"></a>
                      </div>
        </div>
      </div>

    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          php: 'php',
        });
      });
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/themes/">Themes</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/#privacy">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fa fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fa fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fa fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2017 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
  <div class="l-w-100 l-d-f t-bg-white l-jc-cen">
    <div class="l-mv5 l-d-f l-fw-w l-jc-cen">
      <span class="f-bold l-as-cen f-large f-c-grey-300 l-mr3 l-mb3 l-mb0--2col">Recommended Hosting Partner:</span>
      <a href="https://www.siteground.com/go/sitepoint-siteground-promo">
        <img class="l-ml5--2col" src="//www.sitepoint.com/wp-content/themes/sitepoint/assets/images/siteground.png" />
      </a>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "https://www.sitepoint.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'sitepointproduction';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.setAttribute('data-cfasync', 'false'); e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-dfb2dddf3e07e06b11282e3f2248e361.js?ver=4.8.1'></script>
<script type="text/javascript" src="/dist/js/compiled.f602487a77ed4629364b.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
    <script>
    jQuery(document).ready(function() {
      jQuery('.lazyYT').each(function() {
        var id = jQuery(this).data('youtube-id'),
            url = 'https://www.youtube.com/watch?v=' + id;
        jQuery(this).replaceWith('<a href="' + url + '">' + url + '</a>');
      });
    });
    </script>
  
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 1378/1398 objects using memcached
Page Caching using memcached (SSL caching disabled)
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

 Served from: www.sitepoint.com @ 2017-10-19 01:54:26 by W3 Total Cache -->