<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.web.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'web');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
    }]);
  </script>
        
<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Why Self-Hosting Your Website Is a Bad Idea &mdash; SitePoint</title>
<meta name="description" content="Are you planning on self-hosting your website? Take a look at this article to learn about the downsides of on-premise hosting before you take the leap!"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.sitepoint.com/self-hosting-your-website-bad-idea/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Why Self-Hosting Your Website Is a Bad Idea &mdash; SitePoint" />
<meta property="og:description" content="Are you planning on self-hosting your website? Take a look at this article to learn about the downsides of on-premise hosting before you take the leap!" />
<meta property="og:url" content="https://www.sitepoint.com/self-hosting-your-website-bad-idea/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="hosting" />
<meta property="article:tag" content="joelf" />
<meta property="article:tag" content="self hosted" />
<meta property="article:tag" content="siteground" />
<meta property="article:tag" content="web hosting" />
<meta property="article:section" content="Web" />
<meta property="article:published_time" content="2017-06-15T15:30:45-07:00" />
<meta property="article:modified_time" content="2017-06-14T21:46:01-07:00" />
<meta property="og:updated_time" content="2017-06-14T21:46:01-07:00" />
<meta property="fb:admins" content="121300382" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/06/1497309755servers.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="960" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Are you planning on self-hosting your website? Take a look at this article to learn about the downsides of on-premise hosting before you take the leap!" />
<meta name="twitter:title" content="Why Self-Hosting Your Website Is a Bad Idea &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/06/1497309755servers.jpg" />
<meta name="twitter:creator" content="@jeffreylees" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Why Self-Hosting Your Website Is a Bad Idea Comments Feed" href="https://www.sitepoint.com/self-hosting-your-website-bad-idea/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-557b5d4377b8d3b1ee762639176f6ae6.css?ver=4.7.3' type='text/css' media='all' />
<style id='sitepoint-styles-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-c20e7cd33364b9c7aae6cf70992a24e4.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=155591' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fself-hosting-your-website-bad-idea%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fself-hosting-your-website-bad-idea%2F&#038;format=xml" />
<!-- BEGIN wp-parsely Plugin Version 1.10.2 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.10.2' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/self-hosting-your-website-bad-idea\/"},"headline":"Why Self-Hosting Your Website Is a Bad Idea","url":"http:\/\/www.sitepoint.com\/self-hosting-your-website-bad-idea\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/06\/1497309755servers-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/06\/1497309755servers-150x150.jpg"},"dateCreated":"2017-06-15T22:30:45Z","datePublished":"2017-06-15T22:30:45Z","dateModified":"2004-02-02T01:34:47Z","articleSection":"Web","author":[{"@type":"Person","name":"Jeff Smith"}],"creator":["Jeff Smith"],"publisher":{"@type":"Organization","name":"SitePoint"},"keywords":["hosting","joelf","self hosted","siteground","web hosting"]}   </script>
    <!-- END wp-parsely Plugin Version 1.10.2 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        		googletag.pubads().setTargeting("channel", "web");
		googletag.pubads().setTargeting("post_id", "155591");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>

  .t-p-pop-bg { background-color: #FF8480 }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #E66B67}
</style>
    <!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"3/2Rk1ao6C526C", domain:"sitepoint.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->
  </head>

  <body>
    <header class="main-header" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            <a class="l-d-f" href="/?utm_source=sitepoint&utm_medium=nav">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium/courses?utm_source=sitepoint&utm_medium=nav"><i class="l-mr2 f-medium fa fa-play-circle"></i>Courses</a>
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium/books?utm_source=sitepoint&utm_medium=nav"><i class="l-mr2 f-medium fa fa-book"></i>Books</a>
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/community/?utm_source=sitepoint&utm_medium=nav"><i class="l-mr2 f-medium fa fa-comment"></i>Community</a>
            <div class="l-d-f"><a href="/premium/sign-in?utm_source=sitepoint&amp;utm_medium=nav" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width:1px;">Login</a><a href="/premium/sign-up?utm_source=sitepoint&amp;utm_medium=nav" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Create Free Account</a></div>
          </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>

    </header>

<div class="l-d-n l-d-b--4col l-p-rel t-bg-white ChannelsNav">
  <ul class="l-d-f l-jc-cen l-w-100 l-w-3col--3col l-w-4col--4col l-pa0 l-mv0 l-mh-auto">
    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-html-css"><a href="https://www.sitepoint.com/html-css/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">HTML &amp; CSS</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-javascript"><a href="https://www.sitepoint.com/javascript/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">JavaScript</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-php"><a href="https://www.sitepoint.com/php/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">PHP</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-ruby"><a href="https://www.sitepoint.com/ruby/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Ruby</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-design-ux"><a href="https://www.sitepoint.com/design-ux/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Design &amp; UX</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-entrepreneur"><a href="https://www.sitepoint.com/entrepreneur/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Entrepreneur</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-web"><a href="https://www.sitepoint.com/web/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Web</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-wordpress"><a href="https://www.sitepoint.com/wordpress/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">WordPress</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-woorank"><a href="https://www.sitepoint.com/woorank/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">SEO By WooRank</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-developer-center"><a href="https://www.sitepoint.com/developer-center/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Microsoft Tech</a></li>  </ul>
</div>

<div id="SidebarNav" class="SidebarNav">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="l-d-b l-d-n--3col l-pv2 m-border-b">
    <a href="https://www.sitepoint.com/premium/topics/all" class="l-d-b l-pa3 SidebarNav_link">
      <svg class="sp-logo" viewbox="0 0 207 27">
  <g fill-rule="evenodd">
    <g>
      <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75"></path>
      <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z"></path>
      <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12"></path>
      <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z"></path>
      <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z"></path>
      <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z"></path>
      <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z"></path>
      <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12"></path>
      <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12"></path>
      <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87"></path>
      <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15"></path>
      <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58"></path>
      <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58"></path>
    </g>
    <rect height="20" rx="1" width="78" x="129" y="3"></rect>
    <path class="u-fill" d="M139.43,12.90 L139.43,10.02 L141.48,10.02 C142.07,10.02 142.50,10.14 142.78,10.39 C143.05,10.64 143.19,10.99 143.19,11.46 C143.19,11.93 143.05,12.29 142.78,12.54 C142.50,12.79 142.07,12.91 141.48,12.90 L139.43,12.90 Z M138.38,9.14 L138.38,17 L139.43,17 L139.43,13.78 L141.83,13.78 C142.62,13.79 143.22,13.59 143.63,13.18 C144.03,12.77 144.24,12.20 144.24,11.46 C144.24,10.73 144.03,10.16 143.63,9.75 C143.22,9.34 142.62,9.14 141.83,9.14 L138.38,9.14 Z M147.11,9.14 L147.11,17 L148.16,17 L148.16,13.64 L150.71,13.64 C150.97,13.64 151.17,13.68 151.33,13.76 C151.48,13.83 151.60,13.94 151.70,14.06 C151.79,14.19 151.86,14.34 151.91,14.51 C151.95,14.69 151.99,14.87 152.02,15.06 C152.06,15.25 152.08,15.44 152.08,15.64 C152.09,15.84 152.10,16.03 152.11,16.20 C152.11,16.37 152.13,16.53 152.16,16.67 C152.18,16.80 152.23,16.91 152.30,17 L153.47,17 C153.36,16.86 153.28,16.71 153.22,16.54 C153.17,16.37 153.13,16.18 153.10,15.99 C153.07,15.80 153.05,15.61 153.04,15.41 C153.03,15.21 153.02,15.02 153.01,14.83 C152.99,14.64 152.96,14.45 152.92,14.28 C152.87,14.10 152.81,13.94 152.73,13.80 C152.64,13.66 152.53,13.53 152.39,13.43 C152.24,13.33 152.06,13.26 151.83,13.21 L151.83,13.19 C152.31,13.06 152.65,12.81 152.87,12.45 C153.09,12.09 153.20,11.67 153.20,11.20 C153.20,10.56 152.98,10.06 152.56,9.69 C152.14,9.32 151.56,9.14 150.81,9.14 L147.11,9.14 Z M150.34,12.76 L148.16,12.76 L148.16,10.02 L150.75,10.02 C151.24,10.02 151.60,10.15 151.82,10.4 C152.04,10.64 152.15,10.97 152.15,11.36 C152.15,11.65 152.10,11.88 152.00,12.06 C151.90,12.24 151.77,12.38 151.61,12.49 C151.44,12.60 151.25,12.67 151.03,12.71 C150.81,12.74 150.58,12.76 150.34,12.76 L150.34,12.76 Z M156.25,9.14 L156.25,17 L161.70,17 L161.70,16.12 L157.29,16.12 L157.29,13.40 L161.37,13.40 L161.37,12.52 L157.29,12.52 L157.29,10.02 L161.67,10.02 L161.67,9.14 L156.25,9.14 Z M164.59,9.14 L164.59,17 L165.58,17 L165.58,10.46 L165.60,10.46 L168.06,17 L168.95,17 L171.40,10.46 L171.42,10.46 L171.42,17 L172.41,17 L172.41,9.14 L170.98,9.14 L168.50,15.74 L166.02,9.14 L164.59,9.14 Z M175.79,9.14 L175.79,17 L176.84,17 L176.84,9.14 L175.79,9.14 Z M186.47,14.16 L186.47,9.14 L185.42,9.14 L185.42,14.16 C185.42,14.86 185.25,15.39 184.90,15.76 C184.55,16.12 184.04,16.30 183.38,16.30 C182.67,16.30 182.13,16.12 181.76,15.76 C181.39,15.39 181.20,14.86 181.20,14.16 L181.20,9.14 L180.15,9.14 L180.15,14.16 C180.15,15.21 180.44,15.97 181.01,16.45 C181.58,16.93 182.37,17.17 183.38,17.17 C184.37,17.17 185.13,16.92 185.67,16.42 C186.20,15.92 186.47,15.16 186.47,14.16 L186.47,14.16 Z M189.76,9.14 L189.76,17 L190.75,17 L190.75,10.46 L190.77,10.46 L193.23,17 L194.12,17 L196.57,10.46 L196.59,10.46 L196.59,17 L197.58,17 L197.58,9.14 L196.15,9.14 L193.67,15.74 L191.19,9.14 L189.76,9.14 Z"></path>
  </g>
</svg>
    </a>
    <a href="https://www.sitepoint.com/community/" class="l-d-b l-pa3 SidebarNav_link">
      <svg class="sp-logo" viewbox="0 0 202 27">
  <g id="logo">
      <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
      <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
      <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
      <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
      <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
      <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
      <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
      <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
      <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
      <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
      <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
      <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
      <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
  <rect x="129" y="3" width="73" height="20" rx="1"></rect>
  <path class="u-fill" d="M139.62,9.14 L139.62,17 L140.67,17 L140.67,13.40 L144.28,13.40 L144.28,12.52 L140.67,12.52 L140.67,10.02 L144.78,10.02 L144.78,9.14 L139.62,9.14 Z M148.14,13.07 C148.14,12.67 148.19,12.28 148.30,11.90 C148.40,11.51 148.56,11.17 148.78,10.86 C149.00,10.55 149.28,10.30 149.63,10.11 C149.97,9.93 150.38,9.83 150.86,9.83 C151.34,9.83 151.75,9.93 152.09,10.11 C152.44,10.30 152.72,10.55 152.94,10.86 C153.16,11.17 153.32,11.51 153.42,11.90 C153.52,12.28 153.58,12.67 153.58,13.07 C153.58,13.46 153.52,13.85 153.42,14.24 C153.32,14.62 153.16,14.97 152.94,15.28 C152.72,15.59 152.44,15.83 152.09,16.02 C151.75,16.21 151.34,16.30 150.86,16.30 C150.38,16.30 149.97,16.21 149.63,16.02 C149.28,15.83 149.00,15.59 148.78,15.28 C148.56,14.97 148.40,14.62 148.30,14.24 C148.19,13.85 148.14,13.46 148.14,13.07 L148.14,13.07 Z M147.10,13.07 C147.10,13.60 147.18,14.12 147.33,14.61 C147.49,15.11 147.73,15.55 148.04,15.93 C148.36,16.31 148.75,16.61 149.22,16.84 C149.69,17.06 150.24,17.17 150.86,17.17 C151.48,17.17 152.03,17.06 152.50,16.84 C152.97,16.61 153.36,16.31 153.68,15.93 C153.99,15.55 154.23,15.11 154.38,14.61 C154.54,14.12 154.62,13.60 154.62,13.07 C154.62,12.53 154.54,12.02 154.38,11.52 C154.23,11.03 153.99,10.59 153.68,10.21 C153.36,9.83 152.97,9.52 152.50,9.3 C152.03,9.07 151.48,8.95 150.86,8.95 C150.24,8.95 149.69,9.07 149.22,9.3 C148.75,9.52 148.36,9.83 148.04,10.21 C147.73,10.59 147.49,11.03 147.33,11.52 C147.18,12.02 147.10,12.53 147.10,13.07 L147.10,13.07 Z M157.50,9.14 L157.50,17 L158.54,17 L158.54,13.64 L161.09,13.64 C161.35,13.64 161.56,13.68 161.71,13.76 C161.86,13.83 161.99,13.94 162.08,14.06 C162.18,14.19 162.25,14.34 162.29,14.51 C162.34,14.69 162.37,14.87 162.40,15.06 C162.44,15.25 162.46,15.44 162.47,15.64 C162.48,15.84 162.48,16.03 162.49,16.20 C162.50,16.37 162.51,16.53 162.54,16.67 C162.57,16.80 162.62,16.91 162.69,17 L163.86,17 C163.74,16.86 163.66,16.71 163.61,16.54 C163.55,16.37 163.51,16.18 163.48,15.99 C163.45,15.80 163.43,15.61 163.43,15.41 C163.42,15.21 163.41,15.02 163.39,14.83 C163.37,14.64 163.34,14.45 163.30,14.28 C163.26,14.10 163.20,13.94 163.11,13.80 C163.03,13.66 162.91,13.53 162.77,13.43 C162.63,13.33 162.44,13.26 162.22,13.21 L162.22,13.19 C162.69,13.06 163.04,12.81 163.26,12.45 C163.47,12.09 163.58,11.67 163.58,11.20 C163.58,10.56 163.37,10.06 162.95,9.69 C162.53,9.32 161.94,9.14 161.19,9.14 L157.50,9.14 Z M160.72,12.76 L158.54,12.76 L158.54,10.02 L161.14,10.02 C161.63,10.02 161.98,10.15 162.21,10.4 C162.43,10.64 162.54,10.97 162.54,11.36 C162.54,11.65 162.49,11.88 162.39,12.06 C162.29,12.24 162.16,12.38 161.99,12.49 C161.83,12.60 161.63,12.67 161.41,12.71 C161.19,12.74 160.96,12.76 160.72,12.76 L160.72,12.76 Z M172.90,14.16 L172.90,9.14 L171.86,9.14 L171.86,14.16 C171.86,14.86 171.68,15.39 171.33,15.76 C170.99,16.12 170.48,16.30 169.81,16.30 C169.11,16.30 168.57,16.12 168.19,15.76 C167.82,15.39 167.63,14.86 167.63,14.16 L167.63,9.14 L166.59,9.14 L166.59,14.16 C166.59,15.21 166.87,15.97 167.44,16.45 C168.01,16.93 168.80,17.17 169.81,17.17 C170.80,17.17 171.56,16.92 172.10,16.42 C172.63,15.92 172.90,15.16 172.90,14.16 L172.90,14.16 Z M176.20,9.14 L176.20,17 L177.19,17 L177.19,10.46 L177.21,10.46 L179.66,17 L180.55,17 L183.01,10.46 L183.03,10.46 L183.03,17 L184.02,17 L184.02,9.14 L182.59,9.14 L180.10,15.74 L177.63,9.14 L176.20,9.14 Z M191.90,11.44 L192.89,11.44 C192.87,11.01 192.79,10.64 192.64,10.32 C192.49,10.01 192.28,9.75 192.02,9.55 C191.76,9.34 191.46,9.19 191.12,9.10 C190.77,9.00 190.40,8.95 190,8.95 C189.64,8.95 189.29,9.00 188.94,9.09 C188.60,9.18 188.30,9.32 188.03,9.51 C187.76,9.70 187.55,9.93 187.39,10.22 C187.23,10.51 187.15,10.86 187.15,11.25 C187.15,11.61 187.22,11.91 187.36,12.15 C187.50,12.39 187.69,12.58 187.93,12.73 C188.17,12.88 188.44,13.00 188.74,13.10 C189.04,13.19 189.35,13.27 189.66,13.34 C189.97,13.41 190.28,13.47 190.58,13.54 C190.88,13.61 191.15,13.69 191.39,13.80 C191.62,13.91 191.82,14.04 191.96,14.21 C192.10,14.38 192.17,14.60 192.17,14.87 C192.17,15.16 192.11,15.39 192.00,15.58 C191.88,15.76 191.73,15.90 191.54,16.01 C191.34,16.12 191.13,16.19 190.89,16.24 C190.65,16.28 190.42,16.30 190.18,16.30 C189.89,16.30 189.60,16.27 189.32,16.19 C189.05,16.12 188.80,16.01 188.59,15.85 C188.38,15.70 188.21,15.50 188.09,15.26 C187.96,15.02 187.89,14.74 187.89,14.41 L186.90,14.41 C186.90,14.89 186.99,15.30 187.16,15.65 C187.33,16.00 187.57,16.28 187.87,16.51 C188.16,16.73 188.51,16.90 188.90,17.01 C189.29,17.12 189.71,17.17 190.15,17.17 C190.51,17.17 190.87,17.13 191.23,17.04 C191.60,16.96 191.92,16.82 192.22,16.64 C192.51,16.45 192.75,16.21 192.94,15.91 C193.12,15.61 193.22,15.26 193.22,14.84 C193.22,14.45 193.15,14.13 193.00,13.87 C192.86,13.61 192.67,13.40 192.43,13.23 C192.19,13.06 191.92,12.93 191.62,12.83 C191.32,12.73 191.02,12.65 190.70,12.57 C190.39,12.50 190.09,12.43 189.79,12.37 C189.49,12.31 189.22,12.23 188.98,12.13 C188.74,12.04 188.55,11.91 188.41,11.76 C188.26,11.61 188.19,11.42 188.19,11.18 C188.19,10.92 188.24,10.70 188.34,10.53 C188.44,10.36 188.57,10.22 188.74,10.12 C188.90,10.02 189.09,9.94 189.30,9.90 C189.51,9.86 189.73,9.83 189.95,9.83 C190.49,9.83 190.94,9.96 191.29,10.21 C191.64,10.47 191.84,10.88 191.90,11.44 L191.90,11.44 Z"></path>
</svg>
    </a>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-ruby">
            <i class="SidebarNav_icon fa fa-circle u-ruby"></i>
            <a class="f-light" href="https://www.sitepoint.com/ruby/" data-channel="ruby">Ruby</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-mobile">
            <i class="SidebarNav_icon fa fa-circle u-mobile"></i>
            <a class="f-light" href="https://www.sitepoint.com/mobile/" data-channel="mobile">Mobile</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-entrepreneur">
            <i class="SidebarNav_icon fa fa-circle u-entrepreneur"></i>
            <a class="f-light" href="https://www.sitepoint.com/entrepreneur/" data-channel="entrepreneur">Entrepreneur</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-java">
            <i class="SidebarNav_icon fa fa-circle u-java"></i>
            <a class="f-light" href="https://www.sitepoint.com/java/" data-channel="java">Java</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/" data-channel="woorank">SEO By WooRank</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      <li class="SidebarNav_link u-themes/?utm_source=blog&utm_medium=sidebar-nav">
            <i class="SidebarNav_icon fa fa-file-image-o u-themes/?utm_source=blog&utm_medium=sidebar-nav"></i>
            
            <a class="f-light" href="/themes/?utm_source=blog&utm_medium=sidebar-nav">Themes</a>
          </li>      <li class="SidebarNav_link u-versioning-show">
            <i class="SidebarNav_icon fa fa-microphone u-versioning-show"></i>
            
            <a class="f-light" href="/versioning-show/">Podcast</a>
          </li>      <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/">Courses</a>
          </li>      <li class="SidebarNav_link u-newsletter">
            <i class="SidebarNav_icon fa fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/">Newsletters</a>
          </li>      <li class="SidebarNav_link u-versioning">
            
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/">Versioning</a>
          </li>      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/">Forums</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/">Advertise</a>
          </li>      <li class="SidebarNav_link u-write-for-us">
            
            
            <a class="f-light" href="/write-for-us/">Contribute</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/">Contact Us</a>
          </li>      <li class="SidebarNav_link u-about-us">
            
            
            <a class="f-light" href="/about-us/">Our Story</a>
          </li>    </ul>
  </section>

  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">995k<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">132k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">80k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-498"><script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=sitepoint" id="_fancybar_js"></script><script>ga('SitePointPlugin:observeImpressions', 'maestro-498')</script></div><div class="l-pt4 l-p-rel" role="main">
  <div class="Article_bg ChannelBackground u-web"></div>
      <div class="l-p-rel l-w-100 l-mh-auto">
          <div class="l-w-3col--3col l-mh3 l-mh-auto--4col">
      <div class="l-d-f">
              <a href="https://www.sitepoint.com/web/" class="f-c-grey-700 f-bold t-bg-white l-pa2 l-d-if l-ai-cen"><i class="fa fa-circle t-color l-mr2 l-i2"></i>Web - Proudly sponsored by SiteGround</a>
            <div class="l-d-n l-d-b--3col l-ml3 l-pa2 l-d-if l-ai-cen f-c-grey-700 f-bold t-bg-white">Article</div>
        <span class="l-d-ib t-bg-white f-c-grey-500 f-light l-ml3">
          <span class="l-d-n l-d-ib--2col">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/jeffsmith/" class="f-c-grey-500">
            Jeff Smith        </a>
          </span>
    </span>
                <time class="l-d-ib l-pa2" datetime="2017-06-15" pubdate>June 15, 2017</time>
                      </span>
      </div>

      <h1 class="l-mv4 f-lh-title f-larger f-xxlarge--2col">
        <span class="t-bg-white l-pa2 l-d-i">Why Self-Hosting Your Website Is a Bad Idea</span>
      </h1>
      <span class="l-d-n--2col l-d-ib l-mb3 t-bg-white f-c-grey-500 f-light">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/jeffsmith/" class="f-c-grey-500">
            Jeff Smith        </a>
          </span>
    </span>
    </div>
    
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto" data-hellobar="content">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-ml0--4col">
          
              <div class="l-mb4 l-pa3 t-bg-white m-border">
        <div class="l-mb3">
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h">
        <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-353"><div class="l-w-100 l-d-f l-fd-col m-border">
          <div class="f-c-white f-large f-bold l-pv3" style="background: #45C69B;">
            <span class="fa fa-server l-mr2 "></span><span>We teamed up with SiteGround</span>
          </div>
          <div class="l-d-f l-fw-w l-mv3 l-jc-cen">
            <span>To bring you the latest from the web and tried-and-true hosting, recommended for designers and developers.</span>
            <a class="l-mt2 f-underline f-bold" href="/siteground-recommended-65-off-channel-unit" data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-353" data-ga-event-action="click">SitePoint Readers Get Up To 65% OFF Now</a>
          </div>
        </div><script>ga('SitePointPlugin:observeImpressions', 'maestro-353')</script></div>      </div>
    </div>
        <div class="ArticleCopy language-">
      <p class="wp-special"><em>This article is part of a series created in partnership with <a href="https://www.sitepoint.com/siteground-recommended-65-off" rel="nofollow">SiteGround</a>. Thank you for supporting the partners who make SitePoint possible.</em></p>
<div class='ArticleBox u-inline'><h3 class='ArticleBox_header t-bg'>
                    <span class='ArticleBox_icon fa fa-pencil'></span> More from this author
                 </h3><div class='m-border ArticleBox_content'><ul class='ArticleBox_list'><li class='ArticleBox_listItem'><a class='f-c-grey-500 l-b-n' href='https://www.sitepoint.com/think-about-website-security-as-admin/?utm_source=sitepoint&amp;utm_medium=relatedinline&amp;utm_term=&amp;utm_campaign=relatedauthor'>How to Think about Website Security as an Admin</a></li><li class='ArticleBox_listItem'><a class='f-c-grey-500 l-b-n' href='https://www.sitepoint.com/version-control-magento-git/?utm_source=sitepoint&amp;utm_medium=relatedinline&amp;utm_term=&amp;utm_campaign=relatedauthor'>Version Control with Magento and Git</a></li></ul></div></div>
<p>There are many situations in which you might decide that self-hosting your website is the way to go. You may be a freelancer, an entrepreneur, or be running a personal or even non-profit site. You may wish to host the site on an always-on PC in your basement, or on a small server in your workplace.</p>
<p>Regardless of the situation, on-premise hosting is usually a bad idea. In this post, you&#8217;ll have some reasons for that explained, in the hopes of providing useful information or warnings to both business decision makers as well as developers who are inexperienced with the &#8220;operations&#8221; side of the Internet &#8211; in this case, hosting websites.</p>
<h2 id="selfhostinghasmorebarrierstostarting">Self-Hosting Has More Barriers to Starting</h2>
<p>Depending on your Internet Service Provider (ISP) and your situation (whether you have a business class service package or a residential one), you may run into issues with your ISP blocking port 80 — the port to which most Internet traffic defaults. You may also be issued warnings or even have your service shut down if you host websites on-premise. This is most common when you are trying to host a site from your home connection and the ISP prefers that if you wish to do so, you purchase a business Internet package that is perhaps thrice as expensive. </p>
<p>However, some ISPs can still provide limitations even to the business class packages that can thwart your attempts to get your website up and running. Additionally, you will also need a static IP address, which may be an added cost, depending on how your ISP plans work. Most home (and some business) connections use dynamic IP addresses, which means that they change from time to time. If your IP address, the way by which your network can be found online, sometimes changes, you will have no easy, reliable way to point users who come to <code>yourdomain.com</code> to your on-premise hosting setup.</p>
<h2 id="selfhostingyourwebsitecancreatesecurityrisks">Self-Hosting Your Website Can Create Security Risks</h2>
<p>There are security risks in anything you do on the Internet, of course, but hosting a website on your network opens you up to even more, especially if you&#8217;re not certain of what you&#8217;re doing. Websites big and small are subjected to denial of service attacks and scripting attacks, sometimes at mind-blowing volume. Your website can be for a single freelancer, a small startup, a two hundred person small company, or an enterprise outfit, and they all will attract attacks — some of which may even be automated and not even take into account the content of the site in question.</p>
<p>Hosting a web server on your network, if you&#8217;re not careful, may open your network up to a Pandora&#8217;s Box of security troubles that you&#8217;d never have to deal with if you hosted your website with a cloud service provider rather than on premise. Do you know enough about web servers (and, if your web server is Linux, <a href="https://www.sitepoint.com/premium/screencasts/navigating-the-linux-terminal-and-commands">do you know the command line</a>)?</p>
<h2 id="selfhostingyourwebsiteislessreliable">Self-Hosting Your Website is Less Reliable</h2>
<p>Another point to consider about self-hosting your website is that you have less options for dealing with things like downtime and service outages.</p>
<p>If your power goes out in the typical residential or small business location, you have no control over the situation that follows. How long will it be out? Minutes? Hours? Days, even? It depends on the circumstance. What if a child touches or damages something they shouldn&#8217;t, if it&#8217;s in your home? What about in the office, if a careless employee spills a drink, or pulls the wrong cord? </p>
<p>Even if you secure your website on a server in a server cage in a dedicated room in your office, you can still run into random events such as a plumbing leak or an Internet service outage. If your bandwidth is exceeding the allotted amount, your ISP may throttle or shut down your connection. Many of these things are entirely out of your control.</p>
<p>All of these points are mitigated by using <a href="https://www.siteground.com/sitepoint-recommended">a hosting service</a> which uses a professional data center to house its servers. They have multiple power and Internet providers, generators, cooling, security, fire suppression systems, offsite backups, and even redundancy to other locations. It&#8217;s more than you can possibly provide in-house if you&#8217;re the average small business or individual.</p>
<h2 id="consideringthecostsofselfhostingyourwebsite">Considering the Costs of Self-Hosting Your Website</h2>
<p>Let&#8217;s take a few looks at the costs of self-hosting your website:</p>
<ul>
<li>Static IP &#8211; You&#8217;ll need a static IP address in order for people to properly find your web server when they enter your site&#8217;s address into their browser. That typically costs extra on your Internet bill.</li>
<li>Better Internet Connection &#8211; You also may want a better Internet connection, especially if your website begins to gain in traffic. This, too, will cost you.</li>
<li>Equipment &#8211; You also need equipment to put the website on. A server, or a computer whose primary (or only) task is to function as a web server. If you are using Windows, you&#8217;ll need an operating system license and perhaps other software. You may also need extra peripheral equipment &#8211; such as a switch or router — that you might not have needed otherwise.</li>
<li>Backups &#8211; You&#8217;ll need to pay for an external cloud backup service, if at all possible, and you&#8217;ll also need the equipment, software, and time spent on performing local backups as well. You want a backup copy of your data both on-site and off-site, so that you can use the local copy to do quick recoveries, and the off-site copy in a disaster. All of this will also cost money, and the time to set it up and test your backups occasionally to ensure the system is working.</li>
<li>Paying Consultants &#8211; Finally, you should assume you&#8217;ll end up needing to pay consultants. Your business may not have the expertise locally to deal with certain networking or programming issues, and if you&#8217;re a solo shop, even more so. You might as well chalk this up as a necessity, and have an emergency budget to deal with it when you need it.</li>
</ul>
<h2 id="conclusions">Conclusions</h2>
<p>Why are you considering this? </p>
<p>If it&#8217;s to retain control of things (you don&#8217;t trust third parties to host your site) consider the technological and safety concerns here and ask yourself who is in a better position to safely and effectively deliver your website content to visitors &#8211; your business office, or a hosting company whose entire purpose is to do this?</p>
<p>Is it to save money? Take a look at the incredibly affordable and full-featured hosting offerings with reputable hosts such as our partner, <a href="https://www.sitepoint.com/siteground-recommended-65-off">SiteGround</a>. They solve all of these issues for you without a huge investment. If your business requires a website (<a href="https://www.sitepoint.com/why-every-business-needs-a-website/">and which one doesn&#8217;t?</a>) and cannot afford at least a reliable hosting service, perhaps the business itself is in question. What does your business have in its budget that could be replaced (a few dollars a month) in order to pay for the monthly hosting bill? Think about it.</p>
<p>Have any experiences, good or bad, with self-hosting your website? Let us know in the comments.</p>
    </div>
        <div class="l-mb3">
            <thumbvoter-buttons id="155591"
        url="https://www.sitepoint.com/wp-admin/admin-ajax.php"
        user_rating="0"
        channel="Web"
      />
    </div>
        <div class="f-lh-copy l-d-f">
      <div class="l-fs0 l-mr3"><i class="fa fa-tag"></i> More: </div>
      <div class="f-c-teal-500">
<a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/hosting/">hosting</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/self-hosted/">self hosted</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/siteground/">siteground</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/web-hosting-2/">web hosting</a>      </div>
    </div>
        </div>
                    <div class="Article_authorBio l-mb4 l-pa3 t-bg-white m-border">
        <div class="l-d-f">
          <a class="l-s5 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/jeffsmith/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2016/10/1475802311Jeff-Smith-v2-96x96.jpg" width="96" height="96" alt="Jeff Smith" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/jeffsmith/">
                Jeff Smith              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/jeffreylees"><i class="fa fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/jeffreylees"><i class="fa fa-linkedin"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/jeffreylees"><i class="fa fa-github"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://medium.com/@jeffreylees"><i class="fa fa-medium"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Jeff is the WordPress editor at SitePoint. He also works full time for a startup as a technical writer, and is still a web developer, ever behind the keys of a MacBook, and loves tinkering with new projects and ideas. 

In addition to being glued to a computer for a good part of his day, Jeff is also a husband, father, tech nerd, book nerd, and gamer.</div>
      </div>
      
          <div class="ArticleContent_endcap">
            <div class="widget maestro maestro-content-type-html " id="maestro-629"><style>
 .ArticleContent_endcap {
padding: 0;
}
</style>

<div class="l-w-100 l-d-f l-fd-col m-border">
          <div class="f-c-white f-large f-bold l-pv3 f-center" style="background: #45C69B;">
            <span class="fa fa-server l-mr2 "></span><span>We teamed up with SiteGround</span>
          </div>
          <div class="l-d-f l-fw-w l-mv3 l-jc-cen">
            <span>To bring you the latest from the web and tried-and-true hosting, recommended for designers and developers.</span>
            <a class="l-mt2 f-underline f-bold" href="/siteground-recommended-65-off-channel-unit" data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-629" data-ga-event-action="click">SitePoint Readers Get Up To 65% OFF Now</a>
          </div>
        </div><script>ga('SitePointPlugin:observeImpressions', 'maestro-629')</script></div>          </div>

                    <div class="l-pa3 t-bg-white">
            <a id="comments"></a>
            
<div id="disqus_thread">
            <div id="dsq-content">


            <ul id="dsq-comments">
                    <li class="comment even thread-even depth-1" id="dsq-comment-148301">
        <div id="dsq-comment-header-148301" class="dsq-comment-header">
            <cite id="dsq-cite-148301">
                <a id="dsq-author-user-148301" href="http://www.maxwebsitedesign.com" target="_blank" rel="nofollow">Matt</a>
            </cite>
        </div>
        <div id="dsq-comment-body-148301" class="dsq-comment-body">
            <div id="dsq-comment-message-148301" class="dsq-comment-message"><p>I thought about self hosting at one point and came to these same conclusions.  Way too many potential problems and costs for a small business.  I was with bluehost for years, thought that was just the way it was going to have to be, poor service, etc.. then I found peopleshost, the customer service and technical knowledge is phenomenal.  Night and day compared to any EIG company (bluehost, hostgator, etc).   I don&#8217;t see Siteground listed as an EIG company so that&#8217;s good.  </p>
</div>
        </div>

    </li><!-- #comment-## -->
            </ul>


        </div>

    </div>

<script type="text/javascript">
var disqus_url = 'https://www.sitepoint.com/self-hosting-your-website-bad-idea/';
var disqus_identifier = '155591 https://www.sitepoint.com/?p=155591';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'sitepointproduction';
var disqus_title = "Why Self-Hosting Your Website Is a Bad Idea";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

          </div>
        </div>
              </div>

      <div class="u-accordion-end"></div>
      
          <article-sharer data-url="https%3A%2F%2Fwww.sitepoint.com%2Fself-hosting-your-website-bad-idea%2F" data-title="Why Self-Hosting Your Website Is a Bad Idea"></article-sharer>
    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          web: 'web',
        });
      });
    </script>
      </div>
    </div>
<div class="NavBar_stickyZone l-d-n l-d-b--3col">
   <nav class=" NavBar u-sticky l-d-f t-bg-grey-500">
    <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
      <section class="l-d-f l-w-100 l-ai-str l-jc-sb">
        <a class="l-d-f l-as-cen" href="/">
          <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
        </a>
        <a class="f-c-white l-as-cen" href="/premium/l/sitepoint-premium-siteground-article/?utm_source=sitepoint&utm_medium=sticky-nav"><strong>Limited Time:</strong> Get all our design and web dev books, courses and tutorials completely free.</a>
        <div class="l-d-f"><a href="/premium/l/sitepoint-premium-siteground-article?utm_source=sitepoint&amp;utm_medium=sticky-nav" class="Button l-as-cen l-ml3 l-d-n l-d-b--2col l-ph5--4col">Claim This Deal Now</a></div>
      </section>
    </div>
  </nav>
</div>
    <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-555"><script type="text/html" class=" ModalOnce" data-activate-delay=5 data-tracking="channelspecific" data-min-height="650" data-min-width="900" data-tracking-days="14">

<div id="channelspecific-modal" class="reveal-modal" data-reveal aria-labelledby="10 free SitePoint ebooks" aria-hidden="true" role="dialog">

<purchase-form
product="Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvOTQ" 
title="10 free SitePoint ebooks"
 subtitle="Downloaded by more than 100,000 developers!" 
cta="Get Your Free Ebooks Now!" 
subtext="No credit card required. Completely free."
ga_event_label="maestro-555"
>

</purchase-form>
<a  data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-555" data-ga-event-action="close" class="close-reveal-modal" aria-label="Close">&#215;</a>
</script><script>ga('SitePointPlugin:observeImpressions', 'maestro-555')</script></div>    <footer class="l-d-f t-bg-grey-500" role="contentinfo" style="height: 500px; margin-top:60px;">
  <div class="l-d-f l-fw-w l-mh-auto">
    <div class="l-d-f l-mt4 l-w-100 l-w-2col--2col l-w-3col--4col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">About</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/about-us/">Our Story</a>
        </li>
        <li >
          <a class="m-link-white f-small" href="/advertise/">Advertise</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/press/">Press Room</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="http://reference.sitepoint.com/css/" target="_blank">Reference</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/">Terms of Use</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/#privacy">Privacy Policy</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://sitepoint.zendesk.com/hc/en-us" target="_blank">FAQ</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="mailto:feedback@sitepoint.com">Contact Us</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/write-for-us/">Contribute</a>
        </li>
      </ul>

      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Visit</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/">SitePoint Home</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/themes/?utm_source=blog&utm_medium=footer">Themes</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/versioning-show/">Podcast</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/community/">Forums</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/newsletter/">Newsletters</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/premium/">Premium</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/sass-reference/">References</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/versioning/">Versioning</a>
        </li>
      </ul>
    </div>

    <div class="l-mt4 l-w-1col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Connect</div>
        </li>
        <li>
          <a class="m-link-white" href="https://www.sitepoint.com/feed/">
            <i class="fa fa-rss-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="/newsletter/">
            <i class="fa fa-envelope-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-facebook-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
            <i class="fa fa-twitter-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-google-plus-square l-i4"></i>
          </a>
        </li>

        <p class="f-c-white l-mv3">
          &copy; 2000 &ndash; 2017 SitePoint Pty. Ltd.
        </p>
      </ul>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "https://www.sitepoint.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'sitepointproduction';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.setAttribute('data-cfasync', 'false'); e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-c30bfbc04242f0d1a0504e0acfdae874.js?ver=4.7.3'></script>
<script type="text/javascript" src="/dist/js/compiled.02fae44f5059c707636e.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
    <script>
    jQuery(document).ready(function() {
      jQuery('.lazyYT').each(function() {
        var id = jQuery(this).data('youtube-id'),
            url = 'https://www.youtube.com/watch?v=' + id;
        jQuery(this).replaceWith('<a href="' + url + '">' + url + '</a>');
      });
    });
    </script>
  
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 1350/1428 objects using memcached
Page Caching using memcached (SSL caching disabled)
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

 Served from: www.sitepoint.com @ 2017-06-15 23:17:14 by W3 Total Cache -->