<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.2.0/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    <meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KL8PMMW');</script>

    <script class="SP_stripMobile" type="text/javascript">
      var propertag = propertag || {};
      propertag.cmd = propertag.cmd || [];
      (function() {
      var pm = document.createElement('script');
      pm.async = true; pm.type = 'text/javascript';
      var is_ssl = 'https:' == document.location.protocol;
      pm.src = (is_ssl ? 'https:' : 'http:') + '//global.proper.io/sitepoint.min.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(pm, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();

      var oSpP;
    </script>
    <script charset="UTF-8" src="//cdn.sendpulse.com/js/push/ee9a890c7a9d2a9236648c25e40bd03e_1.js" async></script>

    
    
<!-- This site is optimized with the Yoast SEO plugin v8.4 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Getting up and Running with the Vue.js 2.0 Framework &mdash; SitePoint</title>
<meta name="description" content="Jack Franklin tries out Vue.js 2.0, and walks through building a basic GitHub API demo to put the framework through its paces."/>
<link rel="canonical" href="https://www.sitepoint.com/up-and-running-vue-js-2-0/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Getting up and Running with the Vue.js 2.0 Framework &mdash; SitePoint" />
<meta property="og:description" content="Jack Franklin tries out Vue.js 2.0, and walks through building a basic GitHub API demo to put the framework through its paces." />
<meta property="og:url" content="https://www.sitepoint.com/up-and-running-vue-js-2-0/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="github API" />
<meta property="article:tag" content="nilsonj" />
<meta property="article:tag" content="vue.js" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2019-04-15T06:30:24+00:00" />
<meta property="article:modified_time" content="2019-04-15T06:34:52+00:00" />
<meta property="og:updated_time" content="2019-04-15T06:34:52+00:00" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2016/11/1480439398vuejs-logo.png" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2016/11/1480439398vuejs-logo.png" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Vue.js logo" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Jack Franklin tries out Vue.js 2.0, and walks through building a basic GitHub API demo to put the framework through its paces." />
<meta name="twitter:title" content="Getting up and Running with the Vue.js 2.0 Framework &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2016/11/1480439398vuejs-logo.png" />
<meta name="twitter:creator" content="@Jack_Franklin" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Getting up and Running with the Vue.js 2.0 Framework Comments Feed" href="https://www.sitepoint.com/up-and-running-vue-js-2-0/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1554938239' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.9.8' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.a5d3f22b541d65fe3929.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.a5d3f22b541d65fe3929.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-302ae967a92241deb24be6e2a54eeefd.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=144226' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fup-and-running-vue-js-2-0%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fup-and-running-vue-js-2-0%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/up-and-running-vue-js-2-0\/"},"headline":"Getting up and Running with the Vue.js 2.0 Framework","url":"http:\/\/www.sitepoint.com\/up-and-running-vue-js-2-0\/","thumbnailUrl":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2016\/11\/1480439398vuejs-logo-150x150.png","image":{"@type":"ImageObject","url":"https:\/\/dab1nmslvvntp.cloudfront.net\/wp-content\/uploads\/2016\/11\/1480439398vuejs-logo-150x150.png"},"dateCreated":"2019-04-15T06:30:24Z","datePublished":"2019-04-15T06:30:24Z","dateModified":"2019-04-15T06:30:24Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"Jack Franklin"}],"creator":["Jack Franklin"],"keywords":["github api","nilsonj","vue.js"],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "144226");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KL8PMMW"
  height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
        <header class="main-header u-isSingle" role="banner">
      <nav id="navigation-bar" class="l-d-f l-p-fix l-w-100">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto">
          <section class="l-d-f l-ai-str l-jc-sta l-gs-ph2 l-gs-ph1--2col">
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-f l-as-cen l-b-n">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
            </a>
          </section>
          <section id="hamburger-container" class="l-ai-cen l-d-f l-gs-ph1">
            <div class="hamburger">
              <div class="hamburger-box">
                <div class="hamburger-inner"></div>
              </div>
            </div>
          </section>

          <section id="nav-container" class="l-ai-cen">
            <ul id="nav" class="l-d-f l-w-100 l-ma0 l-fd-col">
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a id="nav-blog" href="/blog" data-text="Blog">Blog</a>
              </li>
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a href="/community" data-text="Community">Community</a>
              </li>
              <li class="l-gs-ph2 l-gs-ph1--2col t-ls-n">
                <a href="/premium/library/" data-text="Library">Library</a>
              </li>
                              <div class="l-d-f--2col"><li class="l-gs-ph2 l-gs-ph1--2col t-ls-n invert"><a href="/premium/sign-in" data-text="Login">Login</a></li><a href="/premium/sign-up?ref_source=sitepoint&amp;ref_medium=topnav&amp;ref_campaign=up-and-running-vue-js-2-0&amp;ref_content=javascript" class="Button u-small u-pink l-as-cen l-d-n l-gs-ph1 l-gs-mh1 f-smaller f-small--3col">Free 7-Day Trial</a></div>
                          </ul>
          </section>
        </div>
      </nav>

      <div class="NavBar_offsetSpacer"></div>
      <script>
                var current_category = ['javascript'];
          if (localStorage.getItem('SP_categories') !== null) {
            if (localStorage.getItem('SP_categories').includes(current_category) === false ) {
              var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
              var temp = current_category.concat(sp_categories);
              var filtered_categories = Array.from(new Set(temp));
              localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
            }
          }else {
            localStorage.setItem('SP_categories', JSON.stringify('javascript'));
          }
            // campaign
            localStorage.setItem('SP_slug', 'up-and-running-vue-js-2-0');

        
        /* Toggle mobile navigation */
        var toggleMobileNav = function(event) {
          var target = event.target;
          if(target.className.includes("hamburger")) {
            document.getElementById("hamburger-container").classList.toggle("open");
          }
        }
        var isTouchSupported = 'ontouchstart' in window;
        var startEvent = isTouchSupported ? 'touchstart' : 'click';
        document.addEventListener(startEvent, toggleMobileNav);

        /* Set active navigation item  */
        var current_url = window.location.href;
        if (current_url.indexOf("/blog") > -1) {
          document.getElementById("nav-blog").classList.add("youarehere");
        }  
      </script>
      <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="a5cb42616a9e53744"><script>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</script>
<style>
  .sp-smartbar {
    all: initial;
    -webkit-box-sizing: border-box;
            box-sizing: border-box;
    position: fixed;
    top: 0;
    width: 100%;
    font-size: 18px;
    font-family: "Roboto", "Helvetica Neue", "Helvetica", Helvetica, Arial, sans-serif;
  }
  .sp-smartbar__body {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    min-height: 0px;
    padding: .5em 1.5em;
    -webkit-box-align: center;
        -ms-flex-align: center;
            align-items: center;
    -webkit-box-pack: center;
        -ms-flex-pack: center;
            justify-content: center;
    -ms-flex-wrap: wrap;
        flex-wrap: wrap;
    background-color:#2c2c2c;
    color: #fff;
  }
  .sp-smartbar__body > * {
    margin: 0.25em 0.5em;
  }
  .sp-smartbar__close {
    all: initial;
    padding: .25em;
    display: -webkit-inline-box;
    display: -ms-inline-flexbox;
    display: inline-flex;
    cursor: pointer;
    position: absolute;
    top: 50%;
    right: 1em;
    -webkit-transform: translateY(-50%);
            transform: translateY(-50%);
    background: transparent;
    border: 0;
    color: #9b9b9b;
    font-size: 20px;
  }
  .sp-smartbar__close rect {
    fill: currentcolor;
    stroke: currentcolor;
  }
  .sp-smartbar__text {
    text-align: center;
    font-size: 26px;
    font-weight: 800;
    letter-spacing: .02em;
  }
  .sp-smartbar__countdown {
    display: -webkit-box;
    display: -ms-flexbox;
    display: flex;
    font-size: 1.5em;
    font-weight: 800;
    color: #fd6767;
  }
  .sp-smartbar__button a {
    display: inline-block;
    text-decoration: none;
    color: #fff;
    background: #3ec9cb;
    padding: .5em 1.5em;
    border-radius: 3px;
    font-weight: 500;
  }
</style></div>    </header>
<div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol itemscope itemtype='https://schema.org/BreadcrumbList' class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'>
              <a
                itemprop='item'
                itemscope
                itemtype='https://schema.org/Thing'
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/javascript/">
                <span itemprop='name'>
                  javascript                </span>
              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
            >
                              <span itemprop='name'>
                  April 14, 2019                </span>
                          </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    itemprop='item'
                    itemscope
                    itemtype='https://schema.org/Thing'
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/jfranklin/">
                    <span itemprop='name'>
                      Jack Franklin                    </span>
                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">Getting up and Running with the Vue.js 2.0 Framework</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
                <div class="l-d-f l-jc-sb l-mt3 l-w-4col--4col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-javascript">
      <div class='l-mt3 l-mh5--2col'>
      <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p class="wp-special"><em>Want to learn Vue.js from the ground up? Get an entire collection of Vue books covering fundamentals, projects, tips and tools &amp; more with SitePoint Premium. <a href="https://www.sitepoint.com/premium/products/Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvMzA3?utm_source=blog&amp;utm_medium=articles">Join now for just $9/month</a> or <a href="https://www.sitepoint.com/premium/sign-up?step=0?utm_source=blog&amp;utm_medium=articles">try our 7 day free trial</a>.</em></p>
<p><em>This article has been updated, primarily to bring the tooling section up to date.</em></p>
<p><strong>As soon as the popular JavaScript framework <a style="font-weight:bold" href="https://vuejs.org/">Vue.js</a> released <a style="font-weight:bold" href="https://medium.com/the-vue-point/vue-2-0-is-here-ef1f26acf4b8#.f6sth6njx">v2</a>, I was eager to give it a spin and see what it&rsquo;s like to work with. As someone who&rsquo;s pretty familiar with Angular and React, I was looking forward to seeing the similarities and differences between them and Vue.</strong></p>
<p>Vue 2 sports excellent performance stats, a relatively small payload (the bundled runtime version of Vue weighs in at 30KB once minified and gzipped), along with updates to companion libraries like vue-router and Vuex, the state management library for Vue. There&rsquo;s far too much to cover in just one article, but keep an eye out for some later articles where we&rsquo;ll look more closely at various libraries that couple nicely with the core framework.</p>
<h2 id="inspirationfromotherlibraries">Inspiration from Other Libraries</h2>
<p>As we go through this tutorial, you&rsquo;ll see many features that Vue has that are clearly inspired by other frameworks. This is a good thing; it&rsquo;s great to see new frameworks take some ideas from other libraries and improve on them. In particular, you&rsquo;ll see Vue&rsquo;s templating is very close to Angular&rsquo;s, but its components and component lifecycle methods are closer to React&rsquo;s (and Angular&rsquo;s, as well).</p>
<p>One such example of this is that, much like React and nearly every framework in JavaScript land today, Vue uses the idea of a virtual DOM to keep rendering efficient. Vue uses a fork of <a href="https://github.com/snabbdom/snabbdom">snabbdom</a>, one of the more popular virtual DOM libraries. The Vue site includes <a href="https://vuejs.org/v2/guide/render-function.html#Nodes-Trees-and-the-Virtual-DOM">documentation on its Virtual DOM rendering</a>, but as a user all you need to know is that Vue is very good at keeping your rendering fast (in fact, it performs better than React in many cases), meaning you can rest assured you&rsquo;re building on a solid platform.</p>
<h2 id="componentscomponentscomponents">Components, Components, Components</h2>
<p>Much like other frameworks these days, Vue&rsquo;s core building block is the component. Your application should be a series of components that build on top of each other to produce the final application. Vue.js goes one step further by suggesting (although not enforcing) that you define your components in a single <code>.vue</code> file, which can then be parsed by build tools (we&rsquo;ll come onto those shortly). Given that the aim of this article is to fully explore Vue and what it feels like to work with, I&rsquo;m going to use this convention for my application.</p>
<p>A Vue file looks like so:</p>
<pre><code class="markup language-markup">&lt;template&gt;
  &lt;p&gt;This is my HTML for my component&lt;/p&gt;
&lt;/template&gt;

&lt;script&gt;
  export default {
    // all code for my component goes here
  }
&lt;/script&gt;

&lt;style scoped&gt;
  /* CSS here
   * by including `scoped`, we ensure that all CSS
   * is scoped to this component!
   */
&lt;/style&gt;
</code></pre>
<p>Alternatively, you can give each element a <code>src</code> attribute and point to a separate HTML, JS or CSS file respectively if you don&rsquo;t like having all parts of the component in one file.</p>
<h2 id="settingupaproject">Setting Up a Project</h2>
<p>Whilst the excellent <a href="https://cli.vuejs.org/">Vue CLI</a> exists to make setting up a full project easy, when starting out with a new library I like to do it all from scratch so I get more of an understanding of the tools.</p>
<p>These days, <a href="https://webpack.js.org/">webpack</a> is my preferred build tool of choice, and we can couple that with the <a href="https://github.com/vuejs/vue-loader">vue-loader plugin</a> to support the Vue.js component format that I mentioned previously. We&rsquo;ll also need Babel and the <code>env</code> preset, so we can write all our code using modern JavaScript syntax, as well as the <a href="https://github.com/webpack/webpack-dev-server">webpack-dev-server</a>, which will update the browser when it detects a file change.</p>
<p>Let&rsquo;s initialize a project and install the dependencies:</p>
<pre><code class="bash language-bash">mkdir vue2-demo-project
cd vue2-demo-project
npm init -y
npm i vue
npm i webpack webpack-cli @babel/core @babel/preset-env babel-loader vue-loader vue-template-compiler webpack-dev-server html-webpack-plugin --save-dev
</code></pre>
<p>Then create the initial folders and files:</p>
<pre><code class="bash language-bash">mkdir src
touch webpack.config.js src/index.html src/index.js
</code></pre>
<p>The project structure should look like this:<proper-ad id="2"></proper-ad></p>
<pre><code class="text language-text">.
&#9500;&#9472;&#9472; package.json
&#9500;&#9472;&#9472; package-lock.json
&#9500;&#9472;&#9472; src
&#9474;   &#9500;&#9472;&#9472; index.html
&#9474;   &#9492;&#9472;&#9472; index.js
&#9492;&#9472;&#9472; webpack.config.js
</code></pre>
<p>Now let&rsquo;s set up the webpack configuration. This boils down to the following:</p>
<ul><li>Tell webpack to use the <code>vue-loader</code> for any <code>.vue</code> files</li>
<li>Tell webpack to use Babel and the <code>env</code> preset for any <code>.js</code> files</li>
<li>Tell webpack to generate an HTML file for the dev-server to serve, using <code>src/index.html</code> as a template:</li>
</ul><pre><code class="javascript language-javascript">//webpack.config.js
const VueLoaderPlugin = require('vue-loader/lib/plugin')
const HtmlWebPackPlugin = require("html-webpack-plugin")

module.exports = {
  module: {
    rules: [
      {
        test: /\.vue$/,
        loader: 'vue-loader',
      },
      {
        test: /\.js$/,
        exclude: /node_modules/,
        use: {
          loader: 'babel-loader',
          options: {
            presets: ['@babel/preset-env']
          }
        }
      }
    ]
  },
  plugins: [
    new VueLoaderPlugin(),
    new HtmlWebPackPlugin({
      template: "./src/index.html"
    })
  ]
}
</code></pre>
<p>Finally, we&rsquo;ll add some content to the HTML file and we&rsquo;re ready to go!</p>
<pre><code class="markup language-markup">&lt;!-- src/index.html --&gt;
&lt;!DOCTYPE html&gt;
&lt;html&gt;
  &lt;head&gt;
    &lt;title&gt;My Vue App&lt;/title&gt;
  &lt;/head&gt;
  &lt;body&gt;
    &lt;div id="app"&gt;&lt;/div&gt;
  &lt;/body&gt;
&lt;/html&gt;
</code></pre>
<p>We create an empty <code>div</code> with the ID of <code>app</code>, as this is the element that we&rsquo;re going to place our Vue application in. I always prefer to use a <code>div</code>, rather than just the <code>body</code> element, as that lets me have control over the rest of the page.</p>
<h2 id="writingourfirstvuejsapp">Writing Our First Vue.js App</h2>
<p>We&rsquo;re going to stay true to every programming tutorial ever and write a Vue application that puts &ldquo;Hello, World!&rdquo; onto the screen before we dive into something a bit more complicated.</p>
<p>Each Vue app is created by importing the library and then instantiating a new <code>Vue</code> instance:</p>
<pre><code class="javascript language-javascript">import Vue from 'vue'

const vm = new Vue({
  el: '#app',
})
</code></pre>
<p>We give Vue an element to render onto the page, and with that, we&rsquo;ve created a Vue application! We pass a selector for the element that we want Vue to replace with our application. This means when Vue runs it will take the <code>div#app</code> that we created and replace it with our application.</p>
<p>The reason we use the variable name <code>vm</code> is because it stands for &ldquo;View Model&rdquo;. Although not strictly associated with the <a href="https://en.wikipedia.org/wiki/Model%E2%80%93view%E2%80%93viewmodel">&ldquo;Model View View-Model&rdquo; (MVVM) pattern</a>, Vue was inspired in part by it, and the convention of using the variable name <code>vm</code> for Vue applications has stuck. Of course, you can call the variable whatever you&rsquo;d like!</p>
<p>So far, our application isn&rsquo;t doing anything, though, so let&rsquo;s create our first component, <code>App.vue</code>, that will actually render something onto the page.</p>
<p>Vue doesn&rsquo;t dictate how your application is structured, so this one is up to you. I ended up creating one folder per component, in this case <code>App</code> (I like the capital letter, signifying a component), with three files in it:</p>
<ul><li><code>index.vue</code></li>
<li><code>script.js</code></li>
<li><code>style.css</code></li>
</ul><pre><code class="bash language-bash">mkdir src/App
touch src/App/{index.vue,script.js,style.css}
</code></pre>
<p>The file structure should now be:</p>
<pre><code class="text language-text">.
&#9500;&#9472;&#9472; package.json
&#9500;&#9472;&#9472; package-lock.json
&#9500;&#9472;&#9472; src
&#9474;   &#9500;&#9472;&#9472; App
&#9474;   &#9474;   &#9500;&#9472;&#9472; index.vue
&#9474;   &#9474;   &#9500;&#9472;&#9472; srcipt.js
&#9474;   &#9474;   &#9492;&#9472;&#9472; style.css
&#9474;   &#9500;&#9472;&#9472; index.html
&#9474;   &#9492;&#9472;&#9472; index.js
&#9492;&#9472;&#9472; webpack.config.js
</code></pre>
<p><code>App/index.vue</code> defines the template, then imports the other files. This is in keeping with the structure recommended in the <a href="https://vuejs.org/v2/guide/single-file-components.html#What-About-Separation-of-Concerns">What About Separation of Concerns?</a> section of Vue&rsquo;s docs.</p>
<pre><code class="markup language-markup">&lt;!-- src/App/index.vue --&gt;
&lt;template&gt;
  &lt;p&gt;Hello, World!&lt;/p&gt;
&lt;/template&gt;
&lt;script src="./script.js"&gt;&lt;/script&gt;
&lt;style scoped src="./style.css"&gt;&lt;/style&gt;
</code></pre>
<p>I like calling it <code>index.vue</code>, but you might want to call it <code>app.vue</code> too so it&rsquo;s easier to search for. I prefer importing <code>App/index.vue</code> in my code versus <code>App/app.vue</code>, but again you might disagree, so feel free to pick whatever you and your team like best.</p>
<p>For now, our template is just <code>&lt;p&gt;Hello, World!&lt;/p&gt;</code>, and I&rsquo;ll leave the CSS file blank. The main work goes into <code>script.js</code>, which looks like so:<proper-ad id="3"></proper-ad></p>
<pre><code class="javascript language-javascript">export default {
  name: 'App',
  data() {
    return {}
  },
}
</code></pre>
<p>Doing this creates a component which we&rsquo;ll give the name <code>App</code>, primarily for debugging purposes, which I&rsquo;ll come to later, and then defines the data that this component has and is responsible for. For now, we don&rsquo;t have any data, so we can just tell Vue that by returning an empty object. Later on, we&rsquo;ll see an example of a component using data.</p>
<p>Now we can head back into <code>src/index.js</code> and tell the Vue instance to render our <code>App</code> component:</p>
<pre><code class="javascript language-javascript">import Vue from 'vue'

import AppComponent from './App/index.vue'

const vm = new Vue({
  el: '#app',
  components: {
    app: AppComponent,
  },
  render: h =&gt; h('app'),
})
</code></pre>
<p>Firstly, we import the component, trusting webpack and the vue-loader to take care of parsing it. We then declare the component. This is an important step: by default, Vue components are not globally available. Each component must have a list of all the components they&rsquo;re going to use, and the tag that it will be mapped to. In this case, because we register our component like so:</p>
<pre><code class="javascript language-javascript">components: {
  app: AppComponent,
}
</code></pre>
<p>This means that in our templates we&rsquo;ll be able to use the <code>app</code> element to refer to our component.</p>
<p>Finally, we define the <code>render</code> function. This function is called with a helper &mdash; commonly referred to as <code>h</code> &mdash; that&rsquo;s able to create elements. It&rsquo;s not too dissimilar to the <code>React.createElement</code> function that React uses. In this case, we give it the string <code>'app'</code>, because the component we want to render is registered as having the tag <code>app</code>.</p>
<p>More often than not (and for the rest of this tutorial) we won&rsquo;t use the <code>render</code> function on other components, because we&rsquo;ll define HTML templates. But the <a href="https://vuejs.org/guide/render-function">Vue.js guide to the render function</a> is worth a read if you&rsquo;d like more information.</p>
<p>Once we&rsquo;ve done that, the final step is to create an npm script in <code>package.json</code>:</p>
<pre><code class="javascript language-javascript">"scripts": {
  "start": "webpack-dev-server --mode development --open"
},
</code></pre>
<p>Now, run <code>npm run start</code>. Your default browser should open at <a href="http://localhost:8080/">http://localhost:8080/</a> and you should see &ldquo;Hello, World!&rdquo; on the screen.</p>
<p>Try editing <code>src/index.vue</code> to change the message to something else. If all has gone correctly, webpack-dev-server should refresh the page to reflect your changes.</p>
<p>Yay! We&rsquo;re up and running with Vue.js.</p>
<h2 id="vuedevtools">Vue Devtools</h2>
<p>Before we dive into a slightly more complicated app with Vue, now is a good time to mention that you should definitely get the <a href="https://github.com/vuejs/vue-devtools">Vue devtools</a> installed. These sit within the Chrome developer tools and give you a great way to look through your app and all the properties being passed round, state that each component has, and so on.</p>
<p><img src="https://raw.githubusercontent.com/vuejs/vue-devtools/master/media/screenshot.png" alt="Screenshot of the Vue devtools"></p>
<h2 id="buildingtheapp">Building the App</h2>
<p>As an example application, we&rsquo;re going to be using the GitHub API to build an application that lets us enter a username and see some GitHub stats about that user. I&rsquo;ve picked the GitHub API here as it&rsquo;s familiar to most people, usable without authenticating, and gives us a fair amount of information.<proper-ad id="4"></proper-ad></p>
<p>Before starting an application I like to have a quick think about what components we&rsquo;ll need, and I&rsquo;m thinking that our <code>App</code> component will render two further components: <code>GithubInput</code>, for taking input from the user, and <code>GithubOutput</code>, which will show the user&rsquo;s information on the screen. We&rsquo;ll start with the input.</p>
<p><em>Note: you can find all <a href="https://github.com/sitepoint-editors/vue2-demo-project">the code on GitHub</a> and even check out the <a href="http://sitepoint-vue2-demo.surge.sh/">application running online</a>.</em></p>
<h3 id="initialsetup">Initial Setup</h3>
<p>Create folders for the <code>GithubOutput</code> and <code>GithubInput</code> components within the <code>src</code> directory:</p>
<pre><code class="bash language-bash">mkdir src/{GithubInput,GithubOutput}
</code></pre>
<p>Add the necessary files to each:</p>
<pre><code class="bash language-bash">touch src/GithubInput/{index.vue,script.js,style.css}
touch src/GithubOutput/{index.vue,script.js,style.css}
</code></pre>
<p>The structure of the <code>src</code> folder should now look like so:</p>
<pre><code class="text language-text">.
&#9500;&#9472;&#9472; App
&#9474;   &#9500;&#9472;&#9472; index.vue
&#9474;   &#9500;&#9472;&#9472; script.js
&#9474;   &#9492;&#9472;&#9472; style.css
&#9500;&#9472;&#9472; GithubInput
&#9474;   &#9500;&#9472;&#9472; index.vue
&#9474;   &#9500;&#9472;&#9472; script.js
&#9474;   &#9492;&#9472;&#9472; style.css
&#9500;&#9472;&#9472; GithubOutput
&#9474;   &#9500;&#9472;&#9472; index.vue
&#9474;   &#9500;&#9472;&#9472; script.js
&#9474;   &#9492;&#9472;&#9472; style.css
&#9500;&#9472;&#9472; index.html
&#9492;&#9472;&#9472; index.js
</code></pre>
<h2 id="formsinvuejs">Forms in Vue.js</h2>
<p>Let&rsquo;s start with the <code>GithubInput</code> component. As with the <code>App</code> component, the <code>index.vue</code> file should contain the template, as well as loading in the script and CSS file. The template simply contains <code>&lt;p&gt;github input&lt;/p&gt;</code> for now. We&rsquo;ll fill it in properly shortly. I like putting in some dummy HTML so I can check I&rsquo;ve got the template wired up properly when creating a new component:</p>
<pre><code class="markup language-markup">&lt;!-- src/GithubInput/index.vue --&gt;
&lt;template&gt;
  &lt;p&gt;github input&lt;/p&gt;
&lt;/template&gt;

&lt;script src="./script.js"&gt;&lt;/script&gt;
&lt;style scoped src="./style.css"&gt;&lt;/style&gt;
</code></pre>
<p>When creating this component the one thing we do differently is create a piece of data that&rsquo;s associated with the component. This is very similar to React&rsquo;s concept of state:</p>
<pre><code class="javascript language-javascript">// src/GithubInput/script.js
export default {
  name: 'GithubInput',
  data() {
    return {
      username: '',
    }
  }
}
</code></pre>
<p>This says that this component has a piece of data, <code>username</code>, that it owns and is responsible for. We&rsquo;ll update this based on the user&rsquo;s input shortly.</p>
<p>Finally, to get this component onto the screen, I need to register it with the <code>App</code> component, as it&rsquo;s the <code>App</code> component that will be rendering it.</p>
<p>To do this, I update <code>src/App/script.js</code> and tell it about <code>GithubInput</code>:</p>
<pre><code class="javascript language-javascript">// src/App/script.js
import GithubInput from '../GithubInput/index.vue'

export default {
  name: 'App',
  components: {
    'github-input': GithubInput,
  },
  data() {
    return {}
  },
}
</code></pre>
<p>And then I can update the <code>App</code> component&rsquo;s template:</p>
<pre><code class="markup language-markup">&lt;!-- src/App/index.vue --&gt;
&lt;div&gt;
  &lt;p&gt;Hello World&lt;/p&gt;
  &lt;github-input&gt;&lt;/github-input&gt;
&lt;/div&gt;
</code></pre>
<p>A restriction of Vue components (which is also true in Angular and React) is that each component must have one root node, so when a component has to render multiple elements, it&rsquo;s important to remember to wrap them all in something, most commonly a <code>div</code>.</p>
<h2 id="trackingaforminput">Tracking a Form Input</h2>
<p>Our <code>GithubInput</code> component will need to do two things:<proper-ad id="5"></proper-ad></p>
<ul><li>Keep track of the current value of the input</li>
<li>Communicate that the value has changed, so that other components can know and therefore update their state.</li>
</ul><p>We can do the first version by creating a <code>form</code> with an <code>input</code> element in it. We can use Vue&rsquo;s built-in directives that enable us to keep track of form values. The template for <code>GithubInput</code> looks like so:</p>
<pre><code class="markup language-markup">&lt;form v-on:submit.prevent="onSubmit"&gt;
  &lt;input type="text" v-model="username" placeholder="Enter a github username here" /&gt;
  &lt;button type="submit"&gt;Go!&lt;/button&gt;
&lt;/form&gt;
</code></pre>
<p>There are two important attributes that you&rsquo;ll notice: <code>v-on</code> and <code>v-model</code>.</p>
<p><code>v-on</code> is how we bind to DOM events in Vue and call a function. For example, <code>&lt;p v-on:click="foo"&gt;Click me!&lt;/p&gt;</code> would call the component&rsquo;s <code>foo</code> method every time the paragraph was clicked. If you&rsquo;d like to go through event handling in greater detail, I highly recommend the <a href="https://vuejs.org/v2/guide/events.html">Vue documentation on event handling</a>.</p>
<p><code>v-model</code> creates a two-way data binding between a form input and a piece of data. Behind the scenes, <code>v-model</code> is effectively listening for change events on the form input and updating the data in the Vue component to match.</p>
<p>Taking our template above into consideration, here&rsquo;s how we&rsquo;re using <code>v-on</code> and <code>v-model</code> to deal with the data in the form:</p>
<ul><li><code>v-on:submit.prevent="onSubmit"</code> binds the method <code>onSubmit</code> to be run when the form is submitted. By adding <code>.prevent</code> that means that Vue will automatically prevent the default action from occurring. (If Vue didn&rsquo;t do this, we could call <code>event.preventDefault()</code> in our code, but we might as well take advantage of Vue&rsquo;s feature.)</li>
<li><code>v-model:username</code> binds the input&rsquo;s value to a value, <code>username</code>, in our code. For those of you familiar with Angular you may recognize this as very similar to <code>ng-model</code>. When we created <code>GithubInput</code> we declared that it had a piece of data, <code>username</code>, and here we&rsquo;ve bound that piece of data to the input field. The two will automatically be kept in sync.</li>
</ul><p>Now, back in our component&rsquo;s JavaScript, we can declare the <code>onSubmit</code> method. Note that the name here is entirely arbitrary &mdash; you can choose whatever you&rsquo;d like &mdash; but I like to stick with the convention of naming the function after the event that will trigger it:</p>
<pre><code class="javascript language-javascript">export default {
  name: 'GithubInput',
  data() {
    return { username: '', }
  },
  methods: {
    onSubmit(event) {
      if (this.username &amp;&amp; this.username !== '') {
      }
    }
  }
}
</code></pre>
<p>We can refer to data directly on <code>this</code>, so <code>this.username</code> will give us the latest value of the text box. If it&rsquo;s not empty, we want to let other components know that the data has changed. For this, we&rsquo;ll use a message bus. These are objects that components can emit events on and use to listen to other events. When your application grows larger you might want to look into a more structured approach, such as <a href="https://github.com/vuejs/vuex">Vuex</a>. For now, a message bus does the job.</p>
<p>The great news is that we can use an empty Vue instance as a message bus. To do so, we&rsquo;ll create <code>src/bus.js</code>, which simply creates a Vue instance and exports it:</p>
<pre><code class="javascript language-javascript">import Vue from 'vue'
const bus = new Vue()

export default bus
</code></pre>
<p>In the <code>GithubInput</code> component we can then import that module and use it by emitting an event when the username changes:</p>
<pre><code class="javascript language-javascript">import bus from '../bus'

export default {
  ...,
  methods: {
    onSubmit(event) {
      if (this.username &amp;&amp; this.username !== '') {
        bus.$emit('new-username', this.username)
      }
    }
  },
  ...
}
</code></pre>
<p>With that, our form is done, and we&rsquo;re ready to start doing something with the resulting data.</p>
<h2 id="displayingresultsfromgithub">Displaying Results From GitHub</h2>
<p>The <code>GithubOutput</code> component has the same structure as our other two components. In <code>GithubOutput/script.js</code> we also import the <code>bus</code> module, as we&rsquo;ll need it to know when the username changes. The data that this component will be responsible for will be an object that maps GitHub usernames to the data we got from the GitHub API. This means we won&rsquo;t have to make the request to the API every single time; if we&rsquo;ve already fetched the data previously we can simply reuse it. We&rsquo;ll also store the last username we were given, so we know what data to display on screen:</p>
<pre><code class="javascript language-javascript">// src/GithubOutput/script.js
import bus from '../bus'
import Vue from 'vue'

export default {
  name: 'GithubOutput',
  data() {
    return {
      currentUsername: null,
      githubData: {}
    }
  }
}
</code></pre>
<p>When the component is created, we want to listen for any <code>new-username</code> events that are emitted on the message bus. Thankfully, Vue supports a number of <a href="https://vuejs.org/api/#Options-Lifecycle-Hooks">lifecycle hooks</a>, including <code>created</code>. Because we&rsquo;re responsible developers, let&rsquo;s also stop listening for events when the component is destroyed by using the <code>destroyed</code> event:</p>
<pre><code class="javascript language-javascript">export default {
  name: 'GithubOutput',
  data: { ... },
  created() {
    bus.$on('new-username', this.onUsernameChange)
  },
  destroyed() {
    bus.$off('new-username', this.onUsernameChange)
  }
}
</code></pre>
<p>We then define the <code>onUsernameChange</code> method, which will be called and will set the <code>currentUsername</code> property:<proper-ad id="6"></proper-ad></p>
<pre><code class="javascript language-javascript">methods: {
  onUsernameChange(name) {
    this.currentUsername = name
  }
},
</code></pre>
<p>Note that we don&rsquo;t have to explicitly bind the <code>onUsernameChange</code> method to the current scope. When you define methods on a Vue component, Vue automatically calls <code>myMethod.bind(this)</code> on them, so they&rsquo;re always bound to the component. This is one of the reasons why you need to define your component&rsquo;s methods on the <code>methods</code> object, so Vue is fully aware of them and can set them up accordingly.</p>
<h3 id="conditionalrendering">Conditional Rendering</h3>
<p>If we don&rsquo;t have a username &mdash; as we won&rsquo;t when the component is first created &mdash; we want to show a message to the user. Vue has <a href="https://vuejs.org/guide/conditional.html">a number of conditional rendering techniques</a>, but the easiest is the <code>v-if</code> directive, which takes a condition and will only render the element if it exists. It also can be paired with <code>v-else</code>:</p>
<pre><code class="markup language-markup">&lt;!-- src/GithubOutput/index.vue--&gt;
&lt;template&gt;
  &lt;div&gt;
    &lt;p v-if="currentUsername == null"&gt;
      Enter a username above to see their GitHub data
    &lt;/p&gt;
    &lt;p v-else&gt;
      Below are the results for {{ currentUsername }}
    &lt;/p&gt;
  &lt;/div&gt;
&lt;/template&gt;
&lt;script src="./script.js"&gt;&lt;/script&gt;
&lt;style scoped src="./style.css"&gt;&lt;/style&gt;
</code></pre>
<p>Once again, this will look very familiar to any Angular developers. We use double equals rather than triple equals here because we want the conditional to be true not only if <code>currentUsername</code> is <code>null</code> but also if it&rsquo;s undefined, and <code>null == undefined</code> is <code>true</code>.</p>
<h3 id="fetchingfromgithub">Fetching from GitHub</h3>
<p>Vue.js doesn&rsquo;t ship with a built-in HTTP library, and for good reason. These days the <code>fetch</code> API ships natively in many browsers (although at the time of writing, not IE11, Safari or iOS Safari). For the sake of this tutorial I&rsquo;m not going to use a polyfill, but you can <a href="https://github.com/github/fetch">easily polyfill the API in browsers</a> if you need to. If you don&rsquo;t like the fetch API there are many third-party libraries for HTTP, and the one mentioned in the Vue docs is <a href="https://github.com/mzabriskie/axios">Axios</a>.</p>
<p>I&rsquo;m a big proponent of frameworks like Vue not shipping with HTTP libraries. It keeps the bundle size of the framework down and leaves it to developers to pick the library that works best for them, and easily customize requests as needed to talk to their API. I&rsquo;ll stick to the fetch API in this article, but feel free to swap it out for one that you prefer.</p>
<p>If you need an introduction to the fetch API, check out <a href="https://www.sitepoint.com/introduction-to-the-fetch-api/">Ludovico Fischer&rsquo;s post on SitePoint</a>, which will get you up to speed.</p>
<p>To make the HTTP request, we&rsquo;ll give the component another method, <code>fetchGithubData</code>, that makes a request to the GitHub API and stores the result. It will also first check to see if we already have data for this user, and not make the request if so:</p>
<pre><code class="javascript language-javascript">methods: {
  ...
  fetchGithubData(name) {
    // if we have data already, don't request again
    if (this.githubData.hasOwnProperty(name)) return

    const url = `https://api.github.com/users/${name}`
    fetch(url)
      .then(r =&gt; r.json())
      .then(data =&gt; {
        // in here we need to update the githubData object
      })
  }
}
</code></pre>
<p>We then finally just need to trigger this method when the username changes:</p>
<pre><code class="javascript language-javascript">methods: {
  onUsernameChange(name) {
    this.currentUsername = name
    this.fetchGithubData(name)
  },
  ...
}
</code></pre>
<p>There&rsquo;s one other thing to be aware of, due to the way that Vue keeps track of the data you&rsquo;re working with so that it knows when to update the view. There is a great <a href="https://vuejs.org/guide/reactivity.html">Reactivity guide</a> which explains it in detail, but essentially Vue isn&rsquo;t able to magically know when you&rsquo;ve added or deleted a property from an object, so if we do:</p>
<pre><code class="javascript language-javascript">this.githubData[name] = data
</code></pre>
<p>Vue won&rsquo;t recognize that and won&rsquo;t update our view. Instead, we can use the special <code>Vue.set</code> method, which explicitly tells Vue that we&rsquo;ve added a key. The above code would then look like so:</p>
<pre><code class="javascript language-javascript">Vue.set(this.githubData, name, data)
</code></pre>
<p>This code will modify <code>this.githubData</code>, adding the key and value that we pass it. It also notifies Vue of the change so it can rerender.</p>
<p>Now our code looks like so:</p>
<pre><code class="javascript language-javascript">const url = `https://api.github.com/users/${name}`
fetch(url)
  .then(r =&gt; r.json())
  .then(data =&gt; {
    Vue.set(this.githubData, name, data)
  })
</code></pre>
<p>Finally, we need to register the <code>GitHubOutput</code> component with the <code>App</code> component:<proper-ad id="7"></proper-ad></p>
<pre><code class="javascript language-javascript">// src/App/script.js
import GithubInput from '../GithubInput/index.vue'
import GithubOutput from '../GithubOutput/index.vue'

export default {
  name: 'App',
  components: {
    'github-input': GithubInput,
    'github-output': GithubOutput,
  },
  data() {
    return {}
  },
}
</code></pre>
<p>And include it in the template:</p>
<pre><code class="markup language-markup">&lt;!-- src/App/index.vue --&gt;
&lt;template&gt;
  &lt;div&gt;
    &lt;github-input&gt;&lt;/github-input&gt;
    &lt;github-output&gt;&lt;/github-output&gt;
  &lt;/div&gt;
&lt;/template&gt;
</code></pre>
<p>Although we haven&rsquo;t yet written the view code to show the fetched data on screen, you should be able to fill in the form with your username and then inspect the Vue devtools to see the data requested from GitHub. This shows how useful and powerful these devtools are; you can inspect the local state of any component and see exactly what&rsquo;s going on.</p>
<h3 id="showingsomestatsintheview">Showing Some Stats in the View</h3>
<p>We can now update the template to show some data. Let&rsquo;s wrap this code in another <code>v-if</code> directive so that we only render the data if the request has finished:</p>
<pre><code class="markup language-markup">&lt;!-- src/GithubOutput/index.vue --&gt;
&lt;p v-if="currentUsername == null"&gt;
  Enter a username above to see their GitHub data
&lt;/p&gt;
&lt;p v-else&gt;
  Below are the results for {{ currentUsername }}
  &lt;div v-if="githubData[currentUsername]"&gt;
    &lt;h4&gt;{{ githubData[currentUsername].name }}&lt;/h4&gt;
    &lt;p&gt;{{ githubData[currentUsername].company }}&lt;/p&gt;
    &lt;p&gt;Number of repos: {{ githubData[currentUsername].public_repos }}&lt;/p&gt;
  &lt;/div&gt;
&lt;/p&gt;
</code></pre>
<p>With that, we can now render the GitHub details to the screen, and our app is complete!</p>
<h2 id="refactors">Refactors</h2>
<p>There are definitely some improvements we can make. The above bit of HTML that renders the GitHub data only needs a small part of it &mdash; the data for the current user. This is the perfect case for another component that we can give a user&rsquo;s data to and it can render it.</p>
<p>Let&rsquo;s create a <code>GithubUserData</code> component, following the same structure as with our other components:</p>
<pre><code class="bash language-bash">mkdir src/GithubUserData
touch src/GithubUserData/{index.vue,script.js,style.css}
</code></pre>
<p>There&rsquo;s only one tiny difference with this component: it&rsquo;s going to take a property, <code>data</code>, which will be the data for the user. Properties (or, &ldquo;props&rdquo;) are bits of data that a component will be passed by its parent, and they behave in Vue much like they do in React. In Vue, you have to explicitly declare each property that a component needs, so here I&rsquo;ll say that our component will take one prop, <code>data</code>:</p>
<pre><code class="javascript language-javascript">// src/GithubUserData/script.js
export default {
  name: 'GithubUserData',
  props: ['data'],
  data() {
    return {}
  }
}
</code></pre>
<p>One thing I really like about Vue is how explicit you have to be; all properties, data, and components that a component will use are explicitly declared. This makes the code much nicer to work with and, I imagine, much easier as projects get bigger and more complex.</p>
<p>In the new template, we have exactly the same HTML as before, although we can refer to <code>data</code> rather than <code>githubData[currentUsername]</code>:</p>
<pre><code class="markup language-markup">&lt;!-- src/GithubUserData/index.vue --&gt;
&lt;template&gt;
  &lt;div v-if="data"&gt;
    &lt;h4&gt;{{ data.name }}&lt;/h4&gt;
    &lt;p&gt;{{ data.company }}&lt;/p&gt;
    &lt;p&gt;Number of repos: {{ data.public_repos }}&lt;/p&gt;
  &lt;/div&gt;
&lt;/template&gt;
&lt;script src="./script.js"&gt;&lt;/script&gt;
&lt;style scoped src="./style.css"&gt;&lt;/style&gt;
</code></pre>
<p>To use this component we need to update the <code>GithubOutput</code> component. Firstly, we import and register <code>GithubUserData</code>:</p>
<pre><code class="javascript language-javascript">// src/GithubOutput/script.js
import bus from '../bus'
import Vue from 'vue'
import GithubUserData from '../GithubUserData/index.vue'

export default {
  name: 'GithubOutput',
  components: {
    'github-user-data': GithubUserData,
  },
  ...
}
</code></pre>
<p>You can use any name for the component when declaring it, so where I&rsquo;ve placed <code>github-user-data</code>, you could place anything you want. It&rsquo;s advisable that you stick to components with a dash in them. Vue doesn&rsquo;t enforce this, but the W3C specification on custom elements states that they must contain a dash to prevent naming collisions with elements added in future versions of HTML.</p>
<p>Once we&rsquo;ve declared the component, we can use it in our template:</p>
<pre><code class="markup language-markup">&lt;!-- src/GithubOutput/index.vue --&gt;
&lt;p v-else&gt;
  Below are the results for {{ currentUsername }}:
  &lt;github-user-data :data="githubData[currentUsername]"&gt;&lt;/github-user-data&gt;
&lt;/p&gt;
</code></pre>
<p>The crucial part here is how I pass the <code>data</code> property down to the component:</p>
<pre><code class="javascript language-javascript">:data="githubData[currentUsername]"
</code></pre>
<p>The colon at the start of that attribute is crucial; it tells Vue that the attribute we&rsquo;re passing down is dynamic and that the component should be updated every time the data changes. Vue will evaluate the value of <code>githubData[currentUsername]</code> and ensure that the <code>GithubUserData</code> component is kept up to date as the data changes.</p>
<p>If you find <code>:data</code> a bit short and magical, you can also use the longer <code>v-bind</code> syntax:</p>
<pre><code class="javascript language-javascript">v-bind:data="githubData[currentUsername]"
</code></pre>
<p>The two are equivalent, so use whichever you prefer.</p>
<h2 id="conclusion">Conclusion</h2>
<p>With that, our GitHub application is in a pretty good state! You can find all <a href="https://github.com/sitepoint-editors/vue2-demo-project">the code on GitHub</a> and even check out the <a href="http://sitepoint-vue2-demo.surge.sh/">application running online</a>.</p>
<p>I had high hopes when getting started with Vue, as I&rsquo;d heard only good things, and I&rsquo;m happy to say it really met my expectations. Working with Vue feels like taking the best parts of React and merging them with the best parts of Angular. Some of the directives (like <code>v-if</code>, <code>v-else</code>, <code>v-model</code> and so on) are really easy to get started with (and easier to immediately understand than doing conditionals in React&rsquo;s JSX syntax), but Vue&rsquo;s component system feels very similar to React&rsquo;s.</p>
<p>You&rsquo;re encouraged to break your system down into small components, and all in all I found it a very seamless experience. I also can&rsquo;t commend the Vue team highly enough for their documentation: it&rsquo;s absolutely brilliant. The guides are excellent, and the API reference is thorough yet easy to navigate to find exactly what you&rsquo;re after.</p>
<p>If you&rsquo;ve enjoyed this post and would like to learn more, the best place to start is definitely the <a href="https://vuejs.org/">official Vue.js site</a>.</p></body></html>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/jfranklin/">
            <img src="https://secure.gravatar.com/avatar/aea964cf59c0c81fff752896f070cbbb?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/jfranklin/">
                Jack Franklin              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/Jack_Franklin"><i class="fab fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/jackfranklin"><i class="fab fa-github"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">I'm a JavaScript and Ruby Developer working in London, focusing on tooling, ES2015 and ReactJS.</div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
            <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <div>Sponsors</div>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="a5cb42616ba005765"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_sponsor_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_sponsor_1'); }); </script> </div>

</div></div></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="a5cb42616ba71e763"><div class="proper-ad-unit">

    <div id="proper-ad-sitepoint_side_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_1'); }); </script> 

</div>
</div></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html " id="a5cb42616bacf4728"><div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_side_2"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_2'); }); </script> </div>
</div></div><div class="widget maestro maestro-content-type-html " id="a5cb42616baffb730"><div class="proper-ad-unit Sticky">

    <div id="proper-ad-sitepoint_side_3"> <script> propertag.cmd.push(function() { proper_display('sitepoint_side_3'); }); </script> </div>

</div></div>        <ads-weighted widget='21' data='{"NL":[{"id":"584","weight":"50","randMax":50},{"id":"585","weight":"50","randMax":100}]}' fallback='' url='up-and-running-vue-js-2-0' channelSlug='javascript'></ads-weighted></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
          </div>

      <div class="u-accordion-end"></div>
          <div class="l-pa3 l-mt4">
      <div class="t-t t-o-100"><div class="l-w-100 l-w-4col--4col l-mh-auto  l-d-f l-jc-sb l-fw-w l-ai-cen"><a href="/premium/library/javascript/"><h4>Latest JavaScript Books <i class="fa fa-angle-right"></i></h4></a></div><div class="l-d-n l-d-f--4col l-fw-w l-jc-sa l-pv4 l-w-4col l-mh-auto"><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/real-time-3d-graphics-with-webgl-2-second-edition"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/4a89129f-13ba-4a2c-bf28-019df000d40f_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Real-Time 3D Graphics with WebGL 2 - Second Edition</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/mastering-react-native"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-workflow" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/c83c8e00-687a-4830-8e94-88892768bd6f_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Mastering React Native</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/vue-js-tools-skills"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/d29f36f0-6111-488f-a1d1-88a0bf7523d8_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">Vue.js: Tools &amp; Skills</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard m-border" href="https://www.sitepoint.com/premium/books/how-to-build-a-game-with-vue-js"><div class="l-w-100 t-bg-grey-200 u-book HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/e455bfdc-a22f-40b4-b28d-abeb8ed11d68_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb HomeCard_meta"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="f-mini f-light l-mb0">Ivaylo Gerchev</div></div><h3 class="l-mv1 f-medium f-bold f-lh-title">How to Build a Game with Vue.js</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-smaller f-lh-copy HomeCard_description"></div></div></a></div><div class="l-d-n--4col l-d-f l-fw-w l-jc-sb l-pv4"><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/real-time-3d-graphics-with-webgl-2-second-edition"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/4a89129f-13ba-4a2c-bf28-019df000d40f_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Real-Time 3D Graphics with WebGL 2 - Second Edition</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/mastering-react-native"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-workflow" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/c83c8e00-687a-4830-8e94-88892768bd6f_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Mastering React Native</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/vue-js-tools-skills"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/d29f36f0-6111-488f-a1d1-88a0bf7523d8_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Vue.js: Tools &amp; Skills</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col l-mb4"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel l-h-100" href="https://www.sitepoint.com/premium/books/how-to-build-a-game-with-vue-js"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer l-h-100"><div class="l-w-100 l-mb2 FeaturePanel_image u-book t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/books/e455bfdc-a22f-40b4-b28d-abeb8ed11d68_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-mini f-bold f-uppercase f-c-grey-300 l-mb0 l-ai-cen"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Book</div><div class="l-d-n l-d-b--4col f-mini f-light">Ivaylo Gerchev<span>, Mar 26</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">How to Build a Game with Vue.js</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div></div></div>
    </div>
    <div class="l-d-f l-jc-cen l-w-100 l-mb4">
      <a href="/premium/library/javascript/" class="Button u-large">All JavaScript Books</a>
    </div>
          <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="a5cb42616bb60c649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                      </div>
        </div>
      </div>

    
    <script>
      let data = 'javascript';
      if (localStorage && localStorage.SP_categories) {
        data = JSON.parse(localStorage.SP_categories).toString();
        data = data ? data.replace('-', '') : 'javascript'
      }

      oSpP && oSpP.push('channel', data);
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fas fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2019 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <sp-cookie-warning></sp-cookie-warning>
    

<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<div class="widget maestro maestro-content-type-html " id="a5cb42616bdf5e758"><script id="spout-tag-7c887d1e-c4ea-4682-bad8-216a89ce74e5">
  (function() {
    var r = encodeURIComponent(top.document.referrer.substring(0,250)),
        p = encodeURIComponent(top.document.location.href.substring(0,250)),
        t = Date.now(),
        u = '7c887d1e-c4ea-4682-bad8-216a89ce74e5',
        e = document.createElement('script'),
        s = sessionStorage.getItem('spoutable-' + u);
    if (!s) {
      var m = Math.random.bind(Math);
      s = JSON.stringify({ sessionId: [ t, m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m(), m() ]});
      sessionStorage.setItem('spoutable-' + u, s);
    }
    e.async = true;
    e.src='//s.spoutable.com/s?u='+u+'&s='+encodeURIComponent(s)+'&t='+t+'&r='+r+'&p='+p;
    document.head.appendChild(e);
  })();
</script></div><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="a5cb42616be2d4746"><div id="Sticky--bottom" class="l-d-f l-p-fix l-jc-cen u-fixed l-pt3 l-w-100 l-pt3">
<div class="proper-ad-unit">
    <div id="proper-ad-sitepoint_main_1"> <script> propertag.cmd.push(function() { proper_display('sitepoint_main_1'); }); </script> </div>
</div>
<i class="fas fa-times bottom-ad-close-button l-p-a"></i>
</div></div><script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-77d7df963c349e8aaeb6f2c765ce9a6e.js?ver=4.9.8'></script>
<script type="text/javascript" src="/dist/js/compiled.a5d3f22b541d65fe3929.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 39/58 objects using memcached
Page Caching using memcached 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2019-04-14 23:35:02 by W3 Total Cache
-->