<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'javascript');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
    }]);
  </script>
    <!-- BuySellAds PRO Code -->
<script class="SP_stripMobile" type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
<!-- End BuySellAds PRO Ad Code —>
    
<!-- This site is optimized with the Yoast SEO plugin v5.1 - https://yoast.com/wordpress/plugins/seo/ -->
<title>How to Create a QR Code Reader for Your Mobile Website &mdash; SitePoint</title>
<meta name="description" content="Take advantage of QR codes without the need for a native app. Dmitri Lau demonstrates how to build a QR code reader using just HTML, CSS and JavaScript."/>
<link rel="canonical" href="https://www.sitepoint.com/create-qr-code-reader-mobile-website/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to Create a QR Code Reader for Your Mobile Website &mdash; SitePoint" />
<meta property="og:description" content="Take advantage of QR codes without the need for a native app. Dmitri Lau demonstrates how to build a QR code reader using just HTML, CSS and JavaScript." />
<meta property="og:url" content="https://www.sitepoint.com/create-qr-code-reader-mobile-website/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="jamesh" />
<meta property="article:tag" content="mobile" />
<meta property="article:tag" content="QR code reader" />
<meta property="article:tag" content="QR Codes" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2017-08-14T13:00:32-07:00" />
<meta property="article:modified_time" content="2017-08-14T12:35:28-07:00" />
<meta property="og:updated_time" content="2017-08-14T12:35:28-07:00" />
<meta property="fb:admins" content="121300382" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1501061908qr-code-reader.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1501061908qr-code-reader.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1099" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Take advantage of QR codes without the need for a native app. Dmitri Lau demonstrates how to build a QR code reader using just HTML, CSS and JavaScript." />
<meta name="twitter:title" content="How to Create a QR Code Reader for Your Mobile Website &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1501061908qr-code-reader.jpg" />
<meta name="twitter:creator" content="@sitepointdotcom" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; How to Create a QR Code Reader for Your Mobile Website Comments Feed" href="https://www.sitepoint.com/create-qr-code-reader-mobile-website/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-0fccd23394da5cda365e749676667801.css?ver=4.8.1' type='text/css' media='all' />
<style id='sitepoint-styles-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.1" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=157902' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fcreate-qr-code-reader-mobile-website%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fcreate-qr-code-reader-mobile-website%2F&#038;format=xml" />
<!-- BEGIN wp-parsely Plugin Version 1.10.2 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.10.2' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/create-qr-code-reader-mobile-website\/"},"headline":"How to Create a QR Code Reader for Your Mobile Website","url":"http:\/\/www.sitepoint.com\/create-qr-code-reader-mobile-website\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/07\/1501061908qr-code-reader-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/07\/1501061908qr-code-reader-150x150.jpg"},"dateCreated":"2017-08-14T20:00:32Z","datePublished":"2017-08-14T20:00:32Z","dateModified":"2004-02-02T01:34:47Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"Dmitri Lau"}],"creator":["Dmitri Lau"],"publisher":{"@type":"Organization","name":"SitePoint"},"keywords":["jamesh","mobile","qr code reader","qr codes"]}   </script>
    <!-- END wp-parsely Plugin Version 1.10.2 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        		googletag.defineSlot("/7448792/SP2013_Articles_300x250_1", [300,250], "div-gpt-ad-1392428092543-0").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[300,250]]],[[1024, 0], [[300,250]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP2013_Articles_728x90_1", [728,90], "div-gpt-ad-article-header").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[728,90]]],[[1024, 0], [[728,90]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP2013_Articles_300x600_1", [[300, 600], [300, 250], [160, 600]], "div-gpt-ad-1392428092543-4").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[[300, 600], [300, 250], [160, 600]]]],[[1024, 0], [[[300, 600], [300, 250], [160, 600]]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_1", [200,125], "div-gpt-ad-1436815711585-0").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_2", [200,125], "div-gpt-ad-1436815711585-1").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_3", [200,125], "div-gpt-ad-1436815711585-2").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_4", [200,125], "div-gpt-ad-1436815711585-3").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "157902");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
        googletag.pubads().setTargeting("tags", ["jamesh","mobile","QR code reader","QR Codes"]);
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
    <header class="main-header" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-premium/sign-up">
            <i class="SidebarNav_icon fa fa-user u-premium/sign-up"></i>
            
            <a class="f-light" href="/premium/sign-up/?ref_source=sitepoint&ref_medium=drawer">Create Free Account</a>
          </li>      <li class="SidebarNav_link u-premium/sign-in">
            <i class="SidebarNav_icon fa fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer">Courses</a>
          </li>      <li class="SidebarNav_link u-premium/paths">
            <i class="SidebarNav_icon fa fa-map-marker u-premium/paths"></i>
            
            <a class="f-light" href="/premium/paths/?ref_source=sitepoint&ref_medium=drawer">Paths</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/?ref_source=sitepoint&ref_medium=drawer" data-channel="woorank">SEO By WooRank</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer">Community</a>
          </li>      <li class="SidebarNav_link u-newsletter">
            <i class="SidebarNav_icon fa fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer">Advertise</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium"><i class="l-mr2 f-medium fa fa-book"></i>Books & Courses</a>
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/community/"><i class="l-mr2 f-medium fa fa-comment"></i>Community</a>
            <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/sign-up" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Create Free Account</a></div>
          </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>

    </header>

<div class="l-d-n l-d-b--4col l-p-rel t-bg-white ChannelsNav">
  <ul class="l-d-f l-jc-cen l-w-100 l-w-3col--3col l-w-4col--4col l-pa0 l-mv0 l-mh-auto">
    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-html-css"><a href="https://www.sitepoint.com/html-css/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">HTML &amp; CSS</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-javascript"><a href="https://www.sitepoint.com/javascript/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">JavaScript</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-php"><a href="https://www.sitepoint.com/php/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">PHP</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-design-ux"><a href="https://www.sitepoint.com/design-ux/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Design &amp; UX</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-web"><a href="https://www.sitepoint.com/web/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Web</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-wordpress"><a href="https://www.sitepoint.com/wordpress/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">WordPress</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-woorank"><a href="https://www.sitepoint.com/woorank/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">SEO By WooRank</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-developer-center"><a href="https://www.sitepoint.com/developer-center/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Microsoft Tech</a></li>  </ul>
</div>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-492"><script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=sitepointjavascript" id="_fancybar_js"></script><script>ga('SitePointPlugin:observeImpressions', 'maestro-492')</script></div><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-610"><!-- BuySellAds PRO Zone Code (Pushdown Cookie Ad) -->
<div id="bsap_2431" class="bsaPROrocks" data-serve="CVAI5K3N"></div>
<!-- End BuySellAds PRO Zone Code --><script>ga('SitePointPlugin:observeImpressions', 'maestro-610')</script></div><div class="l-pt4 l-p-rel" role="main">
  <div class="Article_bg ChannelBackground u-javascript"></div>
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-3col--3col l-mh3 l-mh-auto--4col">
      <div class="l-d-f">
              <a href="https://www.sitepoint.com/javascript/" class="f-c-grey-700 f-bold t-bg-white l-pa2 l-d-if l-ai-cen"><i class="fa fa-circle t-color l-mr2 l-i2"></i>JavaScript</a>
            <div class="l-d-n l-d-b--3col l-ml3 l-pa2 l-d-if l-ai-cen f-c-grey-700 f-bold t-bg-white">Article</div>
        <span class="l-d-ib t-bg-white f-c-grey-500 f-light l-ml3">
          <span class="l-d-n l-d-ib--2col">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/dlau/" class="f-c-grey-500">
            Dmitri Lau        </a>
          </span>
    </span>
                <time class="l-d-ib l-pa2" datetime="2017-08-14" pubdate>August 14, 2017</time>
                      </span>
      </div>

      <h1 class="l-mv4 f-lh-title f-larger f-xxlarge--2col">
        <span class="t-bg-white l-pa2 l-d-i">How to Create a QR Code Reader for Your Mobile Website</span>
      </h1>
      <span class="l-d-n--2col l-d-ib l-mb3 t-bg-white f-c-grey-500 f-light">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/dlau/" class="f-c-grey-500">
            Dmitri Lau        </a>
          </span>
    </span>
    </div>
    
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto" data-hellobar="content">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
          
              <div class="l-mb4 l-pa3 t-bg-white m-border">
        <div class="l-mb3">
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h">
        <div class="widget maestro maestro-content-type-ad hide-for-mobile-SP" id="maestro-37"><!-- SP2013_Articles_728x90_1 -->
<div id="div-gpt-ad-article-header" style="" class="adspot m-728x90">
    <script type="text/javascript">googletag.cmd.push(function() { googletag.display("div-gpt-ad-article-header"); });</script>
    <script type="text/javascript">
      window.SP_GPT_Slots.push({
        id      : "article-header",
        name    : "SP2013_Articles_728x90_1",
        sizes   : [728,90],
        desktop : 1,
        tablet  : 1,
        phone   : 0
      });
    </script>
 </div></div>      </div>
    </div>
        <div class="ArticleCopy language-javascript">
      <p class="wp-special">The barcode and QR code have modernized our shopping and searching experience. Customers carrying smartphones can now pick up a product anywhere in the world, scan its barcode or its QR code using one of the many free phone apps and find out its lowest price as well as where it can be bought.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499229151barcode_apps.png" alt="Screenshots of apps with barcode scanner buttons" title="Phone apps that support barcode scanning"></p>
<p>Companies like Walmart and Amazon have embraced this technique to draw customers to their online and offline stores using their phone app. Other companies like Fedex and UPS allow customers to scan the codes on packages using a phone app, instead of needing to manually type in long lists of characters.</p>
<p>If the users of your mobile website have a need to type in long codes like activation codes or they like to look up specific products on your website based on a model number printed in a magazine or advertisement, then you too can take advantage of QR codes to eliminate the frustration of tiny keyboards and spare them the need to double check for errors.</p>
<div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-636"><div class="SP_stripMobile" style="width:100%;margin: 0 auto; max-width: 640px;"><span id="adBox" class="f-small f-light f-center">--ADVERTISEMENT--</span></div>


<script id="aniviewJS" src="https://play.aniview.com/5858ed930b8ee8851941a7bb/59627b0528a0616e231692a2/SitepointPMP.js"></script><script>
var el = document.getElementById('aniBox');
var adBox = document.getElementById('adBox');
// create an observer instance
var observer = new MutationObserver(function(mutations) {
  mutations.forEach(function(mutation) {
    if(mutation.attributeName == 'style'){
      var s = el.getAttribute('style');
      if(s.search('height: 360px') !=  -1) {
        adBox.style = 'display: block';
      }
      else {
        adBox.style = 'display: none';
      }
}
  });    
});

// configuration of the observer:
var config = { attributes: true, attributeFilter: ['style']};
 
// pass in the target node, as well as the observer options
observer.observe(el, config);
</script><script>ga('SitePointPlugin:observeImpressions', 'maestro-636')</script></div><h2 id="qrcodescanningwithyourmobilewebsite">QR Code Scanning with your Mobile Website</h2>
<div class="ArticleBox u-inline"><h3 class="ArticleBox_header t-bg">
                    <span class="ArticleBox_icon fa fa-pencil"></span> More from this author
                 </h3><div class="m-border ArticleBox_content"><ul class="ArticleBox_list"><li class="ArticleBox_listItem"><a class="f-c-grey-500 l-b-n" href="https://www.sitepoint.com/pebble-watch-timeline/?utm_source=sitepoint&amp;utm_medium=relatedinline&amp;utm_term=&amp;utm_campaign=relatedauthor">Understanding the Pebble Watch Timeline</a></li><li class="ArticleBox_listItem"><a class="f-c-grey-500 l-b-n" href="https://www.sitepoint.com/10-ways-make-website-mobile-friendly/?utm_source=sitepoint&amp;utm_medium=relatedinline&amp;utm_term=&amp;utm_campaign=relatedauthor">10 Ways to Make Your Website More Mobile Friendly</a></li></ul></div></div>
<p>You don&rsquo;t need a native phone app to scan QR codes &mdash;it&rsquo;s quite simple to create your own QR code reader. Your website running on a smartphone equipped with a camera and running a little JavaScript can do the same trick.</p>
<p>Here is a demo of a text field with an in-built QR button. In addition to being able to type text into the field, users can also click a button to activate the camera.</p>
<blockquote>
<p><strong>Browser Requirements:</strong><br>
  Your users need to be on an iPhone running iOS 6 or higher or an Android phone running Android 3.0 or higher. Other devices have not been tested.</p>
</blockquote>
<p data-height="200" data-theme-id="6441" data-slug-hash="gxbNwy" data-default-tab="result" data-user="SitePoint" data-embed-version="2" data-pen-title="Bare QR reader demo" class="codepen">See the Pen <a href="https://codepen.io/SitePoint/pen/gxbNwy/">Bare QR reader demo</a> by SitePoint (<a href="https://codepen.io/SitePoint">@SitePoint</a>) on <a href="https://codepen.io">CodePen</a>.</p>
<p><script async src="https://production-assets.codepen.io/assets/embed/ei.js"></script></p>
<p>If you are on a supported device, go ahead and click it. Depending on your phone, it will either launch the camera immediately or ask you whether to open the camera or browse your photo library. On unsupported devices, the browser will open up a regular file explorer window.</p>
<p>If you don&rsquo;t have a QR code handy to scan, here is one that shows the first 8 digits of Pi.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499242522Pi-encoded-as-QR.gif" alt="Test the QR Code Reader: QR code encoding the value of Pi" title="The digits of Pi encoded in a QR"></p>
<div id="premium-mid" class="Article_full_w l-d-f l-jc-cen l-fd-col t-bg-grey-500 l-mv4 l-pa3">
        <h2 class="f-c-white f-center f-large f-xxlarge--2col">Watch Responsive Tips and Tricks</h2>
        <h3 class="f-c-white f-center f-medium f-xlarge--2col l-mb4">No longer cutting edge, it's the norm</h3>
        
          <div class="l-w-100 l-d-f l-jc-cen Article_vid l-w-2col--2col l-mh-auto" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/dfb46398-5994-429d-839b-e8c130d973bc.png)">
            <a class="l-d-f" href="https://www.sitepoint.com/premium/courses/responsive-tips-and-tricks-2976">
              <img class="l-as-cen" src="//www.sitepoint.com/wp-content/themes/sitepoint/assets/svg/play-icon.svg"></a>
          </div>
  
        <div class="l-d-f l-jc-cen l-mt4">
          <a href="https://www.sitepoint.com/premium/courses/responsive-tips-and-tricks-2976" class="l-d-n l-d-ib--2col Button u-large l-ph5 l-mb4">Start Watching Now</a>
          <a href="https://www.sitepoint.com/premium/courses/responsive-tips-and-tricks-2976" class="l-d-n--2col Button l-ph5 l-mb4">Start Watching Now</a>
        </div>
      </div><h2 id="creatingtheqrcodereader">Creating the QR Code Reader</h2>
<p>The magic starts with the file upload element. We spruce it up with an <code>accept</code> attribute which tells the browser that we only want images and we give it a <code>capture</code> attribute which means we want the input to be captured now, as opposed to uploading an old picture from the phone&rsquo;s memory.</p>
<pre><code class="markup language-markup">&lt;input type=file
       accept="image/*"
       capture=environment&gt;
</code></pre>
<h3 id="beautifyingtheuploadelement">Beautifying the Upload element</h3>
<p>Because the file upload element is difficult to style and takes up a whole bunch of space, we want to shrink it down to an icon, which we can achieve by making it invisible and wrapping it inside a <code>label</code> element. The <code>label</code> element provides an area for the user to click on, as well as giving us an area to add our QR icon.</p>
<p>Notice that we&rsquo;ve also added a <code>tabindex=-1</code> attribute to prevent the user from accidentally reaching the file upload element with the <kbd>tab</kbd> key, since we intend to make it invisible.</p>
<pre><code class="markup language-markup">&lt;label class=qrcode-text-btn&gt;
  &lt;input type=file
         accept="image/*"
         capture=environment
         tabindex=-1&gt;
&lt;/label&gt;
</code></pre>
<p>The class name of <code>qrcode-text-btn</code> on the outer <code>label</code> element allows us to style both elements with the following CSS:</p>
<pre><code class="css language-css">.qrcode-text-btn {
  display: inline-block;
  height: 1em;
  width: 1em;
  background: url(qr_icon.svg) 50% 50% no-repeat;
  cursor: pointer;
}

.qrcode-text-btn &gt; input[type=file] {
  position: absolute;
  overflow: hidden;
  width: 1px;
  height: 1px;
  opacity: 0;
}
</code></pre>
<p>In the first CSS block, we are giving the <code>label</code> element a <code>display:inline-block</code> property, which allows us to assign a height and width to the element.</p>
<p>Then we give it a <code>background</code> image, which is the QR icon that the users of our QR code reader will see.</p>
<p>In the second CSS block we are using a direct descendant selector (<code>&gt;</code>) to select the file upload element and apply a couple of CSS properties to make that element invisible:</p>
<p>We give it a <code>position:absolute</code> property, so that it is excluded from the regular document flow, which means objects around it will flow over and under it as if it didn&rsquo;t exist.</p>
<p>We give it the <code>width:1px</code> and <code>height:1px</code> properties, so that it doesn&rsquo;t accidentally cover up other things on the page.</p>
<p>We give it an <code>opacity:0</code> property, so that it becomes transparent and therefore hidden. Note that we can&rsquo;t simply use <code>display:none</code>, because some browsers will completely disable the file upload element if we do that.</p>
<h3 id="introducingthetextinputelement">Introducing the Text Input element</h3>
<p>Next we introduce the text input element that will house the QR button for our QR code reader.</p>
<pre><code class="markup language-markup">&lt;input type=text class=qrcode-text
&gt;&lt;label class=qrcode-text-btn&gt;
   &lt;input type=file
         accept="image/*"
         capture=environment
         tabindex=-1&gt;
&lt;/label&gt;
</code></pre>
<blockquote>
<p><strong>Tip:</strong><br>
  Any white-space characters, including empty lines, in between 2 inline elements will create a gap that you might not want and affects our math. We have eliminated the white-space above by moving the end bracket (<code>&gt;</code>) to the next line touching the other element&rsquo;s opening bracket (<code>&lt;</code>).</p>
</blockquote>
<p>This is what our QR code reader should look like so far:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499242354qr-button-before-shift.png" alt="Button position before shifting to the left"></p>
<p>Right now the QR button is to the right of the text element. To make it appear inside it, we will shift it to the left overlapping part of the text field, using CSS.</p>
<pre><code class="css language-css">.qrcode-text {
  padding-right: 1.7em;
  margin-right: 0;
  vertical-align: middle;
}

.qrcode-text + .qrcode-text-btn {
  width: 1.7em;
  margin-left: -1.7em;
  vertical-align: middle;
}
</code></pre>
<p>In the first CSS block, we are giving the text element some white space on the right where the QR button will be located. Without the <code>padding</code>, any text inside the text element will run into and overlap the QR button.</p>
<p>We give it a <code>margin-right:0</code> property, because by default the text element has a non-zero margin which affects our math.</p>
<p>In the second CSS block, we are using the adjacent element selector (<code>+</code>) to select and apply CSS to the QR button, to cause it to shift to the left to overlap the text element.</p>
<blockquote>
<p><strong>Know Your Selectors</strong>: With the adjacent element selector, the CSS is only applied when the QR button is next to the text element. When the QR button is re-used elsewhere, the selector syntax won&rsquo;t apply and the QR button won&rsquo;t shift to the left unnecessarily.</p>
</blockquote>
<p>We need a <code>vertical-align:middle</code> property on both the text element and QR button to make the QR button appear vertically centered in the text box. Without it, the QR button will shift up because by default, the bottom of all <code>inline-block</code> elements are vertically aligned to the baseline of any inline elements around it.</p>
<p>Notice we&rsquo;re also giving the QR button a bigger <code>width</code> of <code>1.7em</code> to give users a bigger touch target. The QR icon itself won&rsquo;t get bigger, because the icon is only an image centered on the button and the button itself is transparent. The actual clickable area can be observed in this rendering where the button has been given a green background color.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499242356qr-button-actual-width.png" alt="Actual clickable area shown in green"></p>
<h2 id="includingthedependentjavascriptlibraries">Including the Dependent JavaScript Libraries</h2>
<p>The secret to reading QR codes is math and the substitute for math is open source libraries. To read QR codes we will be using the <a href="https://github.com/LazarSoft/jsqrcode">JavaScript port</a> of the Java based <a href="https://github.com/zxing/zxing">image processing library</a> written by ZXing. The JavaScript version was ported by Lazar Laszlo.</p>
<p>Because the JavaScript library consists of 17 files, I have taken the liberty of merging them into one file, wrapping the code in an anonymous function to prevent pollution of the global namespace and putting the file through Google Closure&rsquo;s minifier to make the file size smaller.</p>
<h3 id="someminortweakstothelibrary">Some Minor Tweaks to the Library</h3>
<p>In order to make the library more adaptable, I have also added a few minor changes to the library&rsquo;s output function to differentiate between a <em>success</em> response and an <em>error</em> response.</p>
<p>Two important changes made were made in <a href="https://github.com/sitepoint-editors/jsqrcode/blob/master/src/qrcode.js">qrcode.js</a> to these 2 lines:</p>
<pre><code class="javascript language-javascript">qrcode.result = "error decoding QR Code";
//...
qrcode.callback("Failed to load the image");
</code></pre>
<p>These strings have been replaced by <code>Error</code> objects:</p>
<pre><code class="javascript language-javascript">qrcode.result = Error("error decoding QR Code");
//...
qrcode.callback(Error("Failed to load the image"));
</code></pre>
<p>Now I can detect in my callback function whether an error occurred, just by checking if the callback payload is an instance of <code>Error</code> or not.</p>
<p>Those changes can be found in <a href="https://github.com/sitepoint-editors/jsqrcode/">this fork</a> of the library.</p>
<h3 id="addingthescripttag">Adding the Script Tag</h3>
<p>To use the library in our QR code reader, we first need to include it in our HTML using a regular script tag:</p>
<pre><code class="markup language-markup">&lt;script src="https://rawgit.com/sitepoint-editors/jsqrcode/master/src/qr_packed.js"&gt;
&lt;/script&gt;
</code></pre>
<h3 id="hookinguptheeventhandlers">Hooking up the Event Handlers</h3>
<p>Then we need to hook into the <code>onchange</code> event of the file upload element:</p>
<pre><code class="markup language-markup">&lt;input type=file
       accept="image/*"
       capture=environment
       onchange="openQRCamera(this);"
       tabindex=-1&gt;
</code></pre>
<p>Then we introduce the JavaScript function that will read the image in the file upload element and pass it to the QR library.</p>
<pre><code class="javascript language-javascript">function openQRCamera(node) {
  var reader = new FileReader();
  reader.onload = function() {
    node.value = "";
    qrcode.callback = function(res) {
      if(res instanceof Error) {
        alert("No QR code found. Please make sure the QR code is within the camera's frame and try again.");
      } else {
        node.parentNode.previousElementSibling.value = res;
      }
    };
    qrcode.decode(reader.result);
  };
  reader.readAsDataURL(node.files[0]);
}
</code></pre>
<p>In this function, we are creating a <code>FileReader</code> object which can read the binary data of the file.</p>
<p>Once the <code>FileReader</code> has finished reading the file, we assign a callback to the QR library and send the file contents to the <code>decode</code> function of the library. The library will call our callback and either return an <code>Error</code> object or return the value of the QR code as a string.</p>
<p>If successful, we set the text element to the value of the QR code. If an error occurs, we show an alert box telling the user to try again.</p>
<h3 id="showingahelpfulalertforbeginners">Showing a Helpful Alert for Beginners</h3>
<p>To make our QR code reader a little more intuitive for beginners, we will hook into the <code>onclick</code> event on the upload element and show an alert box before the camera appears, describing how to use the camera.</p>
<pre><code class="markup language-markup">&lt;input type=file
       accept="image/*"
       capture=environment
       onclick="return showQRIntro();"
       onchange="openQRCamera(this);"
       tabindex=-1&gt;
</code></pre>
<p>We will use a confirmation box instead of an alert box, so that the user can abort if they want to, after reading the tip.</p>
<pre><code class="javascript language-javascript">function showQRIntro() {
  return confirm("Use your camera to take a picture of a QR code.");
}
</code></pre>
<h3 id="seetheqrcodereaderinaction">See the QR Code Reader in Action</h3>
<p>This is what our QR code reader looks like so far:</p>
<p data-height="200" data-theme-id="6441" data-slug-hash="WEbVzd" data-default-tab="result" data-user="SitePoint" data-embed-version="2" data-pen-title="Nicer QR reader demo" class="codepen">See the Pen <a href="https://codepen.io/SitePoint/pen/WEbVzd/">Nicer QR reader demo</a> by SitePoint (<a href="https://codepen.io/SitePoint">@SitePoint</a>) on <a href="https://codepen.io">CodePen</a>.</p>
<p><script async src="https://production-assets.codepen.io/assets/embed/ei.js"></script></p>
<h3 id="howaboutunsupportedbrowsers">How about Unsupported Browsers?</h3>
<p>Right now the QR button will show up in all browsers regardless of support. We need a way to hide it in unsupported browsers.</p>
<p>We cannot use feature detection, because only iOS supports the <code>capture</code> attribute, and for Android, we are relying on the default behavior of webkit-derived browsers running on mobile devices of showing a selection sheet with <em>Camera</em> being one of the options.</p>
<p>On Windows tablet and laptop devices, the default behavior is to show the file explorer window, which doesn&rsquo;t help as it doesn&rsquo;t offer a camera option.</p>
<p>Our best bet is to use screen size detection and only show the QR button on smartphones, because marketshare of non-iOS and non-Android devices is <a href="http://www.idc.com/promo/smartphone-market-share/os">only 0.7% according to IDC (Nov 2016)</a>, and it also makes sense since taking photos with a tablet or laptop is difficult considering it&rsquo;s size and weight. We will use the arbitrary cut off size of 750 pixels width, which supports the iPhone 6 Plus (width is 736 pixels) and excludes netbooks (width is 800 pixels in portrait).</p>
<p>We will be using CSS media queries to accomplish this.</p>
<h3 id="usingcssmediaqueries">Using CSS Media Queries</h3>
<p>First we define the media query for when the device width is 750 pixels or less.</p>
<pre><code class="css language-css">@media only screen and (max-device-width:750px) {
  /* previous CSS code goes here */
}
</code></pre>
<p>We need to take all the CSS code we wrote earlier and put it inside the curly brackets above. This causes the CSS to only apply when the device width is less than 750 pixels.</p>
<p>Now we need to add some additional CSS code outside that media query block to hide the QR button by default. Put this code just before the media query block.</p>
<pre><code class="css language-css">.qrcode-text-btn {
  display: none;
}

@media only screen and (max-device-width:750px) {
   /* ... */
</code></pre>
<h3 id="provideconsistencyfordesigners">Provide Consistency for Designers</h3>
<p>While handy but not necessary, we will also add some additional CSS code outside the media query block to make the text input element behave consistently on both supported and unsupported devices.</p>
<pre><code class="css language-css">.qrcode-text {
  box-sizing: border-box;
  vertical-align: middle;
}

@media only screen and (max-device-width:750px) {
   /* ... */
</code></pre>
<p>We have given the <code>qrcode-text</code> element a <code>box-sizing:border-box</code> property, which makes sure its width calculation is inclusive of any padding. This means when the text element gets extra padding (when we previously used <code>padding-right:1.7em</code>), the width of the text element won&rsquo;t be wider, but will instead steal space from it&rsquo;s internal dimensions.</p>
<p>We have given it a <code>vertical-align:middle</code> property, so that it&rsquo;s vertical alignment is consistent regardless of whether it is on a supported or unsupported device.</p>
<h3 id="conclusion">Conclusion</h3>
<p>So there we have it, your very own QR code reader for your mobile website. </p>
<p>QR codes have been around for many years and the image processing code written by ZXing was first ported to JavaScript almost 6 years ago. Lazar Laszlo, the author of the JavaScript port, even has a proof of concept on his website using various HTML technologies to capture images and process for QR codes.</p>
<p>The technique shown here is just a rehashing of current technologies into a more attractive and user-friendly format for user consumption.</p>
<p>There is still room to improve our QR code reader. We can write code to use <code>getUserMedia</code> to capture images from the camera, which is more versatile, but that technology is newer and will exclude older iPhone and Android devices.</p>
<p>The image processing code could also be improved for faster detection and better handling of background noise.</p>
<p>Such changes can be left for a future article.</p>
<h3 id="downloadableassets">Downloadable Assets</h3>
<ul><li><a href="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499401426qr_icon.svg">QR icon in SVG format</a></li>
<li><a href="https://github.com/sitepoint-editors/jsqrcode/raw/master/src/qr_packed.js">QR JavaScript Library (minified)</a></li>
</ul><h3 id="externallinks">External Links</h3>
<ul><li><a href="https://www.w3.org/TR/html-media-capture/">W3 Specification for Image Capture</a></li>
<li><a href="http://caniuse.com/#feat=html-media-capture">CanIUse.com support matrix for Image Capture</a></li>
<li><a href="http://www.webqr.com">Proof of concept by Lazar Laszlo</a></li>
<li><a href="https://github.com/sitepoint-editors/jsqrcode/">Fork of the JavaScript library on Github</a></li>
<li><a href="https://github.com/zxing/zxing">Image Processing Library in Java by ZXing</a> </li>
</ul><p><em>This article was peer reviewed by <a href="https://www.sitepoint.com/author/gmainardi">Giulio Mainardi</a>. Thanks to all of SitePoint&rsquo;s peer reviewers for making SitePoint content the best it can be!</em></p>
    </div>
        <div class="l-mb3">
            <thumbvoter-buttons id="157902"
        url="https://www.sitepoint.com/wp-admin/admin-ajax.php"
        user_rating="0"
        channel="JavaScript"
      />
    </div>
        <div class="f-lh-copy l-d-f">
      <div class="l-fs0 l-mr3"><i class="fa fa-tag"></i> More: </div>
      <div class="f-c-teal-500">
<a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/mobile-2/">mobile</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/qr-code-reader/">QR code reader</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/qr-codes/">QR Codes</a>      </div>
    </div>
        </div>
            </div>
                
      </div>
      
      <div class="u-accordion-end"></div>
      <div class="l-w-100 l-pv2 l-pv4--2col versioning-background f-c-white l-p-rel">
        <svg class="versioning-icon l-d-n l-d-b--2col" viewBox="0 0 480 520">
        <g>
            <path d="M26.55,302.65 C4.63,311.21 -2.20,345.88 29.49,358.68 C14.87,383.59 22.25,398.89 54.48,407.25 C43.36,416.36 52.20,451.61 83.48,451.61 C79.25,468.00 91.71,495.93 126.54,482.94 C123.09,507.62 155.72,524.39 176.66,498.02 C179.98,517.56 210.61,530.04 229.5,507.62 C246.69,524.49 271.67,520.54 279.95,498.02 C305.14,526.81 335.92,506.14 335.92,482.94 C346.86,493.32 383.09,483.46 375.37,448.53 C399.29,452.21 411.99,430.50 407.51,407.25 C416.11,407.25 442.56,401.69 432.97,358.68 C455.37,353.11 462.73,315.11 432.97,300.44 C436.26,286.30 438,271.59 438,256.5 C438,237.85 435.35,219.80 430.40,202.67 C454.32,152.63 449.37,116.06 387.62,92.56 C397.94,72.67 387.62,36.88 348.21,43.26 C335.92,-13.58 279.95,12.02 272.09,26.41 C261.87,-4.25 209.08,-11.59 191.37,26.41 C176.66,10.83 126.54,10.77 120.87,59.98 C56.84,33.93 43.82,80.96 52.40,101.45 C-29.42,128.91 5.29,189.80 27.07,208.26 C23.10,223.71 21,239.86 21,256.5 C21,272.38 22.92,287.83 26.55,302.65 Z M282.53,351 C277.25,375.58 255.51,394 229.5,394 C203.48,394 181.74,375.58 176.46,351 L282.53,351 Z M400.68,266.86 C400.68,275.29 400.08,283.58 398.91,291.69 C393.90,285.77 386.43,282.01 378.09,282.01 C364.32,282.01 352.92,292.26 351.03,305.58 C346.05,300.39 339.07,297.16 331.33,297.16 C323.11,297.16 315.74,300.81 310.73,306.58 C305.72,300.81 298.34,297.16 290.12,297.16 C281.68,297.16 274.14,301.00 269.12,307.05 C264.11,301.00 256.56,297.16 248.12,297.16 C240.53,297.16 233.66,300.27 228.70,305.30 C223.75,300.27 216.88,297.16 209.29,297.16 C200.85,297.16 193.30,301.00 188.28,307.05 C183.27,301.00 175.72,297.16 167.28,297.16 C159.06,297.16 151.69,300.81 146.68,306.58 C141.66,300.81 134.29,297.16 126.07,297.16 C118.34,297.16 111.35,300.39 106.38,305.58 C104.48,292.26 93.09,282.01 79.31,282.01 C71.70,282.01 64.82,285.14 59.87,290.18 C58.84,282.56 58.31,274.77 58.31,266.86 C58.31,232.60 68.26,200.67 85.41,173.84 C109.56,172.10 140.65,165.07 173.36,153.10 C215.99,137.49 251.14,117.22 269.31,99.36 C269.76,99.46 270.20,99.57 270.64,99.68 C277.66,109.77 289.30,116.37 302.47,116.37 C305.41,116.37 308.27,116.04 311.02,115.42 C364.42,144.57 400.68,201.46 400.68,266.86 Z"></path>
            <ellipse cx="290.06" cy="218" rx="26.50" ry="26.50"></ellipse>
            <ellipse cx="169.93" cy="218" rx="26.50" ry="26.50"></ellipse>
        </g>
        </svg>
        <banner-subscribe cta="Make My Day Better" title="The most important and interesting stories in tech. Straight to your inbox, daily. Get Versioning." subtext="Need convincing?" sublinktext="Here's our latest edition." sublink="/versioning/issue/latest/?utm_source=sitepoint&amp;utm_medium=article&utm_content=%2Fcreate-qr-code-reader-mobile-website%2F" confirmation="Thanks! You'll get your first newsletter very soon." image="false" buttonclass="u-outline u-white" custom_fields="formSource" custom_values="Article" server-rendered="1"><div class="l-d-f l-w-2col--2col l-w-3col--3col l-ph4 l-mh-auto l-jc-cen "><form class="l-w-100 l-w-2col--2col"><div class="l-pv3 l-pt0--2col f-c-white f-center f-left--2col f-bold f-large f-larger--2col">The most important and interesting stories in tech. Straight to your inbox, daily. Get Versioning.</div><input aria-label="email" class="Input u-matchButtonHeight l-br f-center" type="email" placeholder="you@email.com" value required="required" /><button aria-label="Subscribe" class="Button l-w-100 l-ma0 u-outline u-white">Make My Day Better</button><div class="l-pt0--2col f-c-white f-center f-large f-larger--2col"><span class="f-c-white f-light f-medium l-ml3">Need convincing?</span><a class="f-c-white f-medium f-light f-underline l-ml3" href="/versioning/issue/latest/?utm_source=sitepoint&amp;utm_medium=article&amp;utm_content=%2Fcreate-qr-code-reader-mobile-website%2F">Here's our latest edition.</a></div></form></div></banner-subscribe>
      </div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
          
                <div class="Article_authorBio l-mv4 l-pa3 t-bg-white m-border">
        <div class="l-d-f">
          <a class="l-s5 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/dlau/">
            <img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2014/08/1409377210dlau2-96x96.jpg" width="96" height="96" alt="Dmitri Lau" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/dlau/">
                Dmitri Lau              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://plus.google.com/+DmitriLau/"><i class="fa fa-google-plus"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="http://www.linkedin.com/in/dmitrilau"><i class="fa fa-linkedin"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://codepen.io/dmitrilau/"><i class="fa fa-codepen"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/dmla"><i class="fa fa-github"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Dmitri Lau is a freelance Ajax developer with a penchant for statistical analysis. When not improving a meta template engine's relative response yield, yawning uninterruptedly every night has become a norm which he hopes will soon be over when his Hong Kong based startup picks up.</div>
      </div>
                
          <div class="widget maestro maestro-content-type-bsa hide-for-mobile-SP" id="maestro-440"><div class="l-pa3 t-bg-white"  id="maestro-440-bsa-149810">
<a href="//srv.buysellads.com/ads/click/x/GTND42QECVSIVK37F6SLYKQMCT7DEK7JF6YDVZ3JCWYD62JLCKAIE2JKC6BITKJUCYAIKK3EHJNCLSIZ" class="l-d-f l-ai-cen l-pa3 t-bg-grey-50" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-440-bsa-149810" data-ga-event-action="click"
>
<img src="//assets.servedby-buysellads.com/p/manage/asset/id/57125">
<span class="l-fg1 l-mh3 f-bold f-center f-underline f-lh-title f-c-grey-700">Kick-start your open source projects with access to hundreds of frameworks</span>
<button class="Button u-outline l-fs0">Learn more</button>
<span class="l-mh3 f-c-grey-300">AD</span>
</a>
</div><img src="https://ad.doubleclick.net/ddm/trackimp/N572608.452584BUYSELLADS.COM0/B20073109.201116379;dc_trk_aid=401148941;dc_trk_cid=90752671;ord=[1502770731];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" height="1" width="1" border="0" style="display: none;" /><img src="https://pixel.adsafeprotected.com/rfw/st/96690/16734277" height="1" width="1" border="0" style="display: none;" /><script>ga('SitePointPlugin:observeImpressions', ['maestro-440-bsa-149810'])</script></div>          <div id="commentsSection" class="l-pa3 t-bg-white">
                <div id="sp_comments_signin">
      <div class="f-larger f-bold l-mb3">Login or Create Account to Comment</div>
      <a href="/premium/sign-in?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fcreate-qr-code-reader-mobile-website%2F%23commentsSection" class="Button u-grey u-outline">Login</a>
      <a href="/premium/sign-up?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fcreate-qr-code-reader-mobile-website%2F%23commentsSection" class="Button l-ml3">Create Account</a>
    </div>
        <div data-spotim-module="recirculation" data-spot-id="sp_hAStREiw"></div>
    <script src="https://recirculation.spot.im/spot/sp_hAStREiw"></script>
    <script async
      src="https://launcher.spot.im/spot/sp_hAStREiw"
      data-spotim-module="spotim-launcher"
      data-spot-id="sp_hAStREiw"
      data-post-id="157902"
      data-disqus-url="https://www.sitepoint.com/create-qr-code-reader-mobile-website/"
      data-disqus-identifier="157902 https://www.sitepoint.com/?p=157902"></script>
    <script>
      if (window.SPOTIM && window.SPOTIM.startSSO) {
        startSSO();
      } else {
        document.addEventListener("spot-im-api-ready", startSSO, false);
      }

      function startSSO() {
        var callback = function(codeA, completeSSOCallback) {
          $.ajax({
            method: "GET",
            url: "/premium/api/v1/users/spot_im_sso/" + codeA,
            success : function(response){
              completeSSOCallback(response.code_b);
            }
        });
        };

        window.SPOTIM.startSSO(callback).then(function(result) {
          var button = document.getElementById("sp_comments_signin");
          button && button.remove();
        })
        .catch(function(reason){
          console.log(reason)
        });
      }
    </script>
                <a id="comments"></a>
                      </div>
        </div>
      </div>

      
          <div class="l-pa3 l-mt4">
      <div class="t-t t-o-100"><div class="l-w-100 l-w-4col--4col l-mh-auto  l-d-f l-jc-sb l-fw-w l-ai-cen"><a href="/premium?q=&amp;limit=24&amp;offset=0&amp;page=1&amp;content_types[]=All&amp;slugs[]=javascript&amp;states[]=available&amp;order="><h4 class="l-as-fs l-mv0 l-pv1 l-ph3 f-light f-larger f-uppercase f-c-white t-bg-grey-500">Latest JavaScript Books and Courses <i class="fa fa-angle-right"></i></h4></a></div><div class="l-d-n l-d-f--4col l-fw-w l-jc-sa l-pv4 l-w-4col l-mh-auto"><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/ember-2-0-2973"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>34m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/c9e39665-7d7c-469c-a944-628358a378d9_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Thomas Greco</div></div><h3 class="l-mv1 f-large f-bold">Ember 2.0</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="star-o"></i><meta content="4" itemProp="ratingValue" /></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Applications with the Ember JavaScript framework</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/introduction-to-grunt-js-2974"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>40m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/886d3c77-eedc-4a03-abc4-a21e4007bd2c_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Thomas Greco</div></div><h3 class="l-mv1 f-large f-bold">Introduction to Grunt.JS</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star-half-o"></i><i class="star-o"></i><meta content="3.5" itemProp="ratingValue" /></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">A quick introduction to Grunt</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/visualizing-data-with-d3-js-2920"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>1h 12m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/cdd1dc44-5982-47e3-a616-3061f5eb284d_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Max Froumentin</div></div><h3 class="l-mv1 f-large f-bold">Visualizing Data with D3.js</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star-half-o"></i><meta content="4.6" itemProp="ratingValue" /></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Illustrate Your Data with JavaScript</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/forms-with-react-and-redux-2935"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>41m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/fc200e21-78f4-4a8b-a7e4-3557ac658711_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Brad Westfall</div></div><h3 class="l-mv1 f-large f-bold">Forms with React and Redux</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star-half-o"></i><meta content="4.83333" itemProp="ratingValue" /></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Easily create forms with Redux Form</div></div></a></div><div class="l-d-n--4col l-d-f l-fw-w l-jc-sb l-pv4"><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/ember-2-0-2973"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>34m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/c9e39665-7d7c-469c-a944-628358a378d9_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Thomas Greco<span>, Jul 12</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Ember 2.0</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/introduction-to-grunt-js-2974"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>40m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/886d3c77-eedc-4a03-abc4-a21e4007bd2c_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Thomas Greco<span>, Jul 06</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Introduction to Grunt.JS</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/visualizing-data-with-d3-js-2920"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>1h 12m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/cdd1dc44-5982-47e3-a616-3061f5eb284d_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Max Froumentin<span>, Jul 05</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Visualizing Data with D3.js</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/forms-with-react-and-redux-2935"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>41m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image: url(https://d2sis3lil8ndrq.cloudfront.net/courses/fc200e21-78f4-4a8b-a7e4-3557ac658711_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Brad Westfall<span>, Jun 15</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Forms with React and Redux</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div></div></div>
    </div>
    <div class="l-d-f l-jc-cen l-w-100 l-mb4">
      <a href="/premium?q=&limit=24&offset=0&page=1&content_types[]=All&slugs[]=javascript&states[]=available&order=" class="Button u-large">All JavaScript Books and Courses</a>
    </div>
            <article-sharer data-url="https%3A%2F%2Fwww.sitepoint.com%2Fcreate-qr-code-reader-mobile-website%2F" data-title="How to Create a QR Code Reader for Your Mobile Website"></article-sharer>
    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          javascript: 'javascript',
        });
      });
    </script>
      </div>
    </div>
    <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-555"><script type="text/html" class=" ModalOnce" data-activate-delay=5 data-tracking="channelspecific" data-min-height="650" data-min-width="900" data-tracking-days="14">

<div id="channelspecific-modal" class="reveal-modal" data-reveal aria-labelledby="10 free SitePoint ebooks" aria-hidden="true" role="dialog">

<purchase-form
product="Z2lkOi8vbGVhcm5hYmxlL1Byb2R1Y3QvOTQ" 
title="10 free SitePoint ebooks"
 subtitle="Downloaded by more than 100,000 developers!" 
cta="Get Your Free Ebooks Now!" 
subtext="No credit card required. Completely free."
ga_event_label="maestro-555"
>

</purchase-form>
<a  data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-555" data-ga-event-action="close" class="close-reveal-modal" aria-label="Close">&#215;</a>
</script><script>ga('SitePointPlugin:observeImpressions', 'maestro-555')</script></div>    <footer class="l-d-f t-bg-grey-500" role="contentinfo" style="height: 500px;">
  <div class="l-d-f l-fw-w l-mh-auto">
    <div class="l-d-f l-mt4 l-w-100 l-w-2col--2col l-w-3col--4col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">About</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/about-us/">Our Story</a>
        </li>
        <li >
          <a class="m-link-white f-small" href="/advertise/">Advertise</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/press/">Press Room</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="http://reference.sitepoint.com/css/" target="_blank">Reference</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/">Terms of Use</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/#privacy">Privacy Policy</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://sitepoint.zendesk.com/hc/en-us" target="_blank">FAQ</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/contact-us/">Contact Us</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/write-for-us/">Contribute</a>
        </li>
      </ul>

      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Visit</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/">SitePoint Home</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/themes/?utm_source=blog&utm_medium=footer">Themes</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/versioning-show/">Podcast</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/community/">Forums</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/newsletter/">Newsletters</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/premium/">Premium</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/sass-reference/">References</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/versioning/">Versioning</a>
        </li>
      </ul>
    </div>

    <div class="l-mt4 l-w-1col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Connect</div>
        </li>
        <li>
          <a class="m-link-white" href="https://www.sitepoint.com/feed/">
            <i class="fa fa-rss-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="/newsletter/">
            <i class="fa fa-envelope-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-facebook-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
            <i class="fa fa-twitter-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-google-plus-square l-i4"></i>
          </a>
        </li>

        <p class="f-c-white l-mv3">
          &copy; 2000 &ndash; 2017 SitePoint Pty. Ltd.
        </p>
      </ul>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "https://www.sitepoint.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'sitepointproduction';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.setAttribute('data-cfasync', 'false'); e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-dfb2dddf3e07e06b11282e3f2248e361.js?ver=4.8.1'></script>
<script type="text/javascript" src="/dist/js/compiled.2a69e5ed3b0cfa0825d0.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
    <script>
    jQuery(document).ready(function() {
      jQuery('.lazyYT').each(function() {
        var id = jQuery(this).data('youtube-id'),
            url = 'https://www.youtube.com/watch?v=' + id;
        jQuery(this).replaceWith('<a href="' + url + '">' + url + '</a>');
      });
    });
    </script>
  
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 1389/1430 objects using memcached
Page Caching using memcached (SSL caching disabled)
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

 Served from: www.sitepoint.com @ 2017-08-14 21:18:51 by W3 Total Cache -->