<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'javascript');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var purchs2s = purchs2s||{};
      purchs2s.cmd = purchs2s.cmd || [];
      purchs2s.timeout=500;
      (function() {
        var ps2s = document.createElement('script');
        ps2s.async = true;
        ps2s.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        ps2s.src = (useSSL ? 'https:' : 'http:') + '//ads.servebom.com/purchs2s.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(ps2s, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//cdn-s2s.buysellads.net/pub/sitepoint.js" data-cfasync="false"></script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
    }]);
  </script>
    <!-- BuySellAds PRO Code -->
<script class="SP_stripMobile" type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
<!-- End BuySellAds PRO Ad Code —>
    
<!-- This site is optimized with the Yoast SEO plugin v7.5.3 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Build a JavaScript Single Page App Without a Framework &mdash; SitePoint</title>
<meta name="description" content="Michael shows how to build an SPA from scratch, without using a client-side JavaScript framework — helping you evaluate what these frameworks actually do."/>
<link rel="canonical" href="https://www.sitepoint.com/single-page-app-without-framework/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Build a JavaScript Single Page App Without a Framework &mdash; SitePoint" />
<meta property="og:description" content="Michael shows how to build an SPA from scratch, without using a client-side JavaScript framework — helping you evaluate what these frameworks actually do." />
<meta property="og:url" content="https://www.sitepoint.com/single-page-app-without-framework/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="Frameworks" />
<meta property="article:tag" content="modernjs" />
<meta property="article:tag" content="modernjs-hub" />
<meta property="article:tag" content="SPA" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2018-06-07T10:00:31-07:00" />
<meta property="article:modified_time" content="2018-05-02T17:51:46-07:00" />
<meta property="og:updated_time" content="2018-05-02T17:51:46-07:00" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/1525052457spa-no-framework.jpg" />
<meta property="og:image:secure_url" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/1525052457spa-no-framework.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Build a JavaScript Single Page App Without a Framework" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Michael shows how to build an SPA from scratch, without using a client-side JavaScript framework — helping you evaluate what these frameworks actually do." />
<meta name="twitter:title" content="Build a JavaScript Single Page App Without a Framework &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/1525052457spa-no-framework.jpg" />
<meta name="twitter:creator" content="@myxsys" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Build a JavaScript Single Page App Without a Framework Comments Feed" href="https://www.sitepoint.com/single-page-app-without-framework/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://www.sitepoint.com/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1528170318' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://www.sitepoint.com/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.9.6' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.03134c64867e12f28df2.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.03134c64867e12f28df2.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=165396' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fsingle-page-app-without-framework%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fsingle-page-app-without-framework%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/single-page-app-without-framework\/"},"headline":"Build a JavaScript Single Page App Without a Framework","url":"http:\/\/www.sitepoint.com\/single-page-app-without-framework\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2018\/04\/1525052457spa-no-framework-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2018\/04\/1525052457spa-no-framework-150x150.jpg"},"dateCreated":"2018-06-07T17:00:31Z","datePublished":"2018-06-07T17:00:31Z","dateModified":"2018-06-07T17:00:31Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"Michael Wanyoike"}],"creator":["Michael Wanyoike"],"keywords":["frameworks","modernjs","modernjs-hub","spa"],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "165396");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
        <header class="main-header u-isSingle" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-premium/l/join">
            <i class="SidebarNav_icon fa fa-user u-premium/l/join"></i>
            
            <a class="f-light" href="/premium/l/join?ref_source=sitepoint&ref_medium=drawer">Sign Up</a>
          </li>      <li class="SidebarNav_link u-premium/sign-in">
            <i class="SidebarNav_icon fa fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      
      <li class="SidebarNav_link u-premium/paths">
            <i class="SidebarNav_icon fa fa-map-marker u-premium/paths"></i>
            
            <a class="f-light" href="/premium/paths?ref_source=sitepoint&ref_medium=drawer">Learning Paths</a>
          </li>
            <li class="SidebarNav_link u-premium/deals/?ref_source=sitepoint&ref_medium=drawer">
            <i class="SidebarNav_icon fa fa-diamond u-premium/deals/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/deals/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer">Deals</a>
          </li>      <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer">Courses</a>
          </li>
    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript u-active">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/?ref_source=sitepoint&ref_medium=drawer" data-channel="woorank">SEO By WooRank</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-developer-center">
            <i class="SidebarNav_icon fa fa-circle u-developer-center"></i>
            <a class="f-light" href="https://www.sitepoint.com/developer-center/?ref_source=sitepoint&ref_medium=drawer" data-channel="developer-center">Microsoft Tech</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer">Community</a>
          </li>      <li class="SidebarNav_link u-versioning">
            
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/?ref_source=sitepoint&ref_medium=drawer">Versioning</a>
          </li>      <li class="SidebarNav_link u-newsletter">
            <i class="SidebarNav_icon fa fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer">Advertise</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
                        <sp-notification-dot
              notification_text="9"
              storage_key="DealsPage"
              url="/premium/deals/?ref_source=sitepoint&ref_medium=topnav"
              icon="diamond"
              link_text="Deals"
              nav_location="topNav"
              class="
                NavBar_item
                f-c-white
                f-light
                f-small
                l-ai-cen
                l-ai-str
                l-d-f--3col
                l-d-n
                l-ml3
                l-ml4--4col
                l-p-rel
                l-ph2
              ">
              <a class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                f-small
                f-light
                f-c-white
                NavBar_item"
                href="/premium/deals/?ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-medium fa fa-diamond"></i>
                Deals
              </a>
            </sp-notification-dot>
            <a
              class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                l-ml3
                l-ml4--4col
                l-pa2
                f-small
                f-light
                f-c-white
                NavBar_item"
              href="/premium/paths?ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-medium fa fa-map-marker"></i>
                Learning Paths
            </a>
                          <a
                class="
                  l-d-n
                  l-d-f--3col
                  l-ai-cen
                  l-ml3
                  l-ml4--4col
                  l-pa2
                  f-small
                  f-light
                  f-c-white
                  NavBar_item"
                href="/premium/topics/all?q=&limit=400&offset=0&page1&ref_source=sitepoint&ref_medium=topnav">
                  <i class="l-mr2 f-medium fa fa-book"></i>
                  Books & Courses
              </a>
            
                          <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=topnav&amp;ref_campaign=single-page-app-without-framework&amp;ref_content=javascript" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Sign Up</a></div>
                      </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>
      <script>
                var current_category = ['javascript'];
          if (localStorage.getItem('SP_categories') !== null) {
            if (localStorage.getItem('SP_categories').includes(current_category) === false ) {
              var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
              var temp = current_category.concat(sp_categories);
              var filtered_categories = Array.from(new Set(temp));
              localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
            }
          }else {
            localStorage.setItem('SP_categories', JSON.stringify('javascript'));
          }
            // campaign
            localStorage.setItem('SP_slug', 'single-page-app-without-framework');

              </script>
      <div class="widget maestro maestro-content-type-html " id="maestro-646"><sp-fixed-countdown-bar button_text="Get All Our Books and Courses for $9" button_url="https://www.sitepoint.com/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar" buttonclass="u-red u-white" end="2018-05-14 22:45:00 +1000" end_message="JOIN 35,339 OTHERS LEARNING WEB DEVELOPMENT WITH SITEPOINT PREMIUM" landingpageclass="v3 l-ph3" ga_event_label="646" countdown_message="Offer Ends In" server-rendered="1"><div class="FixedCountdownBar_trigger t-t false false"><div id="fixed-countdown-bar" class="FixedCountdownBar l-w-100 l-d-f l-jc-cen l-ai-cen l-pv3 l-ph3 f-c-white f-uppercase f-bold v3 l-ph3 false"><div class="fixed-countdown-bar__content-wrapper l-d-f l-ph0--4col l-fw-w l-ai-cen l-w-100 l-w-4col--4col l-mh-auto--4col l-ph4--3col l-jc-cen l-fd-col l-fd-row--3col l-jc-sb--3col"><div class="timer l-d-f l-ai-cen l-mb3 l-mb0--3col"><div class="timer__text-wrapper l-d-n l-d-b--2col l-w-100 f-center f-left--2col l-mb3 l-mb0--2col f-uppercase f-medium f-bold"><span class="f-medium f-larger--3col">Offer Ends In</span></div><div class="timer__countdown l-d-f l-jc-cen l-ai-cen l-fd-row"><span class="l-d-f l-d-n--2col l-w-100 l-jc-cen f-larger--3col false">Offer Ends In</span><div class="l-d-f l-mt0--2col f-medium l-mt0"><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">11</span><span class="f-light">hrs</span></div><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">38</span><span class="f-light">mins</span></div><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">45</span><span class="f-light">secs</span></div></div></div></div><div class><a data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="FixedCountdownBar_646" data-ga-event-action="click" href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar" class="Button l-ph4 l-pv2 f-small f-medium--3col u-red u-white">Get All Our Books and Courses for $9</a></div></div><a class="f-c-white l-d-f l-ai-cen l-pa2 t-t"><i class="fa fa-close"></i></a></div></div></sp-fixed-countdown-bar><script>ga('SitePointPlugin:observeImpressions', 'maestro-646')</script></div>    </header>
        <ads-weighted widget='85' data='{"fallback":[{"id":"673","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":50},{"id":"670","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":100}]}' fallback='' url='single-page-app-without-framework' channelSlug='javascript'></ads-weighted><div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-4col--4col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol itemscope itemtype='https://schema.org/BreadcrumbList' class='Article_breadcrumb l-ml0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'>
              <a
                itemprop='item'
                itemscope
                itemtype='https://schema.org/Thing'
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/javascript/">
                <span itemprop='name'>
                  javascript                </span>
              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
            >
                              <span itemprop='name'>
                  June 07, 2018                </span>
                          </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    itemprop='item'
                    itemscope
                    itemtype='https://schema.org/Thing'
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/mwanyoike/">
                    <span itemprop='name'>
                      Michael Wanyoike                    </span>
                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="f-lh-title f-larger l-mb4 f-c-white f-xxlarge--2col">
              <span class="f-c-white l-mr3">Build a JavaScript Single Page App Without a Framework</span>
            </h1>
                      </div>
                <script>
        var result = 'tools &amp; libraries,apis,raw javascript,jquery,ajax,es6,npm,angularjs,react,node.js,tools &amp; libraries';
        if (localStorage.getItem('SP_subCategories') !== null) {
          var categories = JSON.parse(localStorage.getItem('SP_subCategories'));
          temp = categories.concat(result.split(','));
          var filtered_categories = Array.from(new Set(temp));
          localStorage.setItem('SP_subCategories', JSON.stringify(filtered_categories));
        } else {
          localStorage.setItem('SP_subCategories', JSON.stringify(result.split(',')));
        }
      </script>

            <div class="l-w-1col--3col l-as-cen l-fs0 l-d-n l-d-b--2col l-ml3">
        <div class="f-c-white f-small f-bold l-w-100 l-mb3">Related Topics:</div>
        <div class="l-d-f l-fw-w">
        <a class="f-c-white" href="https://www.sitepoint.com/javascript/apis-javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">APIs</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/raw-javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Raw JavaScript</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/jquery/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">jQuery</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/ajax-javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">Ajax</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/es6/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">ES6</div></a><a class="f-c-white" href="https://www.sitepoint.com/javascript/"><div class="ArticleTags l-mr2 f-smaller l-d-f l-jc-cen l-ai-cen l-mb3">More...</div></a>        </div>
      </div>
              </div>
      </div>
    </div>
                <div class="l-d-f l-jc-sb l-mt3 l-w-4col--4col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
        <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-659"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["Frameworks","modernjs","modernjs-hub","SPA"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-6_123456"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-659')</script></div>      </div>

        <div class="ArticleCopy language-javascript">
      <div class='l-mt3 l-mh5--2col'>
      <p><strong>Front-end frameworks are great. They abstract away much of the complexity of building a single-page application (SPA) and help you organize your code in an intelligible manner as your project grows.</strong></p>
<p>However, there&rsquo;s a flip side: these frameworks come with a degree overhead and can introduce complexity of their own.</p>
<p>That&rsquo;s why, in this tutorial, we&rsquo;re going to learn how to build an SPA from scratch, without using a client-side JavaScript framework. This will help you evaluate what these frameworks actually do for you and at what point it makes sense to use one. It will also give you an understanding of the pieces that make up a typical SPA and how they&rsquo;re wired together.</p>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-682"><script id="aniviewJS" src="https://play.aniview.com/5858ed930b8ee8851941a7bb/59627b0528a0616e231692a2/SitepointPMP.js"></script><script>ga('SitePointPlugin:observeImpressions', 'maestro-682')</script></div><p>Let&rsquo;s get started &hellip;</p>
<h2 id="prerequisites">Prerequisites</h2>
<p>For this tutorial, you&rsquo;ll need a fundamental knowledge of <a href="https://www.sitepoint.com/anatomy-of-a-modern-javascript-application/">modern JavaScript</a> and <a href="https://jquery.com/">jQuery</a>. Some experience using <a href="https://handlebarsjs.com/">Handlebars</a>, <a href="https://expressjs.com/">Express</a> and <a href="https://github.com/axios/axios">Axios</a> will come handy, though it&rsquo;s not strictly necessary. You&rsquo;ll also need to have the following setup in your environment:</p>
<ul><li><a href="https://www.sitepoint.com/quick-tip-multiple-versions-node-nvm/">Node.js</a></li>
<li><a href="https://git-scm.com/downloads">Git</a> or <a href="https://gitforwindows.org/">Git Bash</a> for Window users.</li>
</ul><p>You can find the completed project on our <a href="https://github.com/sitepoint-editors/single-page-application">GitHub repository</a>.</p>
<h2 id="buildingtheproject">Building the Project</h2>
<p>We&rsquo;re going to build a simple currency application that will provide the following features:</p>
<ul><li>display the latest currency rates</li>
<li>convert from one currency to another</li>
<li>display past currency rates based on a specified date.</li>
</ul><p>We&rsquo;ll make use of the following free online REST APIs to implement these features:</p>
<ul><li><a href="https://fixer.io/">fixer.io API</a></li>
<li><a href="https://free.currencyconverterapi.com/">Free Currency Converter API</a>.</li>
</ul><p>Fixer is a well-built API that provides a foreign exchange and currency conversion JSON API. Unfortunately, it&rsquo;s a commercial service and the free plan doesn&rsquo;t allow currency conversion. So we&rsquo;ll also need to use the Free Currency Converter API. The conversion API has a few limitations, which luckily won&rsquo;t affect the functionality of our application. It can be accessed directly without requiring an API key. However, Fixer requires an API key to perform any request. Simply <a href="https://fixer.io/signup/free">sign up on their website to get an access key for the free plan</a>.</p>
<p>Ideally, we should be able to build the entire single-page application on the client side. However, since we&rsquo;ll be dealing with sensitive information (our API key) it won&rsquo;t be possible to store this in our client code. Doing so will leave our app vulnerable and open to any junior hacker to bypass the app and access data directly from our API endpoints. To protect such sensitive information, we need to put it in server code. So, we&rsquo;ll set up an <a href="https://expressjs.com/">Express</a> server to act as a proxy between the client code and the cloud services. By using a proxy, we can safely access this key, since server code is never exposed to the browser. Below is a diagram illustrating how our completed project will work.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396760901-project-plan.png" alt="Project plan"></p>
<p>Take note of the npm packages that will be used by each environment &mdash; i.e. browser (client) and server. Now that you know what we&rsquo;ll be building, head over to the next section to start creating the project.</p>
<h2 id="projectdirectoriesanddependencies">Project Directories and Dependencies</h2>
<p>Head over to your workspace directory and create the folder <code>single-page-application</code>. Open the folder in VSCode or your favorite editor and create the following files and folders using the terminal:</p>
<pre><code class="bash language-bash">touch .env .gitignore README.md server.js
mkdir public lib
mkdir public/js
touch public/index.html
touch public/js/app.js
</code></pre>
<p>Open <code>.gitignore</code> and add these lines:</p>
<pre><code class="bash language-bash">node_modules
.env
</code></pre>
<p>Open <code>README.md</code> and add these lines:</p>
<pre><code class="markdown language-markdown"># Single Page Application

This is a project demo that uses Vanilla JS to build a Single Page Application.
</code></pre>
<p>Next, create the <code>package.json</code> file by executing the following command inside the terminal:</p>
<pre><code class="bash language-bash">npm init -y
</code></pre>
<p>You should get the following content generated for you:</p>
<pre><code class="javascript language-javascript">{
  "name": "single-page-application",
  "version": "1.0.0",
  "description": "This is a project demo that uses Vanilla JS to build a Single Page Application.",
  "main": "server.js",
  "directories": {
    "lib": "lib"
  },
  "scripts": {
    "test": "echo \"Error: no test specified\" &amp;&amp; exit 1",
    "start": "node server.js"
  },
  "keywords": [],
  "author": "",
  "license": "ISC"
}
</code></pre>
<p>See how convenient the npm command is? The content has been generated based on the project structure.  Let&rsquo;s now install the core dependencies needed by our project. Execute the following command in your terminal:</p>
<pre><code class="bash language-bash">npm install jquery semantic-ui-css handlebars vanilla-router express dotenv axios
</code></pre>
<p>After the packages have finished installing, head over to the next section to start building the base of the application.</p>
<h2 id="applicationbase">Application Base</h2>
<p>Before we start writing our front-end code, we need to implement a server&ndash;client base to work from. That means a basic HTML view being served from an Express server. For performance and reliability reasons, we&rsquo;ll inject front-end dependencies straight from the <code>node_modules</code> folder. We&rsquo;ll have to set up our Express server in a special way to make this work. Open <code>server.js</code> and add the following:</p>
<pre><code class="javascript language-javascript">require('dotenv').config(); // read .env files
const express = require('express');

const app = express();
const port = process.env.PORT || 3000;

// Set public folder as root
app.use(express.static('public'));

// Allow front-end access to node_modules folder
app.use('/scripts', express.static(`${__dirname}/node_modules/`));

// Listen for HTTP requests on port 3000
app.listen(port, () =&gt; {
  console.log('listening on %d', port);
});
</code></pre>
<p>This gives us a basic Express server. I&rsquo;ve commented the code, so hopefully this gives you a fairly good idea of what&rsquo;s going on. Next, open <code>public/index.html</code> and enter:</p>
<pre><code class="markup language-markup">&lt;!DOCTYPE html&gt;
&lt;html lang="en"&gt;
&lt;head&gt;
  &lt;meta charset="UTF-8"&gt;
  &lt;meta name="viewport" content="width=device-width, initial-scale=1.0"&gt;
  &lt;meta http-equiv="X-UA-Compatible" content="ie=edge"&gt;
  &lt;link rel="stylesheet" href="scripts/semantic-ui-css/semantic.min.css"&gt;
  &lt;title&gt;SPA Demo&lt;/title&gt;
&lt;/head&gt;
&lt;body&gt;
  &lt;div class="ui container"&gt;
    &lt;!-- Navigation Menu --&gt;
    &lt;div class="ui four item inverted orange menu"&gt;
      &lt;div class="header item"&gt;
        &lt;i class="money bill alternate outline icon"&gt;&lt;/i&gt;
        Single Page App
      &lt;/div&gt;
      &lt;a class="item" href="/"&gt;
        Currency Rates
      &lt;/a&gt;
      &lt;a class="item" href="/exchange"&gt;
        Exchange Rates
      &lt;/a&gt;
      &lt;a class="item" href="/historical"&gt;
        Historical Rates
      &lt;/a&gt;
    &lt;/div&gt;

    &lt;!-- Application Root --&gt;
    &lt;div id="app"&gt;&lt;/div&gt;
  &lt;/div&gt;

  &lt;!-- JS Library Dependencies --&gt;
  &lt;script src="scripts/jquery/dist/jquery.min.js"&gt;&lt;/script&gt;
  &lt;script src="scripts/semantic-ui-css/semantic.min.js"&gt;&lt;/script&gt;
  &lt;script src="scripts/axios/dist/axios.min.js"&gt;&lt;/script&gt;
  &lt;script src="scripts/handlebars/dist/handlebars.min.js"&gt;&lt;/script&gt;
  &lt;script src="scripts/vanilla-router/dist/vanilla-router.min.js"&gt;&lt;/script&gt;
  &lt;script src="js/app.js"&gt;&lt;/script&gt;
&lt;/body&gt;
&lt;/html&gt;
</code></pre>
<p>We&rsquo;re using Semantic UI for styling. Please refer to the <a href="https://semantic-ui.com/collections/menu.html">Semantic UI Menu</a> documentation to understand the code used for our navigation bar. Go to your terminal and start the server:</p>
<pre><code class="bash language-bash">npm start
</code></pre>
<p>Open <a href="http://localhost:3000">localhost:3000</a> in your browser. You should have a blank page with only the navigation bar showing:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396761202-navbar.png" alt="Navigation bar"></p>
<p>Let&rsquo;s now write some view templates for our app.</p>
<h2 id="frontendskeletontemplates">Front-end Skeleton Templates</h2>
<p>We&rsquo;ll use <a href="https://handlebarsjs.com/">Handlebars</a> to write our templates. JavaScript will be used to render the templates based on the current URL. The first template we&rsquo;ll create will be for displaying error messages such as 404 or server errors. Place this code in <code>public/index.html</code> right after the the navigation section:</p>
<pre><code class="markup language-markup">&lt;!-- Error Template --&gt;
&lt;script id="error-template" type="text/x-handlebars-template"&gt;
  &lt;div class="ui {{color}} inverted segment" style="height:250px;"&gt;
    &lt;br&gt;
    &lt;h2 class="ui center aligned icon header"&gt;
      &lt;i class="exclamation triangle icon"&gt;&lt;/i&gt;
      &lt;div class="content"&gt;
        {{title}}
        &lt;div class="sub header"&gt;{{message}}&lt;/div&gt;
      &lt;/div&gt;
    &lt;/h2&gt;
  &lt;/div&gt;
&lt;/script&gt;
</code></pre>
<p>Next, add the following templates that will represent a view for each URL path we specified in the navigation bar:</p>
<pre><code class="markup language-markup">&lt;!-- Currency Rates Template --&gt;
&lt;script id="rates-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Currency Rates&lt;/h1&gt;
  &lt;hr&gt;
&lt;/script&gt;

&lt;!-- Exchange Conversion Template --&gt;
&lt;script id="exchange-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Exchange Conversion&lt;/h1&gt;
  &lt;hr&gt;
&lt;/script&gt;

&lt;!-- Historical Rates Template --&gt;
&lt;script id="historical-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Historical Rates&lt;/h1&gt;
  &lt;hr&gt;
&lt;/script&gt;
</code></pre>
<p>Next, let&rsquo;s compile all theses templates in <code>public/js/app.js</code>. After compilation, we&rsquo;ll render the <code>rates-template</code> and see what it looks like:</p>
<pre><code class="javascript language-javascript">window.addEventListener('load', () =&gt; {
  const el = $('#app');

  // Compile Handlebar Templates
  const errorTemplate = Handlebars.compile($('#error-template').html());
  const ratesTemplate = Handlebars.compile($('#rates-template').html());
  const exchangeTemplate = Handlebars.compile($('#exchange-template').html());
  const historicalTemplate = Handlebars.compile($('#historical-template').html());

  const html = ratesTemplate();
  el.html(html);
});
</code></pre>
<p>Take note that we&rsquo;re wrapping all JavaScript client code inside a <code>load</code> event. This is just to make sure that all dependencies have been loaded and that the DOM has completed loading. Refresh the page and see what we have:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396761503-currency-rates-blank.png" alt="Currency rates blank"></p>
<p>We&rsquo;re making progress. Now, if you click the other links, except <em>Currency Rates</em>, the browser will try to fetch a new page and end up with a message like this: <code>Cannot GET /exchange</code>.</p>
<p>We&rsquo;re a building a single page application, which means all the action should happen in one page. We need a way to tell the browser to stop fetching new pages whenever the URL changes.</p>
<h2 id="clientsiderouting">Client-side Routing</h2>
<p>To control routing within the browser environment, we need to implement client-side routing. There are many client-side routing libraries that can help out with this. For our project, we&rsquo;ll use <a href="https://www.npmjs.com/package/vanilla-router">vanilla router</a>, which is a very easy-to-use routing package.</p>
<p>If you recall, we had earlier included all the JavaScript libraries we need in <code>index.html</code>. Hence we can call the <code>Router</code> class right away. Remove the last two statements you added to <code>app.js</code> and replace them with this code:</p>
<pre><code class="javascript language-javascript">// Router Declaration
const router = new Router({
  mode: 'history',
  page404: (path) =&gt; {
    const html = errorTemplate({
      color: 'yellow',
      title: 'Error 404 - Page NOT Found!',
      message: `The path '/${path}' does not exist on this site`,
    });
    el.html(html);
  },
});

router.add('/', () =&gt; {
  let html = ratesTemplate();
  el.html(html);
});

router.add('/exchange', () =&gt; {
  let html = exchangeTemplate();
  el.html(html);
});

router.add('/historical', () =&gt; {
  let html = historicalTemplate();
  el.html(html);
});

// Navigate app to current url
router.navigateTo(window.location.pathname);

 // Highlight Active Menu on Refresh/Page Reload
const link = $(`a[href$='${window.location.pathname}']`);
link.addClass('active');

$('a').on('click', (event) =&gt; {
  // Block browser page load
  event.preventDefault();

  // Highlight Active Menu on Click
  const target = $(event.target);
  $('.item').removeClass('active');
  target.addClass('active');

  // Navigate to clicked url
  const href = target.attr('href');
  const path = href.substr(href.lastIndexOf('/'));
  router.navigateTo(path);
});
</code></pre>
<p>Take some time to go through the code. I&rsquo;ve added comments in various sections to explain what&rsquo;s happening. You&rsquo;ll notice that, in the router&rsquo;s declaration, we&rsquo;ve specified the <code>page404</code> property to use the error template. Let&rsquo;s now test the links:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396761904-historical-navigation.png" alt="Historical navigation blank"></p>
<p>The links should now work. But we have a problem. Click either the <code>/exchange</code> or <code>historical</code> link, then refresh the browser. We get the same error as before &mdash; <code>Cannot GET /exchange</code>. To fix this, head over to <code>server.js</code> and add this statement right before the listen code:</p>
<pre><code class="javascript language-javascript">// Redirect all traffic to index.html
app.use((req, res) =&gt; res.sendFile(`${__dirname}/public/index.html`));
</code></pre>
<p>You&rsquo;ll have to restart the the server using <kbd>Ctrl</kbd> + <kbd>C</kbd> and executing <code>npm start</code>. Go back to the browser and try to refresh. You should now see the page render correctly. Now, let&rsquo;s try entering a non-existent path in the URL like <code>/exchanges</code>. The app should display a 404 error message:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396762205-404-error.png" alt="404 error"></p>
<p>We&rsquo;ve now implemented the necessary code to create our single-page-app skeleton. Let&rsquo;s now start working on listing the latest currency rates.</p>
<h2 id="latestcurrencyrates">Latest Currency Rates</h2>
<p>For this task, we&rsquo;ll make use of the <a href="https://fixer.io/documentation#latestrates">Fixer Latest Rates Endpoint</a>. Open the <code>.env</code> file and add your API key. We&rsquo;ll also specify the timeout period and the symbols we&rsquo;ll list on our page. Feel free to increase the timeout value if you have a slower internet connection:</p>
<pre><code class="env language-env">API_KEY=&lt;paste key here&gt;
PORT=3000
TIMEOUT=5000
SYMBOLS=EUR,USD,GBP,AUD,BTC,KES,JPY,CNY
</code></pre>
<p>Next create the file <code>lib/fixer-service.js</code>. This is where we&rsquo;ll write helper code for our Express server to easily request information from Fixer. Copy the following code:</p>
<pre><code class="javascript language-javascript">require('dotenv').config();
const axios = require('axios');

const symbols = process.env.SYMBOLS || 'EUR,USD,GBP';

// Axios Client declaration
const api = axios.create({
  baseURL: 'http://data.fixer.io/api',
  params: {
    access_key: process.env.API_KEY,
  },
  timeout: process.env.TIMEOUT || 5000,
});

// Generic GET request function
const get = async (url) =&gt; {
  const response = await api.get(url);
  const { data } = response;
  if (data.success) {
    return data;
  }
  throw new Error(data.error.type);
};

module.exports = {
  getRates: () =&gt; get(`/latest&amp;symbols=${symbols}&amp;base=EUR`),
};
</code></pre>
<p>Again, take some time to go through the code to understand what&rsquo;s happening. If you&rsquo;re unsure, you can also check out the documentation for <a href="https://www.npmjs.com/package/dotenv">dotenv</a>, <a href="https://www.npmjs.com/package/axios">axios</a> and read up on <a href="https://www.sitepoint.com/understanding-module-exports-exports-node-js/">module exports</a>. Let&rsquo;s now do a quick test to confirm the <code>getRates()</code> function is working.</p>
<p>Open <code>server.js</code> and add this code:</p>
<pre><code class="javascript language-javascript">const { getRates } = require('./lib/fixer-service');

...
// Place this block at the bottom
const test = async() =&gt; {
  const data = await getRates();
  console.log(data);
}

test();
</code></pre>
<p>Run <code>npm start</code> or <code>node server</code>. After a few seconds, you should get the following output:</p>
<pre><code class="javascript language-javascript">{
  success: true,
  timestamp: 1523871848,
  base: 'EUR',
  date: '2018-04-16',
  rates: {
    EUR: 1,
    USD: 1.23732,
    GBP: 0.865158,
    AUD: 1.59169,
    BTC: 0.000153,
    KES: 124.226892,
    JPY: 132.608498,
    CNY: 7.775567
  }
}
</code></pre>
<p>If you get something similar to the above, it means the code is working. The values will of course be different, since the rates change every day. Now comment out the test block and insert this code right before the statement that redirects all traffic to <code>index.html</code>:</p>
<pre><code class="javascript language-javascript">// Express Error handler
const errorHandler = (err, req, res) =&gt; {
  if (err.response) {
    // The request was made and the server responded with a status code
    // that falls out of the range of 2xx
    res.status(403).send({ title: 'Server responded with an error', message: err.message });
  } else if (err.request) {
    // The request was made but no response was received
    res.status(503).send({ title: 'Unable to communicate with server', message: err.message });
  } else {
    // Something happened in setting up the request that triggered an Error
    res.status(500).send({ title: 'An unexpected error occurred', message: err.message });
  }
};

// Fetch Latest Currency Rates
app.get('/api/rates', async (req, res) =&gt; {
  try {
    const data = await getRates();
    res.setHeader('Content-Type', 'application/json');
    res.send(data);
  } catch (error) {
    errorHandler(error, req, res);
  }
});
</code></pre>
<p>As we can see, there&rsquo;s a custom error handler function that&rsquo;s designed to handle different error scenarios, which can occur during execution of server code. When an error occurs, an error message is constructed and sent back to the client.</p>
<p>Let&rsquo;s confirm this bit of code is working. Restart the Express server and navigate your browser to this URL: <a href="http://localhost:3000/api/rates">localhost:3000/api/rates</a>. You should see the same JSON result that was displayed in the console. We can now implement a view that will display this information in a neat, elegant table.</p>
<p>Open <code>public/index.html</code> and replace the <code>rates-template</code> with this code:</p>
<pre><code class="markup language-markup">&lt;!-- Currency Rates Template --&gt;
&lt;script id="rates-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Currency Rates&lt;/h1&gt;
  &lt;hr&gt;
  &lt;div class="ui loading basic segment"&gt;
    &lt;div class="ui horizontal list"&gt;
      &lt;div class="item"&gt;
        &lt;i class="calendar alternate outline icon"&gt;&lt;/i&gt;
        &lt;div class="content"&gt;
          &lt;div class="ui sub header"&gt;Date&lt;/div&gt;
          &lt;span&gt;{{date}}&lt;/span&gt;
        &lt;/div&gt;
      &lt;/div&gt;
      &lt;div class="item"&gt;
        &lt;i class="money bill alternate outline icon"&gt;&lt;/i&gt;
        &lt;div class="content"&gt;
          &lt;div class="ui sub header"&gt;Base&lt;/div&gt;
          &lt;span&gt;{{base}}&lt;/span&gt;
        &lt;/div&gt;
      &lt;/div&gt;
    &lt;/div&gt;

    &lt;table class="ui celled striped selectable inverted table"&gt;
      &lt;thead&gt;
        &lt;tr&gt;
          &lt;th&gt;Code&lt;/th&gt;
          &lt;th&gt;Rate&lt;/th&gt;
        &lt;/tr&gt;
      &lt;/thead&gt;
      &lt;tbody&gt;
        {{#each rates}}
        &lt;tr&gt;
          &lt;td&gt;{{@key}}&lt;/td&gt;
          &lt;td&gt;{{this}}&lt;/td&gt;
        &lt;/tr&gt;
        {{/each}}
      &lt;/tbody&gt;
    &lt;/table&gt;
  &lt;/div&gt;
&lt;/script&gt;
</code></pre>
<p>Remember we&rsquo;re using Semantic UI to provide us with styling. I&rsquo;d like you to pay close attention to the <a href="https://semantic-ui.com/elements/segment.html#loading">Segment loading</a> component. This will be an indication to let users know that something is happening as the app fetches the data. We&rsquo;re also using the <a href="https://semantic-ui.com/collections/table.html">Table UI</a> to display the rates. Please go though the linked documentation if you&rsquo;re new to Semantic.</p>
<p>Now let&rsquo;s update our code in <code>public/js/app.js</code> to make use of this new template. Replace the the first <code>route.add('/')</code> function with this code:</p>
<pre><code class="javascript language-javascript">// Instantiate api handler
const api = axios.create({
  baseURL: 'http://localhost:3000/api',
  timeout: 5000,
});

// Display Error Banner
const showError = (error) =&gt; {
  const { title, message } = error.response.data;
  const html = errorTemplate({ color: 'red', title, message });
  el.html(html);
};

// Display Latest Currency Rates
router.add('/', async () =&gt; {
  // Display loader first
  let html = ratesTemplate();
  el.html(html);
  try {
    // Load Currency Rates
    const response = await api.get('/rates');
    const { base, date, rates } = response.data;
    // Display Rates Table
    html = ratesTemplate({ base, date, rates });
    el.html(html);
  } catch (error) {
    showError(error);
  } finally {
    // Remove loader status
    $('.loading').removeClass('loading');
  }
});
</code></pre>
<p>The first code block instantiates an API client for communicating with our proxy server. The second block is a global function for handling errors. Its work is simply to display an error banner in case something goes wrong on the server side. The third block is where we get rates data from the <code>localhost:3000/api/rates</code> endpoint and pass it to the <code>rates-template</code> to display the information.</p>
<p>Simply refresh the browser. You should now have the following view:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396762406-currency-rates.png" alt="Currency rates"></p>
<p>Next we&rsquo;ll build an interface for converting currencies.</p>
<h2 id="exchangeconversion">Exchange Conversion</h2>
<p>For the currency conversion, we&rsquo;ll use two endpoints:</p>
<ul><li><a href="https://fixer.io/documentation#supportedsymbols">Fixer&rsquo;s Symbols Endpoint</a></li>
<li><a href="https://www.currencyconverterapi.com/docs">Free Currency Converter Endpoint</a>.</li>
</ul><p>We need the symbols endpoint to get a list of supported currency codes. We&rsquo;ll use this data to populate the dropdowns that the users will use to select which currencies to convert. Open <code>lib/fixer-service.js</code> and add this line right after the <code>getRates()</code> function:</p>
<pre><code class="javascript language-javascript">getSymbols: () =&gt; get('/symbols'),
</code></pre>
<p>Create another helper file, <code>lib/free-currency-service.js</code>, and add the following code:</p>
<pre><code class="javascript language-javascript">require('dotenv').config();
const axios = require('axios');

const api = axios.create({
  baseURL: 'https://free.currencyconverterapi.com/api/v5',
  timeout: process.env.TIMEOUT || 5000,
});

module.exports = {
  convertCurrency: async (from, to) =&gt; {
    const response = await api.get(`/convert?q=${from}_${to}&amp;compact=y`);
    const key = Object.keys(response.data)[0];
    const { val } = response.data[key];
    return { rate: val };
  },
};
</code></pre>
<p>This will help us get the conversion rate from one currency to another for free. In the client code, we&rsquo;ll have to calculate the conversion amount by multiplying amount by rate. Now let&rsquo;s add these two service methods to our Express server code. Open <code>server.js</code> and update accordingly:</p>
<pre><code class="javascript language-javascript">const { getRates, getSymbols, } = require('./lib/fixer-service');
const { convertCurrency } = require('./lib/free-currency-service');
...
// Insert right after get '/api/rates', just before the redirect statement

// Fetch Symbols
app.get('/api/symbols', async (req, res) =&gt; {
  try {
    const data = await getSymbols();
    res.setHeader('Content-Type', 'application/json');
    res.send(data);
  } catch (error) {
    errorHandler(error, req, res);
  }
});

// Convert Currency
app.post('/api/convert', async (req, res) =&gt; {
  try {
    const { from, to } = req.body;
    const data = await convertCurrency(from, to);
    res.setHeader('Content-Type', 'application/json');
    res.send(data);
  } catch (error) {
    errorHandler(error, req, res);
  }
});
</code></pre>
<p>Now our proxy server should be able to get symbols and conversion rates. Take note that <code>/api/convert</code> is a POST method. We&rsquo;ll use a form on the client side to build the currency conversion UI. Feel free to use the <code>test</code> function to confirm both endpoints are working. Here&rsquo;s an example:</p>
<pre><code class="javascript language-javascript">// Test Symbols Endpoint
const test = async() =&gt; {
  const data = await getSymbols();
  console.log(data);
}

// Test Currency Conversion Endpoint
const test = async() =&gt; {
  const data = await convertCurrency('USD', 'KES');
  console.log(data);
}
</code></pre>
<p>You&rsquo;ll have to restart the server for each test. Remember to comment out the tests once you&rsquo;ve confirmed the code is working so far. Let&rsquo;s now work on our currency conversion UI. Open <code>public/index.html</code> and update the <code>exchange-template</code> by replacing the existing code with this:</p>
<pre><code class="markup language-markup">&lt;script id="exchange-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Exchange Rate&lt;/h1&gt;
  &lt;hr&gt;
  &lt;div class="ui basic loading segment"&gt;
    &lt;form class="ui form"&gt;
      &lt;div class="three fields"&gt;
        &lt;div class="field"&gt;
          &lt;label&gt;From&lt;/label&gt;
          &lt;select class="ui dropdown" name="from" id="from"&gt;
            &lt;option value=""&gt;Select Currency&lt;/option&gt;
            {{#each symbols}}
              &lt;option value="{{@key}}"&gt;{{this}}&lt;/option&gt;
            {{/each}}
          &lt;/select&gt;
        &lt;/div&gt;
        &lt;div class="field"&gt;
          &lt;label&gt;To&lt;/label&gt;
          &lt;select class="ui dropdown" name="to" id="to"&gt;
            &lt;option value=""&gt;Select Currency&lt;/option&gt;
            {{#each symbols}}
              &lt;option value="{{@key}}"&gt;{{this}}&lt;/option&gt;
            {{/each}}
          &lt;/select&gt;
        &lt;/div&gt;
        &lt;div class="field"&gt;
          &lt;label&gt;Amount&lt;/label&gt;
          &lt;input type="number" name="amount" id="amount" placeholder="Enter amount"&gt;
        &lt;/div&gt;
      &lt;/div&gt;
      &lt;div class="ui primary submit button"&gt;Convert&lt;/div&gt;
      &lt;div class="ui error message"&gt;&lt;/div&gt;
    &lt;/form&gt;
    &lt;br&gt;
    &lt;div id="result-segment" class="ui center aligned segment"&gt;
      &lt;h2 id="result" class="ui header"&gt;
        0.00
      &lt;/h2&gt;
    &lt;/div&gt;
  &lt;/div&gt;
&lt;/script&gt;
</code></pre>
<p>Take your time to go through the script and understand what&rsquo;s happening. We&rsquo;re using <a href="https://semantic-ui.com/collections/form.html">Semantic UI Form</a> to build the interface. We&rsquo;re also using Handlebars notation to populate the dropdown boxes. Below is the JSON format used by Fixer&rsquo;s Symbols endpoint:</p>
<pre><code class="javascript language-javascript">{
  "success": true,
  "symbols": {
    "AED": "United Arab Emirates Dirham",
    "AFN": "Afghan Afghani",
    "ALL": "Albanian Lek",
    "AMD": "Armenian Dram",
  }
}
</code></pre>
<p>Take note that the symbols data is in map format. That means the information is stored as key <code>{{@key}}</code> and value <code>{{this}}</code> pairs. Let&rsquo;s now update <code>public/js/app.js</code> and make it work with the new template. Open the file and replace the existing route code for <code>/exchange</code> with the following:</p>
<pre><code class="javascript language-javascript">// Perform POST request, calculate and display conversion results
const getConversionResults = async () =&gt; {
  // Extract form data
  const from = $('#from').val();
  const to = $('#to').val();
  const amount = $('#amount').val();
  // Send post data to Express(proxy) server
  try {
    const response = await api.post('/convert', { from, to });
    const { rate } = response.data;
    const result = rate * amount;
    $('#result').html(`${to} ${result}`);
  } catch (error) {
    showError(error);
  } finally {
    $('#result-segment').removeClass('loading');
  }
};

// Handle Convert Button Click Event
const convertRatesHandler = () =&gt; {
  if ($('.ui.form').form('is valid')) {
    // hide error message
    $('.ui.error.message').hide();
    // Post to Express server
    $('#result-segment').addClass('loading');
    getConversionResults();
    // Prevent page from submitting to server
    return false;
  }
  return true;
};

router.add('/exchange', async () =&gt; {
  // Display loader first
  let html = exchangeTemplate();
  el.html(html);
  try {
    // Load Symbols
    const response = await api.get('/symbols');
    const { symbols } = response.data;
    html = exchangeTemplate({ symbols });
    el.html(html);
    $('.loading').removeClass('loading');
    // Validate Form Inputs
    $('.ui.form').form({
      fields: {
        from: 'empty',
        to: 'empty',
        amount: 'decimal',
      },
    });
    // Specify Submit Handler
    $('.submit').click(convertRatesHandler);
  } catch (error) {
    showError(error);
  }
});
</code></pre>
<p>Refresh the page. You should now have the following view:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396762707-exchange-ui.png" alt="Exchange UI"></p>
<p>Select some currencies of your choosing and enter an amount. Then hit the <em>Convert</em> button:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396762908-exchange-error.png" alt="Exchange error"></p>
<p>Oops! We just hit an error scenario. At least we know our error handling code is working. To figure out why the error is occurring, go back to the server code and look at the <code>/api/convert</code> function. Specifically, look at the line that says  <code>const { from, to } = req.body;</code>.</p>
<p>It seems Express is unable to read properties from the <code>request</code> object. To fix this, we need to install middleware that can help out with this:</p>
<pre><code class="bash language-bash">npm install body-parser
</code></pre>
<p>Next, update the server code as follows:</p>
<pre><code class="javascript language-javascript">const bodyParser = require('body-parser');
...

/** Place this code right before the error handler function **/

// Parse POST data as URL encoded data
app.use(bodyParser.urlencoded({
  extended: true,
}));

// Parse POST data as JSON
app.use(bodyParser.json());
</code></pre>
<p>Start the server again and refresh the browser. Try doing another conversion. It should now work.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396763109-exchange-conversion-works.png" alt="Exchange conversion"></p>
<p>Let&rsquo;s now focus on the final bit &mdash; historical currency rates. Let&rsquo;s start with the views.</p>
<h2 id="historicalcurrencyrates">Historical Currency Rates</h2>
<p>Implementing this feature will be like combining the tasks from the first and second pages. We&rsquo;re going to build a tiny form where the user will be expected to input a date. When the user clicks submit, the currency rates for the specified date will be displayed in table format. We&rsquo;ll use the <a href="https://fixer.io/documentation#historicalrates">Historical Rates Endpoint</a> from Fixer API to achieve this. The API request looks like this:</p>
<pre><code class="m language-m">https://data.fixer.io/api/2013-12-24
    ? access_key = API_KEY
    &amp; base = GBP
    &amp; symbols = USD,CAD,EUR
</code></pre>
<p>And the response will look like this:</p>
<pre><code class="javascript language-javascript">{
  "success": true,
  "historical": true,
  "date": "2013-12-24",
  "timestamp": 1387929599,
  "base": "GBP",
  "rates": {
    "USD": 1.636492,
    "EUR": 1.196476,
    "CAD": 1.739516
  }
}
</code></pre>
<p>Open <code>lib/fixer-service.js</code> and the Historical Rates Endpoint like this:</p>
<pre><code class="javascript language-javascript">...
  /** Place right after getSymbols **/
  getHistoricalRate: date =&gt; get(`/${date}&amp;symbols=${symbols}&amp;base=EUR`),
...
</code></pre>
<p>Open <code>server.js</code> and add this code:</p>
<pre><code class="javascript language-javascript">...
const { getRates, getSymbols, getHistoricalRate } = require('./lib/fixer-service');
...
/** Place this after '/api/convert' post function **/

// Fetch Currency Rates by date
app.post('/api/historical', async (req, res) =&gt; {
  try {
    const { date } = req.body;
    const data = await getHistoricalRate(date);
    res.setHeader('Content-Type', 'application/json');
    res.send(data);
  } catch (error) {
    errorHandler(error, req, res);
  }
});
...
</code></pre>
<p>If you&rsquo;re in any doubt as to how the code is arranged, please refer to the complete <code>server.js</code> file on <a href="https://github.com/sitepoint-editors/single-page-application/blob/master/server.js">GitHub</a>. Feel free to write a quick test to confirm the historical endpoint is working:</p>
<pre><code class="javascript language-javascript">const test = async() =&gt; {
  const data = await getHistoricalRate('2012-07-14');
  console.log(data);
}

test();
</code></pre>
<p>Do remember to comment out the test block once you confirm everything&rsquo;s working. Now let&rsquo;s now work on the client code.</p>
<p>Open <code>index.html</code>. Delete the existing <code>historical-template</code> we used as a placeholder, and replace it with the following:</p>
<pre><code class="markup language-markup">&lt;script id="historical-template" type="text/x-handlebars-template"&gt;
  &lt;h1 class="ui header"&gt;Historical Rates&lt;/h1&gt;
  &lt;hr&gt;
  &lt;form class="ui form"&gt;
    &lt;div class="field"&gt;
      &lt;label&gt;Pick Date&lt;/label&gt;
      &lt;div class="ui calendar" id="calendar"&gt;
        &lt;div class="ui input left icon"&gt;
          &lt;i class="calendar icon"&gt;&lt;/i&gt;
          &lt;input type="text" placeholder="Date" id="date"&gt;
        &lt;/div&gt;
      &lt;/div&gt;
    &lt;/div&gt;
    &lt;div class="ui primary submit button"&gt;Fetch Rates&lt;/div&gt;
    &lt;div class="ui error message"&gt;&lt;/div&gt;
  &lt;/form&gt;

  &lt;div class="ui basic segment"&gt;
    &lt;div id="historical-table"&gt;&lt;/div&gt;
  &lt;/div&gt;
&lt;/script&gt;
</code></pre>
<p>Take a look at the form first. One thing I&rsquo;d like to point out is that Semantic UI doesn&rsquo;t officially have a date input. However, thanks to <a href="https://github.com/mdehoog">Michael de Hoog</a>&rsquo;s contribution, we have the <a href="https://github.com/mdehoog">Semantic-UI-Calendar</a> module available to us. Simply install it using npm:</p>
<pre><code class="bash language-bash">npm install semantic-ui-calendar
</code></pre>
<p>Go back to <code>public/index.html</code> and include it within the scripts section:</p>
<pre><code class="markup language-markup">...
&lt;script src="scripts/semantic-ui-css/semantic.min.js"&gt;&lt;/script&gt;
&lt;script src="scripts/semantic-ui-calendar/dist/calendar.min.js"&gt;&lt;/script&gt;
....
</code></pre>
<p>To display the historical rates, we&rsquo;ll simply reuse the <code>rates-template</code>. Next open <code>public/js/app.js</code> and update the existing route code for <code>/historical</code>:</p>
<pre><code class="javascript language-javascript">const getHistoricalRates = async () =&gt; {
  const date = $('#date').val();
  try {
    const response = await api.post('/historical', { date });
    const { base, rates } = response.data;
    const html = ratesTemplate({ base, date, rates });
    $('#historical-table').html(html);
  } catch (error) {
    showError(error);
  } finally {
    $('.segment').removeClass('loading');
  }
};

const historicalRatesHandler = () =&gt; {
  if ($('.ui.form').form('is valid')) {
    // hide error message
    $('.ui.error.message').hide();
    // Indicate loading status
    $('.segment').addClass('loading');
    getHistoricalRates();
    // Prevent page from submitting to server
    return false;
  }
  return true;
};

router.add('/historical', () =&gt; {
  // Display form
  const html = historicalTemplate();
  el.html(html);
  // Activate Date Picker
  $('#calendar').calendar({
    type: 'date',
    formatter: { //format date to yyyy-mm-dd
      date: date =&gt; new Date(date).toISOString().split('T')[0],
    },
  });
  // Validate Date input
  $('.ui.form').form({
    fields: {
      date: 'empty',
    },
  });
  $('.submit').click(historicalRatesHandler);
});
</code></pre>
<p>Once again, take time to read the comments and understand the code and what it&rsquo;s doing. Then restart the server, refresh the browser and navigate to the <code>/historical</code> path. Pick any date before the year 1999 then click <em>Fetch Rates</em>. You should have something like this:</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396763410-historical-rates.png" alt="Todo historical rates"></p>
<p>If you pick a date before the year 1999 or a date in the future, an error banner will be displayed when you submit the form.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/04/152396763710-historical-rates-error.png" alt="Todo historical rates error"></p>
<h2 id="summary">Summary</h2>
<p>Now that we&rsquo;ve come to the end of the tutorial, you should see that it&rsquo;s not that difficult to build a single-page application powered by REST APIs without using a framework. But there are a few things we should be concerned with:</p>
<ul><li>
<p><strong>DOM Performance</strong>. In our client-side code, we&rsquo;re directly manipulating the DOM. This can soon get out of hand as the project grows, causing the UI to become sluggish.</p>
</li>
<li>
<p><strong>Browser Performance</strong>. There are quite a number of front-end libraries that we&rsquo;ve loaded as scripts in <code>index.html</code>, which is okay for development purposes. For production deployment, we need a system for bundling all scripts such that the browsers use a single request for loading the necessary JavaScript resources.</p>
</li>
<li>
<p><strong>Monolithic Code</strong>. For the server code, it&rsquo;s easier to break down code into modular parts since it runs within a Node environment. However, for client-side code, it&rsquo;s not easy to organize in modules unless you use a bundler like <a href="https://www.sitepoint.com/beginners-guide-to-webpack-2-and-module-bundling/">webpack</a>.</p>
</li>
<li>
<p><strong>Testing</strong>. So far we&rsquo;ve been doing manual testing. For a production-ready application, we need to set up a testing framework like Jasmine, Mocha or Chai to automate this work. This will help prevent recurring errors.</p>
</li>
</ul><p>These are just a few of the many issues you&rsquo;ll face when you approach project development without using a framework. Using something such as Angular, React or Vue will help you alleviate a lot of these concerns. I hope this tutorial has been helpful and that it will aid you in your journey to becoming a professional JavaScript developer.</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/mwanyoike/">
            <img src="https://secure.gravatar.com/avatar/9eada3b4136c22464245df9f55c3b0a1?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/mwanyoike/">
                Michael Wanyoike              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/myxsys"><i class="fa fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/mikewanyoike/"><i class="fa fa-linkedin"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/brandiqa"><i class="fa fa-github"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">I write clean, readable and modular code. I love learning new technologies that bring efficiencies and increased productivity to my workflow.</div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
            <div class="l-w-aside-i l-mt3 l-mh3 l-d-n l-d-f--3col l-fd-col l-fs0">
      <div class="l-mb3">
            <div class="l-as-fs l-mv0 l-pv1 l-ph3 f-light f-larger f-uppercase f-c-white t-bg-grey-500">Sponsors</div>
    <div class="l-w-100 l-mv3 t-bg-white m-border"><div class="widget maestro maestro-content-type-bsa hide-for-mobile-SP" id="maestro-448"><div class="l-pa3" style="border-bottom: 1px solid #e5e5e5" id="maestro-448-bsa-171561">
<a href="//srv.buysellads.com/ads/click/x/GTND42QLFTBD6K3NCEBLYKQMCVADCK7NCYSDPZ3JCW7DE2QEF6SDVKQKC6BI653WCTADEK3EHJNCLSIZ" class="l-d-f l-ai-sta" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-448-bsa-171561" data-ga-event-action="click"
>
<img class="l-s5" src="https://cdn4.buysellads.net/uu/1/3575/1525726841-1519408234-HS_icon_Blue.png">
<div class="f-small l-d-f l-fd-col l-ml3 f-lh-title f-c-grey-700">
<span class="f-bold">HelloSign</span>
<span>HelloSign API: Everything IT requires and Developers love.</span>
</div>
</a>
</div><div class="l-pa3" style="border-bottom: 1px solid #e5e5e5" id="maestro-448-bsa-171391">
<a href="//srv.buysellads.com/ads/click/x/GTND42QLFTBD6K3NCEBLYKQMCVADCK7NCA7IPZ3JCW7DE2QJCT7IK27KC6BI653WCTADEK3EHJNCLSIZ" class="l-d-f l-ai-sta" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-448-bsa-171391" data-ga-event-action="click"
>
<img class="l-s5" src="https://cdn4.buysellads.net/uu/1/2468/1522383420-1514590085-Azure-LB.png">
<div class="f-small l-d-f l-fd-col l-ml3 f-lh-title f-c-grey-700">
<span class="f-bold">Microsoft Azure</span>
<span>This Is The Secret To Why An Azure Free Account Is So Good</span>
</div>
</a>
</div><img src="https://ad.doubleclick.net/ddm/trackimp/N572608.452584BUYSELLADS.COM/B20911639.217792243;dc_trk_aid=416498285;dc_trk_cid=99622446;ord=[1528409346];dc_lat=;dc_rdid=;tag_for_child_directed_treatment=?" height="1" width="1" border="0" style="display: none;" /><img src="https://pixel.adsafeprotected.com/rfw/st/154421/23778735/skeleton.gif" height="1" width="1" border="0" style="display: none;" /><script>ga('SitePointPlugin:observeImpressions', ['maestro-448-bsa-171561','maestro-448-bsa-171391'])</script></div></div>
            <div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-662"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["Frameworks","modernjs","modernjs-hub","SPA"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-3_123456" style="height:250px; width:300px;"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-662')</script></div>      </div>
      <div class="ArticleBox u-premium-preview"></div>
      <div class="ArticleAside_row"><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-661"><script>
bsa_targeting.push([
                "tags", 
                [
                        ["Frameworks","modernjs","modernjs-hub","SPA"]
                ]
]);
</script>

<div id="bsa-zone_1509641776795-4_123456"></div><script>ga('SitePointPlugin:observeImpressions', 'maestro-661')</script></div>        <ads-weighted widget='21' data='{"NL":[{"id":"585","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":50},{"id":"584","demandbase_field":null,"demandbase_value":null,"weight":"50","randMax":100}]}' fallback='' url='single-page-app-without-framework' channelSlug='javascript'></ads-weighted></div>
      <div class="ArticleAside_row ArticleAside_newboxads"></div>
    </div>
          </div>

      <div class="u-accordion-end"></div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span><script>ga('SitePointPlugin:observeImpressions', 'maestro-649')</script></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                        <a id="comments"></a>
                      </div>
        </div>
      </div>

    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          javascript: 'javascript',
        });
      });
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/#privacy">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fa fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fa fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fa fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fa fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2018 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    <sp-cookie-warning server-rendered="1"></sp-cookie-warning>
    <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='64b8e500e3524000ecfa2000d01e2100033e83009398f000ab804c005e0e4300';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>

<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://www.sitepoint.com/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-05d11a1c786bcae1cfb038c489b29193.js?ver=4.9.6'></script>
<script type="text/javascript" src="/dist/js/compiled.03134c64867e12f28df2.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2018-06-07 15:09:06 by W3 Total Cache
-->