Wordpress site really slow

Hello there,

I’m curious if someone can easily tell me why this wordpress site is slow to load: Firm Profile | Blast Resistant Design | Smith LaRock Architecture

Thanks,
Lorne

That would be because the page loads to a total size of: 835.9KB each time!

…and it also tries to load “jquery-scrollTo-min” twice and fails because the file does not exist so instead it gets 404 errors.

Try fixing the 2 js errors (404s) and making some of the images a bit smaller… One of them is over 100KB for a 400x197 px image…

Also try compressing the highslide-full.js file!

If you use Firefox, I suggest installed the firebug and yslow addons. Yslow gives you a very nice overview of how you can speed up the load times of your websites.

Firebug:
https://addons.mozilla.org/en-US/firefox/addon/firebug/

Yslow:
https://addons.mozilla.org/en-US/firefox/addon/yslow/

Wow,
good to know. I will look into these issues and see if I can rectify them.

Also j3ph, yslow and firebug work in google chrome. Just in case anyone is interested.

Thanks again,
Lorne

Ok so I spent all day today making my site faster. I have used teh addons that j3ph suggested and it has improved a bit, but still not 100% and I don’t know what else I’m missing?

I have used this post to help step me through some good info: WordPress Speed Challenge - Make your WordPress blog faster! | Zemalf.com
as well as used Pingdom.com for speed tests etc.

Can any of you look at the site again and see what you would suggest I do next?

Thanks,
Lorne

Remove unnecessary plug ins , Themes and reversion of post from your site , I will surely helps to increase you site’ss speed.

Ok so I have setup everything I’m supposed to setup and it’s still taking a long time to load! So if you go to tools.pingdom.com and put in: www.slarc.com/firmprofile you’ll see it takes forever on the first 2 items? Why is this?

I appreciate the help in trouble shooting this.

Lorne

Any suggestions?

It’s still really slow. It takes about 10-15 seconds to load, but then it all comes on the screen right away, so it’s the initial loading that takes forever.

Ideas?

Thanks,
Lorne

Hey Lorne,

I would disable all the plugins and see if that helps.

If it does then start enabling each one, one-at-atime and retesting.

Do not enable W3TC till last otherwise it will cache.

see if one of the plugins is responsible.

I know that the newest release of W3TC is giving people a lot of problems. I also know that if not configured properly that W3TC can work against you big time and break your site.

It appears what is taking so long to load is the actual html that is output by Wordpress and not the js/css/images loaded in the page.

I would look to see if there are any errors in your error logs. Also, I would repair and optimize all your tables in MySQL although I would assume those db tables can’t be that large.

It looks like you host with GoDaddy. From my experience, GoDaddy is notorious for overloading their shared servers. Therefore there may not be anything wrong with your website, but some other site that is on the same server.

I would assume you could ask GoDaddy to move your site to a server with less activity on it and I can’t imagine they would charge you for that.

  1. try to use “wp-super-cache” plug in to cache the data
  2. there are lot images loading in the page, try to sprite the possible images in to one.

I’m with j3ph, this is probably godaddy being crappy. A lot of the time it’s not the web server, it can be an overloaded database server. Even if you optimize the tables, if Godaddy overloads the DB server and it has terrible IO, it will make everything “feel” super slow.

Ok well here’s an update. First, thanks all for your help.

I got it fixed! If you go to the site now you’ll see it loading quick. It was GoDaddy that was killing me. They switched me over to a new server and it’s working well.

However, now all my highslide images aren’t working? if you go to www.slarc.com/firmprofile and select an image on the right side, nothing happens besides it opening the image in a new window. That was working with highslide before. How do I fix that? Have any suggestions?

Thanks,
Lorne

BTW the bottom box (“WHO”) is a PDF. SO try the Where, How, What boxes.

it is W3 total cache. delete the highslide files from the java minify, save and clear all caches.

Awesome…I just disabled minify. If I activate CSS it messes my whole site up, if I activate js it messes highslide up. It’s still loading fast without that.

Thanks for your help guys!

Lorne

you do not need to disable the java or css minify settings completley. you just need to experiment with which css and java files work being minified.

I use page speed to list all the files then add each one, one-by-one to W3 until it breaks something then omit that file.

You have about 600KB of images… that’s a bit much (I get antsy when I have over 200KB).

There are also a lot of files on there as well, which causes a lot of HTTP Requests. That’s the #1 slowest thing there is. If you can reduce that number by combining images and scripts, it’ll help speed it up.

Also, if you happen to be running it in Windows, switch to Linux. It’ll make a huge difference.

Awesome…I just disabled minify. If I activate CSS it messes my whole site up, if I activate js it messes highslide up. It’s still loading fast without that.

Glad to know that you have troubleshoted the problem :slight_smile:

Wordpress plugin tends to take a lot of server resources so always to minimize the usage. Alternatively, review your hosting package if you require higher server resources to cater your website.

Hey there, I don’t mean to jack anyone’s thread or anything, but I am experiencing slow loading times on wordpress as well. I am a bit of a noob at fixing and diagnosing some of the problems with slow loading times. I tried using yslow, but I couldn’t really understand how to fix some of the things it recommended. Before, you just check out yslow for yourself note that I currently have a hosting plan with godaddy, which is a shared linux plan. The OP, lorne17, said he switched hosts to solve the problem. Is this the correct course of action for me as well? My site has been a bit random in terms of loading times. Sometimes the page loads right up. Other times it can take 3-5 seconds. However, there are times where it can take 7-11 or more seconds to load!

The odd thing is that my phpbb forums, which uses similar assets as the main page on wordpress, is always fast and takes like 1-3 seconds to load. Why is this? Any ideas? I’ve tried caching plug-ins, and I am also using cloudflare. I’m a bit lost as to what is causing the wordpress side of my site to be slow compared to my forums.

Website main page (wordpress = slow): Pixel Smashers

Website Forum (phpbb = fast): Pixel Smashers • Index page