<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="https://dab1nmslvvntp.cloudfront.net/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://pro.fontawesome.com/releases/v5.0.13/css/all.css" >

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'javascript');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var purchs2s = purchs2s||{};
      purchs2s.cmd = purchs2s.cmd || [];
      purchs2s.timeout=500;
      (function() {
        var ps2s = document.createElement('script');
        ps2s.async = true;
        ps2s.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        ps2s.src = (useSSL ? 'https:' : 'http:') + '//ads.servebom.com/purchs2s.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(ps2s, node);
      })();
    </script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="//cdn-s2s.buysellads.net/pub/sitepoint.js" data-cfasync="false"></script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      persistNotification: true,
    }]);
  </script>
    <!-- BuySellAds PRO Code -->
<script class="SP_stripMobile" type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
<!-- End BuySellAds PRO Ad Code —>
    
<!-- This site is optimized with the Yoast SEO plugin v7.5.3 - https://yoast.com/wordpress/plugins/seo/ -->
<title>Build Custom Dashboards with MongoDB, Azure &amp; Serverless Functions &mdash; SitePoint</title>
<meta name="description" content="I’m building a custom WordPress dashboard for an enterprise client which is powered by React.js on top of Node.js, with MongoDB Atlas as the database."/>
<link rel="canonical" href="https://www.sitepoint.com/build-custom-dashboards-with-mongodb-azure-serverless-functions/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Build Custom Dashboards with MongoDB, Azure &amp; Serverless Functions &mdash; SitePoint" />
<meta property="og:description" content="I’m building a custom WordPress dashboard for an enterprise client which is powered by React.js on top of Node.js, with MongoDB Atlas as the database." />
<meta property="og:url" content="https://www.sitepoint.com/build-custom-dashboards-with-mongodb-azure-serverless-functions/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:author" content="https://www.facebook.com/ahmadawais" />
<meta property="article:tag" content="Azure" />
<meta property="article:tag" content="joelf" />
<meta property="article:tag" content="mongodb" />
<meta property="article:tag" content="node" />
<meta property="article:tag" content="React" />
<meta property="article:tag" content="serverless" />
<meta property="article:tag" content="sponsored" />
<meta property="article:section" content="JavaScript" />
<meta property="article:published_time" content="2018-07-06T10:30:58-07:00" />
<meta property="article:modified_time" content="2018-07-05T21:25:45-07:00" />
<meta property="og:updated_time" content="2018-07-05T21:25:45-07:00" />
<meta property="og:image" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/07/1530845969chris-leipelt-254045-unsplash.jpg" />
<meta property="og:image:secure_url" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/07/1530845969chris-leipelt-254045-unsplash.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="667" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="I’m building a custom WordPress dashboard for an enterprise client which is powered by React.js on top of Node.js, with MongoDB Atlas as the database." />
<meta name="twitter:title" content="Build Custom Dashboards with MongoDB, Azure &amp; Serverless Functions &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2018/07/1530845969chris-leipelt-254045-unsplash.jpg" />
<meta name="twitter:creator" content="@mrahmadawais" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; Build Custom Dashboards with MongoDB, Azure &#038; Serverless Functions Comments Feed" href="https://www.sitepoint.com/build-custom-dashboards-with-mongodb-azure-serverless-functions/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1530857045' type='text/css' media='all' />
<link rel='stylesheet' id='wp-postratings-css'  href='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/css/postratings-css.css?ver=1.85' type='text/css' media='all' />
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-63620ced6374adfdc078b1a126c2f666.css?ver=4.9.6' type='text/css' media='all' />
<link rel="stylesheet" id="sitepoint-styles-janus-css" href="/dist/css/compiled.f64da9cafad403fa8c58.css" type="text/css" media="all"><link rel="stylesheet" id="sitepoint-styles-janus-article-css" href="/dist/css/compiledArticle.f64da9cafad403fa8c58.css" type="text/css" media="all">
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.9.6'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.6" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=166865' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fbuild-custom-dashboards-with-mongodb-azure-serverless-functions%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fbuild-custom-dashboards-with-mongodb-azure-serverless-functions%2F&#038;format=xml" />

<!-- BEGIN wp-parsely Plugin Version 1.13.0 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.13.0"/>
	<script type="application/ld+json">
	{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/build-custom-dashboards-with-mongodb-azure-serverless-functions\/"},"headline":"Build Custom Dashboards with MongoDB, Azure &#038; Serverless Functions","url":"http:\/\/www.sitepoint.com\/build-custom-dashboards-with-mongodb-azure-serverless-functions\/","thumbnailUrl":"https:\/\/d1nlfd9mjn1pae.cloudfront.net\/wp-content\/uploads\/2018\/07\/1530845969chris-leipelt-254045-unsplash-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/d1nlfd9mjn1pae.cloudfront.net\/wp-content\/uploads\/2018\/07\/1530845969chris-leipelt-254045-unsplash-150x150.jpg"},"dateCreated":"2018-07-06T17:30:58Z","datePublished":"2018-07-06T17:30:58Z","dateModified":"2018-07-06T17:30:58Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"Ahmad Awais"}],"creator":["Ahmad Awais"],"keywords":["azure","joelf","mongodb","node","react","serverless","sponsored"],"publisher":{"@type":"Organization","name":"SitePoint","logo":{"@type":"ImageObject","url":""}}}
	</script>

	<!-- END wp-parsely Plugin Version 1.13.0 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        purchs2s.cmd.push(function() {
          		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "166865");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
                    googletag.pubads().collapseEmptyDivs();
          googletag.pubads().disableInitialLoad();
          googletag.enableServices();
          purchs2s.setup();
        });
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
        <header class="main-header u-isSingle" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-minor l-mb0 fas fa-bars"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fas fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-premium/l/join ">
            <i class="SidebarNav_icon fas fa-user u-premium/l/join"></i>
            
            <a class="f-light" href="/premium/l/join?ref_source=sitepoint&ref_medium=drawer" onclick="">Sign Up</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/sign-in ">
            <i class="SidebarNav_icon fas fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer" onclick="">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b">
    <ul>
        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fab fa-html5 u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">HTML and CSS</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/bootstrap l-pl5">
            <i class="SidebarNav_icon fas fa-bold u-learn/bootstrap"></i>
            
            <a class="f-light" href="/learn/bootstrap/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Bootstrap</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-# no-link">
            <i class="SidebarNav_icon fab fa-js u-#"></i>
            
            <a class="f-light" href="#" onclick="return false;">Javascript</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/javascript l-pl5">
            <i class="SidebarNav_icon fab fa-js u-learn/javascript"></i>
            
            <a class="f-light" href="/learn/javascript/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Javascript</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/react l-pl5">
            <i class="SidebarNav_icon fab fa-react u-learn/react"></i>
            
            <a class="f-light" href="/learn/react/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn React</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/angular l-pl5">
            <i class="SidebarNav_icon fab fa-angular u-learn/angular"></i>
            
            <a class="f-light" href="/learn/angular/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Angular</a>
          </li>        <li class="SidebarNav_link f-minor l-mb0 u-learn/nodejs l-pl5">
            <i class="SidebarNav_icon fab fa-node-js u-learn/nodejs"></i>
            
            <a class="f-light" href="/learn/nodejs/?ref_source=sitepoint&ref_medium=drawer" onclick="">Learn Node.js</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-premium/deals/?ref_source=sitepoint&ref_medium=drawer ">
            <i class="SidebarNav_icon far fa-gem u-premium/deals/?ref_source=sitepoint&ref_medium=drawer"></i>
            
            <a class="f-light" href="/premium/deals/?ref_source=sitepoint&ref_medium=drawer?ref_source=sitepoint&ref_medium=drawer" onclick="">Deals</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/books ">
            <i class="SidebarNav_icon fas fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer" onclick="">Books</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-premium/courses ">
            <i class="SidebarNav_icon fas fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer" onclick="">Courses</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-html-css">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-javascript u-active">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-php">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-design-ux">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-web">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-wordpress">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink f-minor l-mb0 u-developer-center">
            <i class="SidebarNav_icon fas fa-circle fa-xs u-developer-center"></i>
            <a class="f-light" href="https://www.sitepoint.com/developer-center/?ref_source=sitepoint&ref_medium=drawer" data-channel="developer-center">Microsoft Tech</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-community ">
            <i class="SidebarNav_icon fas fa-comments u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer" onclick="">Community</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-versioning ">
            
            <i class="SidebarNav_icon"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg viewBox="0 0 463 533">
    <g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g id="Misc-Icons" transform="translate(-224.000000, -209.000000)" fill="#A2A2A2">
            <g id="Adam" transform="translate(224.000000, 209.000000)">
                <path d="M205.23914,223.989305 C205.23914,239.058221 193.018305,251.270053 177.938282,251.270053 C162.858259,251.270053 150.637425,239.064975 150.637425,223.989305 C150.637425,208.927144 162.858259,196.708557 177.938282,196.708557 C193.018305,196.708557 205.23914,208.927144 205.23914,223.989305" id="Shape"></path>
                <path d="M319.240023,223.989305 C319.240023,239.058221 307.019188,251.270053 291.939165,251.270053 C276.859142,251.270053 264.638308,239.064975 264.638308,223.989305 C264.638308,208.927144 276.859142,196.708557 291.939165,196.708557 C307.019188,196.708557 319.240023,208.927144 319.240023,223.989305" id="Shape-Copy"></path>
                <path d="M45.9192714,105.68948 C47.1603233,105.013767 48.4156135,104.338834 49.6814591,103.66477 C49.285517,101.268011 49.079511,98.8067359 49.079511,96.2970985 C49.079511,71.6393315 68.9663337,51.6502619 93.4979726,51.6502619 C104.828598,51.6502619 115.168338,55.9145566 123.11028,62.1553999 C123.11028,37.497633 142.997103,17.5085634 167.528742,17.5085634 C177.872808,17.5085634 187.39103,21.0626011 194.940698,27.0220906 C201.994758,11.1002236 217.874616,0 236.33381,0 C255.201408,0 271.374274,11.5968357 278.182101,28.0859033 C285.813075,16.4403992 298.937725,8.75428168 313.84838,8.75428168 C335.217866,8.75428168 352.918943,24.5413571 356.037389,45.1451696 C359.093922,44.2508863 362.326213,43.7714084 365.669919,43.7714084 C384.669913,43.7714084 400.072453,59.2531388 400.072453,78.3508211 C400.072453,84.451539 398.500668,90.1832596 395.741931,95.1591734 C420.545,106.093308 441.166028,118.313655 447.484806,130.438797 C462.05792,158.40324 448.921531,194.216875 441.795446,209.76377 C445.786047,226.227441 447.901492,243.429264 447.901492,261.127716 C447.901492,277.569319 446.075834,293.582324 442.617163,308.973095 C454.31826,313.102542 462.707645,324.30529 462.707645,337.477559 C462.707645,352.446546 451.87352,364.872078 437.657056,367.264056 C442.403415,372.604775 445.288641,379.652197 445.288641,387.376964 C445.288641,404.057219 431.83579,417.579236 415.240858,417.579236 C414.739425,417.579236 414.24086,417.56689 413.745449,417.542485 C416.086983,421.841984 417.418234,426.776628 417.418234,432.023801 C417.418234,448.704055 403.965383,462.226073 387.370451,462.226073 C385.766225,462.226073 384.191363,462.099709 382.655177,461.856345 C383.175775,464.083267 383.451175,466.405199 383.451175,468.791784 C383.451175,485.472038 369.998324,498.994056 353.403392,498.994056 C348.884389,498.994056 344.598385,497.991345 340.753583,496.195199 C340.156973,512.346957 326.941829,525.256901 310.726831,525.256901 C300.435078,525.256901 291.351821,520.056112 285.93648,512.126599 C281.811241,523.856499 270.681444,532.260326 257.598867,532.260326 C247.286985,532.260326 238.188331,527.039174 232.776786,519.083469 C227.365238,527.039175 218.266585,532.260326 207.954704,532.260326 C194.872127,532.260326 183.74233,523.856499 179.617091,512.126599 C174.20175,520.056112 165.118493,525.256901 154.82674,525.256901 C138.611742,525.256901 125.396598,512.346957 124.799988,496.195199 C120.955186,497.991345 116.669182,498.994056 112.150179,498.994056 C95.5552468,498.994056 82.1023962,485.472038 82.1023962,468.791784 C82.1023962,466.405199 82.3777956,464.083267 82.8983938,461.856345 C81.3622084,462.099709 79.7873457,462.226073 78.1831202,462.226073 C61.588188,462.226073 48.1353374,448.704055 48.1353374,432.023801 C48.1353374,426.776628 49.4665878,421.841984 51.8081225,417.542485 C51.312711,417.56689 50.8141464,417.579236 50.312713,417.579236 C33.7177807,417.579236 20.2649301,404.057219 20.2649301,387.376964 C20.2649301,379.652197 23.1501561,372.604775 27.8965152,367.264056 C13.6800506,364.872078 2.84592558,352.446546 2.84592558,337.477559 C2.84592558,324.30529 11.2353108,313.102542 22.9364075,308.973095 C19.4777374,293.582324 17.6520794,277.569319 17.6520794,261.127716 C17.6520794,244.483155 19.5230884,228.277837 23.0652378,212.71266 C23.0461555,212.67345 23.0269954,212.633634 23.0077587,212.593218 C8.40744355,199.915919 -22.2912349,139.477462 27.9975916,114.351569 C34.9803921,110.862741 40.9027514,108.009708 45.9192714,105.68948 L45.9192714,105.68948 Z M321.182928,338.855264 C312.257241,380.392075 275.494697,411.515802 231.5,411.515802 C187.505303,411.515802 150.742759,380.392075 141.817072,338.855264 L321.182928,338.855264 L321.182928,338.855264 L321.182928,338.855264 Z M323.401809,93.513343 C382.119911,125.539939 421.986958,188.049902 421.986958,259.919187 C421.986958,269.181179 421.324839,278.287729 420.045582,287.193626 L420.045582,287.193626 C414.531038,280.687855 406.320283,276.561781 397.150761,276.561781 C382.005642,276.561781 369.476084,287.817909 367.390774,302.461227 C361.921787,296.754612 354.241111,293.204376 345.735474,293.204376 C336.696537,293.204376 328.589254,297.213765 323.07789,303.559722 L323.07789,303.559722 C317.566526,297.213765 309.459243,293.204376 300.420306,293.204376 C291.140116,293.204376 282.841976,297.430646 277.326999,304.072813 C271.812023,297.430646 263.513882,293.204376 254.233693,293.204376 C245.884947,293.204376 238.331009,296.624848 232.883277,302.147652 L232.883277,302.147652 C227.435545,296.624848 219.881607,293.204376 211.532861,293.204376 C202.252672,293.204376 193.954531,297.430646 188.439555,304.072813 C182.924578,297.430646 174.626438,293.204376 165.346248,293.204376 C156.307311,293.204376 148.200028,297.213765 142.688664,303.559722 L142.688664,303.559722 C137.1773,297.213765 129.070017,293.204376 120.03108,293.204376 C111.525443,293.204376 103.844767,296.754612 98.3757799,302.461227 C96.2904699,287.817909 83.7609125,276.561781 68.6157934,276.561781 C60.2507056,276.561781 52.6835401,279.995657 47.2334107,285.537513 C46.105173,277.159748 45.5224867,268.607864 45.5224867,259.919187 C45.5224867,222.269089 56.4635528,187.187552 75.3242153,157.711582 C101.872077,155.792935 136.061257,148.07484 172.032022,134.915239 C218.909805,117.765397 257.559595,95.4909208 277.539381,75.8645287 C278.024685,75.9807367 278.50926,76.0988336 278.993099,76.2188112 C286.713596,87.3063559 299.514894,94.5568665 314.000977,94.5568665 C317.230893,94.5568665 320.377051,94.1964131 323.401809,93.513343 L323.401809,93.513343 L323.401809,93.513343 Z" id="Path"></path>
            </g>
        </g>
    </g>
</svg>
</i>
            <a class="f-light" href="/versioning/?ref_source=sitepoint&ref_medium=drawer" onclick="">Versioning</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-newsletter ">
            <i class="SidebarNav_icon fas fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer" onclick="">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link f-minor l-mb0 u-advertise ">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer" onclick="">Advertise</a>
          </li>      <li class="SidebarNav_link f-minor l-mb0 u-contact-us ">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer" onclick="">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fas fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fab fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fab fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="https://www.sitepoint.com/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
            <div class="NavBar_dropdown l-p-rel l-d-f l-ai-cen">
              <a
                class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                l-pa2
                f-minor
                l-mb0
                f-light
                f-c-white
                l-h-100
                NavBar_item"
                href="#"
                onclick="return false;">
                  <i class="l-mr2 f-minor l-mb0 fas fa-map-marker-alt"></i>
                  Learning Paths
                  <i class="l-ml2 f-minor l-mb0 fas fa-angle-down"></i>
              </a>
              <div class="l-w-col l-fd-col l-d-n NavBar_dropdownInner">
                <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 no-link l-pb0">
                  <i class="fab fa-html5 l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                  HTML and CSS
                </a>
                <div class="l-p-rel l-d-f l-ai-cen l-ml3 l-ml4--4col l-fd-col l-pb0">
                  <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 l-pb0" href="/learn/bootstrap/">
                    <i class="fas fa-bold l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                    <span>Learn Bootstrap</span>
                  </a>
                </div>
                <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 l-pb0 no-link">
                  <i class="fab fa-js l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                  <span>Javascript</span>
                </a>
                <div class="l-p-rel l-d-f l-ai-cen l-ml3 l-ml4--4col l-fd-col l-pb0">
                  <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 l-pb0" href="/learn/javascript/">
                    <i class="fab fa-js l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                    <span>Learn Javascript</span>
                  </a>
                  <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 l-pb0" href="/learn/react/">
                    <i class="fab fa-react l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                    <span>Learn React</span>
                  </a>
                  <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500 l-pb0" href="/learn/angular/">
                    <i class="fab fa-angular l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                    <span>Learn Angular</span>
                  </a>
                  <a class="l-w-100 l-d-f l-ai-cen l-pa3 t-t f-minor l-mb0 f-left f-light f-lh-title m-link f-c-grey-500" href="/learn/nodejs/">
                    <i class="fab fa-node-js l-mr2 l-s3 f-minor l-mb0 l-h-100"></i>
                    <span>Learn Node.js</span>
                  </a>
                </div>
              </div>
            </div>
                          <a
                class="
                  l-d-n
                  l-d-f--3col
                  l-ai-cen
                  l-ml3
                  l-ml4--4col
                  l-pa2
                  f-minor
                  l-mb0
                  f-light
                  f-c-white
                  NavBar_item"
                href="/premium/topics/all?q=&limit=400&offset=0&page1&ref_source=sitepoint&ref_medium=topnav">
                  <i class="l-mr2 f-minor l-mb0 fas fa-book"></i>
                  Books & Courses
              </a>
            </sp-notification-dot>
                        <sp-notification-dot
              notification_text=""
              storage_key="DealsPage"
              url="/premium/deals/?ref_source=sitepoint&ref_medium=topnav"
              prefix="far"
              icon="gem"
              link_text="Deals"
              nav_location="topNav"
              class="
                NavBar_item
                f-c-white
                f-light
                f-minor
                l-mb0
                l-ai-cen
                l-ai-str
                l-d-f--3col
                l-d-n
                l-ml3
                l-ml4--4col
                l-p-rel
                l-ph2
              ">
              <a class="
                l-d-n
                l-d-f--3col
                l-ai-cen
                f-minor
                l-mb0
                f-light
                f-c-white
                NavBar_item"
                href="/premium/deals/?ref_source=sitepoint&ref_medium=topnav">
                <i class="l-mr2 f-minor l-mb0 far fa-gem"></i>
                Deals
              </a>
            </sp-notification-dot>

                          <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width: 1px;">Login</a><a href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=topnav&amp;ref_campaign=build-custom-dashboards-with-mongodb-azure-serverless-functions&amp;ref_content=javascript" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Sign Up</a></div>
                      </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>
      <script>
                var current_category = ['javascript'];
          if (localStorage.getItem('SP_categories') !== null) {
            if (localStorage.getItem('SP_categories').includes(current_category) === false ) {
              var sp_categories = JSON.parse(localStorage.getItem('SP_categories') || "[]");
              var temp = current_category.concat(sp_categories);
              var filtered_categories = Array.from(new Set(temp));
              localStorage.setItem('SP_categories', JSON.stringify(filtered_categories));
            }
          }else {
            localStorage.setItem('SP_categories', JSON.stringify('javascript'));
          }
            // campaign
            localStorage.setItem('SP_slug', 'build-custom-dashboards-with-mongodb-azure-serverless-functions');

              </script>
      <div class="widget maestro maestro-content-type-html " id="maestro-646"><sp-fixed-countdown-bar button_text="Get All Our Books and Courses for $9" button_url="https://www.sitepoint.com/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar" buttonclass="u-red u-white" end="2018-05-14 22:45:00 +1000" end_message="JOIN 35,339 OTHERS LEARNING WEB DEVELOPMENT WITH SITEPOINT PREMIUM" landingpageclass="v3 l-ph3" ga_event_label="646" countdown_message="Offer Ends In" server-rendered="1"><div class="FixedCountdownBar_trigger t-t false false"><div id="fixed-countdown-bar" class="FixedCountdownBar l-w-100 l-d-f l-jc-cen l-ai-cen l-pv3 l-ph3 f-c-white f-uppercase f-bold v3 l-ph3 false"><div class="fixed-countdown-bar__content-wrapper l-d-f l-ph0--4col l-fw-w l-ai-cen l-w-100 l-w-4col--4col l-mh-auto--4col l-ph4--3col l-jc-cen l-fd-col l-fd-row--3col l-jc-sb--3col"><div class="timer l-d-f l-ai-cen l-mb3 l-mb0--3col"><div class="timer__text-wrapper l-d-n l-d-b--2col l-w-100 f-center f-left--2col l-mb3 l-mb0--2col f-uppercase f-medium f-bold"><span class="f-medium f-larger--3col">Offer Ends In</span></div><div class="timer__countdown l-d-f l-jc-cen l-ai-cen l-fd-row"><span class="l-d-f l-d-n--2col l-w-100 l-jc-cen f-larger--3col false">Offer Ends In</span><div class="l-d-f l-mt0--2col f-medium l-mt0"><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">15</span><span class="f-light">hrs</span></div><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">12</span><span class="f-light">mins</span></div><div class="l-d-f l-ml2 f-medium f-larger--3col"><span class="f-bold">38</span><span class="f-light">secs</span></div></div></div></div><div class><a data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="FixedCountdownBar_646" data-ga-event-action="click" href="/premium/l/join?ref_source=sitepoint&amp;ref_medium=noticebar" class="Button l-ph4 l-pv2 f-small f-medium--3col u-red u-white">Get All Our Books and Courses for $9</a></div></div><a class="f-c-white l-d-f l-ai-cen l-pa2 t-t"><i class="fas fa-times"></i></a></div></div></sp-fixed-countdown-bar><script>ga('SitePointPlugin:observeImpressions', 'maestro-646')</script></div>    </header>
<div class="l-p-rel t-bg-white" role="main">
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-100 t-bg">
      <div class="l-w-3col--3col l-mh3 l-mh-auto--3col">
        <div class="f-medium f-c-grey-200 l-pt3">
                    <ol itemscope itemtype='https://schema.org/BreadcrumbList' class='Article_breadcrumb l-ml0 f-minor l-mb0'>
            <li
              class='breadcrumb__item f-capitalize l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'>
              <a
                itemprop='item'
                itemscope
                itemtype='https://schema.org/Thing'
                class='f-c-white f-bold'
                href="https://www.sitepoint.com/javascript/">
                <span itemprop='name'>
                  javascript                </span>
              </a>
            </li>
            <li
              class='breadcrumb__item f-c-grey-200 l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
            >
                              <span itemprop='name'>
                  July 06, 2018                </span>
                          </li>
            <li
              class='breadcrumb__item l-d-ib t-ls-n'
              itemprop='itemListElement'
              itemscope
              itemtype='https://schema.org/ListItem'
              class='breadcrumb_author f-c-white'>
                                                By
                  <a
                    itemprop='item'
                    itemscope
                    itemtype='https://schema.org/Thing'
                    class='f-c-grey-200'
                    href="https://www.sitepoint.com/author/aawais/">
                    <span itemprop='name'>
                      Ahmad Awais                    </span>
                  </a>
                                          </li>
          </ol>
        </div>
        <div class="l-d-f l-fd-col l-fd-row--3col l-jc-sb">
          <div>
            <h1 class="l-mt0 f-bold f-icon-bold l-mb4 f-c-white">
              <span class="f-c-white l-mr3">Build Custom Dashboards with MongoDB, Azure &#038; Serverless Functions</span>
            </h1>
                      </div>
        </div>
      </div>
    </div>
                <div class="l-d-f l-jc-sb l-mt3 l-w-3col--3col l-mh-auto" data-hellobar="content">
        <div class="l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
                        <div class="l-mb4 l-pa3 l-pt0">
    
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h l-mt3">
              </div>

        <div class="ArticleCopy language-">
      <div class='l-mt3 l-mh5--2col'>
      <p class="wp-special"><em>This article was originally published on <a href="https://ahmadawais.com/wordpress-mongodb-atlas-microsoft-azure-serverless-functions/" rel="canonical">Ahmad Awais</a>. Thank you for supporting the partners who make SitePoint possible.</em></p>
<p><strong>TL;DR</strong>: I’m building a custom WordPress dashboard for an enterprise client which is powered by React.js on top of Node.js, with MongoDB Atlas as the database.</p>
<p>This dashboard uses several Microsoft Azure services, e.g., Cognitive Services, Azure App Services, and especially serverless Azure Functions. In this post, you’ll learn how to build a small module from it and the reason behind my choice of stack, apps, and products.</p>
<hr /></p>
<p>One of my enterprise clients who owns a huge networking and media company has a large-scale WordPress site set up. He recently <a href="https://ahmadawais.com/contact/">consulted me</a> about the possibility of building a custom WordPress dashboard (based on the <a href="https://developer.wordpress.org/rest-api/">WordPress REST API</a>) — to help him make intelligent business decisions via Machine Learning and Artificial Intelligence.</p>
<p>With JavaScript eating up the world and WordPress adapting to the move by <a href="https://ahmadawais.com/create-guten-block-toolkit/">creating the Gutenberg project</a>, I thought of an architecture/stack where WordPress would be our content layer, a familiar battle-tested environment that does its job well with a custom dashboard that’s built with JavaScript.</p>
<p>When you’re tasked to build a modern JavaScript application, you find yourself in a mix of different frameworks, tools, and dev workflows. The JavaScript ecosystem has grown a lot over the last couple of years. We have many, many good options available today.</p>
<p>So, after researching my options for a bit, I opted to use React.js on top of Node.js to start building the custom WordPress dashboard. While the project is in its ideation phase at the moment, I think it’s important that I share some of our goals here to define context behind my choice of the stack.</p>
<h2 id="customwordpressdashboardgoals">Custom WordPress Dashboard Goals</h2>
<p>Imagine you own a large networking company where over 500 hotels (in three different countries) use your services to power their conference halls, IT meetings, and online property management like the sites and blogs. That’s what my client does.</p>
<p>Most of this is powered by a huge multi-site WordPress instance that manages everything for the hotels, websites, online booking, registrations, events, tickets, reviews, and comments. There’re also other systems running different software which are able to produce content via REST API.</p>
<p>We’ve set out to create a custom WordPress dashboard with many goals in mind, but I’m listing a few of them which are related to this particular article. Take a look at what I have built so far, it’s all based on serverless Azure functions — which are pretty awesome.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530846055Screen-Recording-2018-05-22-at-08.20-PM-1024x380.gif" alt="A Custom WordPress Dashboard with MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions!" width="1024" height="380" class="aligncenter size-large wp-image-166873" /></p>
<h3 id="highleveldatareporting">👀 High-level Data Reporting</h3>
<p>The custom dashboard will report all the high-level data, e.g. things like live sales happening throughout my client’s portfolio (500+ hotels), entity/time-based and date-based breakdowns.</p>
<p>And how each of his franchise performing on a daily, weekly, monthly basis. All of this data is being fed to <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a>. More on that later.</p>
<h3 id="serverlessautomation">⚡ Serverless Automation</h3>
<p>Most of the modules are built upon serverless architecture — which in this case provides huge benefits. All the automation is always running and the cost is paid as you go i.e. pay for what you use.</p>
<p>An initial rough estimate puts this solution 34% more economical than having a server VM running all the time. We are using <a href="https://azure.microsoft.com/en-us/services/functions/">Azure Functions</a> for this serverless automation.</p>
<h3 id="iotinternetofthingshub">🔥 IoT (Internet of Things) Hub</h3>
<p>There are about ~200 IT managers working for my client who have IoT enabled devices that feed data into several online projects. This custom dashboard also includes that data for making better decisions and connecting the whole registration, management, maintenance team’s hub into a single place.</p>
<p>As you might have already guessed, this project makes use of <a href="https://azure.microsoft.com/en-us/services/iot-hub/">IoT Hub</a> from Microsoft Azure to connect, monitor, and manage all of the IoT assets.</p>
<h3 id="machinelearningandartificialintelligence">🤖 Machine Learning and Artificial Intelligence</h3>
<p>We’re using a lot of different services from Microsoft Azure for the sake of making this dashboard artificially intelligent by Machine Learning.</p>
<p>There’s a huge dataset that is fed to the <a href="https://studio.azureml.net/">ML Studio</a> which later helps us predict different decisions like space management, low registrations trends for IT events, and questions like why and when these things happen.</p>
<p>While the Machine Learning part is beyond the scope of this article, I still plan to touch base with some of the awesome Artificial Intelligence I’ve been able to cook in via Azure’s <a href="https://azure.microsoft.com/en-us/services/cognitive-services/">Cognitive Services</a>.</p>
<h3 id="liverealtime">🕰 Live &amp; Real-time</h3>
<p>One of the most important aspects of this custom dashboard is that it’s live and real-time. Which means I need a managed database that can cope with this amount of data and still stay highly available.</p>
<p>But at the same time, it’s for the management purposes and doesn’t need to have any impact on the WordPress sites. That is a crucial system design decision for this dashboard.</p>
<p>By that what I mean is we can do all sorts of experiments with this custom dashboard but it shouldn’t have any impact on the database/servers which are running the multi-site WordPress instance.</p>
<h2 id="mongodbmongodbatlas">MongoDB &amp; MongoDB Atlas</h2>
<p>For this custom WordPress dashboard, I am using <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a> as a DBaaS (Database as a Service). And I couldn’t be happier. When I first shared that I’d be using MongoDB, many developers had concerns.</p>
<p><a href="https://www.mongodb.com/?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530846089MongoDB_Gray_Logo_FullColor_RGB-01-1024x315-1024x315.jpg" alt="Mongodb" width="1024" height="315" class="aligncenter size-large wp-image-166874" /></a></p>
<p>Most of the questions asked why I&#8217;d add another layer of complexity by adding yet another database to the mix. Why not use the WordPress database as it is? To answer these questions and more I have prepared a list of reasons as to why I am using <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a>.</p>
<h3 id="dislikeforrdbms">♨ Dislike for RDBMS</h3>
<p>I personally dislike relational databases. Most of the time, for me they get in the way of building applications. I have to completely get out of the app I am building, think about my database in the future and design a good schema which always ends up a bad exercise for my dev workflow. It’s counter-intuitive at best — at least for me, it is.</p>
<h3 id="hddischeapcpuramisnot">💸 HDD Is Cheap — CPU/RAM Is Not</h3>
<p>Old databases were mostly designed to save disk space, among other things. This led to a plethora of problems like normalization, indexing, and made sharding, auto-scaling, and replication harder.</p>
<p>Nowadays, disk space is dirt cheap. On the other hand, CPU/RAM is not, and your sysadmin costs can skyrocket very quickly if you end up with a bad choice here.</p>
<p>Like you wanted to create a custom dashboard but your system design architect cost you two sysadmins with how they chose to design your system. Similarly, my client wanted a managed solution without having to hire a team of IT/DevOps folks — at least for an experimental custom dashboard.</p>
<h3 id="mongodbspros">🍀 MongoDB’s Pros</h3>
<ul>
<li><strong>Schema-less</strong>. Flexible schema for the win. I don’t have to change anything, my regular app development workflow, creating a Node.js-based app that I am manipulating with JSON type data, I can just feed that into MongoDB and it just works.</li>
<li><strong>Workflow-consistency</strong>. Creates documents the way my custom dashboard is represented. Sales, Videos, Talks, Comments, Reviews, Registrations, etc. all of that have similar data representation on the frontend and the backend — and even in the database. I manage 3rd party data via middleware. <em>This consistency translates to clean code.</em></li>
<li><strong>Ease of scale-out</strong>. It scales reads by using replica sets. Scales writes by using sharding (auto-balancing). Just fire up another machine and away you go. Most importantly, instead of vertical scaling via RDBMS, MongoDB lets you scale horizontally with different levels of consistency. That’s a big plus. ➕</li>
<li><strong>Cost</strong>. Depends on which RDBMS of course, but MongoDB is free and can run on Linux, ideal for running on cheaper commodity kits.</li>
</ul>
<h3 id="whymongodbatlashttpswwwmongodbcomcloudatlas">🍃 Why <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a>?</h3>
<p>Well, now that I know MongoDB is the right database choice, there are so many different options to host your database. I can self-host on my Linux machine via DigitalOcean, use a cloud provider like AWS/Azure or a choose a DBaaS service specific to MongoDB.</p>
<p><a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308461319-MongoDB-Atlas-1024x337.jpg" alt="Mongodb Atlas" width="1024" height="337" class="aligncenter size-large wp-image-166875" /></a></p>
<p>But I want a fast, secure, and managed MongoDB solution that I can easily scale with the growth of the number of modules we attach in this custom WordPress dashboard. That’s <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a>.</p>
<blockquote>
<p><a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a> is a cloud-hosted MongoDB service engineered and run by the same team that builds the database. And guess what, I trust that they follow the best operational practices since they are the ones who’re building MongoDB in the first place.</p>
</blockquote>
<p>I want this custom dashboard to be self-managed, serverless, and using MongoDB Atlas saves me from worrying about software patching, backups, and reliable configuration setup for new DB updates. Again a big plus. ➕</p>
<p>Also, the fact that MongoDB Atlas is supported <a href="https://www.mongodb.com/blog/post/new-to-mongodb-atlas-cross-region-replication-new-instance-sizes?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">cross-platform as well as cross-region</a> and across different cloud providers makes it a much better choice. I think each Cluster comes with two replica sets, ready to scale.</p>
<h3 id="mongodbcompass">🔋 MongoDB Compass</h3>
<p>Now that we are going to work with MongoDB, it’d be great to have a tool through which we can explore our database, view the changes, debug and so on. For this purpose, MongoDB again takes the lead with a product called <a href="https://www.mongodb.com/products/compass?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Compass</a>. Take a look.</p>
<p><a href="https://www.mongodb.com/products/compass?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308461608-MongoDB-Compass-1024x420.jpg" alt="Mongodb Compass" width="1024" height="420" class="aligncenter size-large wp-image-166876" /></a></p>
<p>I suggest that you go ahead and download <a href="https://www.mongodb.com/products/compass?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Compass</a>. It’s literally the best tool to visualize your MongoDB database. Here’s a set of features:</p>
<ul>
<li><strong>Visualize and explore:</strong> Take a look at your database, find out how things are looking, and even visualize stuff like maps/coordinates.</li>
<li><strong>Insert, modify, and delete:</strong> You can also perform CRUD operations for your DB right from MongoDB compass. Makes testing easier.</li>
<li><strong>Debug and optimize:</strong> Finally, analyze your data, debug it and even find out about performance issues right inside a great GUI for your database. This tool is a must-have if you work with MongoDB.</li>
<li><strong>Extensible:</strong> And the best part is you can build your own plugins to extend MongoDB Compass. Here’s the documentation on <a href="https://docs.mongodb.com/compass/master/plugins/creating-compass-plugins/?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">building your own Compass plugins</a>.</li>
<li><strong>Enterprise Flavor</strong>: MongoDB Compass comes in a few flavors: Community (Free), and Enterprise (Licensed) — the Enterprise version is the one that lets you visualize DB schema.</li>
</ul>
<h2 id="gettingstartedwithmongodbatlas">✅ Getting Started with MongoDB Atlas</h2>
<p>Let’s get started and build a simple module that&#8217;s part of the custom WordPress dashboard I am building. For this module, we are collecting all the sales related data. For that, we need a MongoDB instance, and of course we’re using MongoDB Atlas here.</p>
<h3 id="step1gotomongodbatlashttpswwwmongodbcomcloudatlas">Step #1: Go to <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas →</a></h3>
<p>Go to the <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a> site and register a completely free MongoDB instance hosted on AWS, with shared RAM and 512 MB storage. Click the <em>Get Started Free</em> button.</p>
<p><a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308461891-MongoDB-Atlas-1024x420.jpg" alt="Mongodb Atlas" width="1024" height="420" class="aligncenter size-large wp-image-166877" /></a></p>
<h3 id="step2signupatmongodbatlashttpswwwmongodbcomcloudatlas">Step #2: Sign up at <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas →</a></h3>
<p>Now go ahead and sign up with your email ID and fill up the details. It’s amazing that you can sign up and use a free MongoDB Atlas hosted DB instance, and they don’t even require you to add a credit card for that.</p>
<p><a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308462232-MongoDB-Atlas-Signup-1-1024x420.jpg" alt="Mongodb Atlas Signup" width="1024" height="420" class="aligncenter size-large wp-image-166878" /></a></p>
<h3 id="step3createthecluster">Step #3: Create the Cluster</h3>
<p>Now you’ll be redirected to a page with a bunch of information about the new MongoDB Cluster you’re about to create. I suggest that you review this information, and move ahead by clicking the <em>Create Cluster</em> button at the bottom just like in the screenshot below.</p>
<p><a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308462573-MongoDB-Atlas-Create-Clustor-1024x420.jpg" alt="Mongodb Atlas Create Cluster" width="1024" height="420" class="aligncenter size-large wp-image-166879" /></a></p>
<h3 id="step4createdbusernamepassword">Step #4: Create DB Username &amp; Password</h3>
<p>It’ll take a minute and your DB will be created. Once that happens, head over to the <em>Security</em> > <em>MongoDB Users</em> and click on the <em>+ ADD NEW USER</em> button on the right, to create a new user for your database. Let’s keep all the other settings set to default for the sake of this intro-article.</p>
<p>I’m setting the user/pass as <code>usermongo</code> but you know better.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530846292Screen-Recording-2018-05-21-at-07.35-PM.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="1920" height="634" class="aligncenter size-full wp-image-166880" /></p>
<h3 id="step5addiptowhitelistforaccess">Step #5: Add IP to Whitelist for Access</h3>
<p>To be able to access your MongoDB Atlas database, you need to setup the IP Whitelist with the IP of your server where your app is hosted. Authentication is beyond what I am discussing here so for the purpose of this demo let’s just allow everyone (obviously a bad practice in production).</p>
<p>So, again, head over to the <em>Security</em> > <em>IP Whitelist</em> and click on the <em>+ ADD IP ADDRESS</em> button on the right, and finally <em>ALLOW ACCESS FROM ANYWHERE</em> button to allow the anonymous access.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530846345Screen-Recording-2018-05-21-at-07.45-PM.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="1918" height="618" class="aligncenter size-full wp-image-166881" /></p>
<h3 id="step6connectviamongodbcompass">Step #6: Connect via MongoDB Compass</h3>
<p>Now that our DB’s IP access and a user has been created, we can pick up the connection string and use it to connect to our database with our MongoDB Compass application.</p>
<p>Go to <em>Connect</em> then choose <em>Connect with MongoDB Compass</em> and download Compass if you haven’t. Copy the URI Connection String. Finally, open Compass and it should be able to detect the connection string in your clipboard, allow it to connect to your database.</p>
<p>And you are set to visualize your database, analyze its performance, and even run complete CRUD operations. Awesome! 💯</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530846867ezgif-1-97dc933b41.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="980" height="544" class="aligncenter size-full wp-image-166882" /></p>
<p>Now that we have created a MongoDB Atlas and connected it with MongoDB Compass, we can move forward and start building our Node.js application.</p>
<h2 id="wordpressrestapiftw">WordPress REST API — FTW!</h2>
<p>This WordPress based Node.js custom dashboard interacts with the WordPress instance via the <a href="https://developer.wordpress.org/rest-api/">WordPress REST API</a>. Since this is a Node.js app, I am using an awesome library called <a href="https://www.npmjs.com/package/wpapi"><code>wpapi</code></a> written by <a href="https://twitter.com/kadamwhite">K Adam White</a>. He has also built a demo <a href="https://www.npmjs.com/package/express">Express</a> based WordPress app. That’s what I got inspired by while building this custom dashboard, so you’ll see a lot of it here.</p>
<h3 id="wordpresscustomrouterbasedonexpresshttpswwwnpmjscompackageexpress">🚀 WordPress Custom Router Based on <a href="https://www.npmjs.com/package/express">Express</a></h3>
<p>The router is set up with <a href="https://www.npmjs.com/package/express">Express</a>. Here’s a basic error handler and router template for using WordPress with express.</p>
<pre><code class="javascript language-javascript">'use strict';

var express = require('express');
var router = express.Router();
var siteInfoMiddleware = require('../middleware/site-info');

// Set global site info on all routes
router.use(siteInfoMiddleware);

// Public Routes
// =============

router.get('/', require('./index'));
router.get('/page/:page', require('./index'));
router.get('/:slug', require('./single'));
router.use('/tags/:tag', require('./tag'));
router.use('/categories/:category', require('./category'));

// Catch 404 and forward to error handler.
router.use(function (req, res, next) {
    var err = new Error('Not Found');
    err.status = 404;
    next(err);
});

// Error Handling
// ==============

// Development error handler will print stacktrace.
function developmentErrorRoute(err, req, res, next) {
    res.status(err.status || 500);
    res.render('error', {
        message: err.message,
        error: err
    });
}

// Production error handler. No stacktraces leaked to user.
function friendlyErrorRoute(err, req, res, next) {
    res.status(err.status || 500);
    res.render('error', {
        message: err.message,
        error: {}
    });
}

// Configure error-handling behavior
if (router.get('env') === 'development') {
    router.use(developmentErrorRoute);
} else {
    router.use(friendlyErrorRoute);
}

module.exports = router;
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/d249897d8cf724e244a833a97d9ff053">Gist</a>.</p>
<h3 id="basicexpressbasedimplementation">🎚 Basic Express Based Implementation</h3>
<p>I am not hosting this entire thing on WordPress, but the initial plan was to do just that. If you want to go do that, you’d wanna build the index by querying all the info using the <a href="https://github.com/tildeio/rsvp.js/#hash-of-promises"><code>RSVP.hash</code> utility</a> for convenience and parallelism. For that here’s what you should do.</p>
<pre><code class="javascript language-javascript">'use strict';

var wp = require( '../services/wp' );
var contentService = require( '../services/content-service' );
var pageNumbers = require( '../services/page-numbers' );
var pageTitle = require( '../services/page-title' );
var RSVP = require( 'rsvp' );

function getHomepage( req, res, next ) {
  var pages = pageNumbers( req.params.page );

  RSVP.hash({
    archiveBase: '',
    pages: pages,
    title: pageTitle(),
    // Primary page content
    posts: wp.posts().page( pages.current ),
    sidebar: contentService.getSidebarContent()
  }).then(function( context ) {
    if ( req.params.page &amp;&amp; ! context.posts.length ) {
      // Invalid pagination: 404
      return next();
    }

    res.render( 'index', context );
  }).catch( next );
}

module.exports = getHomepage;
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/056c0f19551356f0740a64c1f7528989">Gist</a>.</p>
<h3 id="authenticationcookedin">🦏 Authentication Cooked In</h3>
<p>For this setup, you’ll also need to authenticate your Node.js app by giving it the authentication data, which along with <code>wpapi</code> can be processed like this. Beware this is not always a best practice if you don’t use correct permissions and environment variables settings.</p>
<pre><code class="javascript language-javascript">var WP = require( 'wordpress-rest-api' );
var _ = require( 'lodash' );

var config = _.pick( require( './config' ).wordpress, [
  // Whitelist valid config keys
  'username',
  'password',
  'endpoint'
]);

var wp = new WP( config );

module.exports = wp;
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/432f285e2ec7dc70bac6973d7f23a1ff">Gist</a>.</p>
<h3 id="sitecontentaccumulation">🦁 Site Content Accumulation</h3>
<p>And finally, you are able to consume all the content by creating a content service which handles recursively fetching:</p>
<ul>
<li>All the pages of a paged collection.</li>
<li>Your WordPress site’s info.</li>
<li>An alphabetized list of categories.</li>
<li>A specific category (specified by slug) from the content cache.</li>
<li>An alphabetized list of tags.</li>
<li>A specific tag (specified by slug) from the content cache</li>
<li>Other content required to have some feature parity with WP.</li>
</ul>
<p><em>The code for this looks somewhat like this.</em></p>
<pre><code class="javascript language-javascript">'use strict';

var wp = require( './wp' );
var cache = require( './content-cache' );
var _ = require( 'lodash' );
var RSVP = require( 'rsvp' );

/**
 * Recursively fetch all pages of a paged collection
 *
 * @param {Promise} request A promise to a WP API request's response
 * @returns {Array} A promise to an array of all matching records
 */
function all( request ) {
  return request.then(function( response ) {
    if ( ! response._paging || ! response._paging.next ) {
      return response;
    }
    // Request the next page and return both responses as one collection
    return RSVP.all([
      response,
      all( response._paging.next )
    ]).then(function( responses ) {
      return _.flatten( responses );
    });
  });
}

function siteInfo( prop ) {
  var siteInfoPromise = cache.get( 'site-info' );

  if ( ! siteInfoPromise ) {
    // Instantiate, request and cache the promise
    siteInfoPromise = wp.root( '/' ).then(function( info ) {
      return info;
    });
    cache.set( 'site-info', siteInfoPromise );
  }

  // Return the requested property
  return siteInfoPromise.then(function( info ) {
    return prop ? info[ prop ] : info;
  });
}

/**
 * Get an alphabetized list of categories
 *
 * All archive routes display a sorted list of categories in their sidebar.
 * We generate that list here to ensure the sorting logic isn't duplicated
 * across routes.
 *
 * @method sortedCategories
 * @return {Array} An array of category objects
 */
function sortedCategories() {
  return all( wp.categories() ).then(function( categories ) {
    return _.chain( categories )
      .sortBy( 'slug' )
      .value();
  });
}

function sortedCategoriesCached() {
  var categoriesPromise = cache.get( 'sorted-categories' );

  if ( ! categoriesPromise ) {
    categoriesPromise = sortedCategories();
    cache.set( 'sorted-categories', categoriesPromise );
  }

  return categoriesPromise;
}

/**
 * Get a specific category (specified by slug) from the content cache
 *
 * The WP API doesn't currently support filtering taxonomy term collections,
 * so we have to request all categories and filter them down if we want to get
 * an individual term.
 *
 * To make this request more efficient, it uses sortedCategoriesCached.
 *
 * @method categoryCached
 * @param {String} slug The slug of a category
 * @return {Promise} A promise to the category with the provided slug
 */
function categoryCached( slug ) {
  return sortedCategoriesCached().then(function( categories ) {
    return _.findWhere( categories, {
      slug: slug
    });
  });
}

/**
 * Get a specific tag (specified by slug) from the content cache
 *
 * The WP API doesn't currently support filtering taxonomy term collections,
 * so we have to request all tags and filter them down if we want to get an
 * individual term.
 *
 * To make this request more efficient, it uses the cached sortedTags promise.
 *
 * @method tagCached
 * @param {String} slug The slug of a tag
 * @return {Promise} A promise to the tag with the provided slug
 */
function tagCached( slug ) {
  return sortedTagsCached().then(function( tags ) {
    return _.findWhere( tags, {
      slug: slug
    });
  });
}

/**
 * Get an alphabetized list of tags
 *
 * @method sortedTags
 * @return {Array} An array of tag objects
 */
function sortedTags() {
  return all( wp.tags() ).then(function( tags ) {
    return _.chain( tags )
      .sortBy( 'slug' )
      .value();
  });
}

function sortedTagsCached() {
  var tagsPromise = cache.get( 'sorted-tags' );

  if ( ! tagsPromise ) {
    tagsPromise = sortedTags();
    cache.set( 'sorted-tags', tagsPromise );
  }

  return tagsPromise;
}

function getSidebarContent() {
  return RSVP.hash({
    categories: sortedCategoriesCached(),
    tags: sortedTagsCached()
  });
}

module.exports = {
  // Recursively page through a collection to retrieve all matching items
  all: all,
  // Get (and cache) the top-level information about a site, returning the
  // value corresponding to the provided key
  siteInfo: siteInfo,
  sortedCategories: sortedCategories,
  sortedCategoriesCached: sortedCategoriesCached,
  categoryCached: categoryCached,
  tagCached: tagCached,
  sortedTags: sortedTags,
  sortedTagsCached: sortedTagsCached,
  getSidebarContent: getSidebarContent
};
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/f1155503694e258d3e2bb16990c4e37d">Gist</a>.</p>
<h3 id="customroutessalesdata">🛠 Custom Routes &amp; Sales Data</h3>
<p>Finally, I have cooked in quite a few custom routes from where I can attain any kind of sales related data. For the particular architecture I have in place, I’m again using the <a href="https://github.com/tildeio/rsvp.js/#hash-of-promises"><code>RSVP.hash</code> utility</a> for convenience and parallelism. It works like a charm.</p>
<pre><code class="javascript language-javascript">var WPAPI = require( 'wpapi' );
var RSVP = require('rsvp');

// Using the RSVP.hash utility for convenience and parallelism
RSVP.hash({
  categories: wp.categories().slug( 'it-services' ),
  tags1: wp.tags().slug('hotel-name'),
  tags2: wp.tags().slug('march-events')
}).then(function( results ) {
    // Combine &amp; map .slug() results into arrays of IDs by taxonomy
    var tagIDs = results.tags1.concat( results.tags2 )
        .map(function( tag ) { return tag.id; });
    var categoryIDs = results.categories
        .map(function( cat ) { return cat.id; });
    return wp.posts()
        .tags( tags )
        .categories( categories );
}).then(function( posts ) {
    // These posts are all fiction, either magical realism or historical:
    console.log( posts );
});
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/3f37580dee585eeaad071bf3b01c8a42">Gist</a>.</p>
<p>Once I have that data, I am sending it to Paddle.com for processing along with the purchased order request so that it can be added to our MongoDB instance via serverless ⚡ Azure Functions.</p>
<pre><code class="javascript language-javascript">// Registering custom routes.
site.itSales = site.registerRoute( 'sales/v1', '/resource/(?P&lt;some_part&gt;\\d+)' );
site.itSales().somePart( 7 ); // =&gt; myplugin/v1/resource/7

// Query Parameters &amp; Filtering Custom Routes.
site.handler = site.registerRoute( 'sales/v1', 'receipts/(?P&lt;id&gt;)', {
    // Listing any of these parameters will assign the built-in
    // chaining method that handles the parameter:
    params: [ 'before', 'after', 'author', 'parent', 'post' ]
});

// Yields from the custom data of buyers.
site.handler().post( 8 ).author( 92 ).before( dateObj )... // Sent to paddle.
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/6b986735aa2f2e36a60b939cf8b30925">Gist</a>.</p>
<p>It might look odd to some but WordPress allows you to set up custom post types and custom taxonomies which is what I’m using here, the above code, however, is not the exact implementation but a similar approach to what I have used via categories and tags.</p>
<p>This data gets sent Paddle, and it’s heavily cached so that our WordPress instances do not get any sort of load while we experiment with the custom dashboard. I’ve also cooked in a small <code>data-refresh</code> module which fetches the data on demand from the WordPress instance of choice.</p>
<h2 id="microsoftazureazurefunctions">Microsoft Azure &amp; Azure Functions</h2>
<p>While building this custom WordPress dashboard, I wanted to make sure that each module of this dashboard lived in form of a serverless app with multiple serverless functions. This decision was based on keeping this dashboard’s cost as economical as possible.</p>
<h3 id="threeoptions">👀 Three Options</h3>
<p>There are three major cloud services providers present. These are <a href="https://azure.microsoft.com/en-us/">Microsoft Azure</a>, <a href="https://cloud.google.com/">Google Cloud Platform</a>, and <a href="https://aws.amazon.com/">Amazon Web Services</a>. Each of these has serverless functions available, respectively called Azure functions, GCP Cloud Functions, and AWS Lambdas.</p>
<h3 id="choosingazure">📘 Choosing Azure</h3>
<p>Azure has one of the biggest cloud architectures and global presences. 50 Azure regions, more than any cloud provider and after testing each of these three, I found that Azure functions had the best response time in UAE (as my client’s business is based out of UAE).</p>
<p>Also, the fact that we’re using Azure ML Studio, AI Cognitive Services, and Virtual Machines to host parts of this project, means it made complete sense to use Azure functions for the serverless architecture.</p>
<h2 id="gettingstartedwithazurefunctions">Getting Started with Azure Functions</h2>
<p>Let’s get started with Azure functions. I am going to take you through the process of creating a simple serverless Azure function, which will be triggered via HTTP requests, and inside it, we’ll process the sales information sent to us from Paddle.com.</p>
<h3 id="whatarewebuilding">⚙ What are we building?!</h3>
<ol>
<li>I am building a serverless Azure function which is based on JavaScript and specifically Node.js code.</li>
<li>This Azure function will get triggered by a simple <code>GET</code> HTTP request from our 3rd party payment solution, i.e., Paddle.com.</li>
<li>As soon as there’s a sale on Paddle.com, it will <a href="https://paddle.com/docs/reference-using-webhooks">trigger a webhook</a> that contains info related to our sale, quantity, item, earnings, and some member-related data that WordPress sent to Paddle.</li>
<li>Using the WordPress REST API, I have added some custom data related to the user who purchased the product, like user’s ID in WordPress DB, which WordPress site had this sale, and that user’s meta info.</li>
<li>When the Azure function receives this <code>GET</code> request, it processes the info, takes out what I need to keep in the MongoDB Atlas Cluster and forms a JavaScript object ready to be saved in the DB.</li>
<li>The Azure function then connects to the MongoDB Atlas instance via an npm package called <a href="http://mongoosejs.com/">mongoose</a>, where after connecting the database, I create a DB Model/Schema, and then this data is saved to the MongoDB Atlas Cluster.</li>
<li>After which Azure function kind of sits there waiting for next sale to happen, where my client only pays for the execution time and amount of executions for Azure functions. (<a href="https://azure.microsoft.com/en-us/pricing/details/functions/">1 million of which are free every month</a> 😮).</li>
</ol>
<p>Now, this is only a high-level summary of what’s happening, there’s a lot of steps that I skipped here like authentication which is beyond the scope of this article. You should always setup authentication and verification to keep things civil and avoid any overage.</p>
<p>So, let’s go ahead and build this thing.</p>
<h3 id="step1setupmicrosoftazurevscode">Step #1: Set up Microsoft Azure &amp; VSCode</h3>
<p>I expect you to have the <a href="https://azure.microsoft.com/">Azure</a> account set up on your end. You’ll need to subscribe with a credit card since we need storage for hosting the Node.js files, which will be used with Azure Functions and you have to pay for storage (you’ll probably get a free $200 credit for the first month, and even after that the cost is quite low).</p>
<p>So, go ahead and set up the following:</p>
<ol>
<li>✅ Setup a <a href="https://azure.microsoft.com/">Microsoft Azure</a> account with a credit card in billing.</li>
<li>✅ Install <a href="https://code.visualstudio.com/">Visual Studio Code</a> (Psst. I’m making a <a href="https://ahmadawais.com/visual-studio-code-power-user/">course on VSCode</a>).</li>
<li>✅ Install the <a href="https://marketplace.visualstudio.com/items?itemName=ms-azuretools.vscode-azurefunctions">Azure Functions extension</a> on your VSCode.</li>
<li>💡 To enable local debugging, install the <a href="https://github.com/Azure/azure-functions-core-tools#installing">Azure Functions Core Tools</a>.</li>
<li>🗂 Create a new directory and open it up in VSCode.</li>
</ol>
<p><em>In case you’re wondering which theme and font I am using, it’s <a href="https://marketplace.visualstudio.com/items?itemName=ahmadawais.shades-of-purple">Shades of Purple 💜</a> — for more info see which <a href="https://ahmadawais.com/uses/">software and hardware I use</a>.</em></p>
<p><a href="https://marketplace.visualstudio.com/items?itemName=ahmadawais.shades-of-purple"><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/15308469057-VSCode-Shades-of-Puple-1024x576.jpg" alt="7 VSCode Shades Of Purple" width="1024" height="576" class="aligncenter size-large wp-image-166883" /></a></p>
<h3 id="step2createanewfunctionappproject">Step #2: Create a New Function App Project</h3>
<p>Now let’s create a new function app project. This is really easy with VSCode. All you have to do is go to the Azure Extension explorer present in the activity bar. From there access <code>FUNCTIONS</code> tab and click on the first <code>Create New Project</code> icon.</p>
<p>This will create a demo project, with basic files required to get started and will initialize a Git repo for you. I’ll keep up with small GIF-based demos to make things easier for you.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530847274ezgif-1-87466006fa.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="1000" height="504" class="aligncenter size-full wp-image-166884" /></p>
<h3 id="step3createanhttptriggeredazurefunction">Step #3: Create an HTTP-triggered Azure Function</h3>
<p>Now that we have created a function app project, let’s create an HTTP-triggered serverless Azure function. For that, go to the Azure Extension explorer present in the activity bar. From there access the <code>FUNCTIONS</code> tab and click on the second icon <code>Create Function</code>.</p>
<p>For the sake of this demo, I am choosing to keep the authentication part simple, so I&#8217;m going to select anonymous access. The name of our Azure function is <code>HttpTriggerJS</code> so you can find a new directory created with that name inside your project. This should contain two files i.e. <code>functions.json</code> and <code>index.js</code></p>
<p>⚡ A <em>function</em> is a primary concept in Azure Functions. You write code for a function in a language of your choice and save the code and configuration files in the same folder.</p>
<p>🛠 The configuration is named <code>function.json</code>, which contains JSON configuration data. It defines the function bindings and other configuration settings. The runtime uses this file to determine the events to monitor and how to pass data into and return data from function execution. <a href="https://docs.microsoft.com/en-us/azure/azure-functions/functions-reference#function-code">Read more on this file in the official documentation here</a>.</p>
<p>The following is an example <code>function.json</code> file that gets created.</p>
<pre><code class="javascript language-javascript">{
  "disabled": false,
  "bindings": [
    {
      "authLevel": "anonymous",
      "type": "httpTrigger",
      "direction": "in",
      "name": "req"
    },
    {
      "type": "http",
      "direction": "out",
      "name": "res"
    }
  ]
}
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/9e0b7a61e4b50c671a132547c5c148ae">Gist</a>.</p>
<p>And then, there’s an <code>index.js</code> file which contains a basic code that you can use to test your Azure function. It receives a parameter <code>name</code> and prints it back to you or shows you an error asking for this parameter.</p>
<pre><code class="javascript language-javascript">module.exports = function (context, req) {
    context.log('JavaScript HTTP trigger function processed a request.');

    if (req.query.name || (req.body &amp;&amp; req.body.name)) {
        context.res = {
            // status: 200, /* Defaults to 200 */
            body: "Hello " + (req.query.name || req.body.name)
        };
    }
    else {
        context.res = {
            status: 400,
            body: "Please pass a name on the query string or in the request body"
        };
    }
    context.done();
};
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/d9791f74cfe114548a58227ed8db2dd1">Gist</a>.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530847308Screen-Recording-2018-05-21-at-11.47-PM.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="1920" height="962" class="aligncenter size-full wp-image-166885" /></p>
<h3 id="step4deploytestyourazurefunction">Step #4: Deploy &amp; Test Your Azure Function</h3>
<p>Now that we have created an Azure function which can be triggered by a <code>GET</code> HTTP request, let’s go ahead and deploy it with VSCode and test it with the <a href="https://www.getpostman.com/">Postman</a> API Explorer.</p>
<p>To deploy the function go to the Azure Extension explorer present in the activity bar. From there access the <code>FUNCTIONS</code> tab and click on the third icon <code>Deploy to Function App</code>.</p>
<p>This will ask you a bunch of questions about the name of your app, use anything unique. I used <code>demo-wp-mdb-azure</code> — VSCode then uses this to create a resource group, to group together your function-app related resources, its storage (used to save the files), and the created Azure function — finally responding back to us with a public URL.</p>
<p>I then went ahead to access this URL and it asked for the <code>name</code> param as per the code. When I sent the <code>name</code> param with the Postman app, it responded with <code>Hello Ahmad Awais</code>. 👍</p>
<p>VSCode also asked me to update the function extension app versions to beta, and I chose yes — because that will help me use Node.js v8 for async/await.</p>
<h3 id="step5createpackagejsonandinstallmongoosehttpmongoosejscom">Step #5: Create <code>package.json</code> and Install <a href="http://mongoosejs.com/">mongoose</a></h3>
<p>Now that our Azure function is up and running, let’s create a <code>package.json</code> file in the root of our project and install <a href="http://mongoosejs.com/">mongoose</a>. We’ll need this to connect and save data to our MongoDB Atlas Cluster.</p>
<p>Mongoose provides a straight-forward, schema-based solution to modeling your application data. It includes built-in typecasting, validation, query building, business logic hooks and more, out of the box. It’s pretty awesome. 💯</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530848721Screen-Recording-2018-05-22-at-12.36-AM.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="1920" height="956" class="aligncenter size-full wp-image-166886" /></p>
<h3 id="step6addappsettingformongodbconnection">Step #6: Add App Setting for MongoDB Connection</h3>
<p>Now we are almost ready to start writing code for our application. But before doing that, we’ll need a connection string to be able to connect to our MongoDB Atlas Cluster (just like we did with MongoDB Compass). This connection string is private and you shouldn’t commit it to the git repo.</p>
<p>💯 This connection string belongs to the <code>local.settings.json</code> file in the project root. Let’s first download the settings, then add the <code>MongodbAtlas</code> setting with our connection string (get this string from the MongoDB Atlas dashboard) and upload the app settings.</p>
<p>To do this, go to the Azure Extension explorer present in the activity bar. From there access the <em>FUNCTIONS</em> tab and select your subscription, then your Azure function app, i.e., <code>demo-wp-mdb-azure</code>. Right click <em>Application Settings</em> and select <em>Download remote settings…</em> to download and <em>Upload local settings…</em> to upload the settings after adding the <code>MongodbAtlas</code> connection string to the settings.</p>
<h3 id="step7updatenodeversionofazurefunction">Step #7: Update Node Version of Azure Function</h3>
<p>In the code, I intend to use <code>async</code>/<code>await</code>, which are not available on Node.js v6.5.0, which comes with the default version 1 of Azure functions. In step #4, VSCode asked me to update the runtime version of Azure function to beta and I did that. This enabled support for the latest Node.js versions on Azure functions.</p>
<p>So, let’s update the <code>WEBSITE_NODE_DEFAULT_VERSION</code> app setting in our local settings and update that to the remote settings.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530849482ezgif-1-acc157a6ee.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="900" height="450" class="aligncenter size-full wp-image-166887" /></p>
<h3 id="step8createmongodbmodelschema">Step #8: Create MongoDB Model/Schema</h3>
<p>Before we save any data to our MongoDB Atlas Cluster, let’s create a <code>modelSale.js</code> file that will contain the model’s schema for what we intend to save in the database. It’s an extremely simple schema implementation, and I suggest you read up on what you can do here with <a href="http://mongoosejs.com/docs/guide.html">mongoose</a> and <a href="https://docs.mongodb.com/manual/data-modeling/?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB</a>.</p>
<p><em>This file is pretty much self-explanatory.</em></p>
<pre><code class="javascript language-javascript">/**
 * Model: Sale
 */
const mongoose = require('mongoose');
mongoose.Promise = global.Promise;

// Sale Schema.
const saleSchema = new mongoose.Schema({
    sale_gross: Number,
    earnings: Number,
    currency: String,
    memberSince: Date,
    customerEmail: String,
    event_time: {
        type: Date,
        default: Date.now
    },
});


// Export the model.
module.exports = mongoose.model('Sale', saleSchema);
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/c4c33b2a0e519ef79efa50e9aeb7f40f">Gist</a>.</p>
<h3 id="step9codetheazurefunctionwithnodejs">Step #9: Code the ⚡ Azure Function with Node.js</h3>
<p>Now let’s code our Azure function. I’m adding all the main code inside the <code>index.js</code> file for the purpose of this demo. I&#8217;m also going to use the <a href="https://docs.microsoft.com/en-us/azure/azure-functions/functions-reference-node#context-object">context object</a> as the first parameter, so make sure you <a href="https://docs.microsoft.com/en-us/azure/azure-functions/functions-reference-node#context-object">read about that</a>. Everything else is explained in the code snippet below.</p>
<p>So, this is just a demo code for this article. It does the following:</p>
<ul>
<li>✅ Gets the data from Paddle.com</li>
<li>⚡ Connects to the MongoDB Atlas via connection string that we added in our Application Settings.</li>
<li>📘 Uses the defined DB schema inside the <code>test</code> database where it creates a <code>sales</code> collection, including documents for our sales.</li>
<li>⚙ Validates the data and creates a <code>finalData</code> object that gets saved in the MongoDB Atlas Cluster. Yay!</li>
<li>🥅 Finally, responds to the Paddle webhook with a <code>200</code> status code if all goes well, and does the <a href="https://docs.microsoft.com/en-us/azure/azure-functions/functions-reference-node#context-object"><code>context.done()</code></a> dance.</li>
</ul>
<p><em>Everything is pretty much explained with inline documentation.</em></p>
<pre><code class="javascript language-javascript">/**
 * Azure Function: Sale.
 *
 * Gets data from Paddle.com (which in turn gets data
 * from WordPress) and processes the data, creates a
 * finalData object and saves it in MongoDB Atlas.
 *
 * @param context To pass data between function to / from runtime.
 * @param req HTTP Request sent to the Azure function by Paddle.
 */
module.exports = async function (context, req) {
    // Let's call it log.
    const log = context.log;

    // Log the entire request just for the demo.
    log('[RAN] RequestUri=%s', req.originalUrl);

    /**
     * Azure function Response.
     *
     * Processes the `req` request from Paddle.com
     * and saves the data to MongoDB Atlas while
     * responding the `res` response.
     */

    // Database interaction.
    const mongoose = require('mongoose');
    const DATABASE = process.env.MongodbAtlas;

    // Connect to our Database and handle any bad connections
    mongoose.connect(DATABASE);
    mongoose.Promise = global.Promise; // Tell Mongoose to use ES6 promises
    mongoose.connection.on('error', (err) =&gt; {
        context.log(`ERROR→ ${err.message}`);
    });

    // Sale Schema.
    require('./modelSale');
    const Sale = mongoose.model('Sale');

    // Create a Response.
    if (req.query.customFieldName) { // Simple authentication for the purpose of demo.

        // Build the data we need.
        const sale_gross = req.query.p_sale_gross || '0';
        const earnings = JSON.parse(req.query.p_earnings)['16413'] || '0'
        const currency = req.query.p_currency || 'USD';
        const memberSince = req.query.memberSince || new Date();
        const customerEmail = req.query.customerEmail || '';
        const event_time = new Date();

        log('[OUTPUT]—— sale_gross: ' + sale_gross);
        log('[OUTPUT]—— earnings: ' + earnings);
        log('[OUTPUT]—— currency: ' + currency);

        const finalData = {
            sale_gross: sale_gross,
            earnings: earnings,
            currency: currency,
            memberSince: memberSince,
            customerEmail: customerEmail,
            event_time: event_time,
        }

        // Save to db.
        const sale = await (new Sale(finalData)).save();
        log("[OUTPUT]—— SALE SAVED: ", sale);

        // Respond with 200.
        context.res = {
            status: 200,
            body: "Thank You for the payment! " + (req.query.customFieldName || req.body.customFieldName)
        };
    } else {
        context.res = {
            status: 400,
            body: "Please pass a name on the query string or in the request body"
        };
    }


    // Informs the runtime that your code has finished. You must call context.done, or else the runtime never knows that your function is complete, and the execution will time out.
    // @link: https://docs.microsoft.com/en-us/azure/azure-functions/functions-reference-node#contextdone-method
    context.done();
};
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/50bf1af0fb30ca80aca1800e46d8af27">Gist</a>.</p>
<h3 id="step10redeploytheazurefunction">Step #10: Re-deploy the Azure Function</h3>
<p>Now let’s re-deploy the Azure function. For that, go to the Azure Extension explorer present in the activity bar. From there access the <em>FUNCTIONS</em> tab and click on the third <em>Deploy to Function App</em> icon.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530849577ezgif-1-37dd72df0c.gif" alt="GIF for MongoDB Atlas, Microsoft Azure, &amp; Serverless Functions" width="900" height="450" class="aligncenter size-full wp-image-166888" /></p>
<h3 id="step11testazurefunctionviapaddleswebhook">Step #11: Test Azure Function via Paddle’s Webhook</h3>
<p>Looks like we’re pretty much done. All that’s left is to test our Azure function by triggering a dummy webhook via Paddle.com. Let’s do that. Also, when things do work, let’s explore how our data looks in the MongoDB Compass.</p>
<p><em>Wow, humph! That was a lot. Glad it worked. 🎉</em></p>
<h2 id="sowhatjusthappened">🤔 So, What Just Happened?!</h2>
<p>Prepare yourself for a mouthful. I created a small part of the <code>Sales</code> module in the custom WordPress Dashboard app that I am building. I used MongoDB Atlas and Compass, then created a Microsoft Azure Function via Function App with VSCode, deployed the app with an env secret as the application string with the MongoDB connection string, updated the Node.js version and triggered the function via a dummy webhook from Paddle.com (like it will trigger when a sale happens) to send data (from Paddle + WordPress) to our Azure function and from there to MongoDB Atlas. <em>And it worked, haha!</em></p>
<h2 id="machinelearningartificialintelligence">Machine Learning &amp; Artificial Intelligence</h2>
<p>Machine learning and artificial intelligence are always a mesmerizing topic in the world of software technology but we don’t talk a lot about that in the context of WordPress or in the WP community.</p>
<p>I set to change that by adding a few small improvements to a select few WordPress sites for my client and have every intention of exploring the same with this custom WordPress dashboard.</p>
<p>I have discussed this topic before and shared what I am working on, take a look at this small artificial intelligence plugin I am building for WordPress, and integrating it with different Azure Cognitive Services.</p>
<p><em>I explained this in a video in another post that you can find here: <a href="https://ahmadawais.com/wordpress-artificial-intelligence/">Building a WordPress Artificial Intelligence Plugin →</a></em>.</p>
<p>I’ve accomplished similar results in this dashboard with the <code>wpapi</code> package. First I upload the image to cognitive services and then on a confident response, I send it to WordPress to be uploaded via WordPress REST API, with an image description that gets generated by Computer Vision AI.</p>
<pre><code class="javascript language-javascript">/**
 * Get Image Alt Recognition with Computer Vision
 * using Azure Cognitive Services.
 */
var WPAPI = require('wpapi');
var wp = new WPAPI({
    endpoint: 'http://src.wordpress-develop.dev/wp-json'
});

/**
 * Handle Image Alt Generation.
 */
function processImage() {
    // **********************************************
    // *** Update or verify the following values. ***
    // **********************************************

    // Replace &lt;Subscription Key&gt; with your valid subscription key.
    var subscriptionKey = "&lt;Subscription Key&gt;";

    // You must use the same region in your REST call as you used to get your
    // subscription keys. For example, if you got your subscription keys from
    // westus, replace "westcentralus" in the URI below with "westus".
    //
    // Free trial subscription keys are generated in the westcentralus region.
    // If you use a free trial subscription key, you shouldn't need to change
    // this region.
    var uriBase =
        "https://westcentralus.api.cognitive.microsoft.com/vision/v2.0/analyze";

    // Request parameters.
    var params = {
        "visualFeatures": "Categories,Description,Color",
        "details": "",
        "language": "en",
    };

    // Display the image.
    var sourceImageUrl = document.getElementById("inputImage").value;
    document.querySelector("#sourceImage").src = sourceImageUrl;

    // Make the REST API call.
    $.ajax({
            url: uriBase + "?" + $.param(params),

            // Request headers.
            beforeSend: function (xhrObj) {
                xhrObj.setRequestHeader("Content-Type", "application/json");
                xhrObj.setRequestHeader(
                    "Ocp-Apim-Subscription-Key", subscriptionKey);
            },

            type: "POST",

            // Request body.
            data: '{"url": ' + '"' + sourceImageUrl + '"}',
        })

        .done(function (data) {
            // Show formatted JSON on webpage.
            $("#responseTextArea").val(JSON.stringify(data, null, 2));

            // Extract and display the caption and confidence from the first caption in the description object.
            if (data.description &amp;&amp; data.description.captions) {
                var caption = data.description.captions[0];

                if (caption.text &amp;&amp; caption.confidence &gt;= 0.5) {
                    const imgDescription = caption.text;

                    // ⬆ Upload to WordPress.
                    wp.media()
                        // Specify a path to the file you want to upload, or a Buffer
                        .file(sourceImageUrl)
                        .create({
                            title: imgDescription,
                            alt_text: imgDescription,
                            caption: imgDescription,
                            description: imgDescription
                        })
                        .then(function (response) {
                            // Your media is now uploaded: let's associate it with a post
                            var newImageId = response.id;
                            return wp.media().id(newImageId).update({
                                post: associatedPostId
                            });
                        })
                        .then(function (response) {
                            console.log('Media ID #' + response.id);
                            console.log('is now associated with Post ID #' + response.post);
                        });
                }
            }
        })

        .fail(function (jqXHR, textStatus, errorThrown) {
            // Display error message.
            var errorString = (errorThrown === "") ? "Error. " :
                errorThrown + " (" + jqXHR.status + "): ";
            errorString += (jqXHR.responseText === "") ? "" :
                jQuery.parseJSON(jqXHR.responseText).message;
            alert(errorString);
        });
};
</code></pre>
<p>View the code on <a href="https://gist.github.com/ahmadawais/0e3a72a255624f6e906c4da71317c202">Gist</a>.</p>
<h3 id="contentmoderationautomation">👀 Content Moderation Automation</h3>
<p>One of the ideas we have is to take AI/ML from Azure to use as a <a href="https://docs.microsoft.com/en-us/azure/cognitive-services/content-moderator/overview">content moderation platform</a>, which offers a built-in human-in-the-loop + machine learning to help moderate images, text, and videos. It’s a work in progress but it’s something really interesting that you should definitely take a look at.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530850493content-moderator-block-diagram.png" alt="Content Moderator Block Diagram" width="751" height="487" class="aligncenter size-full wp-image-166889" /></p>
<h3 id="wordpressgrammarnaziintelligence">🕵 WordPress Grammar (Nazi) Intelligence</h3>
<p>Y’all have a habit of typing the same typos over and over again. I do that all the time. The coolest thing ever is when search engines like Bing and Google can spell check and proofread the search query for you.</p>
<p>Imagine if WordPress had that?! So, I got to work and ended up cooking the same functionality in the WordPress admin area for when you type a typo in your post title (or more than one typos for all I care!).</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2018/07/1530851043ezgif-1-ae80a0249a.gif" alt="WordPress AI Auto title correction proof reading and spell check suggestions" width="500" height="342" class="aligncenter size-full wp-image-166891" /></p>
<p><em>I was so excited that I couldn’t contain myself, so there’s me in the left bottom corner. All happy and surprised!</em> <em>🙌👐👏👊💪🎶☝😌🎧</em></p>
<h2 id="itsyourturnnow">It’s Your Turn Now!</h2>
<p>I really hope that you enjoyed this potential integration between all these modern JavaScript frameworks, AI/ML products, and serverless functions.</p>
<p>This project is a lot of fun. I think if you give this tech-stack a shot you can have this crazy amount of fun as well. So, I&#8217;m leaving it up to you to try <a href="https://www.mongodb.com/cloud/atlas?utm_medium=sp-synd&#038;utm_source=sitepoint&#038;utm_content=serverless-functions&#038;jmp=sp-ref">MongoDB Atlas</a>, in the context of WordPress — and maybe attach all that to a bunch of serverless functions.</p>
      <div class="Article_authorBio l-mv4 t-bg-white m-border l-pa3">
        <div class="l-d-f l-pt3">
          <a class="l-s5 l-pa0 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/aawais/">
            <img src="https://d1nlfd9mjn1pae.cloudfront.net/wp-content/uploads/2015/12/1449760917Ahmad-Awais-96x96.png" width="96" height="96" alt="Ahmad Awais" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/aawais/">
                Ahmad Awais              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/mrahmadawais"><i class="fab fa-twitter"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.facebook.com/ahmadawais"><i class="fab fa-facebook-f"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://www.linkedin.com/in/mrahmadawais"><i class="fab fa-linkedin-in"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://github.com/ahmadawais"><i class="fab fa-github"></i></a><a class="f-c-grey-500 l-mh1" target="_blank" href="https://dribbble.com/mrahmadawais"><i class="fab fa-dribble"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Ahmad Awais is a <a href="https://ahmadawais.com/about/">Full Stack WordPress Developer</a>, WP Core Contributor, Front-end Fanatic and a Designer by night. He loves to read and write about WordPress. Apart from that, he creates optimized but advanced workflows to produce cool pieces of <a href="https://github.com/ahmadawais">Open Source software</a>.</div>
      </div>
      
      </div>
    </div>
        </div>
            </div>
              </div>

      <div class="u-accordion-end"></div>
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">

          <div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-649"><span data-sumome-listbuilder-embed-id="6cbb401075afaa88f82a6ddc686573be3368d07928cf833fe1a56254d6ff9849"></span><script>ga('SitePointPlugin:observeImpressions', 'maestro-649')</script></div>
                    <div id="commentsSection" class="l-pa3 t-bg-white">
                <div id="sp_comments_signin">
      <div class="f-larger f-bold l-mb3">Login or Create Account to Comment</div>
      <a href="/premium/sign-in?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fbuild-custom-dashboards-with-mongodb-azure-serverless-functions%2F%23commentsSection" class="Button u-grey u-outline">Login</a>
      <a href="/premium/sign-up?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fbuild-custom-dashboards-with-mongodb-azure-serverless-functions%2F%23commentsSection" class="Button l-ml3">Create Account</a>
    </div>
        <!-- Popular in the Community section  -->
    <!-- <div data-spotim-module="recirculation" data-spot-id=""></div>
    <script src="https://recirculation.spot.im/spot/"></script> -->
    <script async
      src="https://launcher.spot.im/spot/sp_hAStREiw"
      data-spotim-module="spotim-launcher"
      data-spot-id="sp_hAStREiw"
      data-post-id="166865"
      data-disqus-url="https://www.sitepoint.com/build-custom-dashboards-with-mongodb-azure-serverless-functions/"
      data-disqus-identifier="166865 https://www.sitepoint.com/?p=166865"></script>
    <script>
      if (window.SPOTIM && window.SPOTIM.startSSO) {
        startSSO();
      } else {
        document.addEventListener("spot-im-api-ready", startSSO, false);
      }

      function startSSO() {
        var callback = function(codeA, completeSSOCallback) {
          $.ajax({
            method: "GET",
            url: "/premium/api/v1/users/spot_im_sso/" + codeA,
            success : function(response){
              completeSSOCallback(response.code_b);
            }
        });
        };

        window.SPOTIM.startSSO(callback).then(function(result) {
          var button = document.getElementById("sp_comments_signin");
          button && button.remove();
        })
        .catch(function(reason){
          console.log(reason)
        });
      }
    </script>
                <a id="comments"></a>
                      </div>
        </div>
      </div>

    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          javascript: 'javascript',
        });
      });
    </script>
      </div>
    </div>
        <footer role="contentinfo">
  <div class="l-w-100 l-d-f Footer-bg">
    <div class="l-d-f l-fw-w l-mh-auto">
      <div class="l-d-f l-fw-w l-mt4 l-w-100 l-pa3 l-w-3col--4col l-jc-sb l-jc-sa--4col">
        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Stuff We Do</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/premium/">Premium</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/versioning/">Versioning</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/community/">Forums</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/html-css/css/">References</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">About</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/about-us/">Our Story</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/press/">Press Room</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Contact</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/contact-us/">Contact Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="https://sitepoint.zendesk.com/hc/en-us">FAQ</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/write-for-us/">Write for Us</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/advertise/">Advertise</a>
          </li>
        </ul>

        <ul>
          <li class="t-ls-n">
            <div class="f-c-white f-large f-bold l-mb2">Legals</div>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/legals/">Terms of Use</a>
          </li>
          <li class="l-ml3 f-c-grey-300 l-mb2">
            <a class="Footer-link f-small" href="/privacy-policy/">Privacy Policy</a>
          </li>
        </ul>
      </div>
      <div class="l-d-n l-d-b--4col l-as-cen Footer-hr" >
      </div>
      <div class="l-mt4 l-pa3 l-w-1col--4col">
        <ul class="t-ls-n l-d-f l-fw-w l-d-b--3col">
          <li>
            <div class="f-c-white f-large f-bold l-mb2 l-mr3">Connect</div>
          </li>
          <li class="f-center">
            <a class="f-c-grey-300" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-facebook-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
              <i class="fab fa-twitter-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="/versioning/">
              <i class="fas fa-envelope-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://www.sitepoint.com/feed/">
              <i class="fas fa-rss-square l-i4"></i>
            </a>
            <a class="l-pl3 f-c-grey-300" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
              <i class="fab fa-google-plus-square l-i4"></i>
            </a>
          </li>
          <p class="f-c-grey-300 l-mh-auto l-ml3--2col l-ml0--3col l-mv3--4col f-small f-center">
            &copy; 2000 &ndash; 2018 SitePoint Pty. Ltd.
          </p>
        </ul>
      </div>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <sp-cookie-warning server-rendered="1"></sp-cookie-warning>
    <script async>(function(s,u,m,o,j,v){j=u.createElement(m);v=u.getElementsByTagName(m)[0];j.async=1;j.src=o;j.dataset.sumoSiteId='64b8e500e3524000ecfa2000d01e2100033e83009398f000ab804c005e0e4300';j.dataset.sumoPlatform='wordpress';v.parentNode.insertBefore(j,v)})(window,document,'script','//load.sumo.com/');</script>

<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript'>
/* <![CDATA[ */
var ratingsL10n = {"plugin_url":"https:\/\/www.sitepoint.com\/wp-content\/plugins\/wp-postratings","ajax_url":"https:\/\/www.sitepoint.com\/wp-admin\/admin-ajax.php","text_wait":"Please rate only 1 item at a time.","image":"thumbs","image_ext":"gif","max":"2","show_loading":"1","show_fading":"1","custom":"1"};
var ratings_1_mouseover_image=new Image();ratings_1_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_1_over.gif";var ratings_2_mouseover_image=new Image();ratings_2_mouseover_image.src="https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/images/thumbs/rating_2_over.gif";;
/* ]]> */
</script>
<script type='text/javascript' src='https://dab1nmslvvntp.cloudfront.net/wp-content/plugins/wp-postratings/js/postratings-js.js?ver=1.85'></script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-e986621f708fcb315b991a9b637cabf8.js?ver=4.9.6'></script>
<script type="text/javascript" src="/dist/js/compiled.f64da9cafad403fa8c58.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>

  </body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 58/77 objects using memcached
Page Caching using memcached 
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

Served from: www.sitepoint.com @ 2018-07-06 11:38:12 by W3 Total Cache
-->