To love Opera, or not to love Opera

That is still considered to be a current version of Opera as they still haven’t finished porting all of the option it has to their new version.

I don’t plan on switching until the new version adds the rewind button that I use more than anything else in the browser.

I just tried it with Firefox+NoScript, no problems here.

I just log in directly.


[quote=felgall]… as they still haven’t finished porting all the option it has to their new version.

I don’t plan on switching until the new version adds the reqind button that I use more than anything else in the browser[/quote]

I’m sticking with this Opera until the Blink version
a) fixes the crappy sh*tty horrid mean cruel in-page skip-link bug that forces the Thousand Tabs of Death to get through any page
b) adds back in some keyboarding awesomness like spatial navigation, navigate by headings, etc (I may never know when those get added back in actually unless they announce it loudly)
c) built-in IRC is super handy for basically having html wg open whenever I open a browser…

Re-posting @Stomme_poes code example:

indent preformatted text by 4 spacesIf anyone wants it: button:after {
  content: "\0a" attr(title);
} button.create:after {
  content: "";
} button {
  display: inline-block;
  vertical-align: top;
  padding-right: 7px;
} .show-replies {
  display: none !important;

.post-cloak .reply-to-tab {
  right: auto !important;
  left: 4.5em !important;
  top: 2em !important;

.topic-body .contents .cooked {
  margin-top: 1.8em !important;

(no, I’m not fixing this, the code button should have Just Worked. Learn to love it.)

Screenshots of the steps I took (which fail to reproduce it) (Sorry @Stomme_poes, I’m trying)

Initial Reply:

Pasting of Stomme_poes post content:

Highlighting the code portion:

Clicking the Code button (also works with CTRL + k)

Indentation was applied:

Final result up above this post…

@Stomme_poes, if your process differs, please let me know. I’m trying hard to recreate these issues so I can report them properly and get them fixed.

Edit: Nevermind! I can recreate it now, definitely seems like a bug tied to Opera 12. I’ll keep playing around with it to see if I can discover why. The bad news is, I don’t know if we’ll be able to get Discourse to work on this. They only support the “latest” browsers, and although I can claim, Opera 12 is the latest Linux version of said browser… I’m not sure that will mean much :frowning:

I can still copy the text the old fashioned way on my machine.


We’ve been asking that of the Discourse people too. Presumably the results are particularly odd because we’ve just migrated so much from a foreign source, as you say, but still …

If that’s the case, then I’m willing to live with it, since I can’t see myself upgrading my Opera (I could do it manually, I’m not stuck with my OS .debs) until Blink fixes some major things plus bring back some of the Opera stuff I still use (the devs haven’t said what, if anything, they’ll bring back… the idea is that there’s this small, picky Opera power-user userbase that may not be worth catering to now that Opera uses a "major"engine).

Opera 12 identifies itself as the latest complete version - Opera occasionally release point number upgrades for it.

All of the subsequently numbered ones are feature incomplete versions and so are not considered an upgrade for Opera 12. Effectively they are two completely different browsers that just happen to share a name.

The browser button I use the most is the rewind button - something that Opera 12 (and earlier) have but which no other browser has yet introduced). I for one will not be switching from Opera 12 to a different browser until that browser implements the rewind button. If web sites don’t support Opera 12 then I will switch to alternative sites that do.

It is hard to make an argument for Opera when there are 10 other releases from Opera 12 for Windows. :frowning:

They may not be complete, but they are more than functional and you can actually have Opera 24 and Opera 12 installed side-by-side. Linux definitely doesn’t have that option, you just have to use a different browser.

In fact, Discourse doesn’t even mention Opera support :frowning:

My point was, it would be an uphill battle to try and get it fixed by the core team, and I still believe that to be the case.

With the edit problems I have already found I am getting close to deciding to abandon this forum and start looking for alternatives where the edit option on posts actually works.

Okay, I’ve posted a general question to get their stance on Opera, feel free to also monitor it.

Whenever I go back to edit a post I made and click with the mouse where I want to make the change the edit box scrolls back to the top and selects the point corresponding to where I clicked within the edit box rather than the spot within the text. If I then scroll back down to where I am trying to edit and click again with the mouse then the same thing happens again.

The only way to get to the spot in the post that I want to edit is using the arrow keys on the keyboard.

1 Like

In short, it isn’t edit problems, but lack of support for Opera 12 (which is the latest version of Opera available for Linux, and the latest “complete” version of Opera for Windows/Mac)

Ah right. Has this been discussed at Meta? Opera isn’t listed in their mimimum browser specs.

Lots of sites don’t explicitly support Opera 12 but work just fine with that browser.Unfortunately it appears that Discourse isn’t one of them.

If it comes to choosing between having the rewind button available (which I use all the time) and being able to use particular web sites then the rewind button will win. Only when a decent browser other than Opera 12 offer the rewind button will I consider switching browsers (and while Firefox has a rewind button extension there are other reasons why I will not be switching to that browser).

I just created a topic about it today. I did a search on Meta and nothing popped up on the topic (that contained any “discussion”). (see post #178) or the below :wink:

1 Like

I’m using Opera 24 and couldn’t be happier, ditched FireFox and not even looked at Chrome.

And Opera 24 implements rewind:

Click on the back button and hold it.

That’s just a regular back button listing all the past pages.

If you click and hold the rewind button in Opera 12 you get a list of past sites and not every single page.

Opera 15+ does NOT implement rewind what it implements is the standard back button functionality you can get in just about any browser created in the last 10 or 15 years.

This is Opera-specific?? Dayum. Yes, this makes it insanely difficult to highlight code as highlighting with a mouse is easiest when starting from the bottom up.

I can often get around this by increasing the edit box size to nearly full-page; but then, I often have really long posts, where that doesn’t work.

I don’t have anything in my interface that looks like a rewind button… I don’t recall removing it either.

I just use alt-left arrow to go back, but so far as I know, that’s just back-button functionality. Which the evil and stupid Unity interface constantly interferes with… next “upgrade” I’m either switching to Debian Testing or Gnome-Ubuntu. Unity sucks for non-tablets.

The only browser I explicitly remove stuff from is Firefox, where I remove bookmark bars and the separate search input (which I think they removed at some point anyway).

Opera 15+ has the Blink bug, inherited from Webkit, inherited from KHTML, where in-page links do not work. This is the #1 reason I won’t upgrade my Opera. This isn’t even a functionality request, it’s a terrible, terrible bug that’s ages old and there seems to be little animo to fix it.