Opera, what are the problems?

Okay, so the Discourse team is okay with us solving the Opera issues. So let’s discuss the problems so I have a list to work through!

  • JavaScript Error on page load.
  • Shortcuts do not work in Composer window (PR Submitted)
  • Buttons do not work on highlighted text in Composer window (hold SHIFT and these work)
  • mouse clicking in the edit box when correcting a post keeps jumping the content back to the top.
  • Bad CSRF on Login

What else is there? @Stomme_poes @felgall

mouse clicking in the edit box when correcting a post keeps jumping the content back to the top.

1 Like

Keyboard shortcuts in the composer window are resolved* (I need to test against Opera 24, but I’m fairly certain, it will continue to work).

* In my development environment

“Bad CSRF” when logging in. Hitting the back button shows the login popup still on the page, showing the login name, password field empty. Usually, refreshing at this point shows me logged in.

A few times however, hitting the back button (usually if I’ve been logged in earlier that day) doesn’t show the popup and the page is pre-login. When this happens, several attempts have to be made.

Now I seem to recall Opera having some issues with Twitter and some other sites at some point, not loading their CSS, and it had to do with Opera being picky with certificates or ssl or something. All the Opera help threads kept saying “well the sites are not sending things out correctly” but all the other browsers were apparently just being very lax, and fultilling Postal’s Law (not sure I agree with that, but this meant other browsers “worked” and Opera didn’t).

I don’t get this in Firefox or Chromium.

1 Like

Pull Request sent for Keyboard shortcuts in composer window:

Also, I discovered if you use your mouse to highlight text (or your keyboard) and then go to click a button to apply the formatting desired, you must hold the SHIFT key when clicking the button for the formatting to apply.

In short, this happens because Opera removes the focus/selection on the textarea when you click the button, so there is no text selected anymore. I’ve yet to find a solution to this problem beyond using an onblur event to log the selected start/end positions.

I worked out my own temporary solution to this problem.

What I do now before editing is to drag the top of the edit box up until the scrollbar disappears - then it can’t scroll back to the top when I click because it already is at the top.

And that works so long as your content never exceeds the height of your browser (really long posts). I still haven’t found anything that indicates why this is happening. I know it is Discourse related, but I haven’t uncovered how or why :frowning:

I haven’t had a reply that big that I have needed to edit yet but there’s always the hide preview link to double the space and use the entire browser window and if that were still too small I could temporarily double it again by switching my browser temporarily to full screen mode.