Php Framework Command Line Problem

I’ve had this problem with nearly all the frameworks I’ve tried: executing a command on the command line to start a new web application with a specific framework.

Can someone please tell me what I’m doing wrong? I’d greatly appreciate it.

Edit: For the record, I do have WAMP installed and I have tried this command in different directories (by using “cd …/” and so on).

You need to add the path to the CLI to the Windows “path” environment variable, or include the full path to the PHP CLI in cmd prompt.

  1. Right-click “My Computer”.
  2. Click “Properties” then the “Advanced” tab.
  3. Click the Environment variables button.
  4. Add the full path to the CLI in the “path” system variable. Be sure to preclude it with a semi-colon if one does not already exist.

Edit: Its the Path var, not CLASSPATH. Sorry

Edit: Read your post wrong, I’ll try this out in a moment.

Can you specify on what this is?

full path to the PHP CLI in cmd prompt.

The symfony folder is currently in my webroot (/www), so I’d assume that’s where the PHP CLI is…?

The php path is not related to Symfony, or rather, Symfony assumes that that side of things is already working.

What are you using for your local server? WAMP, or XAMPP or a manual installation of something else?

I am using WAMP

Then the path you’re most likely after is C:\wamp\bin\php

There are also instructions on installing Symfony on Windows with Wamp

I investigated the link you gave me… and again, “pear” is not an acceptable command, my CLI states.

Does anyone know why no commands are executing on my command prompt? No other guides seem to have this problem/detail this phenomenon.

That part of the tutorial says that it “is the continuation of How to install PEAR on windows with WAMP”

You know what that means? Follow it from the beginning of the instructions on How to install PEAR on Windows with WAMP

Now following this new guide, I do have the most up to date WAMP and now it seems I don’t have the “php” folder?

I’m currently on step 3.

Look in the ‘Bin’ directory.

Found it, thank you. I’ll proceed using the tutorial for now.

Just completed the third step… and got this error:

I’m unsure if this is me doing the problem, or the framework itself…

There appears to be a couple of potential solutions at http://pear.php.net/manual/en/installation.getting.php

Meh, I tried a few and no success. For now, it’s on to CakePHP!