PHP Symfony Web Application Hosting

Hi guys,

i m a newbie for symfony framework,

i have done the Jobeet Job Demo Project as given in the symfony guide book.

i used WAMP Server 2.0i and symfony Framework 1.4, Doctrine ORM

now, i want to host this demo project in a domain…

i have a free domain from the 0fees.net,

my domain address is http://lathifmca.0fees.net/

my domain’s PHP INFO is http://lathifmca.0fees.net/phpinfo.php

i already created the database using cPanel and upload the Project using FTP software…

but the project not working in my domain…

pls help me to run the project…

Its better to list the steps to follow for hosting the symfony web application…

pls help me guys…

Thanks in Advance Guys…

Have you checked the error logs?

error logs ?

it simply list out the files, that i uploaded by FTP…

check this link: http://lathifmca.0fees.net/

its a free web hosting… i dont have access to SSH or Command-line…

please help about this hosting problem

You don’t seem to have an index.php or .htaccess uploaded?

no Ruben K.

I uploaded everything…

pls check that link

http://lathifmca.0fess.net

I have, and it doesn’t list index.php

Oops… sorry… my website link is, http://lathifmca.0fees.net/

I upload everything, from my symfony project folder…

/
/apps
/cache
/config
/log/


Pls tell me, how to configure the web server…

Its better to list out the steps for hosting the symfony web application…

Dear Guys,

I m a newbie to symfony,

I have already developed the Symfony Demo Jobeet Job Project, this is really cool…

I have developed this project in NetBeans 6.8 IDE,
symfony framework 1.4.1 and
Doctrine ORM.

Now I tried to upload this project on my free domain…

http://lathifmca.ofees.net/

This is the free hosting domain, I upload the files using FTP,

and I follow the steps as given in

http://trac.symfony-project.org/wiki/InstallingSymfonyOnSharedHostNoSsh

Please check my PHP INFO file and symfony prerequisite Configuration File:

http://lathifmca.0fees.net/phpinfo.php
http://lathifmca.0fees.net/check_configuration.php

Guys, when i try to run the index.php, it shows only the blank page…

And i also create the Database and the neccessary tables and its data too…

now my problem is, it shows only the blank page, when try to run the index.php, frontend_dev.php or backend_dev.php.

Guys, Please help me as soon as possible, This is the demo projec, after this successful launch, we will do the real time projects in symfony… so please help me about this problem…

And guys, pls give the .htaccess file data also,

what i need to change this .htaccess ?

my .htaccess data is as follows…


Options +FollowSymLinks +ExecCGI

<IfModule mod_rewrite.c>
  RewriteEngine On

  # uncomment the following line, if you are having trouble
  # getting no_script_name to work
  #RewriteBase /

  # we skip all files with .something
  #RewriteCond %{REQUEST_URI} \\..+$
  #RewriteCond %{REQUEST_URI} !\\.html$
  #RewriteRule .* - [L]

  # we check if the .html version is here (caching)
  RewriteRule ^$ index.html [QSA]
  RewriteRule ^([^.]+)$ $1.html [QSA]
  RewriteCond %{REQUEST_FILENAME} !-f

  # no, so we redirect to our front web controller
  RewriteRule ^(.*)$ index.php [QSA,L]
</IfModule>


and this is my index.php, I altered as given in that guide,

http://trac.symfony-project.org/wiki/InstallingSymfonyOnSharedHostNoSsh


<?php
$vhost_root_dir = realpath(dirname(__FILE__).'/..');
$project_dir = $vhost_root_dir.'/projects/DCPLD';
//define('SF_ROOT_DIR',    realpath(dirname(__FILE__).'/..'));
define('SF_ROOT_DIR',    $project_dir);
define('SF_APP',         'frontend');
define('SF_ENVIRONMENT', 'prod'); // for myapp_dev.php 'prod' should be 'dev'
define('SF_DEBUG',       false);  // for myapp_dev.php this should be true

// include path
set_include_path(
  $vhost_root_dir.'/pear_libs'.PATH_SEPARATOR.
  get_include_path()
);

unset($vhost_root_dir, $project_dir);

require_once(SF_ROOT_DIR.DIRECTORY_SEPARATOR.'config'.DIRECTORY_SEPARATOR.'ProjectConfiguration.class.php');
sfContext::getInstance()->getController()->dispatch();
?>

Please guide me Guys… :frowning:

What are the steps i need to follow, and what changes i need to do in .htaccess ?

this is my site link : http://lathifmca.0fees.net/

Thanks in Advance Guys… :smiley:

That link returns these HTTP headers

HTTP/1.1 500 Internal Server Error
Date: Sat, 03 Apr 2010 07:38:44 GMT
Server: Apache
Cache-Control: no-store, must-revalidate, max-age=0, proxy-revalidate, no-transform
Expires: Sat, 03 Apr 2010 07:38:44 GMT
Vary: Accept-Encoding,User-Agent
Content-Encoding: gzip
Pragma: no-cache
Content-Length: 20
Content-Type: text/html
X-Cache: MISS from demil1.byetcluster.com
Via: 1.0 demil1.byetcluster.com:80 (Lusca/LUSCA_HEAD)
Connection: close

and I’m guessing it’s your poorly written htaccess file to blame. No offense meant, even a very simple mistake (not to mention the regex) can throw everything to blazes. They look simple enough, but oh boy can they bite!

You could try posting a thread in the Apache forum, but do try reading through dklynn’s tutorials and examples first

If you still have it on your server you are seeing the Symfony White Screen of death. If you could temporarily turn your error reporting on to ALL in php.ini that would help. But judging from you saying you uploaded only these folders:

/
/apps
/cache
/config
/log/

Your error is you didn’t include the Symfony Library, and Symfony requires a little more tweaking then just plopping it into the hosts folder.