<!DOCTYPE html>
<!--[if IE 8]><html class="sp🚧  no-js lt-ie9" lang="en" ><![endif]-->
<!--[if gt IE 8]><!--><html class="sp🚧  no-js" lang="en" ><!--<![endif]-->
  <head>
    <link rel="manifest" href="/manifest.json">
    <link href="//dab1nmslvvntp.cloudfront.net" ref="dns-prefetch">
    <link href="//d2sis3lil8ndrq.cloudfront.net" ref="dns-prefetch">
    <link href="//sitepoint.com" ref="dns-prefetch">
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
        <meta property="og:image" content="https://www.sitepoint.com/wp-content/themes/sitepoint/assets/images/icon.javascript.png">
        
    <link rel="shortcut icon" href="/favicon.ico" />

    <link rel="apple-touch-icon-precomposed" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-57x57-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="72x72" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-72x72-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="114x114" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-114x114-precomposed.png" />
    <link rel="apple-touch-icon-precomposed" sizes="144x144" href="/wp-content/themes/sitepoint/assets/images/apple-touch-icon-144x144-precomposed.png" />

    <!-- Sitepoint's new font from Google Fonts -->
    <link href='https://fonts.googleapis.com/css?family=Roboto:900,900italic,700,700italic,400,400italic,300,300italic' rel='stylesheet' type='text/css'>

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.3.0/css/font-awesome.min.css">

    <link rel="alternate" type="application/rss+xml" title="RSS Feed for SitePoint.com" href="https://www.sitepoint.com/feed/" />

        <link href="https://plus.google.com/+sitepoint" rel="publisher" />
        <meta property="twitter:account_id" content="15743570" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge">

    
<script type="text/javascript">
  window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;

  ga('create', 'UA-30131-1', '.sitepoint.com');

  ga('set', 'dimension2', 'javascript');

  ga('require', 'eventTracker', {
    attributePrefix: "data-ga-",
    events: ["click", "submit"]
  });
  ga('require', 'impressionTracker', {
    attributePrefix: "data-ga-",
    elements: [],
    fieldsObj: {
      eventCategory: "maestro",
    }
  });
  ga('require', 'outboundLinkTracker');
  ga('require', 'SitePointPlugin');

  ga('send', 'pageview');

  // Cross Domain Tracking to Learnable
  ga('require', 'linker');
  // command, domains, useAnchor, enableForms
  ga('linker:autoLink', ['learnable.com'], false, true);

  (function() {
		var ga = window[window['GoogleAnalyticsObject'] || 'ga'];

		var providePlugin = function(pluginName, pluginConstructor) {
			if (ga) {
				ga('provide', pluginName, pluginConstructor);
			}
		};

		var SitePointPlugin = function(tracker) {
			this.impressionObservables = [];
			this.hasIntersectionObserverLoaded = false;
			this.tracker = tracker;
			var originalSendHitTask = this.tracker.get('sendHitTask');
			this.tracker.set('sendHitTask', function(model) {
				originalSendHitTask(model);

        
				if (model.get('eventCategory') !== 'Demandbase') return;
				window.SP_OnDemandBaseReady && window.SP_OnDemandBaseReady(model);
			});
		};

    SitePointPlugin.prototype.observeImpressions = function(el) {
      if (el) this.impressionObservables = this.impressionObservables.concat(el);

      if (this.hasIntersectionObserverLoaded && this.impressionObservables.length) {
		    var ga = window[window['GoogleAnalyticsObject'] || 'ga'];
        ga('impressionTracker:observeElements', this.impressionObservables);
        this.impressionObservables = [];
      }
    }

    SitePointPlugin.prototype.intersectionObserverLoaded = function() {
      this.hasIntersectionObserverLoaded = true;
      this.observeImpressions();
    }

		providePlugin('SitePointPlugin', SitePointPlugin);
	})();
</script>
<script async src='https://www.google-analytics.com/analytics.js'></script>
<meta name="google-site-verification" content="hcQq0cWX73AYby8aMMzNHx8bZrTDI75GWeljGdPmNf8"  />
<meta name="google-site-verification" content="I0jyQlTvZaveab8RtDOjUxSPZXbdSgFrcKdAwaCCfvA"  />
<script 
  src="https://cdn.polyfill.io/v2/polyfill.min.js?features=IntersectionObserver"
  async
  defer
  onload="ga('SitePointPlugin:intersectionObserverLoaded')"
></script>
    <script class="SP_stripMobile" type="text/javascript">
      var googletag = googletag || {};
      googletag.cmd = googletag.cmd || [];
      (function() {
      var gads = document.createElement('script');
      gads.async = true;
      gads.type = 'text/javascript';
      var useSSL = 'https:' == document.location.protocol;
      gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
      var node = document.getElementsByTagName('script')[0];
      node.parentNode.insertBefore(gads, node);
      })();
    </script>
    <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>
    <script>
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "65189cfb-a985-4bd7-a41b-c2666081e811",
      safari_web_id: 'web.onesignal.auto.49d2239d-a04e-422a-89e0-14dbda97fb4d',
      autoRegister: true,
      welcomeNotification: {
        "title": "So you're learning web dev?",
        "message": "Here's 10 FREE ebooks, just for you.",
        "url": "https://www.sitepoint.com/premium/l/free-ebooks-osn",
      },
    }]);
  </script>
    <!-- BuySellAds PRO Code -->
<script class="SP_stripMobile" type="text/javascript">(function(){var bsa = document.createElement('script');bsa.type = 'text/javascript';bsa.async = true;bsa.src = '//cdn.buysellads.com/ac/pro.js';document.getElementsByTagName('head')[0].appendChild(bsa);})();</script>
<!-- End BuySellAds PRO Ad Code —>
    
<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<title>A Practical Guide to Planning a MEAN Stack Application &mdash; SitePoint</title>
<meta name="description" content="From architecture options to wrapping everything in an Express project, Simon Holmes looks at what you need to consider when planning a MEAN stack app."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.sitepoint.com/planning-mean-stack-application/" />
<link rel="publisher" href="https://plus.google.com/+sitepoint/"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="A Practical Guide to Planning a MEAN Stack Application &mdash; SitePoint" />
<meta property="og:description" content="From architecture options to wrapping everything in an Express project, Simon Holmes looks at what you need to consider when planning a MEAN stack app." />
<meta property="og:url" content="https://www.sitepoint.com/planning-mean-stack-application/" />
<meta property="og:site_name" content="SitePoint" />
<meta property="article:publisher" content="https://www.facebook.com/sitepoint" />
<meta property="article:tag" content="Express" />
<meta property="article:tag" content="jamesh" />
<meta property="article:tag" content="mean stack" />
<meta property="article:tag" content="mongodb" />
<meta property="article:section" content="AngularJS" />
<meta property="article:published_time" content="2017-07-17T13:00:03-07:00" />
<meta property="article:modified_time" content="2017-07-17T10:34:39-07:00" />
<meta property="og:updated_time" content="2017-07-17T10:34:39-07:00" />
<meta property="fb:admins" content="121300382" />
<meta property="og:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499972409planning-a-mean-app.jpg" />
<meta property="og:image:width" content="1900" />
<meta property="og:image:height" content="1265" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="From architecture options to wrapping everything in an Express project, Simon Holmes looks at what you need to consider when planning a MEAN stack app." />
<meta name="twitter:title" content="A Practical Guide to Planning a MEAN Stack Application &mdash; SitePoint" />
<meta name="twitter:site" content="@sitepointdotcom" />
<meta name="twitter:image" content="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499972409planning-a-mean-app.jpg" />
<meta name="twitter:creator" content="@simonholmes" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="SitePoint &raquo; A Practical Guide to Planning a MEAN Stack Application Comments Feed" href="https://www.sitepoint.com/planning-mean-stack-application/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sitepoint.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sitepoint-styles-css'  href='//www.sitepoint.com/wp-content/themes/sitepoint/assets/stylesheets/styles-f81a1ab28d2267745390d54cd4f4885c.css?ver=4.7.3' type='text/css' media='all' />
<style id='sitepoint-styles-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-head-42a85c5219e5c4b733340d9ea50d7a36.js?ver=4.7.3'></script>
<link rel='https://api.w.org/' href='https://www.sitepoint.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sitepoint.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sitepoint.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<link rel='shortlink' href='https://www.sitepoint.com/?p=157238' />
<link rel="alternate" type="application/json+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fplanning-mean-stack-application%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sitepoint.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sitepoint.com%2Fplanning-mean-stack-application%2F&#038;format=xml" />
<!-- BEGIN wp-parsely Plugin Version 1.10.2 -->
<meta name='wp-parsely_version' id='wp-parsely_version' content='1.10.2' />
   <script type="application/ld+json">
   {"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/www.sitepoint.com\/planning-mean-stack-application\/"},"headline":"A Practical Guide to Planning a MEAN Stack Application","url":"http:\/\/www.sitepoint.com\/planning-mean-stack-application\/","thumbnailUrl":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/07\/1499972409planning-a-mean-app-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/www.sitepoint.com\/wp-content\/uploads\/2017\/07\/1499972409planning-a-mean-app-150x150.jpg"},"dateCreated":"2017-07-17T20:00:03Z","datePublished":"2017-07-17T20:00:03Z","dateModified":"2004-02-02T01:34:47Z","articleSection":"JavaScript","author":[{"@type":"Person","name":"Simon Holmes"}],"creator":["Simon Holmes"],"publisher":{"@type":"Organization","name":"SitePoint"},"keywords":["express","jamesh","mean stack","mongodb"]}   </script>
    <!-- END wp-parsely Plugin Version 1.10.2 -->
    <script type="text/javascript">
      googletag.cmd.push(function() {
        		googletag.defineSlot("/7448792/SP2013_Articles_300x250_1", [300,250], "div-gpt-ad-1392428092543-0").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[300,250]]],[[1024, 0], [[300,250]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP2013_Articles_728x90_1", [728,90], "div-gpt-ad-article-header").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[728,90]]],[[1024, 0], [[728,90]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP2013_Articles_300x600_1", [[300, 600], [300, 250], [160, 600]], "div-gpt-ad-1392428092543-4").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[[300, 600], [300, 250], [160, 600]]]],[[1024, 0], [[[300, 600], [300, 250], [160, 600]]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_1", [200,125], "div-gpt-ad-1436815711585-0").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_2", [200,125], "div-gpt-ad-1436815711585-1").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_3", [200,125], "div-gpt-ad-1436815711585-2").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.defineSlot("/7448792/SP_Articles_200x125_4", [200,125], "div-gpt-ad-1436815711585-3").defineSizeMapping([[[0, 0], [[]]],[[768, 0], [[200,125]]],[[1024, 0], [[200,125]]]]).addService(googletag.pubads());
		googletag.pubads().setTargeting("channel", "javascript");
		googletag.pubads().setTargeting("post_id", "157238");
		googletag.pubads().setTargeting("AOL",["true", "false"]);
		googletag.pubads().setTargeting("OpenX",["true", "false"]);
		googletag.pubads().setTargeting("Tribal",["true", "false"]);
		googletag.pubads().enableSingleRequest();
        googletag.pubads().setTargeting("tags", ["Express","jamesh","mean stack","mongodb"]);
        googletag.pubads().collapseEmptyDivs();
        googletag.enableServices();
      });
      SP_GPT_Slots = [];
    </script>
    <!--[if lt IE 9]>
      <script src="/wp-content/themes/sitepoint/assets/javascripts/vendor/respond.custom.min.js"></script>
    <![endif]-->
    <style>
  .t-color { color: #F6B33C }
  a.t-color:hover,
  button.t-color:hover { color: #FFD78F }

  .t-bg { background-color: #F6B33C }
  a.t-bg:hover,
  button.t-bg:hover { background-color: #FFD78F}

  .t-border { border-color: #F6B33C }
  a.t-border:hover,
  button.t-border:hover { border-color: #FFD78F }

  .t-bg-dark { background-color: #FFD78F }

  .t-list li:before { background-color: #F6B33C; }

  .t-p-pop-bg { background-color: #1a9b9e }
  a.t-p-pop-bg:hover,
  button.t-p-pop-bg:hover { background-color: #018285}
</style>
  </head>
  <body>
    <header class="main-header" role="banner">
      <nav class=" NavBar l-p-fix l-p-sta--3col l-d-f l-w-100 t-bg-grey-500">
        <div class="l-d-f l-w-100 l-w-3col--3col l-w-4col--4col l-jc-sb l-mh-auto l-ph2">
          <section class="l-d-f l-ai-str l-jc-sta">
            <a tabIndex="0" class="l-d-f l-ai-cen l-pa3 f-c-white t-t NavBar_item" onClick="sitepoint.SidebarNav_toggle(event)" onKeyUp="sitepoint.SidebarNav_toggle(event)">
              <i class="f-medium fa fa-navicon"></i>
            </a>
            
<div id="SidebarNav" class="SidebarNav" onKeyUp="sitepoint.SidebarNav_toggle(event)">
  <header class="m-border-b SidebarNav_header">
    <a href="#" onClick="sitepoint.SidebarNav_toggle(event)" class="l-pt0 f-light">
      <span class="SidebarNav_icon">&times;</span>
    </a>
    <div class="l-d-n l-d-b--3col SidebarNav_search">
      <form method="get" action="https://www.sitepoint.com/">
        <input aria-label="search" autocomplete="off" id="sidebar-search-box" name="s" placeholder="Search" type="text">
        <button><i class="fa fa-search"></i></button>
      </form>
    </div>
  </header>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-premium/sign-up">
            <i class="SidebarNav_icon fa fa-user u-premium/sign-up"></i>
            
            <a class="f-light" href="/premium/sign-up/?ref_source=sitepoint&ref_medium=drawer">Create Free Account</a>
          </li>      <li class="SidebarNav_link u-premium/sign-in">
            <i class="SidebarNav_icon fa fa-sign-in u-premium/sign-in"></i>
            
            <a class="f-light" href="/premium/sign-in/?ref_source=sitepoint&ref_medium=drawer">Login</a>
          </li>                </ul>
  </section>

  <section class="m-border-b SidebarNav_products">
    <ul>
      <li class="SidebarNav_link u-premium/books">
            <i class="SidebarNav_icon fa fa-book u-premium/books"></i>
            
            <a class="f-light" href="/premium/books/?ref_source=sitepoint&ref_medium=drawer">Books</a>
          </li>      <li class="SidebarNav_link u-premium/courses">
            <i class="SidebarNav_icon fa fa-play-circle u-premium/courses"></i>
            
            <a class="f-light" href="/premium/courses/?ref_source=sitepoint&ref_medium=drawer">Courses</a>
          </li>      <li class="SidebarNav_link u-premium/paths">
            <i class="SidebarNav_icon fa fa-map-marker u-premium/paths"></i>
            
            <a class="f-light" href="/premium/paths/?ref_source=sitepoint&ref_medium=drawer">Paths</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_topics">
    <ul>
      <li class="SidebarNav_link SidebarNav_channelLink u-html-css">
            <i class="SidebarNav_icon fa fa-circle u-html-css"></i>
            <a class="f-light" href="https://www.sitepoint.com/html-css/?ref_source=sitepoint&ref_medium=drawer" data-channel="html-css">HTML &amp; CSS</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-javascript">
            <i class="SidebarNav_icon fa fa-circle u-javascript"></i>
            <a class="f-light" href="https://www.sitepoint.com/javascript/?ref_source=sitepoint&ref_medium=drawer" data-channel="javascript">JavaScript</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-php">
            <i class="SidebarNav_icon fa fa-circle u-php"></i>
            <a class="f-light" href="https://www.sitepoint.com/php/?ref_source=sitepoint&ref_medium=drawer" data-channel="php">PHP</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-design-ux">
            <i class="SidebarNav_icon fa fa-circle u-design-ux"></i>
            <a class="f-light" href="https://www.sitepoint.com/design-ux/?ref_source=sitepoint&ref_medium=drawer" data-channel="design-ux">Design &amp; UX</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-web">
            <i class="SidebarNav_icon fa fa-circle u-web"></i>
            <a class="f-light" href="https://www.sitepoint.com/web/?ref_source=sitepoint&ref_medium=drawer" data-channel="web">Web</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-wordpress">
            <i class="SidebarNav_icon fa fa-circle u-wordpress"></i>
            <a class="f-light" href="https://www.sitepoint.com/wordpress/?ref_source=sitepoint&ref_medium=drawer" data-channel="wordpress">WordPress</a>
          </li>      <li class="SidebarNav_link SidebarNav_channelLink u-woorank">
            <i class="SidebarNav_icon fa fa-circle u-woorank"></i>
            <a class="f-light" href="https://www.sitepoint.com/woorank/?ref_source=sitepoint&ref_medium=drawer" data-channel="woorank">SEO By WooRank</a>
          </li>    </ul>
  </section>

  <section class="m-border-b">
    <ul>
      <li class="SidebarNav_link u-community">
            <i class="SidebarNav_icon fa fa-comment u-community"></i>
            
            <a class="f-light" href="/community/?ref_source=sitepoint&ref_medium=drawer">Community</a>
          </li>      <li class="SidebarNav_link u-newsletter">
            <i class="SidebarNav_icon fa fa-envelope u-newsletter"></i>
            
            <a class="f-light" href="/newsletter/?ref_source=sitepoint&ref_medium=drawer">Newsletters</a>
          </li>    </ul>
  </section>

  <section class="m-border-b SidebarNav_admin">
    <ul>
      <li class="SidebarNav_link u-advertise">
            
            
            <a class="f-light" href="/advertise/?ref_source=sitepoint&ref_medium=drawer">Advertise</a>
          </li>      <li class="SidebarNav_link u-contact-us">
            
            
            <a class="f-light" href="/contact-us/?ref_source=sitepoint&ref_medium=drawer">Contact Us</a>
          </li>      <zendesk />
    </ul>
  </section>

  
  <section class="SidebarNav_social">
    <ul>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="/newsletter/">
          <i class="fa fa-envelope SidebarNav_socialIcon u-newsletter"></i>
          <span class="SidebarNav_socialCount">1.2M<br />Subscribers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
          <i class="fa fa-twitter SidebarNav_socialIcon u-twitter"></i>
          <span class="SidebarNav_socialCount">136k<br />Followers</span>
        </a>
      </li>
      <li class="SidebarNav_socialLink">
        <a class="f-light" href="https://facebook.com/sitepoint" rel="noopener" target="_blank">
          <i class="fa fa-facebook SidebarNav_socialIcon u-facebook"></i>
          <span class="SidebarNav_socialCount">100k<br />Followers</span>
        </a>
      </li>
    </ul>
  </section>
</div>

<div class="SidebarNav_lightbox" onClick="sitepoint.SidebarNav_toggle(event)"></div>
            <a class="l-d-f" href="/">
              <div class="l-d-n l-d-f--3col l-as-cen">
                <svg class="sp-logo" viewBox="0 0 123 27">
  <g fill-rule="evenodd">
    <path d="M31.36,16.75 C31.56,17.07 31.82,17.31 32.14,17.50 C32.46,17.68 32.82,17.82 33.23,17.89 C33.63,17.97 34.05,18.01 34.48,18.01 C34.81,18.01 35.16,17.99 35.52,17.94 C35.89,17.89 36.22,17.81 36.53,17.68 C36.83,17.55 37.08,17.36 37.28,17.11 C37.48,16.87 37.58,16.55 37.58,16.17 C37.58,15.64 37.37,15.24 36.96,14.97 C36.55,14.69 36.03,14.47 35.41,14.31 C34.79,14.14 34.12,13.99 33.39,13.85 C32.66,13.71 31.99,13.52 31.37,13.27 C30.75,13.03 30.23,12.68 29.82,12.23 C29.41,11.78 29.20,11.16 29.20,10.36 C29.20,9.73 29.34,9.20 29.63,8.75 C29.92,8.30 30.30,7.94 30.75,7.66 C31.20,7.38 31.72,7.17 32.29,7.03 C32.86,6.90 33.42,6.83 33.99,6.83 C34.71,6.83 35.38,6.89 35.99,7.01 C36.61,7.13 37.15,7.34 37.62,7.63 C38.09,7.93 38.46,8.33 38.75,8.83 C39.03,9.34 39.19,9.96 39.24,10.72 L37.13,10.72 C37.10,10.32 36.99,9.98 36.81,9.72 C36.63,9.46 36.40,9.25 36.12,9.08 C35.84,8.92 35.53,8.81 35.19,8.74 C34.85,8.66 34.51,8.63 34.16,8.63 C33.84,8.63 33.53,8.65 33.20,8.70 C32.88,8.75 32.59,8.83 32.32,8.95 C32.06,9.07 31.84,9.23 31.68,9.43 C31.51,9.63 31.43,9.89 31.43,10.21 C31.43,10.56 31.56,10.86 31.82,11.09 C32.07,11.32 32.40,11.51 32.80,11.66 C33.19,11.82 33.64,11.95 34.13,12.05 C34.63,12.15 35.13,12.26 35.62,12.37 C36.15,12.49 36.67,12.62 37.17,12.78 C37.67,12.94 38.12,13.15 38.51,13.42 C38.90,13.68 39.21,14.01 39.45,14.41 C39.69,14.81 39.81,15.31 39.81,15.90 C39.81,16.66 39.65,17.28 39.33,17.77 C39.01,18.27 38.58,18.67 38.06,18.98 C37.54,19.28 36.96,19.49 36.30,19.61 C35.65,19.73 35.00,19.79 34.36,19.79 C33.65,19.79 32.97,19.72 32.32,19.58 C31.68,19.43 31.11,19.20 30.61,18.87 C30.12,18.54 29.72,18.11 29.42,17.57 C29.13,17.03 28.96,16.38 28.93,15.61 L31.03,15.61 C31.05,16.06 31.16,16.44 31.36,16.75" id="Fill-1"></path>
    <path d="M42.27,7.12 L44.37,7.12 L44.37,19.53 L42.27,19.53 L42.27,7.12 Z" id="Fill-2"></path>
    <path d="M53.13,7.12 L53.13,8.92 L50.57,8.92 L50.57,16.62 C50.57,16.86 50.59,17.05 50.63,17.20 C50.67,17.34 50.75,17.46 50.87,17.54 C50.99,17.62 51.15,17.67 51.35,17.69 C51.56,17.71 51.83,17.73 52.16,17.73 L53.13,17.73 L53.13,19.53 L51.51,19.53 C50.97,19.53 50.50,19.49 50.11,19.42 C49.72,19.35 49.41,19.22 49.17,19.02 C48.93,18.83 48.75,18.56 48.64,18.21 C48.52,17.86 48.46,17.39 48.46,16.81 L48.46,8.92 L46.28,8.92 L46.28,7.12 L48.46,7.12 L48.46,3.39 L50.57,3.39 L50.57,7.12 L53.13,7.12" id="Fill-3"></path>
    <path d="M64.53,18.73 C63.57,19.44 62.36,19.79 60.91,19.79 C59.89,19.79 59.00,19.63 58.25,19.31 C57.49,18.99 56.86,18.54 56.35,17.97 C55.84,17.39 55.45,16.70 55.20,15.90 C54.94,15.10 54.80,14.23 54.76,13.29 C54.76,12.34 54.91,11.48 55.21,10.69 C55.51,9.91 55.92,9.23 56.46,8.65 C57.00,8.08 57.63,7.63 58.37,7.31 C59.11,6.99 59.91,6.83 60.79,6.83 C61.93,6.83 62.87,7.05 63.63,7.51 C64.38,7.97 64.98,8.55 65.44,9.25 C65.89,9.96 66.20,10.73 66.38,11.56 C66.55,12.39 66.62,13.18 66.59,13.93 L56.99,13.93 C56.98,14.48 57.04,14.99 57.19,15.48 C57.34,15.97 57.58,16.40 57.91,16.78 C58.24,17.16 58.66,17.46 59.18,17.68 C59.69,17.90 60.29,18.01 60.98,18.01 C61.88,18.01 62.61,17.82 63.18,17.41 C63.75,17.02 64.13,16.41 64.31,15.59 L66.39,15.59 C66.11,16.98 65.49,18.03 64.53,18.73 L64.53,18.73 Z M64.02,10.76 C63.83,10.33 63.58,9.96 63.25,9.65 C62.93,9.34 62.55,9.09 62.11,8.90 C61.68,8.72 61.19,8.63 60.66,8.63 C60.12,8.63 59.62,8.72 59.19,8.90 C58.75,9.09 58.37,9.34 58.06,9.66 C57.75,9.98 57.50,10.35 57.32,10.78 C57.13,11.20 57.03,11.65 56.99,12.13 L64.36,12.13 C64.32,11.65 64.21,11.20 64.02,10.76 L64.02,10.76 Z" id="Fill-4"></path>
    <path d="M70.95,7.12 L70.95,8.80 L71.00,8.80 C71.35,8.11 71.89,7.61 72.64,7.30 C73.38,6.98 74.20,6.83 75.09,6.83 C76.09,6.83 76.95,7.00 77.68,7.36 C78.42,7.71 79.03,8.18 79.52,8.78 C80.01,9.38 80.37,10.08 80.62,10.86 C80.87,11.65 80.99,12.48 80.99,13.36 C80.99,14.24 80.87,15.07 80.63,15.85 C80.39,16.64 80.03,17.32 79.54,17.91 C79.06,18.49 78.44,18.95 77.71,19.29 C76.97,19.62 76.12,19.79 75.14,19.79 C74.83,19.79 74.48,19.76 74.09,19.70 C73.70,19.63 73.32,19.53 72.94,19.38 C72.56,19.24 72.20,19.04 71.86,18.79 C71.52,18.55 71.23,18.24 71.00,17.87 L70.95,17.87 L70.95,24.26 L68.84,24.26 L68.84,7.12 L70.95,7.12 L70.95,7.12 Z M78.53,11.52 C78.37,10.97 78.13,10.48 77.81,10.04 C77.49,9.61 77.07,9.27 76.57,9.01 C76.06,8.76 75.47,8.63 74.79,8.63 C74.08,8.63 73.48,8.76 72.98,9.04 C72.49,9.31 72.08,9.67 71.77,10.10 C71.46,10.55 71.23,11.05 71.09,11.60 C70.95,12.17 70.88,12.73 70.88,13.31 C70.88,13.92 70.95,14.51 71.10,15.07 C71.25,15.64 71.48,16.14 71.81,16.57 C72.13,17.01 72.55,17.35 73.06,17.62 C73.57,17.88 74.19,18.01 74.92,18.01 C75.65,18.01 76.25,17.88 76.74,17.61 C77.23,17.34 77.62,16.98 77.92,16.53 C78.22,16.08 78.43,15.57 78.56,14.99 C78.70,14.41 78.76,13.82 78.76,13.21 C78.76,12.64 78.68,12.07 78.53,11.52 L78.53,11.52 Z" id="Fill-5"></path>
    <path d="M83.17,10.78 C83.44,9.98 83.84,9.30 84.36,8.71 C84.89,8.13 85.55,7.67 86.33,7.33 C87.10,7.00 87.99,6.83 89.00,6.83 C90.03,6.83 90.92,7.00 91.69,7.33 C92.46,7.67 93.11,8.13 93.64,8.71 C94.17,9.30 94.56,9.98 94.83,10.78 C95.09,11.57 95.23,12.42 95.23,13.33 C95.23,14.25 95.09,15.09 94.83,15.88 C94.56,16.66 94.17,17.35 93.64,17.93 C93.11,18.52 92.46,18.97 91.69,19.30 C90.92,19.63 90.03,19.79 89.00,19.79 C87.99,19.79 87.10,19.63 86.33,19.30 C85.55,18.97 84.89,18.52 84.36,17.93 C83.84,17.35 83.44,16.66 83.17,15.88 C82.91,15.09 82.78,14.25 82.78,13.33 C82.78,12.42 82.91,11.57 83.17,10.78 L83.17,10.78 Z M85.32,15.34 C85.53,15.92 85.81,16.41 86.18,16.80 C86.54,17.19 86.96,17.49 87.45,17.70 C87.94,17.91 88.46,18.01 89.00,18.01 C89.55,18.01 90.06,17.91 90.55,17.70 C91.04,17.49 91.46,17.19 91.83,16.80 C92.19,16.41 92.48,15.92 92.68,15.34 C92.89,14.75 92.99,14.09 92.99,13.33 C92.99,12.58 92.89,11.91 92.68,11.33 C92.48,10.75 92.19,10.25 91.83,9.85 C91.46,9.45 91.04,9.15 90.55,8.94 C90.06,8.73 89.55,8.63 89.00,8.63 C88.46,8.63 87.94,8.73 87.45,8.94 C86.96,9.15 86.54,9.45 86.18,9.85 C85.81,10.25 85.53,10.75 85.32,11.33 C85.11,11.91 85.01,12.58 85.01,13.33 C85.01,14.09 85.11,14.75 85.32,15.34 L85.32,15.34 Z" id="Fill-6"></path>
    <path d="M97.83,7.12 L99.94,7.12 L99.94,19.53 L97.83,19.53 L97.83,7.12 Z" id="Fill-7"></path>
    <path d="M105.19,7.12 L105.19,9.08 L105.24,9.08 C106.12,7.58 107.51,6.83 109.41,6.83 C110.25,6.83 110.95,6.94 111.51,7.16 C112.08,7.39 112.53,7.70 112.88,8.10 C113.23,8.50 113.47,8.98 113.61,9.53 C113.75,10.08 113.82,10.69 113.82,11.36 L113.82,19.53 L111.71,19.53 L111.71,11.12 C111.71,10.36 111.48,9.75 111.02,9.30 C110.56,8.85 109.92,8.63 109.11,8.63 C108.46,8.63 107.91,8.72 107.43,8.92 C106.96,9.11 106.57,9.38 106.26,9.73 C105.94,10.08 105.71,10.50 105.55,10.97 C105.39,11.44 105.32,11.96 105.32,12.52 L105.32,19.53 L103.21,19.53 L103.21,7.12 L105.19,7.12" id="Fill-8"></path>
    <path d="M122.47,7.12 L122.47,8.92 L119.92,8.92 L119.92,16.62 C119.92,16.86 119.94,17.05 119.98,17.20 C120.02,17.34 120.10,17.46 120.22,17.54 C120.33,17.62 120.49,17.67 120.70,17.69 C120.91,17.71 121.18,17.73 121.50,17.73 L122.47,17.73 L122.47,19.53 L120.86,19.53 C120.32,19.53 119.85,19.49 119.46,19.42 C119.07,19.35 118.76,19.22 118.52,19.02 C118.28,18.83 118.10,18.56 117.99,18.21 C117.87,17.86 117.81,17.39 117.81,16.81 L117.81,8.92 L115.63,8.92 L115.63,7.12 L117.81,7.12 L117.81,3.39 L119.92,3.39 L119.92,7.12 L122.47,7.12" id="Fill-9"></path>
    <path d="M0.67,11.87 L2.62,13.76 L8.76,19.50 L11.41,16.94 C11.65,16.61 11.64,16.16 11.36,15.84 L8.94,13.72 L8.95,13.72 L6.34,11.19 C6.04,10.84 6.04,10.32 6.37,9.99 L13.38,3.21 L10.20,0.12 L0.68,9.31 C-0.05,10.02 -0.05,11.17 0.67,11.87" id="Fill-10"></path>
    <path d="M21.60,15.15 L19.66,13.27 L13.51,7.53 L10.86,10.08 C10.62,10.42 10.64,10.87 10.91,11.19 L13.33,13.31 L13.33,13.31 L15.93,15.84 C16.24,16.19 16.23,16.70 15.91,17.04 L8.89,23.82 L12.08,26.91 L19.65,19.60 L21.60,17.71 C22.33,17.01 22.33,15.86 21.60,15.15" id="Fill-11"></path>
    <path d="M44.55,4.58 C44.55,5.24 44.00,5.77 43.32,5.77 C42.64,5.77 42.09,5.24 42.09,4.58 C42.09,3.93 42.64,3.39 43.32,3.39 C44.00,3.39 44.55,3.93 44.55,4.58" id="Fill-12"></path>
    <path d="M100.11,4.58 C100.11,5.24 99.56,5.77 98.88,5.77 C98.20,5.77 97.65,5.24 97.65,4.58 C97.65,3.93 98.20,3.39 98.88,3.39 C99.56,3.39 100.11,3.93 100.11,4.58" id="Fill-13"></path>
  </g>
</svg>
              </div>
              <div class="l-d-f l-d-n--3col l-as-cen">
                <svg width="22px" height="27px" viewBox="0 0 22 27">
    <g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd">
        <g transform="translate(-52.00, -407.00)" fill="#FFFFFF">
            <g transform="translate(52.00, 407.00)">
                <path d="M0.54,11.75 L2.49,13.64 L8.63,19.38 L11.28,16.82 C11.52,16.49 11.51,16.04 11.23,15.72 L8.81,13.60 L8.82,13.60 L6.21,11.07 C5.91,10.72 5.91,10.20 6.24,9.87 L13.25,3.09 L10.06,0 L0.54,9.19 C-0.18,9.90 -0.18,11.05 0.54,11.75"></path>
                <path d="M20.71,14.62 L18.76,12.74 L12.62,7 L9.97,9.55 C9.73,9.89 9.74,10.34 10.02,10.65 L12.44,12.78 L12.43,12.78 L15.04,15.31 C15.34,15.66 15.33,16.17 15.01,16.51 L8,23.29 L11.18,26.38 L18.75,19.06 L20.70,17.18 C21.43,16.48 21.44,15.33 20.71,14.62"></path>
            </g>
        </g>
    </g>
</svg>
              </div>
            </a>
          </section>

          <section class="l-d-f l-w-100 l-ai-str l-jc-fe">
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium/courses"><i class="l-mr2 f-medium fa fa-play-circle"></i>Courses</a>
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/premium/books"><i class="l-mr2 f-medium fa fa-book"></i>Books</a>
            <a class="l-d-n l-d-f--3col l-ai-cen l-ml3 l-ml4--4col l-pa2 f-small f-light f-c-white NavBar_item" href="/community/"><i class="l-mr2 f-medium fa fa-comment"></i>Community</a>
            <div class="l-d-f"><a href="/premium/sign-in" class="Button u-small u-outline u-white l-as-cen l-ml3 l-d-n l-d-b--2col" style="border-width:1px;">Login</a><a href="/premium/sign-up" class="Button u-small l-as-cen l-ml3 l-d-n l-d-b--2col">Create Free Account</a></div>
          </section>
        </div>
      </nav>

      <div class="l-d-n--3col NavBar_offsetSpacer"></div>

    </header>

<div class="l-d-n l-d-b--4col l-p-rel t-bg-white ChannelsNav">
  <ul class="l-d-f l-jc-cen l-w-100 l-w-3col--3col l-w-4col--4col l-pa0 l-mv0 l-mh-auto">
    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-html-css"><a href="https://www.sitepoint.com/html-css/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">HTML &amp; CSS</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-javascript"><a href="https://www.sitepoint.com/javascript/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">JavaScript</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-php"><a href="https://www.sitepoint.com/php/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">PHP</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-design-ux"><a href="https://www.sitepoint.com/design-ux/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Design &amp; UX</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-web"><a href="https://www.sitepoint.com/web/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Web</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-wordpress"><a href="https://www.sitepoint.com/wordpress/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">WordPress</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-woorank"><a href="https://www.sitepoint.com/woorank/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">SEO By WooRank</a></li>    <li class="l-d-ib l-p-rel f-left t-t ChannelsNav_link u-developer-center"><a href="https://www.sitepoint.com/developer-center/" class="l-d-ib l-pv0 l-mt1 l-ph3 f-smaller f-bold f-uppercase f-c-grey-300 f-nowrap t-t">Microsoft Tech</a></li>  </ul>
</div>
<div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-492"><script async type="text/javascript" src="//cdn.fancybar.net/ac/fancybar.js?zoneid=1502&serve=C6ADVKE&placement=sitepointjavascript" id="_fancybar_js"></script><script>ga('SitePointPlugin:observeImpressions', 'maestro-492')</script></div><div class="widget maestro maestro-content-type-html hide-for-mobile-SP" id="maestro-610"><!-- BuySellAds PRO Zone Code (Pushdown Cookie Ad) -->
<div id="bsap_2431" class="bsaPROrocks" data-serve="CVAI5K3N"></div>
<!-- End BuySellAds PRO Zone Code --><script>ga('SitePointPlugin:observeImpressions', 'maestro-610')</script></div><div class="l-pt4 l-p-rel" role="main">
  <div class="Article_bg ChannelBackground u-javascript"></div>
      <div class="l-p-rel l-w-100 l-mh-auto Article_overflow">
          <div class="l-w-3col--3col l-mh3 l-mh-auto--4col">
      <div class="l-d-f">
              <a href="https://www.sitepoint.com/javascript/" class="f-c-grey-700 f-bold t-bg-white l-pa2 l-d-if l-ai-cen"><i class="fa fa-circle t-color l-mr2 l-i2"></i>JavaScript</a>
            <div class="l-d-n l-d-b--3col l-ml3 l-pa2 l-d-if l-ai-cen f-c-grey-700 f-bold t-bg-white">Article</div>
        <span class="l-d-ib t-bg-white f-c-grey-500 f-light l-ml3">
          <span class="l-d-n l-d-ib--2col">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/sholmes/" class="f-c-grey-500">
            Simon Holmes        </a>
          </span>
    </span>
                <time class="l-d-ib l-pa2" datetime="2017-07-17" pubdate>July 17, 2017</time>
                      </span>
      </div>

      <h1 class="l-mv4 f-lh-title f-larger f-xxlarge--2col">
        <span class="t-bg-white l-pa2 l-d-i">A Practical Guide to Planning a MEAN Stack Application</span>
      </h1>
      <span class="l-d-n--2col l-d-ib l-mb3 t-bg-white f-c-grey-500 f-light">    <span class="l-d-ib l-pa2">By
                      <a href="https://www.sitepoint.com/author/sholmes/" class="f-c-grey-500">
            Simon Holmes        </a>
          </span>
    </span>
    </div>
    
      <div class="l-d-f l-jc-sb l-w-3col--3col l-mh-auto" data-hellobar="content">
        <div class="u-showseriesx l-w-100 l-w-2col-i--2col l-fg1 l-mh3--2col l-mh0--4col">
          
              <div class="l-mb4 l-pa3 t-bg-white m-border">
        <div class="l-mb3">
      <div class="l-d-f l-jc-cen f-center l-mh-auto l-o-h">
        <div class="sp-message-big l-w-100 l-d-f l-fd-col m-border" style="background-color: #339bcb;">
  <script>ga('send', 'event', 'Survey2017', 'Survey2017', 'impression');</script>
  <div class="l-d-f l-fw-w l-mv3 l-jc-cen f-c-white">
    <span class="l-w-100 l-mb3 f-large">Help us help you!  You'll get a...</span>
    <span class="l-w-100 l-mb3 f-bold f-xlarge">FREE 6-Month Subscription to SitePoint Premium </span>
    <span class="l-w-100 f-large l-mb2">Plus you'll go in the draw to </span>
    <span class="l-w-100 l-mb3 f-bold f-xlarge">WIN a new Macbook </span>
    <span class="l-w-100 l-mb3 f-bold f-xlarge">SitePoint 2017 Survey</span>
    <span class="l-d-f l-fd-col">
    <a  class="Button l-mt2  l-mb2 l-ph5" 
        href="https://sitepoint.typeform.com/to/tutr2i?source=us-onsite" 
        data-ga-on="click" 
        data-ga-event-category="Survey2017" 
        data-ga-event-label="Survey2017" 
        data-ga-event-action="click">Yes, let's Do this
    </a>
    <small>It only takes 5 min</small>
    </span>
  </div>
</div>      </div>
    </div>
        <div class="ArticleCopy language-javascript">
      <p class="wp-special">A Practical Guide to Planning a MEAN Stack Application is an excerpt from Manning&rsquo;s <a href="http://bit.ly/2sWafwu">Getting MEAN with Mongo, Express, Angular, and Node, Second Edition</a>. Getting MEAN, Second Edition is completely revised and updated to cover Angular 2, Node 6 and the latest mainstream release of JavaScript ES2015 (ES6). This Second Edition will walk you through how to develop web applications using this updated MEAN stack.</p>
<div class="widget maestro maestro-content-type-html hide-for-tablet-SP hide-for-mobile-SP" id="maestro-636"><div class="SP_stripMobile" style="width:100%;margin: 0 auto; max-width: 640px;"><span id="adBox" class="f-small f-light f-center">--ADVERTISEMENT--</span><div id="aniBox" style="height:1px;"><div id="aniplayer"></div></div></div>


<script class="SP_stripMobile" src="https://play.aniview.com/Templates/Viewability/AViewability.js"></script><script class="SP_stripMobile" type="text/javascript" id="aniviewJS">
(function()
{
	var myPlayer,
		adConfig = {
		publisherId 		: 	'5858ed930b8ee8851941a7bb',
		channelId			: 	'594184ff28a0616f281562db', 
		ref1			: '',
		width           : 100,
		height          : 0,
		HD              : true,
		skipTimer	: 15,
		closeButton	: true,
		autoPlay        : false,
		Preroll		: 1,
		midrolltime     : 5,
		loop            : false,
		lastFrame       : true,
		logo            : true,
		timelineMode    : 'bottom',
		soundButton     : true,
		pauseButton     : true,
		pauseOnBlur     : true,
		unMuteOnMouseEnter:true,
		customLogo:{
			link:'https://aniview.hs.llnwd.net/d1/so/ftpAdops/Hooly/hooly_56x20.png',
			height:'25',
			width:'70',
			text:'Ads by ',
			clickthrough:'http://hoolymedia.com/'
		},
		playOnView :true,
floting :{
			size : 0.55,
			right : 0,
			bottom : 80,
		},
		position		: 'aniplayer'
	};
	(new Image).src = "https://track1.aniview.com/track?pid="+adConfig.publisherId+"&cid="+adConfig.channelId+"&e=playerLoaded"+"&cb="+Date.now();
	var PlayerUrl = 'https://player.aniview.com/script/6.1/aniview.js';
	function downloadScript(src,adData) {
	   var scp = document.createElement('script');
	   scp.src = src;
	   scp.onload = function() {
			myPlayer= new avPlayer(adData);
			AVStartViewability(myPlayer,adData);	
			myPlayer.play(adConfig);
	   }
		document.getElementsByTagName('head')[0].appendChild(scp);
	};
	downloadScript(PlayerUrl,adConfig);
})();
var el = document.getElementById('aniBox');
var adBox = document.getElementById('adBox');
// create an observer instance
var observer = new MutationObserver(function(mutations) {
  mutations.forEach(function(mutation) {
    if(mutation.attributeName == 'style'){
      var s = el.getAttribute('style');
      if(s.search('height: 360px') !=  -1) {
        adBox.style = 'display: block';
      }
      else {
        adBox.style = 'display: none';
      }
}
  });    
});

// configuration of the observer:
var config = { attributes: true, attributeFilter: ['style']};
 
// pass in the target node, as well as the observer options
observer.observe(el, config);
</script><script>ga('SitePointPlugin:observeImpressions', 'maestro-636')</script></div><h2 id="planningarealapplication">Planning a Real Application</h2>
<div class="ArticleBox u-inline"><h3 class="ArticleBox_header t-bg">
                    <span class="ArticleBox_icon fa fa-pencil"></span> More from this author
                 </h3><div class="m-border ArticleBox_content"><ul class="ArticleBox_list"><li class="ArticleBox_listItem"><a class="f-c-grey-500 l-b-n" href="https://www.sitepoint.com/user-authentication-mean-stack/?utm_source=sitepoint&amp;utm_medium=relatedinline&amp;utm_term=&amp;utm_campaign=relatedauthor">User Authentication with the MEAN Stack</a></li></ul></div></div>
<p>For the purposes of this article, let&rsquo;s imagine that we&rsquo;re building a working application on the MEAN stack called Loc8r. Loc8r will list nearby places with WiFi where people can go and get some work done. It will also display facilities, opening times, a rating, and a location map for each place.</p>
<h2 id="planningthemeanstackapplicationatahighlevel">Planning the MEAN Stack Application at a High Level</h2>
<p>The first step is to think about what screens we&rsquo;ll need in our application. We&rsquo;ll focus on the separate page views and the user journeys. We can do this at a high level, not concerning ourselves with the details of what&rsquo;s on each page. It&rsquo;s a good idea to sketch out this stage on a piece of paper or a whiteboard, as it helps to visualize the application in its entirety. It also helps with organizing the screens into collections and flows, serving as a good reference point when we build it. As there&rsquo;s no data attached to the pages or application logic behind them, it&rsquo;s easy to add and remove parts, change what&rsquo;s displayed and where, and even change how many pages we want. The chances are that we won&rsquo;t get it right the first time; the key is to start and iterate and improve until we&rsquo;re happy with the separate pages and overall user flow.</p>
<h2 id="planningthescreens">Planning the Screens</h2>
<p>Let&rsquo;s think about Loc8r. As stated our aim is as follows:</p>
<blockquote>
<p>Loc8r will list nearby places with WiFi where people can go and get some work done. It displays facilities, opening times, a rating, and a location map for each place. Visitors can to submit ratings and reviews.</p>
</blockquote>
<p>From this we can get an idea about some of the screens we&rsquo;re going to need:</p>
<ol><li>A screen that lists nearby places</li>
<li>A screen that shows details about an individual place</li>
<li>A screen for adding a review about a place</li>
</ol><p>We&rsquo;ll probably also want to tell visitors what Loc8r is for and why it exists, and we should add another screen to the list:</p>
<ol style="counter-reset: item 4"><li>A screen for &ldquo;about us&rdquo; information</li>
</ol><h2 id="dividingthescreensintocollections">Dividing the Screens into Collections</h2>
<p>Next, we want to take the list of screens and collate them where they logically belong together. For example, the first three in the list are all dealing with locations. The <em>About</em> page doesn&rsquo;t belong anywhere and it can go in a miscellaneous <em>Others</em> collection. Sketching this out brings us something like figure 1.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499952356fig-1-collate-screens.png" alt="Planning a MEAN stack application: collections"></p>
<p><em>Figure 1: Collate the separate screens for our application into logical collections.</em></p>
<p>Having a quick sketch like this is the first stage in planning, and we need to go through this stage before we can start thinking about architecture. This stage gives us a chance to look at the basic pages, and to also think about the flow. Figure 1, for example, shows a basic user journey in the <em>Locations</em> collection, going from the <em>List</em> page, to a <em>Details</em> page, and then onto the form to add a review.</p>
<div id="premium-mid" class="Article_full_w l-d-f l-jc-cen l-fd-col t-bg-grey-500 l-mv4 l-pa3">
        <h2 class="f-c-white f-center f-large f-xxlarge--2col">Read Modern JavaScript</h2>
        <h3 class="f-c-white f-center f-medium f-xlarge--2col l-mb4">Keep up-to-date with the evolving world of JavaScript</h3>
        
        <div class="l-d-f l-jc-cen">
          <div>
            <img class="l-mh3 Article_img_book l-mh-auto" src="https://d2sis3lil8ndrq.cloudfront.net/books/7cb6d470-2167-476b-aa0b-28a4f680aa4c.png"></div>
        </div>
  
        <div class="l-d-f l-jc-cen l-mt4">
          <a href="https://www.sitepoint.com/premium/books/modern-javascript" class="l-d-n l-d-ib--2col Button u-large l-ph5 l-mb4">Start Reading Now</a>
          <a href="https://www.sitepoint.com/premium/books/modern-javascript" class="l-d-n--2col Button l-ph5 l-mb4">Start Reading Now</a>
        </div>
      </div><h2 id="architectingtheapplication">Architecting the Application</h2>
<p>On the face of it Loc8r is a simple application, with only a few screens. But we still need to think about how to architect it, because we&rsquo;re going to be transferring data from a database to a browser, letting users interact with the data and allowing data to be sent back to the database.</p>
<h3 id="startingwiththeapi">Starting with the API</h3>
<p>Because the application is going to be using a database and passing data around, we&rsquo;ll start building the architecture with the piece we&rsquo;re definitely going to need. Figure 2 shows the starting point, a REST API built with Express and Node.js to enable interactions with the MongoDB database.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499952358fig-2-rest-api.png" alt="Planning a MEAN stack application: API"></p>
<p><em>Figure 2 Start with the standard MEAN REST API, using MongoDB, Express, and Node.js.</em></p>
<p>Building an API to interface with our data is the base point of the architecture. The more interesting and difficult question is: How do we architect the application?</p>
<h3 id="applicationarchitectureoptions">Application Architecture Options</h3>
<p>At this point, we need to look at the specific requirements of our application and how we can put together the pieces of the MEAN stack to build the best solution. Do we need something special from MongoDB, Express, Angular, or Node.js that&rsquo;ll swing the decision a certain way? Do we want HTML served directly from the server, or is an SPA the better option?</p>
<p>For Loc8r there are no unusual or specific requirements, and whether it should be easily crawlable by search engines depends on the business growth plan. If the aim is to bring in organic traffic from search engines, then yes, it needs to be crawlable. If the aim is to promote the application as an application and drive use that way, then search engine visibility is a lesser concern.</p>
<p>We can immediately envisage three possible application architectures, as shown in figure 3:</p>
<ol><li>A Node.js and Express application</li>
<li>A Node.js and Express application with Angular additions for interactivity</li>
<li>An Angular SPA</li>
</ol><p>With these three options in mind, which is the best for Loc8r?</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499952360fig-3-options.png" alt="Planning a MEAN stack application: architecture"></p>
<p><em>Figure 3 Three options for building the Loc8r application, ranging from a server-side Express and Node.js  application to a full client-side Angular SPA.</em></p>
<h3 id="choosinganapplicationarchitecture">Choosing an Application Architecture</h3>
<p>No specific business requirements are pushing us to favor one architecture over another. Building all three of the architectures allows us to explore how each approach works and enables us to look at each of the technologies in turn, building up the application layer by layer.</p>
<p>We&rsquo;ll be building the architectures in the order they&rsquo;re shown in figure 3, starting with a Node.js and Express application, then moving on to add some Angular before refactoring to an Angular SPA. Although this isn&rsquo;t necessarily how you might normally build a site, it gives you a great opportunity for learning all aspects of the MEAN stack. </p>
<h2 id="wrappingeverythinginanexpressproject">Wrapping everything in an Express project</h2>
<p>The architecture diagrams we&rsquo;ve been looking at imply that we&rsquo;ll have separate Express applications for the API and the application logic. This is perfectly possible and a good way to go for a large project. If we&rsquo;re expecting large amounts of traffic, we might even want our main application and our API on different servers. An additional benefit of this is that we can have more specific settings for each of the servers and applications which are best suited to the individual needs.</p>
<p>Another way is to keep things simple and contained and have everything inside a single Express project. With this approach, we have only one application to worry about hosting and deploying and one set of source code to manage. This is what we&rsquo;ll be doing with Loc8r, giving us one Express project containing a few sub-applications. Figure 4 illustrates this approach.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499952362fig-4-architecture.png" alt="Planning a MEAN stack application: Express"></p>
<p><em>Figure 4 The architecture of the application with the API and application logic wrapped inside the same Express project.</em></p>
<p>When putting together an application in this way, it&rsquo;s important to organize our code well to allow the distinct parts of the application to be kept separate. As well as making our code easier to maintain, it makes it easier to split it out into separate projects further down the line if we decide it&rsquo;s the right route. This is a key theme that we&rsquo;ll keep coming back to throughout the book.</p>
<h2 id="theendproduct">The End Product</h2>
<p>As you can see, we&rsquo;ll use all layers of the MEAN stack to create Loc8r. We&rsquo;ll also include Twitter Bootstrap to help us create a responsive layout. Figure 5 shows some screenshots of what can be built.</p>
<p><img src="https://dab1nmslvvntp.cloudfront.net/wp-content/uploads/2017/07/1499952370fig-5-end-product.png" alt="Planning a MEAN stack application: the end product"></p>
<p><em>Figure 5 Loc8r is a sample application. It displays differently on different devices, shows a list of places and details about each place, and enables visitors to log in and leave reviews.</em></p>
<h2 id="conclusion">Conclusion</h2>
<p>That&rsquo;s all for this article. If you&rsquo;d like start putting these steps into practice, then please head over to Manning&rsquo;s website where you can either download the free first chapter of <a href="http://bit.ly/2sWafwu">Getting MEAN with Mongo, Express, Angular, and Node, Second Edition</a>, or purchase the book. Otherwise, if you have any questions about what I have covered in this article, please post them in the comments below.</p>
    </div>
        <div class="l-mb3">
            <thumbvoter-buttons id="157238"
        url="https://www.sitepoint.com/wp-admin/admin-ajax.php"
        user_rating="0"
        channel="JavaScript"
      />
    </div>
        <div class="f-lh-copy l-d-f">
      <div class="l-fs0 l-mr3"><i class="fa fa-tag"></i> More: </div>
      <div class="f-c-teal-500">
<a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/express/">Express</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/mean-stack/">mean stack</a>, <a class="f-c-teal-500 f-underline" href="https://www.sitepoint.com/tag/mongodb/">mongodb</a>      </div>
    </div>
        </div>
                    <div class="Article_authorBio l-mb4 l-pa3 t-bg-white m-border">
        <div class="l-d-f">
          <a class="l-s5 l-mr3 l-round l-o-h" href="https://www.sitepoint.com/author/sholmes/">
            <img src="https://secure.gravatar.com/avatar/c7c7b1183ec1ce69e4568935a585c1db?s=96&#038;d=mm&#038;r=g" width="96" height="96" alt="" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 photo avatar-default" />          </a>
          <div class="f-lh-title">
            <div class="f-c-grey-300">Meet the author</div>
            <div class="f-large">
              <a class="f-bold f-c-grey-500" href="https://www.sitepoint.com/author/sholmes/">
                Simon Holmes              </a>
              <a class="f-c-grey-500 l-mh1" target="_blank" href="https://twitter.com/simonholmes"><i class="fa fa-twitter"></i></a>            </div>
          </div>
        </div>
        <div class="f-light f-lh-copy l-mt3">Simon has been a full stack developer since the late 1990's, and is a massive fan of good JavaScript. He is the author of "Getting MEAN" and "Mongoose for Application Development", and co-founder of Full Stack Training Ltd.</div>
      </div>
      
          <div class="ArticleContent_endcap">
                      </div>

          <div class="widget maestro maestro-content-type-bsa hide-for-mobile-SP" id="maestro-440"><div class="l-pa3 t-bg-white"  id="maestro-440-bsa-143120">
<a href="//srv.buysellads.com/ads/click/x/GTND42QECT7IK2QICYBLYKQMCTYD65QUCA7DPZ3JCWYDT23YCA7ILKJKC6BITK3ICYYI6K3EHJNCLSIZ" class="l-d-f l-ai-cen l-pa3 t-bg-grey-50" 
data-ga-on="click" data-ga-event-category="maestro" data-ga-event-label="maestro-440-bsa-143120" data-ga-event-action="click"
>
<img src="//assets.servedby-buysellads.com/p/manage/asset/id/55770">
<span class="l-fg1 l-mh3 f-bold f-center f-underline f-lh-title f-c-grey-700">Is Your DevOps Pipeline Leaking?</span>
<button class="Button u-outline l-fs0">Read the Report</button>
<span class="l-mh3 f-c-grey-300">AD</span>
</a>
</div><img src="https://www.launchbit.com/taz-pixel/474-6651-111" height="1" width="1" border="0" style="display: none;" /><script>ga('SitePointPlugin:observeImpressions', ['maestro-440-bsa-143120'])</script></div>          <div id="commentsSection" class="l-pa3 t-bg-white">
                <div id="sp_comments_signin">
      <div class="f-larger f-bold l-mb3">Login or Create Account to Comment</div>
      <a href="/premium/sign-in?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fplanning-mean-stack-application%2F%23commentsSection" class="Button u-grey u-outline">Login</a>
      <a href="/premium/sign-up?ref_source=sitepoint&ref_medium=comments&redirect_path=%2Fplanning-mean-stack-application%2F%23commentsSection" class="Button l-ml3">Create Account</a>
    </div>
        <div data-spotim-module="recirculation" data-spot-id="sp_hAStREiw"></div>
    <script src="https://recirculation.spot.im/spot/sp_hAStREiw"></script>
    <script async
      src="https://launcher.spot.im/spot/sp_hAStREiw"
      data-spotim-module="spotim-launcher"
      data-spot-id="sp_hAStREiw"
      data-post-id="157238"
      data-disqus-url="https://www.sitepoint.com/planning-mean-stack-application/"
      data-disqus-identifier="157238 https://www.sitepoint.com/?p=157238"></script>
    <script>
      if (window.SPOTIM && window.SPOTIM.startSSO) {
        startSSO();
      } else {
        document.addEventListener("spot-im-api-ready", startSSO, false);
      }

      function startSSO() {
        var callback = function(codeA, completeSSOCallback) {
          $.ajax({
            method: "GET",
            url: "/premium/api/v1/users/spot_im_sso/" + codeA,
            success : function(response){
              completeSSOCallback(response.code_b);
            }
        });
        };

        window.SPOTIM.startSSO(callback).then(function(result) {
          var button = document.getElementById("sp_comments_signin");
          button && button.remove();
        })
        .catch(function(reason){
          console.log(reason)
        });
      }
    </script>
                <a id="comments"></a>
                      </div>
        </div>
              </div>

      <div class="u-accordion-end"></div>
          <div class="l-pa3 l-mt4">
      <div class="t-t t-o-100"><div class="l-w-100 l-w-4col--4col l-mh-auto  l-d-f l-jc-sb l-fw-w l-ai-cen"><a href="/premium?q=&amp;limit=24&amp;offset=0&amp;page=1&amp;content_types[]=All&amp;slugs[]=javascript&amp;states[]=available&amp;order="><h4 class="l-as-fs l-mv0 l-pv1 l-ph3 f-light f-larger f-uppercase f-c-white t-bg-grey-500">Latest JavaScript Books and Courses <i class="fa fa-angle-right"></i></h4></a></div><div class="l-d-n l-d-f--4col l-fw-w l-jc-sa l-pv4 l-w-4col l-mh-auto"><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/ember-2-0-2973"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>34m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/3e3bbe8f-be0c-4fb9-99e8-3a59c71201aa_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Thomas Greco</div></div><h3 class="l-mv1 f-large f-bold">Ember 2.0</h3><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Applications with the Ember JavaScript framework</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/introduction-to-grunt-js-2974"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>40m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/494d4afa-20f7-4f4b-b381-3b21075f7fc2_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Thomas Greco</div></div><h3 class="l-mv1 f-large f-bold">Introduction to Grunt.JS</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><meta content="5" itemprop="ratingValue"/></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">A quick introduction to Grunt</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/visualizing-data-with-d3-js-2920"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>1h 12m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/cdd1dc44-5982-47e3-a616-3061f5eb284d_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Max Froumentin</div></div><h3 class="l-mv1 f-large f-bold">Visualizing Data with D3.js</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><meta content="5" itemprop="ratingValue"/></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Illustrate Your Data with JavaScript</div></div></a><a class="l-w-col l-p-rel l-d-f l-fd-col l-fw-w l-mb3 l-mh3--2col l-mh0--3col l-o-h t-t HomeCard" href="https://www.sitepoint.com/premium/courses/forms-with-react-and-redux-2935"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white undefined u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>41m</span></div><div class="l-w-100 t-bg-grey-200 u-course HomeCard_image t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/fc200e21-78f4-4a8b-a7e4-3557ac658711_medium.png);"></div><div class="l-w-100 l-pa3 t-bg-white f-c-grey-500 t-t HomeCard_content"><div class="l-d-f l-jc-sb l-pv2 HomeCard_meta"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="f-small f-light">Brad Westfall</div></div><h3 class="l-mv1 f-large f-bold">Forms with React and Redux</h3><div class="l-pt3 f-small f-c-grey-300"><div class="Stars"><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><i class="fa fa-star"></i><meta content="5" itemprop="ratingValue"/></div></div><div class="l-d-n l-h5 l-pt3 l-w-100 f-small f-light f-lh-copy HomeCard_description">Easily create forms with Redux Form</div></div></a></div><div class="l-d-n--4col l-d-f l-fw-w l-jc-sb l-pv4"><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/ember-2-0-2973"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>34m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/3e3bbe8f-be0c-4fb9-99e8-3a59c71201aa_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Thomas Greco<span>, 7 days ago</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Ember 2.0</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/introduction-to-grunt-js-2974"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>40m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/494d4afa-20f7-4f4b-b381-3b21075f7fc2_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Thomas Greco<span>, Jul 06</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Introduction to Grunt.JS</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/visualizing-data-with-d3-js-2920"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>1h 12m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/cdd1dc44-5982-47e3-a616-3061f5eb284d_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Max Froumentin<span>, Jul 05</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Visualizing Data with D3.js</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div><div class="l-w-100 l-w-49--3col"><div class="l-d-f l-jc-sb l-ml2 l-mb2 f-small l-d-n--2col"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div></div><a class="l-p-rel l-d-f l-jc-cen l-jc-fs--2col l-w-100 l-mb3 l-mb4--2col t-bg-white FeaturePanel" href="https://www.sitepoint.com/premium/courses/forms-with-react-and-redux-2935"><div class="l-p-rel l-mb0 l-fs0 t-bg-grey-200 FeaturePanel_imageContainer"><div class="l-pv2 l-ph2 l-ph3--2col f-small f-bold f-c-white l-w-100 u-course HomeCard_numbers"><div class="l-w-100 t-bg-grey-500 HomeCard_numbersBg"></div><span class="l-p-rel"><i class="l-pr2 l-d-n l-d-ib--2col fa fa-clock-o"></i>41m</span></div><div class="l-w-100 l-mb2 FeaturePanel_image u-course t-t HomeResult_image u-javascript" style="background-image:url(https://d2sis3lil8ndrq.cloudfront.net/courses/fc200e21-78f4-4a8b-a7e4-3557ac658711_medium.png);"></div></div><div class="l-d-f l-fw-w l-w-100 l-ai-cen l-ai-fs--2col l-ph3 l-mh3--2col f-c-grey-500 FeaturePanel_content"><div class="l-d-n l-d-f--2col l-pt2--2col l-w-100 l-jc-sb"><div class="l-d-f f-small f-bold f-uppercase f-c-grey-300"><i class="l-d-n l-d-ib--2col l-pr1 fa fa-lock"></i> Premium Course</div><div class="l-d-n l-d-b--4col f-small f-light">Brad Westfall<span>, Jun 15</span></div></div><h3 class="l-mv1 f-medium f-bold f-large--4col FeaturePanel_title">Forms with React and Redux</h3><div class="l-d-n l-d-b--4col l-mb3 l-mb0--2col f-small f-light f-lh-copy FeaturePanel_description"></div></div></a></div></div></div>
    </div>
    <div class="l-d-f l-jc-cen l-w-100 l-mb4">
      <a href="/premium?q=&limit=24&offset=0&page=1&content_types[]=All&slugs[]=javascript&states[]=available&order=" class="Button u-large">All JavaScript Books and Courses</a>
    </div>
              <category-subscribe slug="javascript" server-rendered="1"><div class="l-w-100 l-pv2 l-pv5--2col f-c-white CategorySubscribeForm u-javascript " data-reactroot="" data-reactid="1" data-react-checksum="-1967595865"><form class="l-w-100 l-w-2col--2col l-ph3" data-reactid="2"><div class="l-pv3 l-pt0--2col l-mt0 f-c-white f-center f-bold f-large f-xlarge--2col" data-reactid="3"><!-- react-text: 4 -->Get the latest in <!-- /react-text --><!-- react-text: 5 -->JavaScript<!-- /react-text --><!-- react-text: 6 -->, once a week, for free.<!-- /react-text --></div><input type="email" class="l-pb3 l-br f-center" placeholder="Enter your email" value="" required="" data-reactid="7"/><button class="Button l-w-100 l-ma0 l-h5 u-large u-cta" data-reactid="8">Subscribe</button></form></div></category-subscribe>
              <article-sharer data-url="https%3A%2F%2Fwww.sitepoint.com%2Fplanning-mean-stack-application%2F" data-title="A Practical Guide to Planning a MEAN Stack Application"></article-sharer>
    
    <script>
      OneSignal.push(function() {
        OneSignal.sendTags({
          javascript: 'javascript',
        });
      });
    </script>
      </div>
    </div>
            <ads-weighted widget='86' data='{"US":[{"id":"638","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"AR":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"AU":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"BE":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"BR":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"CA":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"CN":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"DE":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"DK":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"ES":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"FR":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"GB":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"HK":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"ID":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"IL":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"IN":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"IT":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"JP":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"KP":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"KR":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"MX":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"MY":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"NL":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"NZ":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"PH":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"PK":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"PL":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"PT":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"RU":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"SE":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"SG":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"TR":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"TW":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"UA":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}],"VN":[{"id":"641","demandbase_field":null,"demandbase_value":null,"weight":"0","randMax":0}]}' fallback='' url='planning-mean-stack-application' channelSlug='javascript'></ads-weighted>    <footer class="l-d-f t-bg-grey-500" role="contentinfo" style="height: 500px; margin-top:60px;">
  <div class="l-d-f l-fw-w l-mh-auto">
    <div class="l-d-f l-mt4 l-w-100 l-w-2col--2col l-w-3col--4col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">About</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/about-us/">Our Story</a>
        </li>
        <li >
          <a class="m-link-white f-small" href="/advertise/">Advertise</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/press/">Press Room</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="http://reference.sitepoint.com/css/" target="_blank">Reference</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/">Terms of Use</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/legals/#privacy">Privacy Policy</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://sitepoint.zendesk.com/hc/en-us" target="_blank">FAQ</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/contact-us/">Contact Us</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/write-for-us/">Contribute</a>
        </li>
      </ul>

      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Visit</div>
        </li>
        <li>
          <a class="m-link-white f-small" href="/">SitePoint Home</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/themes/?utm_source=blog&utm_medium=footer">Themes</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/versioning-show/">Podcast</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/community/">Forums</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/newsletter/">Newsletters</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/premium/">Premium</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="/sass-reference/">References</a>
        </li>
        <li>
          <a class="m-link-white f-small" href="https://www.sitepoint.com/versioning/">Versioning</a>
        </li>
      </ul>
    </div>

    <div class="l-mt4 l-w-1col">
      <ul class="t-ls-n l-w-100">
        <li>
          <div class="f-c-white f-medium f-bold l-mb2">Connect</div>
        </li>
        <li>
          <a class="m-link-white" href="https://www.sitepoint.com/feed/">
            <i class="fa fa-rss-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="/newsletter/">
            <i class="fa fa-envelope-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://www.facebook.com/sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-facebook-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="http://twitter.com/sitepointdotcom" rel="noopener" target="_blank">
            <i class="fa fa-twitter-square l-i4"></i>
          </a>
          <a class="l-pl1 m-link-white" href="https://plus.google.com/+sitepoint" rel="noopener" target="_blank">
            <i class="fa fa-google-plus-square l-i4"></i>
          </a>
        </li>

        <p class="f-c-white l-mv3">
          &copy; 2000 &ndash; 2017 SitePoint Pty. Ltd.
        </p>
      </ul>
    </div>
  </div>
</footer>
    <script type="text/javascript">
  adroll_adv_id = "DJI3I3WGJBGL7PDJEDAYHV";
  adroll_pix_id = "4RKMV6N56FGA7ANPGL4FQW";
  (function () {
    var adblocked = false;
    var onAdblock = function() {
      if(adblocked) return;

      adblocked = true;

      gaEventQueue && gaEventQueue.track('CanSeeAds', 'adrollBlocked', {'nonInteraction': true});

      Array.prototype.slice.call(document.getElementsByClassName('CantSeeAds'))
        .forEach(function(el) {
          el.className = el.className.replace('CantSeeAds', '');
        });

    };
    var _onload = function(){
      if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
      if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
      var scr = document.createElement("script");
      var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
      scr.setAttribute('async', 'true');
      scr.type = "text/javascript";
      scr.src = host + "/j/roundtrip.js";
      scr.onerror = onAdblock;
      ((document.getElementsByTagName('head') || [null])[0] ||
          document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
    };
    if (window.addEventListener) {window.addEventListener('load', _onload, false);}
    else {window.attachEvent('onload', _onload)}
  }());
</script>
    <script>
(function(d,b,a,s,e){ var t = b.createElement(a),
  fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s;
  fs.parentNode.insertBefore(t, fs); })
(window,document,'script','https://scripts.demandbase.com/IM2QfEma.min.js','demandbase_js_lib');
</script>
    				<script type='text/javascript'><!--
			var seriesdropdown = document.getElementById("orgseries_dropdown");
			if (seriesdropdown) {
			 function onSeriesChange() {
					if ( seriesdropdown.options[seriesdropdown.selectedIndex].value != ( 0 || -1 ) ) {
						location.href = "https://www.sitepoint.com/series/"+seriesdropdown.options[seriesdropdown.selectedIndex].value;
					}
				}
				seriesdropdown.onchange = onSeriesChange;
			}
			--></script>
			        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'sitepointproduction';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        
<!-- START Parse.ly Include: Standard -->
<div id="parsely-root" style="display: none">
  <div id="parsely-cfg" data-parsely-site="sitepoint.com"></div>
</div>
<script data-cfasync="false">
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.setAttribute('data-cfasync', 'false'); e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>
<!-- END Parse.ly Include: Standard -->
    <script type="text/javascript">
    (function(googletag, SP_GPT_Slots) {
      if(!SP_GPT_Slots.length) return;

      var SP_GPT_First_Slot_Rendered = false;
      googletag.cmd.push(function(){
        googletag.pubads().addEventListener("slotRenderEnded", function(e){
          if (!SP_GPT_First_Slot_Rendered) {
            gaEventQueue.track("CanSeeAds", "dfpFirstRendered", {"nonInteraction": true});
            SP_GPT_First_Slot_Rendered = true;
          }
        });
      });

    })(googletag, SP_GPT_Slots);
    </script>
<script type='text/javascript' src='//www.sitepoint.com/wp-content/themes/sitepoint/assets/javascripts/scripts-foot-9f6f37027570279c548a1d2666f370ca.js?ver=4.7.3'></script>
<script type="text/javascript" src="/dist/js/compiled.141e43f35ebf5c4f9f5f.js"></script>
<script type='text/javascript' src='https://www.sitepoint.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
    <script>
    jQuery(document).ready(function() {
      jQuery('.lazyYT').each(function() {
        var id = jQuery(this).data('youtube-id'),
            url = 'https://www.youtube.com/watch?v=' + id;
        jQuery(this).replaceWith('<a href="' + url + '">' + url + '</a>');
      });
    });
    </script>
  
  </body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 1262/1287 objects using memcached
Page Caching using memcached (SSL caching disabled)
Content Delivery Network via Amazon Web Services: CloudFront: dab1nmslvvntp.cloudfront.net

 Served from: www.sitepoint.com @ 2017-07-18 00:08:41 by W3 Total Cache -->