Using external usb drive: empty folders in Windows 7 but I know the files are there!

Hello -

I’m using Windows 7 Professional and everything seems to be working fine. I attached my new Transcend f25 USB drive (300g) to use for backups. I copied over about 20 gigs of archives and had Windows run it’s first backup.

Everything seemed OK, and the available space on the drive is now about 230g, which sounds right. The problem is, I can only see empty folders on the drive!!

Now, I know for sure that the files are there because I tried plugging the drive into an old XP laptop - bingo there were all my files! Can anyone advise me ? This seems like a configuration problem, or maybe a drive error. The files were there when I first added them, though, so it’s very odd!

How can I see my files? Help!!
Any Windows 7 gurus have any tips ??

thanks, Dave

Have you checked that the files aren’t hidden? Backup might automatically hide them as hidden files (just a guess here), there should be an option in the folder options to show files marked as hidden which might make them appear. I know from past experience that sometimes windows likes to make important stuff invisible for the generic user whom might delete something they may need later on by accident. :slight_smile:

I checked that and they weren’t hidden, no. But, to my surprise the files are now visible from Win 7. I have no idea why, which makes me nervous but I was never worried that the files were actually gone. Very odd!

When stuff like that happens to me, I just think to myself… Don’t worry, it’s Windows. That’s usually a pre-cursory excuse to explain anything out of the ordinary :wink:

so might be possible that files are hidden go to tools> option > view > chk the option show hidden files and folder. It still not working then it means your pc have some viruses