Ugh. Flash CS4 motion tweening is a nightmare

I realise some people love it, but I just can’t figure it out. I’m ready to pull my hair out here.

I just want to do one simple thing: “move” the keyframe (the little “new skool” diamond crap thing) along the timeframe to extend/shorten the tween. I’ve been searching tutorials and even watched 15 minute video presentations on the new tweening tool and I can’t find a solution anywhere. If it’s the last keyframe in the tween, it extends the entire tween which I admit looks useful. But how do you move the keyframes around in the middle of the tween?

Using the “classic tween” you just click, hold and drag the bloody keyframe. Why on earth did they feel the need to change that?

Apologies for the sheer frustration coming out in the post. I suppose I’ll probably like it when I know what I’m doing, but for the moment it seems like an incredibly un-intuative “fix” to something that was never broken in the first place.


Surely I’m just missing something here? Don’t tell me nobdoy knows how to move a keyframe along the timeframe in a CS4 motion tween???

ctrl+ click the diamond to select, then drag. The new tweening is way more powerful, and more in keeping with the advanced motion editing you get in e.g after effects. Once you’ve sussed it you won’t want to go back, just stick with it :slight_smile:

Ctrl + click doesn’t seem to be doing anything at all (Mac). Nor alt-click, opt-click or shift-click.

Are you sure that’s it?

Yep. If I click on a diamond keyframe without ctrl, it selects the entire tween not just one frame (so you can’t reposition the diamond) If I ctrl+click the frame it’s now selected a single frame. I can then drag the selected frame to wherever I want. I’m on a PC btw

Doesn’t work for me at all on Mac.

Cmd-click does nothing and ctrl-click brings up the right-click menu.

Ctrl-click is actually what mac’s use to display the right-click menu for one-button mouses. I wonder if they’ve made a silly blunder with CS4 for Mac? You’d think they wouldn’t miss something as obvious as that, especially since the Adobe graphic design software is supposedly built primarily for Mac, not PC.

Anyone else having this problem with a Mac?

This is why I have never wanted to buy a mac.

Have you tried looking for a cs4 mac manual? you might be able to find a pdf somewhere online.

Also try some mac forums.

I doubt it’s a bug or omission, because as you point out, there will be many mac users.
Have a look at

Well to be fair, it’s hardly the fault of Apple if Adobe created some buggy software.

You’d let a bug in the Adobe software put you off buying a Mac but will happily wade through a decade and a half of crap that Microsoft OS’s put you through? Unless you’re using Linux it would seem like a very strange decision indeed.

Each to their own I guess.

In fact, I take this back (seems it’s not an Adobe bug at all), I’ve got the problem fixed now.

I have no idea how on earth how this could have any effect at all, but I changed my mouse and now it works perfectly. In fact, I used a pen and tablet and it works perfectly and now when I plug a mouse in, it works too.

Beats me what was wrong before, but I’m not complaining. :blush: :x

Can’t just simplt drag the keyframe (without also moving the entire animation) - as was posssable in CS3!! Tried CTRL/Click - doesn’t work for me on PC!!

Ok, I played around with this for a while, changing my mouse etc. before I found out that you have to Ctrl+Click to select the property keyframe first AND THEN Click+drag the selected keyframe to actually move it (without moving the rest of your animation with it.) Hope this is helpful for at least one more person cause it took me WAY to long to figure it out…:rolleyes:

(oh and I’m on a PC…:))