Shown result in google

i dont know why my website show in google like this , !?
not also all other pages of my website shown without WWW !? while all other websites shown in search result ?
can anyone tell me why ?

You need to do proper url structuring, remove these !? signs. It will improve your website ranking. Best SEO practice is to have page naming convention to make best use of keywords or keyword phrases. I think one of the most important requirements is URL structure and page naming. What I am referring to is setting up the website structure.

Dear add i use OScommerce .
how i should use proper url structuring ?
should i use any meta tag , code ?
can you explain me how to revise my website address in google ?

If you log in to Google Webmaster Tools, you can set a preference to have your domain shown with or without the www. prefix. Go to “Site Configuration” and choose “Settings”. Then you can specify how you wish your pages to be indexed.

TechnoBear has given you the solution, but what it comes down to is what version of the URL most of the links point to, including those on your own site.

But does it matter? As long as the pages are listed and indexed consistently, you’ll get the same results whether they are using the www version or not.

Actually, unless I have misunderstood your sentiments, I think this is a red herring.

If you specify your preferred domain as and Google finds a link to your site that is formatted as, Google will treat that link as if it was

But, I whole-heartedly agree with Stevie D when he says: TechnoBear has given you the solution

I was working on the assumption that the OP hadn’t set any preferences in GWT, and so Google would just be trying to figure things out as it went along…

Yep, use Google Webmaster Tool is the best way to fix your problem. You also can make a 301 redirect, but it might be a little risky if you have added lots of contents to your website.