Recovering data from external usb drive

I have a 1TB WD MyBook Essential Edition External Hard Drive USB 2.0 drive that is no longer ‘read’ by my computer or laptop (Athlon Win XP / HP Duocore win 7) meaning I can’t see it in the directory (even under ‘computer mgmt’) even though it still powers up. I tried different ports but nothing. Last message I got was ‘…I/O error…’ after trying to use the disconnect icon in Windows to move the drive to my laptop. Before that it was working fine; I was able to transfer files, open, and even disconnect with no problems. After that last message it stopped reading, the message a few minutes before that when I initially tried to disconnect was ‘…drive still busy…’ but I’ve gotten that before with no problems. I tried removing the drive itself from the housing but I couldn’t slave it because the drive is a SATA and I don’t have the connections (I have IDE) – I figured it would be easier to run my recovery software (spinrite or data recovery 2) by doing so since I couldn’t boot thru the usb (or can I?). I didn’t notice a power surge or anything so I believe the data is still intact.

-Is there anything I could do myself to salvage this drive?
-What pci card or equipment would I need to do this thru my desktop assuming that’s possible?


The problem is that it’s not reading thru the usb; I’m starting to think the WD “smartware” software is the root of the problem so I need to know how to bypass it when it’s connected.

There is a connector that is not very expensive and you can buy at any specialised store that will allow you to connect a HD to a USB port. I know that your HD is already external, but the cable is not expensive and maybe is worth a try. In my case, I had a MyBook external drive and it fell on the floor by accident… and I couldn’t recover the information inside… I had this connector so I opened the box and got the HD out of the case and plug it to my USB port… and it worked well enough to recover the info inside.

I plugged in a sata to usb adapter and while the desktop and laptop read a device plugged in:

The desktop (running winXP) doesn’t read it as a drive (not even in setup or computer mgmt) and the laptop (running win7) reads it in computer mgmt but states it must be initialized (reformatted) which I believe will just erase the drive if I do. I right clicked for ‘properties’ and it reads 0 volume. wtf?

I tried running spinrite but it doesn’t read it on the desktop and I have trouble accessing the BIOS on the laptop (HP pavilion) to change it to 'boot from cd). I’m going to keep looking for ways to get in (F2 and esc only takes me to a ‘setup’ that doesn’t access BIOS).

Try a plug-in caddy for the bare drive, which should allow you to access it through USB. Sounds like the firmware in the WD box could be corrupt, which is why you can’t get to it through USB while it’s still in the WD box.


Why don’t you try to download Ubuntu? the software will not start with Linux… and Linux doesn’t have any problem to read and use Windows strucutures and directories… and if you save your files in your computer, you will not have problems to read them under Windows. Download the USB boot version which is light and you can use your USB to start the computer, read what’s inside and then start your computer as usual.

This FAQ from WD may help too

I remember that I read something about a recovery tool… not sure though… going to search for the link and if I find it, I’ll post it. I did a lot of reading when my HD broke but that was a few months ago :slight_smile:

I appreciate your help :slight_smile: