Disk Read Error. And File missing. Boot Error

Yes I know there is a thread very similar to this, actually alive.

I read through it. However I’m not savvy at all with hardware stuff or anything non web relevant so I didn’t want to hijack his thread.

I read about pressing F8 and I would get some recovery console. I spammed F8 and was unable to get any sort of thing happen.

Here is my problem with as much detail as possible.

Upon start-up, I would get a Boot Error. Saying I need to select a new boot device, or something like that.

After messing around with some system settings, now when I restart, it’s just a black screen (after showing “Press Tab to show post BIOS message, F2 to run setup”) with a blinking underscore. That’s it. Hours and hours it’ll stay that. Every 1/3 start-ups it’ll try doing a loading bar thing at the bottom of the blank screen and try loading. But it says after like 1 or two bars fill, that PCI.sys is corrupted. IIRC that is the file name. When that loading screen doesn’t show up, it says I have a disk read error. I don’t know if the issues are the same or what.

There is only one thing I’d like recovered, because it took weeks of work, and that is an ANKI deck I made on there, with like 600 cards in it. It’s something for my Rubiks Cube stuff and it’s quite important to me.

I don’t have the money to take it to a recovery place. So I’d love you guys if you told me this is something even I could fix :).

As said before, I’m not smart with computer hardware stuff, or system stuff. So do try and give me a plethora of information, and how to fix something (steps as well)

Does the hard drive light blink at all (showing if the drive is doing anything?

Has the drive been making any unusual noises recently?

Has any message appeared when booting from S.M.A.R.T. ?

Have you had any power surges recently?

It sounds like your Hard Drive or the HDD Controller has failed.
You mentioned “After messing around with some system settings…” and that worries me.

So, to begin, can you describe the hardware; your system. Is it a laptop or a desktop? What brand is it? The manufacturer website might have good step-by-step (with photos) instructions.

Then please explain what “Settings” you changed. I assume they were in the BIOS (that initial screen that comes up regardless of any installed software).

I see a few lights going on at the botttom of the laptop, which is normal.
What’s S.M.A.R.T? How do I boot from that?
No unusual noises.
No power surges lately. That I know of. Though on an unrelated note, my battery is so shot that if I leave it unplugged for 5 seconds, it dies. My laptop also crashes a lot (programs I mean) because the processor is so slow. Crappy netbook.

My hardware I can’t describe unless you give me details on where to look.
It’s a netbook. Asus EEE PC 901. You can look up the specs on that.

I’ll actually go look up and see if the manufacturer has anything.

Sorry for the double post.


How old is the laptop and how much use has it had?

I got the laptop when I turned 17. So 3 years and 2 weeks old.

A lottttt of use.

A lot. Hours and hours a day.

Can you at least get into the BIOS menu to set it to boot from a CD? If yes, then you could try booting from a Linux disc, as I mentioned in the other thread you quoted in your first post. It’s not difficult and I can give you step-by-step instructions, if you want to give it a go. (It’s also free.)

I think your OS is corrupted. You might need to install your oS again. What is your OS?

I don’t think it’s the OS because according to the OP’s description of the symptoms it’s failing during POST and not even getting to the stage where the OS is even started. Much more likely to be a a hardware or BIOS problem.


My OS is Windows XP. My netbook doesn’t have a CD drive. Does this mean I can’t boot from a CD?

Also, how would I normally get to BIOS screen? I’ll see if I can get to it.

Googling gave me this site: http://www.sitepoint.com/forums/showthread.php?792581-Disk-Read-Error.-And-File-missing.-Boot-Error.&p=4984038#post4984038

go to the BIOS (press F2 to go to the AMI Bios)

Although he seems to be talking about a newer model, it still might work.

That would seem a logical conclusion. :slight_smile: However, I believe it’s possible to use the same approach but boot from a USB drive instead. I’ve never needed to do this, but I’ll check out the instructions.

Depends on your system. When you first start up, you should see a message telling you to press F10 or Del or something to enter BIOS or setup. Once there, there should be a menu to allow you to change the boot order. e.g. set it to boot from a USB device rather than your hard drive.

Edit: Beaten to it by Guido. Try F2 first!

Ah. That. Yes I can press F2 and get to the screen.

BTW, that pci.sys file I mentioned earlier is in the folder called DRIVERS. On that same error page it says hit “r” on startup to repair the file. Just a heads up. And on that startup screen I can also press “TAB” for a post BIOS message. Thingy. Whatever :p.

Anyway, I’m currently on the BIOS screen on my computer awaiting instructions.

Have you tried hitting “r” to repair the file? It might be the easiest option. If that fails, have a look and check if there is an option in the BIOS to boot from a USB drive.

I’ve tried, but nothing happens. No screen or anything appears. I don’t know whether it’s supposed to or not.

I’ve looked around there before and I don’t think there is an option. Any chance you’d know which “menu” it’d be under? I doubt I missed it but you never know.

Again, it depends on your system. Somewhere there should be a “boot order” or “boot options” menu, or something like that, where you can set the boot order e.g. 1st hard drive, 2nd hard drive, CD drive, etc. There’s probably also a menu to select the “boot first” device as a “one-off” i.e. you can choose to boot from a CD or whatever on this occasion, but next time it will revert to the normal boot order. I have come across a system where I couldn’t find that, but it was very old. I’m guessing that a three-year-old machine should be able to boot from a USB drive, but you’ll need to set it to do so in order to use that option. Best advice I can give you is just keep looking until you find it. :slight_smile:

Hmm, there’s no message listing all the device or hard disk at the start? It could be loose connection to the drive or the wire is fried. Or you disk is damaged.

So now you are agreeing it’s much more likely a hardware or BIOS issue :slight_smile: