Phase two of ruby gem install headaches

Ok so. morning all.
I need to install compass & sass in ruby. I spent some time searching and looking for the commands, started a ruby tutorials but that is primarily about programming in ruby, which i have not interest in doing.
In the ruby folder: C:\Ruby21
I have place a folder called C:\Ruby21\gems that has sass, compass & susy in it.
Can i just drag just drag them to the ruby command interface to install them? copy the to the one of the other folders that come w/the ruby install?
I tried the cd command , no dice. I’d rather move on and try to lean sass.
Thank you for your help

Once ruby is installed you should be able to just run gem install sass on the command line.

nope. tried that.
that firewall thingie.
also tried to go off vpn & no dice .
That is why am asking how to do it from command line.

Doing it from the command line would be C:\> gem install compass

But if you get this:

Then you’re blocked by a firewall and you need to do this:

Or do the proxy I suggested in your last thread.

1 Like

Awesome! thank you mawburn & hadn’t changed dir in a command prompt in ages but once i got around i got both susy & sass installed. compass seems to have some un-resolvable dependency issues. so i’ll deal w/that. think might need to choose another version.
thank you !

ps why did you blank out the user name in the screen grab?
i have posted some shots where i left mine in. didn’t think it would be a security issue.

last question i suppose. Do you folks use ruby for anything other than compiling css?

Yeah, I don’t think I was able to install compass using this method.

It contains my real name. I don’t feel comfortable using my real name online.

I do not. If you run into firewall issues like this, I wouldn’t suggest doing anything else with it, either. You need to get the proxy working from whoever runs your firewall.

Not to say Ruby or Ruby on Rails isn’t good, because it is. But, you’re going to need constant access to the gem repository to do much else with the langauge or try to do anything with Rails.

Thank you mawburn. Preciate all the info & assist.

Mawbur do you remember what you did to install compass?
I tried six diff versions of it. not one of them installed they all had dependency issues.
I tried uninstalling sass then installing compass.
still same prob.
Is there a diff program that would work the same as compass instead?

So how long have you spent on this? I’m just curious because seriously a vm w/ puphpet you would be up in about 10 minutes max. That is unless the issues you are having originate from a firewall blocking installation. In that case you really need to talk to whom ever manages the network and get the firewall issue resolved.

didn’t count as i was busy w/other tasks and want to pick up sass on my own time.
that being said. Yes it is a firewall issue. thought the thread would have established that.
I really appreciate that you love vm, vagrant & puphet…but that is not the solution for everybody. Some day i might get around to them. But it seems like a lot of other designers make do w/out them as well.
Thank you tough.
have a good weekend

As a learning exercise this is all find. However, when dealing with actual clients you are inevitably going to run into projects that use different versions of ruby and gems. So in that regards it is easiest to set-up a vm with rvm (ruby version manager) to fulfill the needs of allowing multiple ruby environments on a single machine. There are some projects for windows that do the same but the main one pik is no longer maintained and I haven’t tried the one which pik recommends uru zen as an alternative. So the safe bet is to use a dedicated linux environment for EVERYTHING since you can then use rvm on a windows machine indirectly via vm.

Oddz…i just wish vagrant, puphet and linux vm would pay you for your heartfelt endorsment :slight_smile:

So do I.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.