Install Compass gems for all users

I had Compass working correctly for one user on a linux machine. Starting

compass watch

worked without problems.

But if I logged in with another user on the same machine starting

compass watch

gives me this:

LoadError on line ["36"] of /usr/share/rubygems/rubygems/custom_require.rb: cannot load such file -- animation
Run with --trace to see the full backtrace

I have animation gem installed from here https://github.com/ericam/compass-animate
I’m guessing this is causing the problem?

Now I’m having problems even with the original user:

   create css/forms-rtl.css 
   create css/nodes.css 
   create css/pages-rtl.css 
Errno::EACCES on line ["25"] of /usr/local/share/gems/gems/sass-3.2.8/lib/sass/cache_stores/filesystem.rb: Permission denied - /var/www/html/pidteam/sites/all/themes/pidteams/.sass-cache/3dc4b9f0c4f30009e0899b7856303e7df4da16ec/pages.scssc
Run with --trace to see the full backtrace

I tried to install the gem with and without sudo, is that causing problems?

How do I make everything work for all users?

How did you install ruby? RVM installs to the users local directory into .rvm i believe, so whenever you’re installing a gem, it’s getting installed to the user account into a specific ruby version.

Seems like it would be more efficient, but having all users share the same gem could lead to issues down the road. Space is cheap and installing gems is plain easy, I would just require the gem in projects, and have each user use bundle install before getting started.

Thank you for your help! Yes I did install it for the second user as well.

There was also one other problem, the animation gem I used before was included in the next compass version, which was I guess updated in the meantime so they clashed. Once I sorted the animation gem on the old project, cleared and compiled CSS it all went ok.

But now I have another issue:

$ compass watch
>>> Compass is watching for changes. Press Ctrl-C to Stop.
[Listen warning]:
  Missing dependency 'rb-inotify' (version '~> 0.9')!
  Please run the following to satisfy the dependency:
    gem install --version '~> 0.9' rb-inotify
  
  For a better performance, it's recommended that you satisfy the missing dependency.
  Compass is polling for changes

When i try to install it I get this:

$ gem install --version '~> 0.9' rb-inotify
Fetching: ffi-1.9.0.gem (100%)
Building native extensions.  This could take a while...

ERROR:  Error installing rb-inotify:
	ERROR: Failed to build gem native extension.

        /usr/bin/ruby extconf.rb
mkmf.rb can't find header files for ruby at /usr/share/include/ruby.h


Gem files will remain installed in /home/name/.gem/ruby/1.9.1/gems/ffi-1.9.0 for inspection.
Results logged to /home/name/.gem/ruby/1.9.1/gems/ffi-1.9.0/ext/ffi_c/gem_make.out

I tried searching for a solution but couldn’t find anything within my non-programmer reach. As far as I can tell it does have something to do with dependencies or how ruby was installed.