Gem install sass not working

installed the latest version of ruby.
the command prompt

ruby -v

gives me

ruby 2.0.0p247 <2013-06-27> [i386-mingw32]

I then go & type

gem install sass

and nothing happens. I type sass and it is not recognized as an external or internal command etc…
What am I doing wrong please?



That’s weird.

Sass is compatible with Ruby 2 as of version 3.1.18, so that shouldn’t be an issue.

I just tried installing it on my Win 8 box which is running 1.9.3:

C:\\Users\\Pullo>ruby -v
ruby 1.9.3p429 (2013-05-15) [i386-mingw32]

C:\\Users\\Pullo>gem install sass
Fetching: sass-3.2.10.gem (100%)
Successfully installed sass-3.2.10
Installing ri documentation for sass-3.2.10
1 gem installed

What is the exact error message you are getting when you try to install the gem?

possible firewall prob?
"could not find a valid gem ‘sass’ <>=0>, here is why: unable to download data from

You’re not running Norton Internet Security (or similar) are you?

Also, it would be helpful to know what came after the “etc”, as that was the interesting bit of the error message.

a connection attempt failed because the connected party did not properly resond after a period of time, or established connection failed because connected host has failed to respond - connect <2> <;

My guess would be that it is a network issue and that your computer is behind a proxy/firewall that is blocking downloads from
Do you have any security software installed?
Do you have a rule for the ruby interpreter in the Windows firewall?
Are you using a proxy?

Hi Pullo, this is actually my work laptop. So i am betting on a solid firewall, and securities…so might just go to IT dept & ask them to help out.
will try it later on my home laptop. as it is i think there were no probs w/less. as they seem to be the same give or take I 'll just start picking up less instead.

No probs :slight_smile:

My money would be on some kind of firewall, too.

If the IT dept. won’t comply, maybe Less is a better bet for you, as it is written in JS and can be run on the client-side (where JS is present by default).

Had the same problem, I went to, downloaded that. CD into the unzipped folder and in the command line ran ‘rub setup.rb’.

Then reran the Sass installer and it worked fine.

Hope this helps.

Wow…that was a long time back. Thanks JonnoW but actually i gave up on sass for now. figure i’d focus on css3/html5 & js instead.
Take care

You should give it another shot. SASS/SCSS is pretty great. But of course, it’s just a CSS processor so you should have a fairly strong understanding of CSS before using it.

But, I had to do the same thing @JonnoW mentioned and it worked well.

Hello Mawburn. Actually i might have to go back and get acquainted w/less first. it seems one of the vendors we work w/ is using it. So more experience and a better understanding of that would be good.
So far our lead css/web person is not too happy they are doing that. Adding extra files & all