Error: D:\\ is not accessible. Incorrect funct

Hello,

The following is my laptop spec:

Technology TL-60
1.99Ghz, 1.87BG of Ram,
Physical Address Extension
Matshita DVD-Ram UJ-860H

Windows XP Professional
Version 2002
Service Pack 3

Now, whenever I insert a cd on my Matshita DVD-Ram UJ-860H, it shows this error message:
“D:\ is not accessible. Incorrect function”.
I experience the same whenever I insert a blank dvd rw.
However, if the dvd rw is not blank then I am able to see the contents of the dvd rw disc without getting this error.
What is wrong ?

On my Windows Registry, I have 24 instances of this:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}
and on more than one of then the “Upper Filter” exists therefore I am unable to decide which one’s “Upper” I should delete to see if the problem gets fixed or not.
I have seen on many forums others experiencing the same and getting advised to uninstall Roxio but I don’t think I have it or the Nero because I can’t find them on my Start-> All Programs.
And, I don’t think that, me not having a cd burner software is the problem because like I mentioned before, I am able to see the contents of a dvd disc inserted on my dvd drive providing the disc is not empty.

I have seen the following solution mentioned on the internet:
"Got to the Drive letter in Windows Explorer
and right clicking on it. Go to Properties; Click on Recording; Check “Enable CD recording on this drive”.
But the problem is, I can see only this much on my WinXp SP3:
Windows Explorer-> DVD-Ram’
and after right clicking on it -> Properties; but there is no “recording” tab.
Therefore, I cannot check the “Enable CD recording on this drive” option.

I am really stuck now ! Can some techie specialist help ?

Thank You

I didn’t say update the driver, I said uninstall the drive and reinstall it using the latest drivers. :slight_smile:

It’s probably because I uninstalled all the dvd burners few weeks back.
Which free ones you recommend ?

Windows doesn’t allow me to update the driver saying it’s the latest. :frowning:

You could also try updating the firmware.
Can be a tricky business when you do it wrong though, don’t blame me if it does :wink:

As it worked before, then ‘something’ has changed. Try downloading the latest drivers for it, then uninstall and reinstall it. If that doesn’t work, you’re probably out of luck.

Rushiku,

Before, with this dvd-ram drive, I was able to write to dc-r and dvd rw discs but now not. :sick:

As this is a DVD-RAM drive, have you tried using a DVD-RAM disc?

A DVD-RAM drive cannot record to a DVD-RW disc, though, I assume, once recorded, a DVD is a DVD and can be read by any DVD drive.

Firmware is hardware specific. You need to look on the website of the manufacturer of your dvd burner to see if they have firmware for your drive.
There is no such thing as “one size fits all” firmware :slight_smile: