Boot from DVD/CD fails

Greetings!

I have a problem with a friend’s PC… The PC is infected with a virus (or other malicious sw) which is blocking the internet connection. I tried to format the HD and reinstall the OS (WinXP), but the machine simply ‘refuses’ to boot from DVD/CD. I tried WinXP SP2 boot DVD, WinXP SP2 CD, Linux Ubuntu boot CD, nothing worked! The system says


Disk boot failure, insert system disk and press enter!

I replaced the optical drive with another (tested) DVD drive, same result… :injured:

Is it possible that the BIOS is harmed? Should I try to update BIOS???
Thanks for your advice!

You need to put the DVD drive before the hard drive in the boot sequence in bios.

Thanks j3ph but I thought it was obvious what I said at the code line, wasn’t it? :wink:

I think I misunderstood your original post. Normally when Disk boot failure, insert system disk and press enter! is displayed it is referring to a bad hard drive.

Have you tried connecting the DVD drive to a different IDE channel? Or tried connecting with a different IDE cable?

Have you tried deleting then re-creating the partitions on the hard disk?

Have you tried to access the book CD from a known working computer to verify that the disk works?

Thank you guys for the tips! :slight_smile:
Unfortunately, there’s only one IDE channel on the motherboard (the rest is SATA)… The IDE cable must be correct because the DVD drive is reading the media in Windows AND the Hard Disk is functional as well (it’s on the same IDE cable).

I couldn’t delete and recreate the partition(s) of the hard disk because I cannot load the partitioner (I can’t boot from DVD/CD)… :frowning:

The boot DVD and CD are both functional!

What’s the current order of devices to try and boot from set to in the BIOS?

Well, set up 1st and 2nd device for the optical drive (DVD/CD), the 3rd for the HD, the PC have not booted from the disc. Then I removed completely the HD and set just the optical drive (try other devices –> disabled).

Then I received the disk boot failure message for 3 boot DVD/CD’s (2 WinXP and Linux Ubuntu). I tried another optical drive too (a tested one) with the same result… :frowning:

Is the comp beeping when it is trying to boot?

Yes, I can enter the BIOS and the OS can be loaded as well (an infected WinXP SP2)! The MAIN PROBLEM IS THAT THE MACHINE WON’T BOOT FROM THE OPTICAL DRIVE!

Have you tried swapping the hard drive and cd-rom drive over so that whichever one is on the primary master is moved to the primary slave and vice-versa?