Cloning Wordpress site locally using xampp-problem!

Hi. Am cloining my wordpress blog to my local server, but having a problem that my homepage displays, but cannot get other webpages to display. Have edited my url’s to suit localhost address, but I click on one of my links and it just directs me to my default localhost/xampp page every time I click on a link.

Here is checklist that have done

Download my website to local folder using FileZilla, edited my wp-config.php

Exported my database using PHPmyAdmin and imported to my phpmyadmin locally and edited wp-options home and site url to suit my localhost directory.

Edited my links on my pages to suit localhost links.

Any idea where I could be going? As mentioned my homepage is fine all graphics, stylesheets etc are all working, but cannot get to another page.

Check out permalinks structure or htaccess file maybe.

My permalinks are set to postname

and not usre if anything is wrong with my htaccess file?

htaccess file is as follows

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /gomanandvan/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /gomanandvan/index.php [L]

Looks ok…
I had the same problem lately… What’s the url under the page link when you look at the source?

What’s the url under the page link when you look at the source?
Sorry dont know what you mean? Are you on about my localhost address? if so http://localhost/gomanandvan/

Take a look at source view…What is the link to page that you cannot see… (<a href=“???” >Services</a>)

Sorry bit slow there. Yeah my link is localhost/gomanandvan/services Have even tried to enter the link address in the browser url address, but does not go to the page just reverts to [URL=“http://localhost/xampp/”]http://localhost/xampp/ Proper head scratcher

[<li><a class=“navlinks” href=“http://localhost/gomanandvan/services”>Services</a></li>](<li><a class=“navlinks” href=“http://localhost/gomanandvan/services”>Services</a></li>)

Try disable permalinks and try again

Cannot disable permalinks snecz. Just have radio option buttons to select which are default, Day and name, Month and name, Numeric, post name and custom structure?

Have set permalinks to default and still not working, don’t know what the problem is. Crazy

And all the files you have in C:\wamp\www\agamaphoto\gomanandvan ?

Sorry, it’s xampp… So generally the files are in gomanandvan catalogue?

Couple things:

  • Make sure the .htaccess file for your Wordpress install is read/write for your computer user, not just read (this is what happened to me)
  • Are you absolutely sure you have the mod_rewrite module enabled on the Apache Server that RUNS xampp?
  • Open up C:/xampp/apache/apache.conf and make sure DocumentRoot is set to your projects directory
  • Edit or delete the original xampp index.html file and take out this line:
    <meta http-equiv=“refresh” content=“0;url=/xampp/”>

Make sure to clear your cache.

Hi Carlos. Am using a mac so will have a look for it. Will let you ASAP. Regards

Hi Carlos. Have definitely got the mod_rewrite module enabled ‘LoadModule rewrite_module modules/’

Hi Carlos. BINGO. Got it working thanks to you, much appreciated! Was having exactly same issue as you the .htaccess file for Wordpress needed to be read/write. Thank you!