Localhost WordPress problem

Can i still react to this topic? I hope so…

I am a recent user of WAMP and I installed Wordpress 3.5 on the localhost.
When I visit the home page I created in Wordpress, everything works fine. But when I want to navigate to another page I created (by clicking it in the menu) I get the following message:

Not Found

The requested URL /wordpresstest1/even-voorstellen/ was not found on this server.

Does anyone have a clue what I am doing wrong? Any help is much appreciated.

Hi pelgrimrat,

Welcome to the forums.

Where did you install WordPress on your hard drive?
For example, I use xampp to test locally and mine is located at C:/xampp/htdocs/wordpress.

Also, could you post the contents of the .htaccess file located in your WP root folder.

Hello Pullo,

Thanks for the quick reply!!

The Worpress installation is located at

Content of the .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /wordpresstest1/
RewriteRule ^index\\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /wordpresstest1/index.php [L]

# END WordPress

Thanks for your time!

No problem!

The .htaccess file seems to be ok.
Can you access your WP dashboard? (something like http://localhost/wordpresstest1/wp-admin/ for you).
If so, go to “Settings” -> “General”
What do you see listed under “WordPress Address (URL)” and “Site Address (URL)”?

Yes, I can access the dashboard. I can also normally view the home page I created. The problem starts when I try to view the other pages.

WordPress Address (URL): http://localhost/wordpresstest1
Site Address (URL): http://localhost/wordpresstest1 (the same)

Weird. That’s all as it should be.

If you go to “Settings” -> “Permalinks” what is your permalink structure?

Try reverting it to “default” and see if that makes a difference.

If it doesn’t can you please post your new error message.

It should now be different to

Not Found
The requested URL /wordpresstest1/even-voorstellen/ was not found on this server.

That did the trick!!!
I had tried setting the permalinks to ‘custom’, bit it automatically changed back to ‘post name’.
Now I set it to ‘default’ and I can view the other pages as well!!

Thank you so much for helping me so quickly! Now I can continue with the site!

You’re welcome.
Thanks for taking the time to follow up :slight_smile: