Cloned xampp Wordpress site doesn't show posts

I’ve made a local copy of a live WP site with XAMPP and I’ve noticed my post pages get routed to a XAMPP page titled, “welcome to XAMPP for Windows.”
I’ve looked at other posts and I don’t think it’s my .htaccess file permissions, as I’ve changed them to full permissions.
Any help greatly appreciated.

Where do the WordPress files live on your hard drive?
They should be somewhere below C:/xampp/htdocs (presuming a Windows install)
The page you are seeing is the default Xampp landing page and is reached via ‘http://localhost/
You’ll need to type ‘http://localhost/path_to_the_root_folder_of_your_wordpress_install_relative_to_xamps_htdocs_folder’ in to the address bar.
For example, for me this is ‘http://localhost/wordpress/’ (imaginatively enough).

I don’t want to have to modify the URL for every page I want to see, so how do I set the path? Do I set the root directory in httpd.conf or something? I’ll look at that. So I just did that. It’s around line 183. "DocumentRoot “C:/xampp/htdocs/” and I appended the subdirectory at the end of the path. But there must be something else I need to do because that didn’t fix it. I cleared Chrome’s cache as well. Am I on the right track?

Let’s just see if we can find WP first.
What happens when you type in ‘http://localhost/’ followed by the path to your WordPress root directory, relative to the htdocs folder?

I’m not trying to be funny, I just want to be sure that WP is running, then we can look at how you would rather have things.

I also tried changing the wp_cofig.php file where it sets the WP_HOME and WP_SITEUDRL and that didn’t work either. Should I be using a trailing slash on both of them?

which folder on your hard drive contains your wordpress files?

I get to the site by typing in that URL.This is one of those “one-page” sites, so I see a lot of content. But when a link goes to another page for a post, that’s when I get to the default xampp page. Thanks for your help.

Ok, one last try. I think we’re getting our wires crossed.
My wordpress install is located at C:/xampp/htdocs/wordpress.
This means I can access it via http://localhost/wordpress/ (with trailing slash)

Where is yours located?

path is c:/xampp/htdocs/[folder that contains WP files]
Sorry,I think we were responding to each other’s posts at the same time.

Ok, and what happens if you enter http://localhost/name-of-folder-that-contains-WP-files/ ?

I get to the home page of my site with seemingly all the content there. It’s only when I have to go to another page (like a post) that I get the xampp screen.

Ahh, ok, now I understand.

Can you access your WP dashboard via http://localhost/WP-folder/wp-admin/ ?


Go to Dashboard -> Settings -> General and check that the WordPress Address URL is set to http://localhost/WP-folder
Does that help?

yes, it’s correct there, but no trailing slash. It’s also grayed out so I can’t edit it directly there.

Yeah, the trailing slash isn’t important, but it shouldn’t be grayed out.
What does the Site Address say?
Which version of WP are you running?

WP 3.4.2 is the version. site address same as WP address.

That’s weird then.
What’s the .htaccess file in your WP root folder saying?
Could you post the contents of that file?

BEGIN WordPress

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

END WordPress

Change this:
RewriteBase /

RewriteBase /your-wordpress-folder/

Does that work?