Wireless there, can't get an IP

ok, my problems a lil weird, but typical!! ok let me start explaining how it happen. I have the Logitech Cordless MX Duo Keyboard. I also have the [URL=http://www.linksys.com/products/product.asp?grid=33&scid=36&prid=435]Linksys Wireless “B” USB Adapter WUSB11 and I got a notice to update my drivers and I followed along. I installed the keyboard drivers and restarted my computer and my wireless was GONE! My computer can find the wireless network (my SSID shows up) but it wont get an IP. Now my keyboard was connected thru USB @ the time, and my linksys wifi adapter was plugged in as well. I installed WinXP SP2 last week, and that went smooth, and I didnt notice and flaws until now. I was getting a no connectivity error message. It was telling me that it couldn’t renew my IP address. So I hit repair and continued to get the same message. So I know a little about internet connections so i went and checked my router to make sure that it was handing out IP’s from the DHCP, and sure enough it was. I even tried that same USB adapter on my laptop and that worked just fine. My laptop is running service park 1a. So after a day of not being able to get online, I’m losing it and uninstalled WinXP SP2 from my main computer, b/c im thinkin that its the service pack 2 install. well, with my luck it wasn’t Im still getting the same error under service pack 1. I know my usb ports work, b/c my scanner, digiCAM, and webcam work fine. I talk to linksys and they couldnt figure it out. I know my router is ok, b/c all my other computers can get IP’s from my router. I dont know what to do, I need my internet. I’ve got lots of PHP questions! LOL But let me say thanx in advance to replies. I won’t be able to check my email as frequent as usual, my computer is no good to me w/o internet!


Are you sure your computer is setup to receive the IP through DHCP? The router might be handing out the addresses but your computer may have it set not to receive.

Also, is your wireless adapter configured for WEP?

I just checked my TCP/IP settings for that linksys wireless b adapter and its showing obtain address automatically. I disabled WEP for this particular situation. I’m about to go and try and ping my router from that computer.

I can actually ping my router and I get a response, it just wont give my computer an IP address. I think has something do w/ my computer? any suggestions?

Maybe it’s your router not wanting to hand out IP addresses. If you are able to ping the router then you should get an IP.

What is the IP that it shows when you go to your connections properties? Is it ?

its shows the default IP for that Linksys Wireless adapter which is I tried that same adapter on my laptop and it gave that computer an IP address. and its giving the computer that Im using right now an IP address.

I even tried manually configuring the IP for that computer. I gave my computer its own IP address, subnet mask and default gateway. Of course, I applied these settings according to my router, and still no internet connection. I’m starting to believe that TCP/IP is corrupted on that computer. Is there a way to reinstall or whatever the TCP/IP?

I pinged the router, I tried to renew IP address from the command prompt… wouldnt work :bawling:

I don’t think your TCP/IP is corrupted…

The next thing I would try is to uninstall your wireless adapter completely and then reinstall it and try to get an IP after that.

I attempted that, the linksys techie had me do that like 50 times. instead of just placing a new one in my device manager, everytime i uninstalled and installed the drivers, it came up as, “Linksys Wireless network adpater #1, Linksys Wireless network adpater #2, Linksys Wireless network adpater #3, Linksys Wireless network adpater #4” and now I’m on 5 and still no luck. i’m tired of Windows bout to get a MAC! dammit lol

hey hartmann I GOT IT!!! so happy. Had to do a lot of research and found out that theres a couple of people out there that have the same problem as me. It was my TCP/IP protocol, it was corrupted. I downloaded a program called WinSockXP fix and it when into my registry and put the keys that needed to be replaced in the right spot, rebooted, AND BAM!! im online again! thanx for all ya help. you being a mentor and all should remember this post b/c i can see this problem coming up for a lot of other people. People w/ dial up and even wired LAN connections were having the same problem!!!

Really glad you got it fixed! :smiley:

I am just did a search on Google about TCP/IP corruption on Windows, pretty interesting how easily it can happen (didn’t know that it was that common).

I’ll definitely remember thsi thread :wink:

I had the exact same problme as MystaMax, the only difference being i have xp home not pro. mine also occured after installation of service pack 2. iv tried just about everything including WinSockXP fix and even that had no efect. i still get the “limited or no connectivity” message popup in the bottom right and the network icon with the yellow triangle and an explanation mark although, as MystaMax said, there is no identifiable problem with surfin etc. repairin doesnt work, winsockxp fix doesnt work and i cant even uninstall SP2 - it has some strange message about having decided to Bosnian! :S and that it is not compatible before SP2 and that i have to change it b4 i can uninstall which i cant do because u need the readmesp.htm file to do that (apparently) and that doesnt come with the auto update. please help someone! im gonna try n get the head of IT at skool (whos a gd frend of mine) to give it a shot but i really am at a loss when even what u guys say is a solution failed. HELP! :S

have u tried going into command prompt and releasing and renewing ya IP addys? If you aren’t familar w/ command prompt you can download the old familar WinIPcfg program that will have a GUI interface allowing you to release and renew any network adapters IP address, you can get that @:


it’ll work under WinXP pro and home. I’m use it now, and it works well :slight_smile:

I also went ahead and did a google search for you, to find other means of replacing your TCP/IP protocol, which is what is needed for to fix your problem (if it is as similar as you say it is to mine)


hope that helps, and i’ll try and help as much as i can :slight_smile:

I have a problem…I have a shared internet connection with my mother’s router. Long story…had the line put in and with WIN 98 there was really no problem connecting…then a tractor ran over the connection (yes I know…I live on a farm)…then we ran a new line and in the mean time i upgraded to a new puter and WIN XP Pro and the connection could not be established at all…Clueless I gave up after about a week (school started) and dealt with internet on dial-up…still on dial up *** However, last night…out of curiosity i connected the lan line again and voila! i got it to work. Then this morning…i don’t know what I did but it wasn’t working. How do I connect to the internet using the line that I put in. What are the right steps? I have tried making a internet connex…but it doesn’t work…Here are my specs…
Win XP Pro
Line from router to my puter…
Had a connection yesterday…cannot recover it
Keep getting error about limited or no connectivity
I have run the wizards and still natha…
When I set it up the right way, I had to restart…then when I restarted I had a message appear when I did…the only thing is i don’t remember how i did it.

Please someone be kind enough to help me…I am lost…


you have WinXP SP2 correct? what type of router do you have? read the rest of this post concerning the command line, and follow those steps and let us know what you get. are u getting an IP address?

Yes I have the new SP2 thingy. We have a Belkin router…I was not getting an IP addy at first cause for some reason the repair would not work using the arp -d command in the run box. I went to this site…
and downloaded said file. I ran it…although I was unable to back up my registry due to some kind of error…C:\ERDNT Security ! it was a warning and kept asking me to renew…after a little research…I decided not to back up that way and back up conventionally…I ran the pgm, rebooted and VOILA!! I am talking to you via non-dial up and dern does it feel GREAT!!! I think I am going to go watch a few movie trailers…a pleasure you cannot enjoy on dial up…

Thank-you so much…I so appreciate your help and all who suffered without internet or with dial - up…I am glad this thread pops up in google! THanks again so much…I truly am grateful! Woo Hoo!!!


Okay…the celebration was premature. I was out of the house all day and did not use my puter, but left it up and running…when I got home I came and checked to see if I could access the internet and check mail via OE…Must to my dismay…I could not. Why would my internet connection just stop working? THe little icon in the bottom right hand corner is still showing that it is connected…althoug the little lights flash VERY VERY slow…what can I do now…I am so at a loss…it is frustrating…OI VAY…Please advise me again…what do you think is causing the interruption in the connection?


Another note…after i wrote this I ran the winsock xp thingy again…it is working again…why won’t it stay fixed though? What could be causing my registry to corrupt again so soon?


try not to use your router @ all, just hardwire from your modem straight into your puter, bypassing your router.

Thing is it is my mother’s modem and I do not think there is another slot for me. We bought this thing with the intention of running my puter in my house, the antique shop puter in her shop and the construction business in my dads shop…so far it has been nothing but a headache…I am back on dial up now cause I cannot get it to work at all…:(:(:frowning:


Now when I enable the LAN I cannot even get an IP address off the bat…OI VAY!!

Hey guys…
well i have the same problem as MystaMax and i was simply looking for the reason andsolution.

so, for my first post i would like to bash on LinkSys for the ****ty product and technical support.
As soon as i was having this issue i called their technical support, eventually got transferd to their senior technician who concluded that it was defective.

i swiched it with another one today and get the same problem.

the sad part is i tried it on multiple machines and THEY ALL SHOW THE SAME PROBLEM.
WindowsXP or Windows2K… same issue.

i dont think it has much to do with windows… i would say the drivers (from linksys or microsoft) have poor support.

well… i am going to try MystaMax’s solution (hope it works for this pc(win2k))

i would like to thank MystaMax.

i am just surprised that linksys can not help people for that issue… i am sure they get tones of calls for this problem.

good day everyone.

i would also like to say good jobs to the admins of this forum.
very friendly and mature people :slight_smile: