Website Error codes?

Error pages

400 Page (Bad request)
401 Page (Authorization required)
403 Page (Forbidden)
404 Page (Wrong page)
500 Page (Internal server error)

Does anyone know where I can get a full listing of website error codes and what causes them?

Im looking to do some customised pages, ran a search on the forums, didn’t get anything back.

Crippler I think this covers most HTTP error codes:

100 Continue
101 Switching Protocols
200 OK
201 Created
202 Accepted
203 Non-Authoritative Information
204 No Content
205 Reset Content
206 Partial Content
300 Multiple Choices
301 Moved Permanently
302 Moved Temporarily
303 See Other
304 Not Modified
305 Use Proxy
400 Bad Request
401 Unauthorised
402 Payment Required
403 Forbidden
404 Not Found
405 Method Not Allowed
406 Not Acceptable
407 Proxy Authentication Required
408 Request Time-Out
409 Conflict
410 Gone
411 Length Required
412 Precondition Failed
413 Request Entity Too Large
414 Request-URL Too Large
415 Unsupported Media Type
500 Server Error
501 Not Implemented
502 Bad Gateway
503 Out of Resources
504 Gateway Time-Out
505 HTTP Version not supported

cool! thanks xhtml … can we archive this post?


I wasn’t expecting there to be THAT many!

Thanks xhtml, appreciate it.

Now how on earth did mvd’s reply get to the top of the post?

There were some difficulties with the forum and server, which have caused this. This problem also occured in a couple of other threads.

The full definitive list, together with explanations of what they all mean, can be found in section 10 of RFC 2068

It’s a 100kb text file formatted for printing, but if you do a text search for “Status Code Definitions”, it should take you to it. And, of course, it’s an RFC, so the language can get a bit techie in places.

For those running Apache, here is the joy that is the ErrorDocument directive. This way you can warn users about missing pants. shurg It’s some inside joke at work, something about powerful pants or something.

All of the fun at work comes from the Crack Benefits Package that we get… mine activates in a few more weeks… :eek"

On a more reality-based note: I love apache directives. They’re relatively easy and extremely powerful.

Originally posted by xhtmlcoder
[B]Crippler I think this covers most HTTP error codes:

100 Continue
200 OK
201 Created
202 Accepted

Is this errors??

No not all were errors, I let quite a few other status codes slip past the net :smiley:

Is this errors??

nope, they’re “status codes”. more generally, error codes are a subset of status codes…blah :wink:

Look at HTTP/1.1: Response codes

-What they mean
We have tried to assemble a list of some of the more common Error Messages and have explained what they mean and how to fix the problem.

The descriptions in this particular section are a lot more detailed than the other error articles, and generally provide a specific action that should remedy the fault.

The other articles contain a full listing of all error messages and simply have a brief translation from Error code to English.

To quickly find the answer you were after, you can press CTRL F and enter your message.

Obviously, if you can’t find an explanation or don’t understand the one we have written, please don’t hesitate to email me

400 - Bad request

There’s something wrong with the URL (Uniform Resource Locator) you typed. This can be caused by one of the following:

  • The server you’re contacting doesn’t recognise the document you’re asking for

  • Your browser doesn’t support the form you’re trying to access

  • It doesn’t exist

  • Not authorised to access it


Check the spelling of the URL. Pay special attention to uppercase and lowercase letters, colons, and slashes.

There may be a problem with that document. Send a message to the site administrator. Normally <>

401 - Unauthorized Connection refused by host

This error will usually occur, when an Internet site is protected, and the server didn’t receive the correct password for entry.


If you are registered with the site, you could try entering your password again if you have the opportunity. As with URLs passwords are often case sensitive, so type the password carefully.

If you aren’t registered, but think you’re eligible for one, contact the site’s Webmaster and ask for it.

Some sites also put a block on domain types–if you’re not from a .gov or .edu domain, for example, you may not be able to gain access.

403 - Forbidden

This error will usually occur, when an Internet site is protected and the wrong password was entered.
It could also mean that the server isn’t properly configured.


If you are registered with the site, you could try entering your password again, if you have the opportunity. As with URLs, passwords are often case sensitive, so type the password carefully.

If you aren’t registered, but think you’re eligible for one, contact the site’s Webmaster and ask for it.

Some sites also put a block on domain types–if you’re not from a .gov or .edu domain, for example, you may not be able to gain access.

404 - Not Found or File Not Found Unable to Locate the Server

This means that the document you’ve requested no longer exists in its original location. This could be because:

  • Document has been moved to another location on the server

  • The URL may have been mistyped

  • Has been removed entirely from the system


Try carefully retyping the URL, paying particular attention to capitals and making sure there are no spaces.

Try going one level up, by deleting the portion of the URL that follows the last slash, to see if the site is live. If it is, check to see if there are links to the document you were looking for. Failing that, you could delete the last slash and type .html instead and see what that gives you.

It may also mean that this site doesn’t exist any more.

500 - Internal Error

The server was unable to send the HTML document, due to an internal (server software) error. An improperly configured server causes this.

Contact the site’s administrators and tell them to fix it

501 - Not Implemented

The server doesn’t support the feature you have requested.


Don’t request it?

502 - Service Temporarily Overloaded

This error indicates that the server is experiencing high-traffic load and can’t process the request.


You can often access the site by trying to reload it. If the error persists, you may want to try again later.

503 - Service unavailable or Gateway Timeout

One of your settings (Gateway) is wrong.


It is fairly unlikely that you will get this error, if you do, contact the administrator, or even the ISP, as it’s a fairly big problem ™

You can’t log on as an Anonymous User

This error message appears when you try to access certain FTP sites.

*It indicates that the site allows access only to registered members

*The site may only allow access to a limited number of non-members, in which case the site is simply busy

*Your browser may not support anonymous FTP access


You can try to access the site again later, or if you’re a registered member try entering your User ID and Password manually using FTP software package.

Too many users Network Connection was refused by the Server Too many connections–try again later

No site has unlimited access: physical connections or administrator policy allocate a number of anonymous users to a given site. When that number is exceeded, all who try to log on, receive this message. This error frequently turns up when you try to connect to a busy FTP software site that can’t generate its own error messages.


Just keep trying until you get lucky. However, on a busy site (like Netscape’s the week after a big announcement) or one with very limited access rights, you may be out of luck. If so, check to see whether the site has mirror sites, and try one of those.

Cannot add form submission result to bookmark list

You have just entered a search request and tried to save the result as a bookmark. Though it may appear as a discrete address, the result isn’t a legitimate URL, so you can’t add it to your bookmark list.


Try using the ‘Save As’ command from your browser, then add the saved page to your bookmark list. Depending on the CGI/asp/php etc script behind the query, you may or may not be successful. You never know, it could be worth a try.

Host unavailable

The ‘Host Unavailable’ error occurs when the host server is down. This could possibly be for maintenance.


Hit the Refresh or Reload again. But wait a while between refreshes.

File contains no data

The site you’ve accessed is however the right one, but there are no Web page documents on it. You may have stumbled upon this site just as updated versions are being uploaded.


Try the URL again, carefully. If that doesn’t help, try again in an hour. You could also sometimes by-pass this error by re-typing the URL with a :80 before the last slash. For example

Helper application not found

Your browser didn’t recognise a file at the Web or Net site you visited. Most browsers can be extended using helper applications (or viewers) to read files they don’t otherwise recognise. These files aren’t necessarily graphics–they can be sound files, movie clips, or ZIP or SIT archive files you’re trying to download.


The dialog box that carries this message will usually give a clue about the file type that’s missing. (You may see some gibberish about octet streams, but after that you’ll probably see some reference to graphic-TIFF, which gives it away.) Look at our help for your computing platform (Windows, Mac etc) for viewers for the most common file types. Then follow your browser’s instructions for assigning a viewer for each file format that you wish to view online.

NNTP server error

You’re trying to log on to a USENET newsgroup, but you can’t get to it. The Usenet server is one of the services that most ISP’s provide; however they can’t subscribe to all the newsgroups in the world, so it may be that this newsgroup isn’t available.


Make sure you’ve typed the URL correctly. If that doesn’t help, You could let them know that you would like it enabled, and they may then look into making this available, provided there is enough interest from other people.

Permission denied

This error message occurs when your are trying to upload a file to an FTP site. The error indicates that the site will not allow the upload, the site is too busy, or you have typed the wrong URL.


Check the spelling first and type it again. If the error message reappears, try again later. If it persists, send email to the Webmaster and ask how you can upload a file to that site.

Host Unknown
Unable to Locate Host

These errors will occur for one of the following reasons:

  • The host server is down for maintenance,

  • You typed the URL incorrectly.

  • You’ve lost your Internet connection


Hit the Reload/Refresh button. This is often a temporary problem with the Net. Check the URL for any spelling mistakes (and don’t forget case-sensitivity), then make sure you’re connected by hitting Reload/Refresh, which will re-establish connections in many cases.

Viewer not found
Helper Application not found

Your browser doesn’t recognise a file at the Web or Net site you’re visiting. Viewable files aren’t necessarily graphics–they can be sound files, movie clips, ZIP or SIT archive files, and so on. If it’s not a GIF or JPEG file, your browser may not know what it is.


Save the file to disk and then get the application called for by it. Setup in the browser Helper section is required to make it work
The dialog box that carries this message, will usually give a clue about the file type that’s missing. (You may see some gibberish, but after that you’ll probably see some reference to graphic-TIFF, which gives it away.) Then just follow your browser’s instructions for assigning a viewer for each file format that you wish to view online.

Failed DNS lookup

The domain name system (DNS) can’t translate the URL into a valid Internet address. This is either:

  • A harmless blip

  • The server that you’re trying to connect to may be overloaded with traffic or temporarily down

  • The result of a mistyped URL (specifically, a mistyped host name).

  • If you’re accessing the Internet via a modem and you get a DNS error for each Web Site you try to access, chances are something is wrong with your connection.


  • Blips in DNS lookup can be fairly common, and often you can rectify this by clicking the Reload/Refresh button. If that doesn’t work, check your typing of the URL carefully. If the problem persists,

  • You could also try re-launching your browser and your required communications software. If the problem persists, contact your ISP and they can talk you through some other options.

  • Unfortunately, there’s no easy way for you to tell whether a server is down or just busy. Try again after an hour or so.

Please check your username and password and try again

Username Password is wrong


If you can’t connect because your password is not working, double check that you are typing in the letters EXACTLY as shown on your signup sheet. All usernames are in lower-case and passwords are case sensitive.
The most common password problem is the CAPS LOCK key being on Also, make sure you are not using your e-mail login name and password. If you have tried all of this, please call the helpdesk and we can re-set your password.

how about that for my first ever post here :wink:

and for added fun, dial up error codes (always helpful when calling the helpdesk, and it makes you look like a g33k :))

600 An operation is pending.
601 The port handle is invalid.
602 The port is already open.
603 Caller’s buffer is too small.
604 Wrong information specified.
605 Cannot set port information.
606 The port is not connected.
607 The event is invalid.
608 The device does not exist.
609 The device type does not exist.
610 The buffer is invalid.
611 The route is not available.
612 The route is not allocated.
613 Invalid compression specified.
614 Out of buffers.
615 The port was not found.
616 An asynchronous request is pending.
617 The port or device is already disconnecting.
618 The port is not open.
619 The port is disconnected.
620 There are no endpoints.
621 Cannot open the phone book file.
622 Cannot load the phone book file.
623 Cannot find the phone book entry.
624 Cannot write the phone book file.
625 Invalid information found in the phone book.
626 Cannot load a string.
627 Cannot find key.
628 The port was disconnected.
629 The port was disconnected by the remote machine.
630 The port was disconnected due to hardware failure.
631 The port was disconnected by the user.
632 The structure size is incorrect.
633 The port is already in use or is not configured for Remote Access dialout.
634 Cannot register your computer on the remote network.
635 Unknown error.
636 The wrong device is attached to the port.
637 The string could not be converted.
638 The request has timed out.
639 No asynchronous net available.
640 A NetBIOS error has occurred.
641 The server cannot allocate NetBIOS resources needed to support the client.
642 One of your NetBIOS names is already registered on the remote network.
643 A network adapter at the server failed.
644 You will not receive network message popups.
645 Internal authentication error.
646 The account is not permitted to log on at this time of day.
647 The account is disabled.
648 The password has expired.
649 The account does not have Remote Access permission.
650 The Remote Access server is not responding.
651 Your modem (or other connecting device) has reported an error.
652 Unrecognized response from the device.
653 A macro required by the device was not found in the device .INF file section.
654 A command or response in the device .INF file section refers to an undefined macro
655 The <message> macro was not found in the device .INF file section.
656 The <defaultoff> macro in the device .INF file section contains an undefined macro
657 The device .INF file could not be opened.
658 The device name in the device .INF or media .INI file is too long.
659 The media .INI file refers to an unknown device name.
660 The device .INF file contains no responses for the command.
661 The device .INF file is missing a command.
662 Attempted to set a macro not listed in device .INF file section.
663 The media .INI file refers to an unknown device type.
664 Cannot allocate memory.
665 The port is not configured for Remote Access.
666 Your modem (or other connecting device) is not functioning.
667 Cannot read the media .INI file.
668 The connection dropped.
669 The usage parameter in the media .INI file is invalid.
670 Cannot read the section name from the media .INI file.
671 Cannot read the device type from the media .INI file.
672 Cannot read the device name from the media .INI file.
673 Cannot read the usage from the media .INI file.
674 Cannot read the maximum connection BPS rate from the media .INI file.
675 Cannot read the maximum carrier BPS rate from the media .INI file.
676 The line is busy.
677 A person answered instead of a modem.
678 There is no answer.
679 Cannot detect carrier.
680 There is no dial tone.
681 General error reported by device.
691 Access denied because username and/or password is invalid on the domain.
692 Hardware failure in port or attached device.
698 A response keyname in the device .INF file is not in the expected format.
699 The device response caused buffer overflow.
700 The expanded command in the device .INF file is too long.
701 The device moved to a BPS rate not supported by the COM driver.
702 Device response received when none expected.
707 X.25 diagnostic indication.
708 The account has expired.
709 Error changing password on domain.
710 Serial overrun errors were detected while communicating with your modem.
711 RasMan initialization failure. Check the event log.
712 Biplex port is initializing. Wait a few seconds and redial.
713 No active ISDN lines are available.
714 Not enough ISDN channels are available to make the call.
715 Too many errors occurred because of poor phone line quality.
716 The Remote Access IP configuration is unusable.
717 No IP addresses are available in the static pool of Remote Access IP addresses.
718 PPP timeout.
719 PPP terminated by remote machine.
720 No PPP control protocols configured.
721 Remote PPP peer is not responding.
722 The PPP packet is invalid.
723 The phone number including prefix and suffix is too long.
724 The IPX protocol cannot dial-out on the port because the computer is an IPX router.
725 The IPX protocol cannot dial-in on the port because the IPX router is not installed…
726 The IPX protocol cannot be used for dial-out on more than one port at a time.
727 Cannot access TCPCFG.DLL.
728 Cannot find an IP adapter bound to Remote Access.
729 SLIP cannot be used unless the IP protocol is installed.
730 Computer registration is not complete.
731 The protocol is not configured.
732 The PPP negotiation is not converging.
733 The PPP control protocol for this network protocol is not available on the server.
734 The PPP link control protocol terminated…
735 The requested address was rejected by the server…
736 The remote computer terminated the control protocol.
737 Loopback detected…
738 The server did not assign an address.
739 The remote server cannot use the Windows NT encrypted password.
740 The TAPI devices configured for Remote Access failed to initialize or were not installed correctly.
741 The local computer does not support encryption.
742 The remote server does not support encryption.
743 The remote server requires encryption.
744 Cannot use the IPX net number assigned by the remote server. Check the event log.
752 A syntax error was encountered while processing a script.