Unable to post new thread

The Contact Us page suggested I post my question here first:

I just tried to post a new topic in your General Web Development forum. I tried twice, and it appeared to work, but my post isn’t showing up under either the forum or my account.

I thought that it might be because it’s my first post and must be approved by a moderator, but my friend Serenarules who has much experience with your forum says you don’t do that, and that there must be something wrong with the forum if it’s not showing up.

Please fix your forum.


Welcome to the SP forums.
For some reason your post triggered the automatic moderation script that puts posts that need a moderator to look at them before being published. That’s why you didn’t see them.
I now approved one of them in the General web development & Application design issues forum: http://www.sitepoint.com/forums/showthread.php?920501-Help-finding-a-programmer
and removed all others.

Ok, thanks. My friend, who has used this forum for several years, says that’s never happened to him.

It doesn’t happen often, but it does happen.

It would also be useful if the forum were to notify me that the post was being held for moderation, instead of just dumping me back at the index after I hit post.

Let’s see what our administrator @HAWK; thinks about that idea.

TBH I thought it DID do that! I’ll look into it because I agree - you should be notified.