Self web hosting

Hello all

I’m trying to host my site on my own machine. I’m using wampserver.

I tried all things as much as I can search on google but still not able to access it over internet.

I’ve registered on Dyndns .com and as well on no-ip too.

On my adsl router, I forwarded the port 80, to my machine ip. still not able to access it.

While if I change my ip on in my account to my machine ip instead of external ip, then I can access it by typing my dyndns hostname.

But others are not able to access it. How can make it work ?

Most ISPs block port 80 for residential use. Try using a different public port, say 8080. Then forward 8080 to 80 on your router (or tell Apache to check port 8080).

Port 8080 is blocked by my ISP. and 80 is open.

But then port 80 is being used to access the web interface of my router admin panel.

One thing I forgot to mention here that I’ve not altered or modified my apache settings or didn’t add any entry for virtual host.

It is just raw as I d/l from wampserver’s site and installed on my machine.

So do I need to configure it or it will work fine w/o any modification ?

If you can brows by local IP address, then you do not need to worry about Apache for port 80. Make sure the local server firewall. To enable port forwarding or nating you should refer the documentation of your ADSL router.

It seems that you are using two DNS services. First try only one DNS service either or no-ip.

Do not use your local IP address in the DNS registration as it is not live IP address. Only use the external IP address. If external IP address settled at is accurate, then the problem surely from your ADSL router or local server.

I uninstalled the no-ip and not using that. I’m only using dyndns now.

I’ve a static ip 59...***, made the apache to listen the port 8080 as well, forwarded both port on router to the same local ip, disabled th firewall, but still no sucess… :sick:

The Problem I’m facing is when ever I’m trying to access by using wanip, I’m getting the login form. :shifty:

Here is my router configuration for port forwarding.

Now please point out, where I’m going wrong.

So where is configuration?

I’ve inserted the pic but dunno why it is not showing, while if you right click on that fractured mark and open in the new tab, then it will show that.

I’ve uploaded that pic to picasa.

Here I’m inserting again both the link as well the pic.


Maybe it will be more simply to buy a VPS?