Running more than one version of Java?

Could someone around here help me understand something about running more than one version of Java?

I’m trying to run some training CDs from Oracle on my computer and from what I understand, they all require version 1.5.whatever… I previously had the more recent version 1.6.whatever and I did the following to ensure that the older version “was taking precedence” for these CDs I have (by the way, I’m running XP Pro):

1.) Installed Java version 1.5… Everything installed okay; no problems at all.
2.) Went into “Settings / Control Panel / Java / Java Tab”, clicked on “View” and made sure only 1.5-specific environment settings were checked. Pressed “OK”.
3.) When none of this seemed to help, I finally decided to right-click on “My Computer” where I then went to “Properties / Advanced Tab / Environment Variables” to edit the PATH variable to reflect the Java 1.5.whatever version I sought to use while also adding the SHLIB_PATH variable to reflect the value of my shared library (i.e. - “C:\Program Files\Java\jre1.5.0_11\lib”). Both of the above environment variables were within the “User variables” section.

Everything I did I did so without a computer restart. Would this explain why these CDs won’t run? I ran them perfectly fine when I had ONLY 1.5.whatever installed, but now that 1.6.whatever is installed, the CDs just nosedive upon the intro screen that pops up upon inserting them into the drive.

Any ideas or insight is appreciated. :injured:

what is the value of your JAVA_HOME environment variable? if you set it to “C:\Program Files\Java\jre1.5.0_11” does it help?

Thanks for the suggestion, Jurn.

I created a environment-user variable with the name “JAVA_HOME” and the value of “C:\Program Files\Java\jre1.5.0_11”, pressed “OK”, and it still gives me this “white intro page” upon inserting the CD. Should I restart the computer for this to take affect?

When I put the CD into the drive, it loads up and pops up an intro page of nothing but a pure white background… It makes me think it’s trying to load, but just can’t…

hmm I don’t think you’ll need a computer restart.
sorry but I’m out of further ideas…


At least you’re honest. :slight_smile:

Is there any WAMP equivalents for Java? I feel like I’m going through the same frustration I did back when I tried to install Apache, PHP, and MySQL for the first time… And then… There was WAMP. Problem solved.

Does it have .bat files? then I tweak w/ that file

If it contains something like

java …blah…bah

change it to
c:/program~1/jre/bin/java …blah…blah

Thanks for the suggestion, sg707, but it appears to be some form of registry issue now.

I found, downloaded, and used “JD-GUI Decompiler” on some of the files and discovered that these training CDs makes references to specific keys over in the registry. Unfortunately, however, there seems to be at least 1 that’s rather dynamic and difficult for me to ascertain just how to modify it. In the end, I’ve just thrown my hands up and said hell with it. I’m using the older version of Java the CDs require and I guess I’ll keep doing it until I need to change it again.