Wordpress: I can only see the WAMP server home page

good day,
I’ve installed Wordpress and WAMP server (the most recent versions). The Wordpress control panel is there and is workable so I know it’s basically working. The problem is that when I go to local host, only the WAMPserver home page displays. At one point it was working, the Wordpress base page displayed – there was a MS auto-update, might be related at all?
Help please. This is keeping me from doing anything.

Chances are you installed WordPress to localhost/blog/. The WP control panel is localhost/blog/wp-admin/, which works. And you are going to localhost/.

thanks for getting back to me.
I really very sure I’ve downloaded the correct version (went to wordpress.org and have the 3.2 version). When I go to http://localhost/blog I get a 404 error.
thing is, it did work at one point and now doesn’t.
more thoughts?:confused:

Are you sure you are typing the correct URL? What is your Wordpress install folder named?

What was the MS update? Typically you can use system restore to go back to your previous version to test and see if it was the update.

If you don’t have anything added to the blog as far as content or configuration, maybe just install a new blog locally, fresh.

Are you using IIS or apache?

The path is C/wamp/www/

I’m using Apache. I stopped the IIS services through the control panel. Using Windows 7. Before I stopped IIS I was getting the windows server page.

Not sure about the windows update. System Restore always make me nervous.

more thoughts before I go and redownload WP and begin anew?

Sounds like you don’t have enabled mod_rewrite. In the system tray icon of Wamp, go to apache > apache modules, and tick rewrite_module

Apache will then restart itself and everything should work as intended.

If the above doesn’t work, open up %WAMP%\bin\apache\apache<x.x.x>\conf\httpd.conf and look for the line

LoadModule rewrite_module modules/mod_rewrite.so

and make sure it looks like that and doesn’t start with a #

If it starts with a # remove that and restart WAMP / your system.

I tried all the suggestions. At one point I did do a system restore, actually two of them. I got this message when I tried to uninstall WAMP: “Internal error: Cannot find utCompiledCode record for this version of the uninstaller”. Very scary.
None of the suggestions worked. I am very thankful for all of them. :slight_smile:
I renamed the wamp folder (I thought anything might help) and downloaded the latest version as well as WP. Still the same problem.
What I finally did that worked was to delete the index.php file. I looked at it and could see the WAMP server page. I went and looked at the WP index.php; that should be what I was supposed to be seeing.
I replaced the WAMP index.php file with the WP file and ta-da-da-da, success.
I still have no idea why the one index file became the other.
Any idea ideas? This would be very scary to have happen online rather than locally.
thanks to all for your help.


Download Download WampServer from SourceForge.net

Insall to d:\


Download WordPress › Download
copy the folder to d:\wamp\www\


open in firefox http://localhost/ look for phpmyadmin OR http://localhost/phpmyadmin/

Create new database wp


open the folder d:\wamp\www\wordpress\
rename the file wp-config-sample.php to wp-config.php
open the file: wp-config.php
and look/replace the lines

define(‘DB_NAME’, ‘wp’);
define(‘DB_USER’, ‘root’);
define(‘DB_PASSWORD’, ‘’);


open in firefox http://localhost/wordpress/