Flash links not working when site first loads

Hiya,

I have a very odd bug happening with a flash movie on a site I have developed:
http://www.pocketcomms.co.uk/

When you first go to the site and click on the blue button “Create your own PocketComms” nothing happens - it should take you to:
http://pocketcomms.co.uk/index.php/pocketcomms/3

Code is:


view_your_own.onRelease = function() {
    getURL('index.php/pocketcomms/3');
};

I’ve also tried it with the full URL in front and it makes no difference.

It affects all browsers.

If you vist another page on the site and then come back to it, the button then works. Any ideas suggestions?! I’m thoroughly bemused.

Thanks in advance.
Ian

Doesn’t work for me whether I visit another site or not.

Visiting another page on the same site is what seems to make the difference at my end, visiting another website makes no difference.

Hi,

I think I’ve managed to resolve the problem.

It was due to the paramater “allowScriptAccess” which was set to “sameDomain”, I’ve changed it to “always” and it now will go through to the links. Not sure why this should make any difference as it was on the same domain but heh!

Hope that will be of help to someone,
Ian

you’re a lifesaver, Ian - we have an old (pre-AJAX) flash selector embedded in a document manager (Hummingbird) that stopped working in a similar manner, most likely after a plugin update in Internet Explorer. surprisingly it was still working via the local loop, but allowScriptAccess to Always fixed it for the rest of the clients.