Strange issue with a Flash Menu

I am building this site at and for some reason, when you click on portfolio at the top you go to the portfolio page.

However, once on that page, you cannot seem to navigate away from it from that flash menu.

I don’t know what is causing it but I think it is in the actionscript.

Can someone tell me what might be wrong with this actionscript causing it to do this?

onClipEvent (load) {
    num = 4;
    link = "minishowcase/";
    this.hitArea = this.area;
on (rollOver) {
    if (<>num) {
on (releaseOutside, rollOut) {
    if (<>num) {
on (release) {
    if (<>num) {
        _root["item"].gotoAndPlay("s2"); = num;

Actually, I take that back. That seemed to backfire in a way I did not think it would.

Sigh, back to the begining…

Can it be just “/” to say to look in the root for those pages the links are refering too? because that is where the pages are.


I gave up and just uploaded the contents of the site or coppied it to the minishowcase folder.

No matter what I did with the actionscript it would not work so I figured I would take the cheap way out and just coppied it there.

Problem solved for now. LOL

Thanks for the help,


Thanks Paul,

I know, How can I adjust the actionscript to fix that?

Do you have the source fla?
The code will be on the buttons themselves or on the timeline.

Yes, I have the source.

That actionscript posted above was from that button itself. It says in there /minishowcase as the link.

Should I be looking somewhere else in the actionscript for this to see why the buttons are not working on that page?

so in that actionscript, the part that says

link = “minishowcase/”;

is where i make that change or somewhere else in the .fla file?

Sorry that I am not getting this, it has been a while since I worked in Flash.

Thanks Paul

The links in the swf within the page swf need to be …/name of page or folder.

This will take you back up out of the minishowcase folder.

When you enter portfolio you are entering a sub directory of the site

Most probably this is where the issue is.