Experience with APC Backup Batteries

So I have a backup battery tied to my main computers (as where I lived prior, it was common to get power surges), this morning the battery in it completely died and so the APC refused to distribute any power to the devices that were plugged in.

Does this sound right to any one else? I thought these type of devices were used with Servers and wouldn’t this be a terrible response to a dead battery? All of a sudden your server goes down because the battery died and won’t hold a charge… doesn’t seem like a logical response to me, but I’m new to these devices (this was my first one) and I am curious if others had similar experiences.


My understanding is that the batteries have an expected life of several years after which you will need to replace the dead battery. The UPS powering the servers at my main client ended up with a completely dead battery about a year ago (after about five years of use) and the decision was made to upgrade the UPS rather than just replace the dead battery. The UPS I have on my main computer is only about two years old and so I would expect to get at least another two or three years out of the current battery.

If the batteries last about five years then you end up with the server it protects going down once in five years due to power issues rather than going down every time there are power issues.

I have ended up with the power going out in the middle of my working on something on perhaps three or four occasions si9nce I got the UPS for my main computer and so the UPS has served its purpose by allowing me to finish what I was doing rather than having everything stop when the power went off. On each occasion the UPS provided messages on the computer screen as to how long the battery was expected to last for and it would have shut the computer down for me if the remaining time had reached the point where there was just going to be enough time to shut down. So I’d expect to get some sort of warning come up on the computer screen if there were some issue with the battery not charging properly in advance of the battery completely dying - will have to wait until it happens to see if that is what results.

The cost for the battery replacement is about 80 dollars for me plus shipping, and I know my UPS was 270 when I bought it new, so I think the battery replacement makes sense. It still “sort of” bothers me that it doesn’t default to a electrical pass through when the battery dies entirely and just powers off everything in a hard manor. Oh well. Guess that is just how they might be designed. I can’t complain too much, it served its purpose very well during all sorts of electrical storms, power surges, etc.

This actually depends on what UPS type you have, as there is several different types. Some allow this functionality, others don’t.

It is possible that in your case if you take out the battery that it will work as you want. Ive seen in the past that sometimes when a battery fail that it has a failure inside causing the issue you refer to, then when we removed the battery the UPS worked again, of course it would have shut down if the power went down, but at least it allow you to make certain it remove any spikes in the grid until you get the battery replacement.

In regards to battery life, it mainly depends on the operating temperature. The higher the temperature, the shorter lifespan they will have. You will especially see this if you compare how long runtime a new battery have, compared to the runtime it has after one year.

As a side note, APC has a bonus program if you return a old UPS. I think you get either 20% or 25% off on the price of a new UPS. We have always used this instead of buying new batteries, and at the same time we get the extended warranty, giving give us a operation time on five year per UPS. If you browse some around on their website, I am sure you can locate this program.

I did find the bonus program, but to get a similar device that I already have, I’d still be spending well over the price of a new battery… Didn’t seem like the best buy at this time.

Thanks for the input, I’m at least glad that this has happened to others and that it could be “typical” behavior. I’ll have to see if removing the battery allows it to keep the current running to the devices (haven’t tried that).