Email is not going in hotmail inbox

I am trying to send email in hotmail inbox, every thing works fine but email goes in the junk folder of hotmail. I want to send the email in the inbox. In addition with, it works fine in case of gmail, msn and yahoo. here is my code:

<?php

if(isset($_POST['done']) )
{

$name = $_POST['xclient'];
$phoneno  = $_POST['xphoneno'];        
$clemail       =    $_POST['xclemail'];    
$jouneytype = $_POST['xjouneytype'];  
$pickup         =  $_POST['xpickup']; 
$dropof         =  $_POST['xdropof']; 
$jobdate             =   date('d-m-Y', strtotime($_POST['xjobdate']));
$jobtime         = $_POST['xjobtime'];         
$enddate  =   date('Y-m-d', strtotime($_POST['xenddate']));
$endtime       =     $_POST['xendtime'];  
$to      =     $_POST['xdrvmail'];  
   
$Cc = "myaddress@example.com"; 
// Multiple recipients

// Subject
$subject = ' ORDER DETAILS -  ECL-WORLDWIDE';

// Message
$message = "
<html>
<head>
  <title>Order Details</title>
</head>
<body>
  
  <table>
    
    <tr>
      <td><b>Client Name</b></b></td><td>$name</td>
    </tr>
    <tr>
      <td><b>Contact No</b></td><td>$phoneno</td>
    </tr>

      <td><b>Pickup Location</b></td><td>$pickup  </td>
    </tr>
    <tr>
      <td><b>Drop of Location</b></td><td>$dropof</td>
    </tr>




  <tr>
      <td><b>Job Date</b></td><td>$jobdate</td>
    </tr>

  <tr>
      <td><b>Job Time</b></td><td>$jobtime</td>
    </tr>

  <tr>
      <td><b>Completion Date</b></td><td>$jobdate</td>
    </tr>

  <tr>
      <td><b>Completion Time</b></td><td>$jobtime</td>
    </tr>




 </table>
</body>
</html>
";


$headers = "MIME-Version: 1.0" . "\r\n";
$headers .= "Content-type: text/html; charset=iso-8859-1" . "\r\n";
$headers .= "Cc: $Cc" . "\r\n";
$headers .= "From: ECL-Worldwide <myaddress@example.com>" . "\r\n" .
"Reply-To:   myaddress@example.com" . "\r\n" .
"X-Mailer: PHP/" . phpversion();


mail($to, $subject, $message,  $headers);

}
?>

Can you whitelist the senders email address so that Hotmail doesn’t mark it as junk?

the email goes to my new clients so it is not possible to ask them to add my sending email address in their whitelist.

The problem seems to be with Hotmail and what it thinks is spam, rather than the email transmission, which clearly works.

Perhaps you need to try small changes to your email. One thing I would suggest is not using all caps for the subject.

1 Like

IMHO the best place to ask is during the opt-in

An option would be to use an email service instead of sending the emails from your own server.
Or, AFAIK, plain-text emails should get through to most inboxes.

But as presumably you want to send HTML emails from your own server, I think the best chance you have of getting them to the inbox short of having them whitelisted is to use a “spam check” site and follow any suggestions they offer. (search for “spam check email content”)

Yes, that can upset things. The leading space might also make a difference.

That would be an issue, but I do often see web sites have a comment along the lines of “add our email to your ‘safe senders’ list to avoid our emails being marked junk”, so it’s not uncommon. Mail hosts don’t tend to reveal a lot of firm detail on how to avoid their junk detection otherwise the junk mail senders would read it too.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.