Copying and pasting from Notepad++

When doing the above into for example, MS Word, Adobe Dreamweaver, emails, etc, it turns text from single line spacing to double - how do you stop it from doing that please?

When saving there is an option to choose line ending for Mac Os, Unix/Linux and Windows.

Windows use both Carriage Return and Line Feed,
Mac Os uses only CR and Linux uses only LF.

Windows CR and LF gives double line space in Linux. There should be an option to edit in Windows mode that uses CR/LF in Linux editors.

1 Like

Thanks Eric, but not referring to saving the document anywhere, just trying to copy and paste from notepad++ to another programme.

Any help in solving this is much appreciated.

Dez.

What are the line settings for the documents you copy from and to?

I could imagine the recieving apps don’t have the same line endings as your Notepad++ has.

How do I find those line settings please?

Usually you choose the line format when creating or saving new docs.

Hope this article could be of help:

Thanks, I’ve done that, but how do I stop the single line spacing becoming double line spacing when I copy and paste from notepad++ ?