Access localhost from network computer?

I’ve got AppServ (Apache, MySQL, PHP) installed on a local computer. Is it possible for me to access those files in the browser of a computer on the same network but not the same computer? If so, how would I go about doing that?

It should be. Your router assigns your computer and every other computer on the network an ip address. To find the address on your computer(the one with the server), go to start, click run, type in cmd and hit enter. IN the window that comes up type in ipconfig and hit enter. Make a note of the ip address. If you go to the other computer on the net work and type in the ip address, you should be able to access the default page.

It pulls up the default page, but then when I try to pull up any other folders it tells me that it switches from the IP to localhost and it won’t load the page. Any ideas?

On the computer where the files reside, can you open up the site in your browser and navigate through it without any errors comming up? For instance, when you go to http://127.0.0.1/foldername/filename, does that page open up or do you get the same error?

It works fine on the computer where everything is installed. It’s just when trying to access it via the network computer the problem happens. When I go to the IP address it brings up the default page without a problem. It’s when I try to access a sub-folder that the IP reverts to localhost and I get the error.

Here’s an example: Say I go to http://192.168.1.100/. This pulls up the page fine. But if I try to go to http://192.168.1.100/subfolder/ it starts to go then reverts to http://localhost/subfolder/ and I get the Problem Loading Page screen.

Thanks for all the help!

I actually figured a bit of this out. Seems that every time I try to load something I have to type in the exact file name no empty directories expecting index to just pull it up. It also seems that every time I load something that connects to the db the Norton Security comes up blocking the connection. For some strange reason, eventhough I’ve created a rule for it, it still continues to block the connection. I have to turn the firewall off while I need to connect and then back on when I’m done.

There’s got to be a way around this. Any ideas?

I remember having the same problem a year or so ago. I think I fixed it by setting the UseCanonicalName directive to off in httpd.conf. Not sure about this, though. And, of course, restart Apache after modifying httpd.conf.