Wordpress website linking to localhost

I have a website uploaded. www.arenabadminton.com.my

The problem is all the links point to localhost. I have no idea on what to do because all this while i developed it locally, now i’m having troubles going to www.arenabadminton.com.my/wp-admin.

Thanking you in advance,

The links seem to be working correctly from here, I don’t see localhost links anywhere. I did notice however that it’s trying to load something from localhost, which is the image on the frontpage.

I would go into your WP database (using phpMyadmin), and do a search for localhost, you should find entries relating to this, changing it should help solve the situation.

maybe u use SQL dump from your localhost without change localhost links…

Did you manually edit any of your connection files or templates? This happened to me one before when making custom edits to templates

I’ve managed to sort one part of the problem, now there’s a new problem. But please allow me to tell you what i did.

I deleted everything on my webhost’s root folder. I made backups to the database before doing that. I opened my webhost’s tools and i went on to the database section to create a new database with the same name as the database i created locally. I managed to do that. Then i wanted to manage that database with phpMyAdmin but i wasn’t allowed to do so. Error: There are no users created yet to manage the database. So i created a new user with the same details as the user of the database on my local installation. When i did that, i got another error that didn’t allow me to create the user.

error: User kenneth already exists.

So what i did was i opened wp_config.php (locally) and edited the

define(‘DB_USER’, ‘kenneth’);


define(‘DB_USER’, ‘kennethjaysone’);

Then i went back to my Webhost’s tools and attempted to create a new user (kennethjaysone) and it allowed me to do that.

Since the database has been created, the user created, i was allowed to go into phpMyAdmin to manage the database. Then i imported the tables (database that i backed up on my desktop). So my database is up.

I transfered my wordpress files that i developed locally to the webserver using filezilla.

Everything was in place, then when i hit the URL (http://www.arenabadminton.com.my), the page appeared giving me hope that everything turned out alright…then to my horror, all the links we’re pointing to the localhost.

I solved that by going to the database (going to wp_options) table. I browsed the table in phpMyAdmin and look for the option_name called siteurl. The value for siteurl was [B]http://localhost/arenabadminton[/B]. So i figured out that i had to change that to http://www.arenabadminton.com.my.

Then i had another problem, the images that we’re intended to be on the posts we’re missing? So since the site was live, i tried to upload the pics into the posts, i get a new error:

Unable to create directory /home/httpd/vhosts/arenabadminton.com.my/httpdocs/wp-content/uploads/2009/01. Is its parent directory writable by the server?

Now i found the article to solve that problem and i’m just about to read it.

Just a note: I went in to my webserver and found that there is no uploads folder inside the wp-content folder.

I may need some help on changing file permissions so i’ll read up and if i’m unsure about anything i will come back here. Thank you all for you support.

One more thing. If you’ve seen the site http://www.arenabadminton.com.my, you’ll notice the awkward contact us link in the middle. I simply don’t know how to push it to the end.

The template tag that was used to generate the navigation is

<?php wp_page_menu('show_home=1&menu_class=mainnav'); ?>

The version of wordpress i’m using is 2.7

Thank you all again. I just wanted to document this long journey of mine so that people who are facing the same problem can find this post of help.

Thanks a million! sorry if this is a long post.

I think ur site is working now???

Everything’s working fine except that i’m trying to move the contact us link to the right side way to the end and i’m having difficulty doing so…

Thanks everyone.