Wordpress error message inside the post

I have bought a theme Gallerypro 2-1 and getting error messages when i try to edit the post.from the theme creator almost no support i thought someone can help me here.

i have just installed new wordpress and uploaded with ftp the new theme.

i get this message under Post Template when i edit the default post.

Warning: file(…/wp-content/themes/gallerypro/wp-pagenavi/wp-pagenavi.php) [function.file]: failed to open stream: No such file or directory in …/wp-content/themes/gallerypro/custom-post-template/custom-post-templates.php on line 126

Warning: implode() [function.implode]: Invalid arguments passed in …/wp-content/themes/gallerypro/custom-post-template/custom-post-templates.php on line 126

I am using php5 with 1and1 Mysql >=5 here is the site http://www.talinesart.com/ i don’t want to build anything without fixing this bug.
thank you

The first thing to do is make sure those files are where they’re being looked for and the spelling (including case) is correct.

While you’re at that, make sure the folder/file access permisions are adequate.

Your post shows “…” for the path beginnings. If they are “http://…” your server needs to be configured with allow_url_fopen true. If it isn’t, try using relative paths instead.

I have attached the complete error messages with the path.
the theme is in the correct folder /content/themes/galpro

the theme seems to work but when i go to edit a post at the bottom i see all these error messages under post themplate