SQL Server 2000 - Conection could be not be established

When trying to connect to my SQL Server I’m getting the following error:

A connection could not be established to (local).

Reason: Logon failed for user.

Please vertify SQL Server is running and check your SQL Server registration properties (by right-clicking on the (local) node) and try again.

SQL Server is definately running, but I’m unable to connect.

I’ve tried changing the ODBC settings but I can’t get past the “MIcrosoft SQL Server DNS Configuration” window. I choose “With Windows NT authentication using the network lognin ID” and click “Conect to SQL Server to obtain default setting for the additional congiruation options” and click “Next” but I get stopped by the following error:

connection failed:
SQLState: ‘28000’
SQL Server Error: 18456
[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user machine1\Administrator’

Does anyone have any ideas on what I need to do to fix this? If it helps, this all seems to have started occuring since I changed the Administrator password

I had this issue and worked around it by adding a username and password to the database and then in the ODBC connection I specified my new username and password to log in with instead of using Windows Credentials.

Thanks for the response.

How did you go about about creating that database user? I can’t get into Enterprise Manager at all.

  1. Do you connect using trusted connection?
  2. What happens if you change back your administrator password?
  3. Is your master database all right? Check your EventLog for any MSSQLSERVER related errors.

BTW is the SQL running locally or on a remote server?

If you cant access by Enterprise Manager and the SQL server is running locally then right click on My Computer and click Manage. Once there you should be able to open up the bottom tree and you will see it listed in there.

Let us know if you cant find this or are not sure how to add the user.

I changed it to mixed mode and managed to guess the “sa” password so I’m in!

Someone had changed the Bulletin/Administrators group to “Deny”.