Setting a static home page

Hello all.
followed the info here
and created a home.php. but I wanted my index.php to be the static page.
however when I went to settings>reading>a static page> index.php is not listed as one of the drop down options.

how can I make my index.php my static page?

You’ll have to go with another name. It won’t work otherwise.

All right, Ron. Will stick w/home page and style that.
thank you!