Sass works in codepen but not on desktop

Hello all run some very super simple sass (just getting started with it. it is not displaying correctly on my desktop. even tough the ruby command lines seems to be working fine, it lists, recgongizes the files in the appropriate dir & it flags errors and realizes when they have been corrected.

it is however displaying in the codepen

Any advice on how i could fix this (without switching to vagrant,puphet or a linux vm…)

What is the outputted CSS in your local file test? E.g. what’s in the view-source?

Don’t use SASS :wink: .

yes. Would love not to use sass! sadly just want to get some extra experience in what is out there and trying to stay a bit current :smile:
(Seems i can’t copy & past the source.)
but i did that in the code pen. After you mentioned it i went and double checked the css link, updated it to
link rel="stylesheet" href="style.scss"
I have both a .css & .scss stylecheet. After the update i got this on my .css

/*# */

AFAIK your css files should be in .css (it gets run though the SASS engien to produce .css) so change it back to .css

What’s the view-source of the .css file? style.css?

body {
  font-family: Helvetica, Arial, sans-serif; }
  body p {
    font-family: Times; }
  body p#mypara {
    font-family: "Courier New"; }

h1, h2 {
  color: navy; }

#mypara {
  font-size: 24px;
  border: 2px solid navy;
  padding: 15px 15px 15px 35px; }

#mypara:after {
  content: "with an appended string"; }

/*# */

Seems accurate to what the codepens scss should be outputting. What display issues are you having locally? The CSS should be producing the same result that you see in codepen.

Screenshots are welcome.

& this is the scss

$myColor1: navy;
$myStringVar: "with an appended string";
$myFontSize: 24px;
$thinBorder: 2px solid $myColor1;
$paddingVar: 15px 15px 15px 35px;

	font-family:Helvetica, Arial, sans-serif;
	font-family:"Courier New";

h1, h2 {

border: $thinBorder;
padding: $paddingVar;

and this is the

"version": 3,
"sources": ["style.scss"],
"names": [],
"file": "style.css"

frankly the tutorial am following was not 100% clear as to how many files you are eventually supposed to have and there was no mention of a map.

The SASS you posted should be outputting the same CSS you posted in your previous post.

I’m still not entirely sure what your issue is here. Can you get this up on a server somewhere so we can actually see the differences your SASS is producing compared to codepen?

not right now actually. but will try later on today from another location. thank you though.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.