Reset password validation not working

Hi Paul
unfortunately password check in modal (change password) stopped working. I looked it but I didn’t see anything, please help me to sort out it. thank you

registration4

Did you trying validating your HTML thru http://validator.w3.org/ ? Plenty of duplicated ids some badly formated tags, see print screen.

3 Likes

thank you for help,I didn’t these results, the modal password retype stopped working and registration form city field changes with by clicking in login menu. thank you.
I’ve put

.btnclose {
			color:white;}

to change the color of x.

<button type="button btnclose" class="close stylecls" data-dismiss="modal" style="">&times;</button>

also I used w3 validator

You need to correct all the errors the Validator shows. That’s always the first step in debugging issues.

I copied the HTML from your Codepen into a separate document, and the Validator is showing 74 errors and warnings. It may well be that fixing one or two errors will have a knock-on effect and solve some of the later ones, too, but there is no point in proceeding with anything else until you have valid code to work from.

1 Like

thank you for help. I run w3 validator and I have only what I presented on ‘print screen’.

Then please post a new CodePen with the corrected code.

ok
I present it in a full code as I have it in my notepadd++
regFull
as I check it with w3 validator, I get the already posted 5 error only. I need help with does too. thank you.

No, please don’t do that.

You have been asked multiple times to use CodePen correctly and post the HTML, CSS and JS in the correct panels.

You are asking others to give up their time to assist you. Does it really seem reasonable to you to ask people to hunt through huge amounts of irrelevant code to find your issues? Please post valid code, correctly presented, and preferably only the code required to reproduce the problem.

I tried to put different js in one and my experiment is not working. I try again.

I try to put two script in one and my former code is not working at all, clicking on form fields nothing happens.

<script> 
        $(document).ready(function(){
            $("#changepsw").on("click", function(){
                $("#login").css("display","none");
                $("#changepw").css("display","block");
                //e.preventDefault();
            });
            $("#changepsw2").on("click", function(){
                $("#login").css("display","none");
                $("#changepw").css("display","block");
                //e.preventDefault();
            });
            $("#login2").on("click", function(){
                $("#login").css("display","block");
                $("#changepw").css("display","none");
                //e.preventDefault();
            });
            
            $("#myBtn")
                .click(function () {
                    $("#myModal").modal();
                });
       });
     
    </script>
  
  <script>
  
  $(document)
    .ready(function () {
        $(".icon")
            .click(function () {
                $(".bar1")
                    .toggleClass("blue");
                $(".bar1")
                    .toggleClass("rotate45dg");
                $(".bar2")
                    .toggleClass("opacity");
                $(".bar3")
                    .toggleClass("rotate-45dg");
                
            });
        
        

I am sorry I have a new problem. as you can see, I have a modal that works but it has faulty parts. one important is password comparison at change password. I realized mpdal form needs its own jquery separated from main form and this is working faulty not comparing psw. but I am not sure if te login part is ok… please have a look. thank you.
registration4modified

The Analyze JavaScript command on that page shows you the problems.

thank you for help. I checked my code with w3 validator, many things corrected even my previous code is not working , pressing submit button error check is not happening, reset neither, modal useless total failure, please help me, thank you
updates:
updates

The Analyze JavaScript command on that page still helps you to find more problems.

In this case, it’s showing that <script> tags in the JavaScript section are causing the problem.

thank you for help. yes I was thinking on merging scripts in one but as I do it the previous working one is not working not doing anything and I don;t understand at all. can You help me with that. the relevant post is just above my present post.thank you.

You have script tags peppered throughout your code, that need removing.

I tried to but as I did the form stopped working , I don’t understand it, please help me, thank you.

Your code after being put through standardJS and various fixes done.

codepen

Errors remaining:
Line No.
1406 - ‘inputattr’ is not defined. (no-undef)

1684 - ‘st2’ is assigned a value but never used. (no-unused-vars)

1750 - ‘st2’ is assigned a value but never used. (no-unused-vars)

1822 - ‘value’ is assigned a value but never used. (no-unused-vars)

1927 - ‘st2’ is assigned a value but never used. (no-unused-vars)

1993 - ‘st2’ is assigned a value but never used. (no-unused-vars)

ok, thank you I’ll fix it

thank you for help. I made another experiment. I try to fix the modal but password retype doesn’t work, as you retype password ther is no comparison in any way. can you help me with that? thank you.
register update