Problem installing Apache server in windows XP (Apache, MySQL & PhP)


I’ve purchased the following book;

It had excellent instructions on installing a server of which I was successful. For practice, I tried to redo this on the same computer (after uninstalling everything) and got error messages.

I’m a beginner at this, and my goal is to install Joomla, right after I successfully install the Apache server. Would appreciate any detailed installation procedure and troubleshooting documents?

If I do this the easier way, do I have to install XAMPP or WAMP prior to installing Joomla (on windows?

I would really appreciate anybody’s input.:slight_smile:

I did it! Thank you. Let me go and change the port again to 80 and try once more to start Apache. Wish me luck.:wink:

Yes, you need to install Apache (yourself, or by installing XAMPP or WAMP) before you can use Joomla. The best way to fix error messages is to look up the exact error, in quotes, on a search engine. You’ll find either appropriate documentation or others that have had the error and how they fixed it.

Thank you Dan, really appreciate it.


If your installation was successful, what’s the problem (please show your error messages)?

Okay, without that, I have to guess at potential problems:

  1. Did you stop IIS and prevent it from starting with WinDoze?

  2. Did you use as the IP for your server?

WHICH version of WinDoze are you using?

I started with Kevin’s book (some years ago) and have never had a problem. I’m a firm believer in NOT using a canned “snapshot” app like XAMPP or WAMP which installs someone else’s versions of the Apache/PHP/MySQL team of daemons (with phpmyadmin). If you install using the same apps from the source, you can match your host’s versions AND learn a lot about the server.

As to your question about installing PHP applications, yes, you need to have Apache and PHP installed. Without PHP, you’ll not be able to test your application locally.



Thank you for your quick reply.

The only thing that I tried to install was MySQ, Apache, and PHP. In that order.
Not familiar with IIS and WinDoze. I’m a real beginner in server-side languages.

Let me try again installing Apache/PHP/MySQL and if that’s ok I’ll email you again when I run into problems.

Best regards,



Okay, but know that you must UNINSTALL in order to begin again.

IIS is MicroSoft’s server which has been installed with WinDoze (the various versions of Windows). To check on whether it’s been installed (as it was on Windows XP), click the Start button, then Run. In the box it provides, enter services.msc. That will present you with a view of the services being run on your computer. Check the list in the right side panel for IIS and STOP the service. Use the Properties to tell IIS not to start when Windows loads. THEN (and only then) you can install Apache on port 80.

After that, it’s only the small configuration bits which Kevin covered very well in his book.



I just installed Apache, MySQL and PHP. When I tried to read http:/localhost/ it sent me to a page with IIS. I changed Apache to port 8080 because I have IIS6 and IIS7 installed. It marks an error saying that each port should only be used by one instance ( I suppose something else is using port 8080) and that there are no ports available. I checked what you said to STOP IIS but there’s not an option in Poperties to inidcate that IIS doesn’t start when Windows loads. I’m using Windows 7. What I’m doing wrong?

On the properties screen, there is a box labeled “Startup Type”. Change it from “Automatic”, meaning the service automatically starts when Windows does, to “Manual” or “Disabled”.

I changed to port 80. And when I start Apache manually, I got the same message:
[<OS 10048> Only one usage of each socket address <protocol/network adress/port> is normally permitted.: make-sock: could not bind to adress…
unable to open logs]

nn, is not the same thing as Change the localhost IP address, too!


Thanks for stepping up with that. It’s easy enough is you know what you’re looking for but … :tup:



O.K. I reaaaaally don’y know what I’m doing. I’ve worked with a computer for only one month, but I allready design all my main page with stylesheet and everything (and it works beatifully) and my registration form with PHP. ( Now I’m trying to test my PHP script). Everything is new to me. So, thank you for your patience and help.

Said so, I change my line to: listen and got this error:

[<OSO100137> An attempt was made to access a socket in a way forbidden by its access permissions.: make_sock: could not bind to address
no listening sockets available, shutting down
Unable to open logs

Could you help me? Thank you:D

I’d really appreciate if somebody tells me where to get more info abot IP addresses and ports. Or where to look for the info I need. I’ve already read the explanations of each of the directives.:confused:

thank you.


Sorry to have to say this but you must go back to REinstall (uninstall first) Apache and use as the IP address. That’s the standard IP address for “me” or “this computer” or … “LOCALHOST” (suggestion for the server’s name).

Better yet, you’ll need a little help with the configuration, too, so let me advise you to go get the FREE download for Kevin Yank’s book. READ the first chapter and take notes pertaining to your version of WinDoze, Apache and PHP. THEN reinstall using your notes as a checklist.



Thank you. Don’t be sorry. This is helping me a lot to get to know my computer. I used Localhost as the name when I installed the WAM.

I set the IP to, and got a 100137 error. I made some changes in my firewall config. and got a 10048 error, so, I change the port to 8080 and problem solved! Now I get two warnings:

DocumentRoot[C:/www/docs/] does no exist
and the same for “_host2”

The only reference to /www/ that i can see in my config file is:
I wonder if this is the problem? :eye:

I checked /cgi-bin/ and only has a file called “” (?)

Does that help?


There is only a need to use port 8080 when you have something else parked on port 80 (and already started - that’s the default for IIS on XP). Horrors! STOP IIS and tell it (properties) not to start when WinDoze starts! THEN (and only then) can you properly install Apache on port 80 (on a WinDoze box).

Okay, now that you’ve succumbed to Gates’ imposition of IIS on you, look in your httpd.conf file for :80 and change it to :8080 in every instance (look for the Listen line).

The cgi-bin is normally a special case as it’s supposed to be OUTSIDE the webspace and accessed via mod_alias.



Thank you. I already changed the line “Listen” to

What about the two warnings? Should I just comment out the line ScrpitArias… and its Override loop?


What about your VirtualHost (or localhost definition)? It definitely needs to be there, too!



O.K. I uninstalled and installed another wamp “PL WAMP” and it worked since the beggining, well I just had to write the Listen and enable the CannonicalName ON.
Now it shows from my browser (IE) when I "http://localhost/ . FINALLY!

Next step: to test my first PHP script. It gives me an example and the instructions to write it, save it an upload it. So I already have a file saved as “test.php” with some PHP code. The instructions say that I have to upload it to my server using FTP. (?)
The WAMP has all the info. about the server config. (Apache, PHP, my SQL)available in charts that are accessible via main menu. So, I checked and it says that it has FTP “enabled”
I guess this is good news. Now what? How do I upload my test.php to “my website” using FTP? Is “localhost” my website? How doi FTP works?

I’m lost, AGAIN! Anybody with patience out there? Thank you.