Need help with some networking issues

Long story short, I’m on a Windows 7 Pro home network behind a router. I recently purchased an iPod to navigate to IIS7 websites hosted on my PC.

Thing is, I can get the iPod connected wirelessly to the router, but it seems to inherit the DNS servers that the router gets from my ISP. So when I tell the iPod to goto: it can’t resolve this because it goes out to my ISP’s DNS servers and (understandably) cannot resolve the DNS to my internal PC.

I have a basic understanding of networks, but I’ve yet to find a resolve on getting this to work. Anyone have an idea?

First, how are you typing the address to get to your site? If you’re writing and want any device (iPod or computer or tablet) to go to your home server, then you need to change the IP tables of your router. In this way, when the router is asked for, it will not go to the external network but direct the device to the right computer.

If you’re typing (substitute this number for whatever IP your computer has), then your iPod shoud not be sent by the router to the interent, but stay in the local network and visit your computer (because it will be the one with this IP).

Of course, just by typing the IP in the address of your web browser will head to the IIS main page if you haven’t changed IIS default configuration and you haven’t changed the default home page… then, if you saved your site in a subfolder, you may have to type

I hope this helps

Hey Molona. I think I’ve found a new issue.

Initially I tried going to and the iPod said it couldn’t find anything. But I went to my PC hosting IIS and rather than using http://localhost (which works) I tried using http://ip.of.the.pc and it failed to come up. For some reason my IIS will not serve up pages using the internal LAN IP address that my computer has.

I think I need to figure out how to get my IIS to serve files on that IP address and then try again with the iPod.

Have you tried to use the port number too? If you have installed IIS (or any other web server) previously, the port 80 may be already in used and it will not answer to the default http://ip.of.your.pc.with.ii7. If that’s the case, whether because you didn’t have a clean installation or because you have more than web server you’ll need to go to IIS7 configuration panel to know which port is using (very likely 8080). Then, it would not be http://ip.of.your.pc.with.ii7 but http://ip.of.your.pc.with.ii7:8080

It seems ESET’s personal firewall is stopping me from using the IP address.

I had to bind the 192.168.x.x address to a site in IIS7, and once I did that I then had to temporarily disable the ESET Personal Firewall, and I could then goto http://192.168.x.x on the iPod and the website loaded up. Looks like I’m going to have to look through ESET documentation on why it’s blocking internal devices from connecting to it via IP…

Well, that firewall is there to protect that computer… so it is natural that stops any traffic that you has not been started by it. I guess you’ll have to create an exception :slight_smile:

Yeah. I really wish I knew more about networks, but as far as IT stuff goes, it’s usually geared towards hardware/software, Web/Data Servers and Graphic Design.

Don’t get me wrong, I love ESET a LOT, and I’m glad its done such a great job protecting me. I just have to see if I can decipher its myriad of features to see if I can create such an exception without accidentally doing something detrimental to my network or exposing a computer to a threat.

Thanks for the troubleshooting Molona!

Also make sure the windows firewall or any other firewall software is not running in addition to ESET’s firewall on the IIS computer. I spent half a day once at a client trying to figure why they couldn’t share a printer properly, only to find out they had bothy Symantec and Windows firewall running. No wonder opening file sharing in symantec didn’t work, it was still blocked by the windows firewall.

Off Topic:

I understand the feeling. I spent half day trying to connect a computer to the business network to use the internet… all the network configuration was OK and the computer could see and share other computers but I couldn’t browse… then I realized that I forgot to install the proxy client :headbang: