Modifying Existing Website to work with two different versions of jQuery

Hi Guys,
I am working with a 3rd party vendor which has provided us ways to incorporate some widgets from their website. These widgets have a bunch of jQuery code which works with jQuery 1.7.2 which is loaded from their website. My website still uses jQuery 1.4.2 .So far I am thinking may be I should assign my jQuery object to a custom variable e.g $j123 = jQuery.noConflict().
But wouldn’t this mean that I will have to update all existing javascript on my website? If so , my main conern is the plugins I use, there is a bunch of them e.g

(function($){$.fn.jcarousel=function(o){.............}(jQuery);

Would this mean I will have to find/replace all instances of $ and jQuery within the plugin code to work with my jQuery ?

Please advise.